WAN : Relais de trames

Configuration de la mise en file d'attente pondérée basée sur les classes avec FRTS

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon pour le Mise en file d'attente pondérée basée sur les classes (CBWFQ) le Formatage du trafic de relais de trames (FRTS).

CBWFQ étend la fonctionnalité standard de la mise en file d'attente pondérée (WFQ) pour fournir le support pour les classes définies par l'utilisateur du trafic. FRTS emploie des files d'attente sur un réseau de Relais de trames pour limiter les surtensions qui peuvent entraîner l'encombrement. Des données sont mises en mémoire tampon et puis envoyées dans le réseau dans des montants réglés pour s'assurer que les adaptations du trafic dans l'enveloppe promise du trafic pour la connexion particulière.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

CBWFQ est pris en charge en date des versions logicielles suivantes de Ý de Cisco IOS selon la plate-forme :

  • Gamme Cisco 7500 avec des Versatiles Interfaces Processor (VIP) (CBWFQ distribué) - Logiciel Cisco IOS version 12.1(5)T

  • Gamme Cisco 7200, gamme 2600/3600, et d'autres Plateformes de la gamme non-7500 - Logiciel Cisco IOS version 12.1(2)T

Cependant les les deux les Routeurs utilisés pour ce document de configuration exécutaient la version du logiciel Cisco IOS 12.2(2).

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Pourquoi utilisation CBWFQ avec FRTS ?

Si vous avez des données spécifiques à protéger, CBWFQ fournit une manière de spécifier plus loin ces données utilisant les classes spécifiques. Utilisant CBWFQ, le poids spécifié pour une classe devient le poids de chaque paquet qui apparie les critères de classe. Ce poids est dérivé de la bande passante que vous assignez à la classe. WFQ est alors appliqué à ces classes, au lieu de l'application aux écoulements eux-mêmes, et les classes peuvent inclure plusieurs écoulements.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

La table ci-dessous fournit un guide de référence rapide des entrées que vous pourriez voir dans les configurations :

Champ Description
Interface de relais de trame Interface de sortie.
sous-interface Interface logique.
dlci Identificateur de connexion de liaison de données. La valeur qui spécifie un circuit virtuel permanent (PVC) ou le circuit virtuel commuté (SVC) dans un réseau de Relais de trames.
classe XXX Applique le map-class frame-relay XXX.
map-class frame-relay XXX Paramètres FRTS.
service-stratégie ZZZ CBWFQ.
policy-map ZZZ Stratégie Désignée.
classe YYY Nomme la classe.
bande passante, maintenant l'ordre, priorité Particularités pour ceci écoulement.
classe-par défaut de classe Sujets de syntaxe et d'orthographe en créant vos classes par défaut.
class-map correspondance-tout YYY Établit le critère de correspondance contre lequel le paquet est vérifié.
match access-group 101 Attache le class-map à une liste d'accès.
IP tout quel d'autorisation de la liste d'accès 101 Liste d'accès normale.

Remarque:  Gamme Cisco 7500 : En date du Logiciel Cisco IOS version 12.1(5)T, les stratégies de Qualité de service (QoS) doivent fonctionner dans le mode distribué sur la Versatile Interface Processor (VIP) parce que le processeur d'artère/commutateur (RSP) QoS basé sur n'est plus pris en charge. , Utilisez par conséquent la commande de forme et d'autres commandes pour l'interface de ligne de commande modulaire de QoS (CLI) de mettre en application le Formatage du trafic distribué (dTS) pour des interfaces de Relais de trames sur des VIPs sur la gamme Cisco 7500. DTS combine le Formatage du trafic générique (GTS) et le FRTS.

Procédure obligatoire

Configurant CBWFQ avec FRTS inclut les trois étapes obligatoires suivantes :

  1. Définissez les class map (class-map).

    Établissez le critère de correspondance contre lequel un paquet est vérifié pour déterminer s'il appartient à une classe.

  2. Configurez la carte de stratégie (policy-map) et définir des classes (classe).

    Spécifie le nom de la carte de stratégie. Caractéristiques d'associés pour des garanties, le maintien de l'ordre, et la priorité de bande passante à chaque classe du trafic. Ce processus nécessite la configuration de la bande passante, et ainsi de suite, pour être appliqué aux paquets appartenant à un des class-map précédemment définis. Pour ce processus, configurez une carte de stratégie qui spécifie la stratégie pour chaque classe du trafic.

  3. Reliez la stratégie de service au map-class FRTS (service-stratégie).

    Reliez les stratégies prescrites identifiées avec la service-stratégie spécifique au map-class (et ainsi au DLCI ou à la sous-interface où le map-class frame-relay est appliqué).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/17920/traffic_shaping.gif

Le schéma de réseau ci-dessus utilise les valeurs suivantes :

  • HUB - débit physique = 192 Kbps, taux garanti = 32 Kbps

  • DISTANT - débit = 64 Kbits/s physiques, taux garanti = 32 Kbps

Configurations

Ce document utilise les configurations présentées ci-dessous.

Hub avec CBWFQ configuré
<snip> 
!
class-map match-all YYY
  match access-group 101
!
!
policy-map ZZZ
  class YYY
   bandwidth percent 50
<snip>
interface Serial0/0 
  no ip address 
  encapsulation frame-relay 
  no fair-queue 
  frame-relay traffic-shaping 

 interface Serial0/0.1 point-to-point 
  ip address 10.1.1.1 255.255.255.0 
  frame-relay interface-dlci 16  
  frame-relay class XXX 
 ! 
 map-class frame-relay XXX 
  frame-relay cir 64000  
  frame-relay mincir 32000 
  frame-relay adaptive-shaping becn 
  frame-relay bc 8000
  service-policy output ZZZ
<snip>
!
access-list 101 permit ip host 10.0.0.1 host 11.0.0.1

Distant
interface Serial0/0 
no ip address 
encapsulation frame-relay 
no fair-queue 
frame-relay traffic-shaping 
! 
interface Serial0/0.1 point-to-point 
ip address 10.1.1.2 255.255.255.0 
frame-relay interface-dlci 16  
frame-relay class XXX 
! 
map-class frame-relay XXX 
frame-relay cir 64000 
frame-relay mincir 32000 
frame-relay adaptive-shaping becn 
frame-relay bc 8000 
!

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show frame-relay pvc - Affiche des statistiques au sujet de PVCs pour des interfaces de Relais de trames.

  • show policy-map - Affiche la configuration de toutes les classes comportant la carte de stratégie de service indiquée ou toutes les classes pour toute la stratégie existante trace.

  • show policy-map [interface] - Affiche la configuration de toutes les classes configurées pour toutes les stratégies de service sur l'interface spécifiée ou pour afficher les classes pour la stratégie de service pour un PVC de particularité sur l'interface.

Ce qui suit est sortie témoin de la commande de show frame-relay pvc :

Hubrouter#show frame-relay pvc [interface interface ][dlci]
PVC Statistics for interface Serial0/0 (Frame Relay DTE)

              Active     Inactive      Deleted       Static
  Local          0            1            0            0
  Switched       0            0            0            0
  Unused         0            0            0            0

DLCI = 16, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

  input pkts 0             output pkts 0            in bytes 0
  out bytes 0              dropped pkts 0           in pkts dropped 0
  out pkts dropped 0       out bytes dropped 0
  in FECN pkts 0           in BECN pkts 0           out FECN pkts 0
  out BECN pkts 0          in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0
  pvc create time 00:01:12, last time pvc status changed 00:01:12
Hubrouter#

Vous pouvez utiliser la syntaxe suivante avec cette commande :

  • interface - (facultatif) indique une interface spécifique pour laquelle les informations PVC sont affichées.

  • interface - nombre (facultatif) d'interface contenant les DLCI pour lesquels vous souhaitez afficher les informations PVC.

  • dlci - numéro DLCI spécifique (facultatif) A utilisé sur l'interface. Des statistiques pour le PVC spécifié sont affichées quand un DLCI est également spécifié.

Ce qui suit est sortie témoin de la commande de show policy-map :

Hubrouter#show policy-map 
   Policy Map ZZZ 
    Class YYY 
      Weighted Fair Queueing 
            Bandwidth 50 (%) Max Threshold 64 (packets) 
    Class WWW 
      Weighted Fair Queueing 
            Bandwidth 25 (%) Max Threshold 64 (packets)

Ce qui suit est sortie témoin du show policy-map [interface].

 Hubrouter#show policy-map interface s0/0.1 
  Serial 0/0.1: DLCI 16 
  Service-policy output: ZZZ (1057) 
    Class-map: YYY (match-all) (1059/2) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 101 (1063) 
      Weighted Fair Queueing 
        Output Queue: Conversation 73 
        Bandwidth 50 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: WWW (match-all) (1067/3) 
      0 packets, 0 bytes 
      30 second offered rate 0 bps, drop rate 0 bps 
      Match: access-group 102 (1071) 
      Weighted Fair Queueing 
        Output Queue: Conversation 74 
        Bandwidth 25 (%) Max Threshold 64 (packets) 
        (pkts matched/bytes matched) 0/0 
        (depth/total drops/no-buffer drops) 0/0/0 
    Class-map: class-default (match-any) (1075/0) 
         2 packets, 706 bytes 
         30 second offered rate 0 bps, drop rate 0 bps    
         Match: any  (1079)

D'autres termes que vous pouvez également voir dans les configurations semblables sont expliqués ci-dessous :

  • CIR - Débit de données garanti. Évaluez à ce qu'un réseau de Relais de trames accepte de transférer le dans des conditions normales de l'information, fait la moyenne au-dessus d'un incrément minimum de temps.

  • Mise en file d'attente FIFO - Queue de first-in, first-out. Le FIFO implique de bufferiser et expédier des paquets dans la commande de l'arrivée. Le FIFO n'incarne aucun concept de priorité ou de classes du trafic. Il y a seulement une file d'attente, et tous les paquets sont traités également. Des paquets sont envoyés une interface dans la commande dans laquelle ils arrivent.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 17920