Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette sur ATM (MPLS sur ATM)

MPLS VPN sur ATM : avec BGP ou RIP sur le site client

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon d'un Commutation multiprotocole par étiquette (MPLS) VPN au-dessus d'atmosphère quand le Protocole BGP (Border Gateway Protocol) ou le Protocole RIP (Routing Information Protocol) est présent sur des sites client.

La caractéristique du réseau privé virtuel (VPN), une fois utilisée avec le MPLS, permet à plusieurs sites pour interconnecter d'une manière transparente par un réseau du fournisseur de service. Un réseau du fournisseur de service peut prendre en charge plusieurs VPN d'IP différents. Chacun de ces derniers apparaît à ses utilisateurs en tant que réseau privé, séparé de tous les autres réseaux. Dans un VPN, chaque site peut envoyer des paquets IP à n'importe quel autre site dans le même VPN.

Chaque VPN est associé avec un ou plusieurs VPN de routage ou instances de transmission (VRF). UN VRF se compose d'une table de Routage IP, de la table dérivée de Technologie Cisco Express Forwarding (CEF), et de l'ensemble d'interfaces qui utilise cette table d'expédition.

Le routeur conserve un routage distinct et la table CEF pour chaque VRF. Ceci ne permet pas les informations à envoyer en dehors du VPN, mais il permet le même sous-réseau à utiliser dans plusieurs VPN sans problèmes d'adresse IP en double.

Le routeur qui utilise le BGP distribue les informations de routage VPN avec les communautés BGP étendues.

Pour plus d'informations sur la propagation des mises à jour par un VPN, voir les ces liens :

Conditions préalables

Matériel et versions de logiciel

Ces lettres représentent les différents types des Routeurs et de Commutateurs utilisés :

  • P : Principal routeur de fournisseur

  • PE : Routeur de Provider Edge

  • CE : Routeur de Customer Edge

  • C : Routeur client

Nous avons développé et avons testé la configuration avec des ces logiciel et versions de matériel :

  • Routeurs de PE :

    • Logiciel : Version de logiciel 12.1(3)T de½ du¿Â du Cisco IOSïÂ. La release 12.0(5)T inclut le MPLS VPN.

    • Matériel : Tout routeur de Cisco de la gamme 3600 ou plus élevé, comme le Cisco 3660 ou les 7206.

  • Routeurs de la CE : Utilisez n'importe quel routeur qui peut permuter les informations de routage avec son routeur PE.

  • Routeurs et Commutateurs P : La fonction d'intégration MPLS VPN réside seulement au bord du réseau MPLS, ainsi utilisez n'importe quel commutateur MPLS-capable. Dans la configuration d'échantillon, le nuage MPLS se compose de 8540 MSR et un LightStream 1010. Si vous utilisez le LightStream 1010, nous recommandons que vous utilisiez la version de logiciel WA4.8d ou plus élevé. Vous pouvez également utiliser d'autres Commutateurs ATM, tels que le BPX 8650 de Cisco ou MGX 8850 dans le réseau de noyau atmosphère.

Conventions

Ce diagramme affiche une configuration typique qui illustre ces conventions :

/image/gif/paws/10468/mpls_bgp_rip1.gif

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Description

Nous avons installé un circuit principal standard atmosphère MPLS avec la région 0 de Protocole OSPF (Open Shortest Path First) comme Protocole IGP (Interior Gateway Protocol). Nous avons configuré deux VPN différents avec ce circuit principal. Les premiers de ces utilisations DÉCHIRENT en tant que son Customer Edge au protocole de routage du Provider Edge (CE-PE), et l'autre utilise le BGP en tant que son protocole de routage PE-CE.

Nous avons configuré de diverses artères de bouclage et de charge statique sur les Routeurs de la CE pour simuler la présence d'autres Routeurs et réseaux.

Configurez la procédure

Remarque: Il est obligatoire d'utiliser le BGP comme IGP VPN entre les Routeurs de PE. C'est parce que l'utilisation des communautés BGP étendues est la seule manière de transporter les informations de routage pour le VPN entre les Routeurs de PE.

Diagramme du réseau

/image/gif/paws/10468/mpls_bgp_rip2.gif

Partie I de procédure de configuration

La documentation Cisco IOS (réseaux privés virtuels MPLS) décrit également cette procédure de configuration.

Assurez-vous que l'ip cef est activé. Si vous utilisez un routeur de Cisco 7500, assurez-vous que l'ip cef distribué est activé. Sur le siège potentiel d'explosion, une fois que le MPLS a été installé, suivez ces étapes :

  1. Créez un VRF pour chaque VPN lié à la commande de name> de routage/instance de transfert du vrf <VPN d'IP :

    1. Spécifiez le moteur de distinction de route correct utilisé pour ce VPN. Ceci est utilisé pour étendre l'adresse IP de sorte que vous puissiez identifier le VPN auquel elle appartient.

      rd <VPN route distinguisher>
      
    2. Installez les propriétés d'importation et d'exportation pour les communautés BGP étendues. Ceux-ci sont utilisés pour filtrer le processus d'importation et d'exportation.

      route-target [export|import|both] <target VPN extended community>
      
  2. Configurez les détails de transfert pour les interfaces respectives avec cette commande :

    ip vrf forwarding <table name>
    

    Remarque: Souvenez-vous pour installer l'adresse IP après que vous fassiez ceci.

  3. Personne à charge sur le protocole de routage PE-CE que vous utilisation, vous devez maintenant faire un ou plusieurs de ces derniers :

    • Configurez les artères statiques :

      ip route vrf vrf-name prefix mask [next-hop-address] [interface {interface-number}]
      
    • Configurez le RIP avec cette commande :

      address-family ipv4 vrf <VPN routing/forwarding instance name>
      

      Une fois que vous avez fait la présente partie, sélectionnez les commandes normales de configuration RIP.

      Remarque: Ceci est seulement appliqué aux interfaces de transfert pour le VRF en cours.

      Remarque: Vous devez redistribuer le BGP correct dans le RIP. Quand vous faites ceci, souvenez-vous pour spécifier également la mesure qui est utilisée.

    • Déclarez les informations sur les voisins BGP.

    • Configurez l'OSPF avec la nouvelle commande IOS :

      router ospf <process ID> vrf <VPN routing/forwarding instance name>.
      

      Remarque: Ceci est seulement appliqué aux interfaces de transfert pour le VRF en cours.

      Remarque: Vous devez redistribuer le BGP correct dans l'OSPF. Quand vous faites ceci, souvenez-vous pour spécifier également la mesure qui est utilisée.

      Remarque: Une fois que vous attribuez le processus OSPF à un VRF, ce nombre de processus est toujours utilisé pour ce VRF particulier. Ceci s'applique même si vous ne le spécifiez pas dans la ligne de commande.

Partie II de procédure de configuration

Configurez le BGP entre les Routeurs de PE. Il y a plusieurs manières de configurer le BGP ; une manière est d'utiliser les méthodes de réflecteur ou de confédération d'artère. La méthode utilisée ici ? configuration de voisinage directe ? est la plus simple et moins extensible.

  1. Déclarez les différents voisins.

  2. Écrivez le name> de routage/instance de transfert du vrf <VPN d'ipv4 d'address-family pour chaque VPN actuel à ce routeur PE. Effectuez un ou plusieurs de ces étapes, selon les besoins :

    • Redistribuez les informations de routage statiques.

    • Redistribuez les informations de routage de RIP.

    • Redistribuez les informations de routage OSPF.

    • Lancez le BGP dans la proximité aux Routeurs de la CE.

  3. Entrez le mode d'address-family vpnv4, et exécutez un de ces derniers :

    • Activez les voisins.

    • Spécifiez que la communauté étendue doit être utilisée. Ceci est obligatoire.

Configurations

Dans la configuration d'Alcalzaba, des lignes spécifiques au VPN 101 sont affichées en gras, ces la particularité au VPN 102 sont en italique, et ces la particularité à chacun des deux sont affichées en gras et italique.

Alcazaba
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip vrf vrf102
 rd 1:102
 route-target export 1:102
 route-target import 1:102
!
ip cef
!
interface Loopback0
 ip address 223.0.0.3 255.255.255.255
!
interface Ethernet1/0
 ip vrf forwarding vrf102
 ip address 10.200.10.3 255.255.252.0

!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 150.150.0.1 255.255.255.0
!
interface ATM3/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal
 pvc ilmi 0/16 ilmi
 !
!
interface ATM3/0.1 tag-switching
 ip address 10.0.0.17 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
interface ATM4/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.13 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip 
!
router ospf 1
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.3 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 0
 network 150.150.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 
neighbor 223.0.0.21 remote-as 1

 
neighbor 223.0.0.21 update-source Loopback0

 no auto-summary
 !
 address-family ipv4 vrf vrf102
 redistribute connected
 neighbor 10.200.10.14 remote-as 158
 neighbor 10.200.10.14 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended

 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended

 no auto-summary
 exit-address-family
!


Kozel
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
!
ip vrf vrf102
 rd 1:102
 route-target export 1:102
 route-target import 1:102
!
ip cef
!
interface Loopback0
 ip address 223.0.0.21 255.255.255.255
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 200.200.0.1 255.255.255.0
!
interface Ethernet1/2
 ip vrf forwarding vrf102
 ip address 201.201.201.1 255.255.255.252
!
interface ATM4/0
 no ip address
 no atm scrambling cell-payload
 no atm ilmi-keepalive
 pvc qsaal 0/5 qsaal     
 pvc ilmi 0/16 ilmi
!
interface ATM4/0.1 tag-switching
 ip address 10.0.0.6 255.255.255.252
 tag-switching atm vpi 2-4
 tag-switching ip
!
router ospf 1
 log-adjacency-changes
 network 10.0.0.0 0.0.0.255 area 0
 network 223.0.0.21 0.0.0.0 area 0
!
router rip
 version 2
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 200.200.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 125.2.2.2 remote-as 1
 neighbor 125.2.2.2 update-source Loopback0
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 no auto-summary
 !
 address-family ipv4 vrf vrf102
 redistribute connected
 redistribute static
 neighbor 201.201.201.2 remote-as 69
 neighbor 201.201.201.2 activate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family ipv4 vrf vrf101
 redistribute rip
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 125.2.2.2 activate
 neighbor 125.2.2.2 send-community extended
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 no auto-summary
 exit-address-family
!

La Médina
Current configuration:
!
ip vrf vrf101
 rd 1:101
 route-target export 1:101
 route-target import 1:101
ip cef
!
interface Loopback1
 ip vrf forwarding vrf101
 ip address 11.2.2.2 255.255.255.252
!
interface ATM2/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM2/0.66 tag-switching
 ip address 125.1.4.2 255.255.255.252
 tag-switching ip
!
interface Ethernet1/1
 ip vrf forwarding vrf101
 ip address 11.3.3.1 255.255.255.252
!
router ospf 1
 
 network 125.1.4.0 0.0.0.3 area 0
 network 125.2.2.2 0.0.0.0 area 0
!
router rip
 version 2
 network 11.0.0.0
 !
 address-family ipv4 vrf vrf101
 version 2
 redistribute bgp 1 metric 1
 network 11.0.0.0
 no auto-summary
 exit-address-family
!
router bgp 1
 no synchronization
 neighbor 223.0.0.3 remote-as 1
 neighbor 223.0.0.3 update-source Loopback0
 neighbor 223.0.0.21 remote-as 1
 neighbor 223.0.0.21 update-source Loopback0
 !
 address-family ipv4 vrf vrf101
 redistribute connected
 redistribute static
 redistribute rip
 default-information originate
 no auto-summary
 no synchronization
 exit-address-family
 !
 address-family vpnv4
 neighbor 223.0.0.3 activate
 neighbor 223.0.0.3 send-community extended
 neighbor 223.0.0.21 activate
 neighbor 223.0.0.21 send-community extended
 exit-address-family
!

Rapide
Current configuration:


!
interface Loopback0
 ip address 223.0.0.12 255.255.255.255
!         
interface Loopback2
 ip address 7.7.7.7 255.255.255.0
!
interface FastEthernet0/1
 ip address 150.150.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 7.0.0.0
 network 10.0.0.0
 network 150.150.0.0
 no auto-summary
!
ip route 158.0.0.0 255.0.0.0 Null
!

Damme
!
interface Loopback1
 ip address 6.6.6.6 255.0.0.0
!
interface FastEthernet0/0
 ip address 10.200.10.14 255.255.252.0
 duplex auto
 speed autoa
!
router bgp 158
 no synchronization
 network 6.0.0.0
 network 10.200.0.0 mask 255.255.252.0
 neighbor 10.200.10.3 remote-as 1
 no auto-summary
!

Pivrnec
Current configuration:
!
interface Loopback0
 ip address 223.0.0.22 255.255.255.255
!
interface Loopback1
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/1
 ip address 200.200.0.2 255.255.255.0
 duplex auto
 speed auto
!
router rip
 version 2
 redistribute static
 network 6.0.0.0
 network 200.200.0.0
 no auto-summary
!
ip route 69.0.0.0 255.0.0.0 Null0
!

Guilder
!
interface Loopback2
 ip address 150.150.0.1 255.255.0.0
!
interface Ethernet0/2
 ip address 201.201.201.2 255.255.255.252
!
router bgp 69
 no synchronization
 network 7.7.7.0 mask 255.255.0.0
 network 150.150.0.0
 network 201.201.201.0 mask 255.255.255.252
 redistribute connected
 neighbor 201.201.201.1 remote-as 1
 no auto-summary
!

Purkmister
Current configuration:
!
interface Loopback0
 ip address 11.5.5.5 255.255.255.252
!
interface FastEthernet0/1
 ip address 11.3.3.2 255.255.255.252
 duplex auto
 speed auto
!
router rip
 version 2
 network 11.0.0.0
!

Commandes show

Commandes de Routage-particularité

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • vrf de show ip rip database

  • vrf de show ip bgp vpnv4

  • show ip route vrf

  • show ip route

Sur un routeur PE, la méthode de routage PE-CE (telle que le RIP, le BGP ou la charge statique) et les mises à jour BGP PE-PE indiquent la table de routage qui est utilisée pour un VRF particulier. Vous pouvez afficher les informations de RIP pour un VRF particulier :

Alcazaba#show ip rip database vrf vrf101
 0.0.0.0/0 auto-summary  
 0.0.0.0/0
 [2] via 150.150.0.2, 00:00:12, Ethernet1/1
 6.0.0.0/8 auto-summary
 6.6.6.6/32 redistributed
 [1] via 223.0.0.21,
 7.0.0.0/8 auto-summary
 7.7.7.0/24
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.0.0.0/8 auto-summary
 10.0.0.0/8 redistributed
 [1] via 125.2.2.2,
 10.0.0.0/16
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 10.200.8.0/22
 [1] via 150.150.0.2, 00:00:12, Ethernet1/1 
 11.0.0.0/8 auto-summary
 11.0.0.4/30 redistributed
 [1] via 125.2.2.2,
 11.1.1.0/30 redistributed
 [1] via 125.2.2.2,
 11.3.3.0/30 redistributed
 [1] via 125.2.2.2,
 11.5.5.4/30 redistributed
 [1] via 125.2.2.2,
 69.0.0.0/8 auto-summary
 69.0.0.0/8 redistributed
 [1] via 223.0.0.21,
 150.150.0.0/16 auto-summary
 150.150.0.0/24 directly connected, Ethernet1/1
 158.0.0.0/8
 [1] via 150.150.0.2, 00:00:17, Ethernet1/1
 200.200.0.0/24 auto-summary 
 200.200.0.0/24 redistributed 
 [1] via 223.0.0.21,  

Vous pouvez également afficher les informations BGP pour un VRF particulier avec la commande de vrf de show ip bgp vpnv4. Les résultats PE-PE du BGP interne (IBGP) sont indiqués par un I.

Alcazaba#show ip bgp vpnv4 vrf vrf101 
   BGP table version is 46, local router ID is 223.0.0.3 
   Status codes: s suppressed, d damped, h history, * valid, best, i - internal    
   Origin codes: i - IGP, e - EGP, ? - incomplete 
 
 Network Next Hop Metric LocPrf Weight Path 
   Route Distinguisher: 1:101 (default for vrf vrf101) 
   *i6.6.6.6/32 223.0.0.21 1 100 0 ? 
   * 7.7.7.0/24 150.150.0.2 1 32768 ? 
   * 10.0.0.0/16 150.150.0.2 1 32768 ? 
   * 10.200.8.0/22 150.150.0.2 1 32768 ? 
   *i11.2.2.0/30 125.2.2.2 0 100 0 ? 
   *i11.3.3.0/30 125.2.2.2 0 100 0 ? 
   *i11.5.5.4/30 125.2.2.2 1 100 0 ? 
   *i69.0.0.0 223.0.0.21 1 100 0 ? 
   * 150.150.0.0/24 0.0.0.0 0 32768 ? 
   * 158.0.0.0/8 150.150.0.2 1 32768 ? 
   *i200.200.0.0 223.0.0.21 0 100 0 ?  

Kozel#show ip bgp vpnv4 vrf vrf102
BGP table version is 48, local router ID is 223.0.0.21
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
 
   Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 1:102 (default for vrf vrf102)
* i6.0.0.0          223.0.0.3                0    100      0 158 i
*>i                 223.0.0.3                0    100      0 158 i
*> 7.7.0.0/16       201.201.201.2            0             0 69 ?
*  10.200.8.0/22    201.201.201.2            0             0 69 ?
* i                 223.0.0.3                0    100      0 ?
*>i                 223.0.0.3                0    100      0 ?
*> 102.102.0.0/16   201.201.201.2            0             0 69 ?
*> 150.150.0.0      201.201.201.2            0             0 69 i
*  201.201.201.0/30 201.201.201.2            0             0 69 i
*>                  0.0.0.0                  0         32768 ?

Vous pouvez vérifier la table de routage globale pour un VRF sur le PE et les Routeurs de la CE. Ceux-ci s'assortissent. Pour le routeur PE, vous devez spécifier le VRF avec la commande de show ip route vrf.

Alcazaba#show ip route vrf vrf101
   Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP   
   D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area    
   * - candidate default, U - per-user static route, o - ODR
   P - periodic downloaded static route
    Gateway of last resort is not set
   B 69.0.0.0/8 [200/1] via 223.0.0.21, 00:11:03
   B 200.200.0.0/24 [200/0] via 223.0.0.21, 00:11:03
    6.0.0.0/32 is subnetted, 1 subnets
   B 6.6.6.6 [200/1] via 223.0.0.21, 00:11:03 
    7.0.0.0/24 is subnetted, 1 subnets
   R 7.7.7.0 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
   R 10.0.0.0/16 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
   R 10.200.8.0/22 [120/1] via 150.150.0.2, 00:00:05, Ethernet1/1 
    11.0.0.0/30 is subnetted, 3 subnets
   B 11.3.3.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.2.2.0 [200/0] via 125.2.2.2, 00:07:05
   B 11.5.5.4 [200/1] via 125.2.2.2, 00:07:05
    150.150.0.0/24 is subnetted, 1 subnets
   C 150.150.0.0 is directly connected, Ethernet1/1
   R 158.0.0.0/8 [120/1] via 150.150.0.2, 00:00:06, Ethernet1/1

Pour Pivrnec, c'est la table de routage standard, ainsi utilisez la commande de show ip route :

Pivrnec#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP  
  D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
  N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2 
  E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
  i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area  
  * - candidate default, U - per-user static route, o - ODR 
  P - periodic downloaded static route Gateway of last resort is not  set S 69.0.0.0/8 is directly connected, Null0 
  223.0.0.0/32 is subnetted, 1 subnets 
 C 223.0.0.22 is directly connected, Loopback0 
 C 200.200.0.0/24 is directly connected, FastEthernet0/1 
  6.0.0.0/32 is subnetted, 1 subnets 
 C 6.6.6.6 is directly connected, Loopback1 
  7.0.0.0/24 is subnetted, 1 subnets 
 R 7.7.7.0 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
  10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks 
 R 10.0.0.0/16 [120/1] via 200.200.0.1, 00:00:23, FastEthernet0/1 
 R 10.200.8.0/22 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
  11.0.0.0/30 is subnetted, 3 subnets 
 R 11.3.3.0 [120/1] via 200.200.0.1, 00:00:24, FastEthernet0/1 
 R 11.2.2.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 11.5.5.4 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
  150.150.0.0/24 is subnetted, 1 subnets 
 R 150.150.0.0 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 
 R 158.0.0.0/8 [120/1] via 200.200.0.1, 00:00:25, FastEthernet0/1 

Mpls label

Vérifiez la pile d'étiquette utilisée pour n'importe quelle artère particulière :

 Alcazaba#show tag-switching forwarding-table vrf vrf101 11.5.5.5 detail    
   Local Outgoing Prefix Bytes tag Outgoing Next Hop
   tag tag or VC or Tunnel Id switched interface
   None 2/91 11.5.5.4/30 0 AT4/0.1 point2point
    MAC/Encaps=4/12, MTU=4466, Tag Stack{2/91(vcd=69) 37} 
    00458847 0004500000025000

Vous pouvez également utiliser les commandes normales de visualiser les allocations de balise et des relations VPI/VCI ici.

Superposer d'adresse

La même adresse peut être utilisée dans différents VPN sans interférence avec les autres. Dans cet exemple, l'adresse de 6.6.6.6 est connectée deux fois, à Pivrnec dans le VPN 101 et à Damme dans le VPN 102. Nous pouvons vérifier ceci avec le ping sur un site et le debug ip icmp sur l'autre site.

Guilder#ping 6.6.6.6
   Type escape sequence to abort.
   Sending 5, 100-byte ICMP Echos to 6.6.6.6, timeout is 2 seconds:
   !!!!!
   Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

Damme#debug ip icmp
   ICMP packet debugging is on
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2
   6d22h: ICMP: echo reply sent, src 6.6.6.6, dst 201.201.201.2

Exemple de sortie de débogage

La sortie témoin qui utilise la même configuration est disponible ici.


Informations connexes


Document ID: 10468