Voix et communications unifiées : Cisco Unified Communications Manager Express

Exemple de configuration de liaison SIP Cisco CallManager Express (CME)

18 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (26 septembre 2014) | Commentaires


Contenu


Introduction

Aujourd'hui, l'industrie des télécommunications opère une transition, en passant des systèmes laborieux de commutation et des technologies de transport au transport par IP et aux périphériques réseau. La révolution de la communication IP a eu un impact commercial important pour les PME. Ces petites et moyennes entreprises se rendent compte que l'utilisation de l'IP est très efficace. En effet, la technologie IP peut exploiter sur un réseau unique les capacités de voix, de vidéo et de données, au lieu d'utiliser 3 réseaux distincts pour chacune de ces utilités. La figure 1 montre l'évolution du déploiement de la téléphonie IP vers l'utilisation de la liaison IP.

Figure 1 - Système de téléphonie IP

cme-sip-trunking-config1.gif

La technologie IP PBX commence à s'imposer dans le domaine de la technologie vocale, la technologie TDM PBX n'étant plus la solution unique de communication vocale entre deux réseaux. L'utilisation de TDM PBX s'est faite plus rare ces dernières années. IP PBX devient un investissement de plus en plus fiable, notamment pour les réseaux IP LAN et WAN. Afin de se connecter au RTPC, PBX nécessite un type de liaison, tel que TDM (T1/E1) ou une ligne analogique. IP PBX peut accéder au RTPC à l'aide de ces types de liaisons, mais nécessite une passerelle multimédia chargée de convertir le trafic vocal IP en RTPC traditionnel, ce qui peut parfois amener à une traduction successive d'un domaine IP vers un domaine TDM. Ces traductions successives entraînent une augmentation des coûts de maintenance des passerelles, de la latence, ainsi qu'une réduction de la qualité vocale.

Afin d'éviter ces problèmes, IP PBX utilise des protocoles pour l'initialisation de session et la gestion, dont le plus important est le Protocole d'initiation de session (SIP). Ce document fournit une description sur la liaison SIP et le Cisco CallManager Express (CME), ainsi qu'une configuration pour mettre en application un système de téléphonie IP avec le CME à l'aide d'une liaison SIP pour les appels entrants et sortants.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • CME version 4.1 est installé

  • Une image du logiciel Cisco IOS® version 12.4(11)XJ ou IOS 12.4(6th)T est installée sur le routeur

  • Un module NM-CUE est installé avec la version 2.3.4 du logiciel CUE.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur Cisco 3825 avec le logiciel Cisco IOS Version 12.4(11)XJ

  • Commutateur Cisco Catalyst 3550 avec logiciel Cisco IOS Version 12.4

  • Téléphone Cisco IP 7960

  • Cisco CallManager Express 4.1

  • Cisco Unity Express 2.3.4

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Protocole SIP

SIP est un protocole de contrôle de la couche applicative basé sur la norme ASCII et pouvant être utilisé pour passer, conserver, et mettre fin à des appels vers deux destinations ou plus. Le SIP est rapidement devenu un protocole standard pour les transmissions IP, car il agit en tant que protocole multimédia et peut servir à la transmission de sessions vidéos et de messagerie instantanée, en plus de la voix. En outre, le SIP peut gérer les conférences vocales, les diffusions et les sessions linéaires. Le SIP a un grand potentiel pour transformer et développer les moyens de communication actuels. Ainsi, Cisco joue continue de jouer un rôle important dans la création de nouvelles technologies vouées à devenir le standard des communications IP pour SIP et ses différentes applications.

Les liaisons SIP sont similaires à une ligne téléphonique, à l'exception qu'elles passent par le réseau IP, pas par le RTPC. En outre, les liaisons SIP permettent la convergence de la voix et des données sur les connexions communes de toutes les connexions IP. Afin d'accéder au réseau IP à l'aide d'une liaison SIP, il est nécessaire que les configurations soient définies aussi bien par le fournisseur de service que par les clients. Les clients doivent installer et configurer CME, le PBX qui interprétera convenablement le signal SIP et fera passer le trafic avec succès. Le fournisseur de service doit configurer un serveur proxy SIP. Cependant, les liaisons SIP sont plus compliquées à établir que les liaisons traditionnelles RTPC. En effet, les clients font face à de nouveaux défis en gérant les différentes traductions et mises en application du SIP par constructeurs. Ainsi, la sécurité, la gestion de la qualité de service (QoS), la traduction d'adresses réseau (NAT), la configuration de pare-feu, la continuité des services et la fiabilité du niveau de transport sont garantis.

Ces points décrivent pourquoi les liaisons SIP deviennent si importants dans les PME :

  • Déploiement rapide et facile

  • Utilisation de la capacité du réseau améliorée

  • Potentiel pour consolider et diminuer les coûts de téléphonie

  • Economical Direct Inward Dial (DID)

  • Continuité dans les affaires

Prise en charge de liaison CME SIP

Cisco CME est une solution de téléphonie IP qui est directement intégrée dans le logiciel Cisco IOS. CME permet aux petites et moyennes entreprises de déployer des systèmes vocaux, de données et de vidéo sur une seule plate-forme. Un réseau de téléphonie IP est simple à installer, car CME fonctionne sur un seul routeur, ce qui offre une fonctionnalité PBX pour les entreprises. Par conséquent, en utilisant CME, les petites et moyennes entreprises peuvent adopter la téléphonie IP et le routage des données en utilisant une solution de convergence et unique, et ce à un coût minime.

Relai DMTF pour les liaisons SIP

CME a commencé à prendre en charge la liaison SIP dès la version CME 3.1. Cependant, certains problèmes existaient déjà lorsqu'un téléphone SIP appelait un téléphone SCCP ou tentait d'accéder à la messagerie vocale. Le problème est que les téléphones SCCP connectés à CME nécessitent l'utilisation d'un relai DTMF hors-bande pour le transport de DTMF (chiffres) à travers les connexions VoIP. Or, les téléphones SIP utilisent un transport intrabande. Une distorsion du DTMF se produisait entre les deux périphériques. Lorsque CME 3.2 est sorti, la prise en charge de ce problème a été ajoutée au relais DTMF. Les chiffres DTMF du SCCP ont pu être convertis en mécanisme de relai DTMF intrabande via RFC2833 ou en méthodes de notification.

CME prend actuellement en charge la liste suivante d'interconnexion DTMF SIP pour les appels SIP :

  • Annoncez <------> Notification depuis 12.4(4)T

  • RFC2833 <------> Notification depuis 12.4(4)T

  • Annoncez <------> RFC2833 depuis 12.4(4)T

  • Intrabande G711 <------> depuis 12.4(11)T [exige un transcodeur]

CME prend actuellement en charge cette interconnexion DTMF pour les appels SIP SCCP :

  • Hors-bande SCCP - Notification SIP/RFC2833 depuis 12.4(4)T

Prise en charge de codec et transcodage

Un autre aspect important à considérer lorsque vous configurez une liaison SIP est la prise en charge des codecs. Les codecs représentent le code de modulation d'impulsions d'échantillonnage pour les signaux à fréquences vocales. Les liaisons SIP prennent en charge ces codecs : G.711 et G.729. Toutefois, pour différentes fonctionnalités telles que Cisco Unity Express (CUE) et Music on Hold (MOH), seul le codec G.711 est pris en charge. Cela signifie que les appels vocaux qui utilisent les liaisons SIP avec le codec G.729 ne peuvent pas accéder à CUE, sauf si un transcodeur existe pour permettre la compression et la décompression des flux vocaux afin de correspondre aux capacités CUE. MOH peut également utiliser le codec G.729 pour économiser la bande passante, mais ce dernier ne fournit pas une qualité suffisante aux flux MOH. Cela est dû au fait que G.729 est optimisé pour la parole. Par conséquent, vous devez forcer MOH à utiliser G.711.

Renvoi d'appel

Lorsqu'un appel arrive sur une liaison SIP puis est réexpédié (CFNA / CFB / CFA), alors le comportement par défaut de CME consiste à envoyer le message SIP 302 « Moved Temporarily » au fournisseur de services (SP) proxy. La partie utilisateur de l'en-tête Contact dans le message 302 pourrait nécessiter une traduction pour correspondre à un appel DID pour lequel le proxy peut assurer la redirection. La partie hôte de l'en-tête Contact dans le message 302 devrait être modifié pour tenir compte de l'adresse de l'enregistrement (AOR), à l'aide de l'interface de ligne de commande host-registrar dans sip-ua et l'interface de ligne de commande b2bua sur l'appareil VoIP dirigé vers CUE.

Certains proxys SIP pourrait ne pas prendre en charge ces fonctionnalités. Dans ce cas, vous devez ajouter ceci :

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip moved-temporarily

La figure 2 illustre le comportement du système CME lorsque le message 302 est désactivé.

Figure 2 - Flux de renvoi automatique d'appel (CFB) avec message 302 désactivé

/image/gif/paws/91535/cme-sip-trunking-config2.gif

Cette méthode permettra d'intercepter les messages SIP 302 pour les renvois d'appel sur le CME. Ce qui précède est également requis si certaines extensions n'ont pas de mapping DID, d'autant que le proxy du fournisseur de services ne peut pas toujours savoir comment rediriger ces appels. Si vous désactivez la réponse 3xx, l'initiateur de numéro appelant peut être utilisé pour préserver l'ID de visiteur de l'appelant initial.

Transfert d'appel

Lorsqu'un appel passe d'une liaison SIP à un téléphone SCCP ou CUE AutoAttendant (AA) puis est transféré, le CME par défaut enverra un message SIP REFER au proxy du fournisseur de services. La plupart des serveurs proxy fournisseur de services ne supportent pas la méthode REFER. Ce doit être configuré afin de forcer le CME à intercepter l'appel :

Router(config)#voice service voip
Router(conf-voi-serv)#no supplementary-service sip refer

La figure 3 décrit le comportement du système lorsque la méthode CME REFER est désactivée.

Figure 3- Transfert avec REFER désactivé

cme-sip-trunking-config3.gif

Si REFER est supportée sur le proxy SIP, la partie utilisateur Refer-To et Referred-By doit être traduite par un appel DID compris par le proxy. La partie hôte des champs Refer-To et Referred-By doit être une adresse IP ou DNS vers laquelle le proxy peut effectuer un routage (c'est le cas par défaut sur CME 4.1).

Suspension d'appel

Si un téléphone SCCP passe un appel de RTPC sur HOLD, le CME modifiera localement le média utilisé. Aucun message SIP n'est envoyé sur la liaison SIP. La musique en attente (Music on Hold) sera diffusée à l'utilisateur à travers la liaison SIP en tenant compte de la configuration CME.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/91535/cme-sip-trunking-config4.gif

Configurations

Ces éléments de configuration fournissent un aperçu des étapes nécessaires pour configurer votre CME avec des liaisons SIP :

  • Éléments d'infrastructure : Interfaces, TFTP et services DHCP, NTP, etc

  • Service de téléphonie : Active le contrôle d'appel « PBX » IOS sur la plate-forme CME, dont les éléments de gestion du téléphone.

  • Ephones et Ephones-dns : Définissez les téléphones IP et leurs numéros de téléphone

  • Plan de numérotation : Dial-peers, extensions, règles de traduction vocale

  • Configuration SIP IOS : Permet la liaison SIP, l'enregistrement de téléphone avec le proxy SIP, l'acheminement des appels sur des liaisons, etc

  • Prise en charge de messages vocaux : Cisco Unity Express

  • Configuration des commutateurs Catalyst : Adresse IP, interfaces, etc

Il s'agit de la configuration complète nécessaire pour déployer un système CME continu avec des liaisons SIP :

Routeur - Configuration CME
!
AUSNML-3825-01#show run
Building configuration...

Current configuration : 8634 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AUSNML-3825-01
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$vBU1$MCMG1rXM5ejME8Wap6W0H1
!
no aaa new-model
clock timezone central -8
clock summer-time central recurring
ip cef
!

!--- DHCP Configuration ---

ip dhcp pool Voice
   network 172.22.100.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.100.1 
!
ip dhcp pool Data
   network 172.22.101.0 255.255.255.0
   option 150 ip 172.22.1.107 
   default-router 172.22.101.1 
!
!
ip domain name cisco.com
ip name-server 205.152.0.20
multilink bundle-name authenticated
!
voice-card 0
 no dspfarm
!
!
!
!

!--- Voice Class and Service VoIP Configuration ---

voice service voip 
 allow-connections sip to sip
 no supplementary-service sip moved-temporarily

!---Disable 302 sending

 no supplementary-service sip refer

!---Disable REFER sending

 sip
  registrar server expires max 3600 min 3600
  localhost dns:domain.test.com 
!
!
voice class codec 1
 codec preference 1 g711ulaw
!
!
!
!
!
!
!
!
!
!
!

!--- Voice Translation Rules ---

voice translation-rule 1
 rule 1 /5123781291/ /601/

!--- An inbound rule for AA pilot "601

 rule 2 /5123781290/ /600/

!--- An inbound rule for the voicemail pilot "600"

!
voice translation-rule 2
 rule 1 /^911$/ /911/

!--- An outbound rule to allow "911"

 rule 2 /^9\(.*\)/ /\1/


!--- An outbound rule to strip "9" from PSTN calls

!
voice translation-rule 3
 rule 1 /^.*/ /5123781291/

!--- An outbound rule to change calling-number CLID to a
!--- "main" number

!
voice translation-rule 4
 rule 1 /^9(.......)$/ /512\1/

!--- An outbound rule to add areacode for local calls

 rule 2 /600/ /5123788000/

!--- An outbound rule to present the voicemail pilot extension as DID

 rule 3 /601/ /5123788001/

!--- An outbound rule to present the AA pilot extension as DID

 rule 4 /^2(..)$/ /51237812\1/

!--- An outbound rule to support transfers and call-forwards

 rule 5 /^9(.*)/ /\1/

!--- An outbound rule to strip "9" from "9+" transfers and call-forwards

!
!
voice translation-profile CUE_Voicemail/AutoAttendant

!--- Applied to the inbound dial-peers for CUE

 translate called 1
!
voice translation-profile PSTN_CallForwarding

!--- Applied to CUE dial-peers

 translate redirect-target 4
 translate redirect-called 4
!
voice translation-profile PSTN_Outgoing

!--- Applied to all outbound dial-peers

 translate calling 3
 translate called 2
 translate redirect-target 4
 translate redirect-called 4
!
!
!
!
!
!
!
vlan internal allocation policy ascending
!
!
!
!

!--- Internet Connection Configuration ---

interface GigabitEthernet0/0
 no ip address
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface GigabitEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 172.22.1.71 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 172.22.101.1 255.255.255.0
!
interface GigabitEthernet0/0.100
 encapsulation dot1Q 100
 ip address 172.22.100.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
 media-type rj45
 no keepalive
!
interface Service-Engine1/0
 ip unnumbered GigabitEthernet0/0.1
 service-module ip address 172.22.1.253 255.255.255.0
 service-module ip default-gateway 172.22.1.71
!
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip route 172.22.1.253 255.255.255.255 Service-Engine1/0
!
!
ip http server
no ip http secure-server
!
!
!

!--- TFTP Server Configuration  ---

tftp-server flash:P0030702T023.bin
tftp-server flash:P0030702T023.loads
tftp-server flash:P0030702T023.sb2
tftp-server flash:P0030702T023.sbn
!
control-plane
!
!
!
!
!
!
!

!--- SIP Trunk Configuration ---

dial-peer voice 1 voip
 description **Incoming Call from SIP Trunk**
 translation-profile incoming CUE_Voicemail/AutoAttendant
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 incoming called-number .%
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 2 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9........
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 3 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 4 voip
 description **Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[0-1][2-9]..[2-9]......
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 5 voip
 description **911 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 6 voip
 description **Emergency Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9911
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 7 voip
 description **911/411 Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9[2-9]11
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 8 voip
 description **International Outgoing Call to SIP Trunk**
 translation-profile outgoing PSTN_Outgoing
 destination-pattern 9011T
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!
dial-peer voice 9 voip
 description **Star Code to SIP Trunk**
 destination-pattern *..
 voice-class codec 1
 voice-class sip dtmf-relay force rtp-nte
 session protocol sipv2
 session target sip-server
 dtmf-relay rtp-nte
 no vad
!
!
!

!--- Voicemail Configuration ---

dial-peer voice 10 voip
 description **CUE Voicemail**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 600
 b2bua

!--- Used by CME to send its IP address to SP proxy instead of CUE

 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify

!--- This can also be RFC2833 going to CUE

 codec g711ulaw

!--- CUE only supports G711ulaw as the codec

 no vad

!--- With VAD enabled, messages left on CUE could be blank or poor quality

!
!
!
dial-peer voice 11 voip
 description **CUE Auto Attendant**
 translation-profile outgoing PSTN_CallForwarding
 destination-pattern 601
 b2bua
 session protocol sipv2
 session target ipv4:172.22.1.155
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
!

!--- SIP UA Configuration ---

sip-ua 
 authentication username 5123781000 password 075A701E1D5E415447425B
 no remote-party-id
 retry invite 2
 retry register 10
 retry options 0
 timers connect 100
 registrar dns:domain.test.com expires 3600
 sip-server dns:domain.test.com
  host-registrar
!
!

!--- CME Telephony Service Configuration ---

telephony-service
 no auto-reg-ephone
 load 7960-7940 P0030702T023
 max-ephones 168
 max-dn 500
 ip source-address 172.22.1.107 port 2000
 calling-number initiator

!--- Preserves the caller-id of a call when transferred or forwarded

 dialplan-pattern 1 51237812.. extension-length 3 extension-pattern 2.. no-reg
 voicemail 600
 max-conferences 12 gain -6
 call-forward pattern .T
 call-forward system redirecting-expanded

!--- Enables translation rule features for call-forwarding

 moh music-on-hold.au
 transfer-system full-consult dss
 transfer-pattern 9.T
 secondary-dialtone 9
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!

!--- Ephone and Ephone-dn Configuration ---

ephone-dn  11  dual-line
 number 201 secondary 5123781201 no-reg both

!---"no-reg both" means do not try to register either extension with SP SIP Proxy

 name John Smith
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  12  dual-line
 number 202 secondary 5123781202 no-reg both
 name Enrique Zurita
 call-forward busy 600
 call-forward noan 600 timeout 15
!
!
ephone-dn  13
 number 5123788000
 description **DID Number for Voicemail**
!
!
ephone-dn  14
 number 5123788001
 description **DID Number for Auto Attendant*
!
!
ephone-dn  15
 number 8000... no-reg primary
 mwi on
!
!
ephone-dn  16
 number 8001... no-reg primary
 mwi off
!
!
ephone  1
 mac-address 0008.A371.28E9
 type 7960
 button  1:11
!
!
!
ephone  2
 mac-address 0008.A346.5C7F
 type 7960
 button  1:12
!
!
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
line vty 0 4
 password ut69coe
 login
!
scheduler allocate 20000 1000
ntp server 172.22.1.107
!
end

Routeur - Configuration CUE
se-172-22-1-253#show run
 
Generating configuration:


clock timezone America/Chicago

hostname se-172-22-1-253

ip domain-name localdomain



groupname Administrators create
groupname Broadcasters create


!--- Users ---

username Enrique create
username John create
username Enrique phonenumberE164 "5123781202"
username John phonenumberE164 "5123781201"
username Enrique phonenumber "202"
username John phonenumber "201"


!--- AutoAttendant ---

ccn application autoattendant
 description "**AutoAttendant**"
 enabled
 maxsessions 4
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "operExtn" "601"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "disconnectAfterMenu" "false"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "businessSchedule" "systemschedule"
 parameter "MaxRetry" "3"
 end application


!--- MWI ---

ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "CallControlGroupID" "0"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 end application


!--- Voicemail ---

ccn application voicemail
 description "**Voicemail**"
 enabled
 maxsessions 4
 script "voicebrowser.aef"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 end application


!--- SIP ---

ccn subsystem sip
 gateway address "172.22.100.1"

!--- Must match the "ip source-address" in telephony-service

 dtmf-relay sip-notify
 mwi sip outcall

!--- Subscribe / Notify and Unsolicited Notify have not been tested

 transfer-mode blind bye-also

!--- Testing with REFER method on CUE has caused certain call flows to break

 end subsystem


!--- Trigger Phones ---

ccn trigger sip phonenumber 600
 application "voicemail"
 enabled
 maxsessions 4
 end trigger

ccn trigger sip phonenumber 601
 application "autoattendant"
 enabled
 maxsessions 4
 end trigger

service phone-authentication
 end phone-authentication

service voiceview
 enable
 end voiceview


!--- Voicemail Mailboxes ---

voicemail default mailboxsize 21120
voicemail broadcast recording time 300

voicemail mailbox owner "Enrique" size 300
 description "**Enrique_Mailbox**"
 expiration time 10
 messagesize 120
 end mailbox

voicemail mailbox owner "John" size 300
 description "**John'sMailbox**"
 expiration time 10
 messagesize 120
 end mailbox

end

Configuration du commutateur

!--- Interface Connected to CME/CUE Router ---

interface FastEthernet0/2
 description Trunk to 3825
 switchport trunk encapsulation dot1q
 switchport mode trunk
 no ip address
 duplex full
 speed 100


!--- Interfaces Connected to the IP Phones ---

interface FastEthernet0/7
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20

!--- Data Traffic ---

 switchport mode trunk
 switchport voice vlan 100

!--- Voice Traffic ---

 no ip address
 spanning-tree portfast


interface FastEthernet0/8
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 20
 switchport mode trunk
 switchport voice vlan 100
 no ip address
 spanning-tree portfast
 

!--- IP Address ---

interface Vlan1
 ip address 172.22.1.194 255.255.255.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.22.1.1
ip http server

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Dépannage de l'enregistrement

Les commandes pour le dépannage de liaison SIP sur CME sont similaires aux commandes que vous utilisez pour le dépannage IOS SIP GW et CME. Utilisez ces commandes afin de contrôler si votre nom de domaine est enregistré :

  • show sip-ua register status - Utilisez cette commande pour afficher l'état des numéros E.164 enregistrés par une passerelle SIP avec un enregistreur externe principal SIP.

  • debug ccsip message - Permet le suivi des messages SPI SIP, tels que ceux échangés entre le client agent-utilisateur (UAC) et le serveur d'accès.

Dépannage de la configuration d'appel

Les commandes pour le dépannage des appels sur liaison SIP sont identiques à celles que vous utilisez pour le dépannage traditionnel de SIP GW et CME.

Commandes show :

  • show ephone registered - Vérifie l'enregistrement d'ephone.

  • show voip rtp connection - Affiche des informations sur les paquets RTP nommés par événement, comme l'identifiant de l'appelant, l'adresse IP et les ports à chaque extrémité.

  • show sip-ua call - Affiche les UAC actifs et les informations sur le serveur d'agent utilisateur (UAS) pour les appels SIP.

  • show call active voice brief - Affiche les informations sur les appels voix ou fax actifs en cours.

Commandes de débogage :

  • debug ccsip message - Permet le suivi des messages SPI SIP, tels que ceux échangés entre le client agent-utilisateur (UAC) et le serveur d'accès.

  • debug voip ccapi inout - Trace le chemin d'exécution à travers l'API de contrôle des appels.

  • debug voice translation - Contrôle le bon fonctionnement d'une règle de traduction.

  • debug ephone detail mac-address <adresse mac du téléphone> - Permet de définir un débogage détaillé pour un téléphone IP Cisco.

  • debug voip rtp session named-events - Active le débogage pour les paquets d'événements nommés du protocole Real-Time Transport Protocol (RTP).

  • debug sccp message - affiche la séquence des messages SCCP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 91535