Interfaces et modules Cisco : Modules de réseau Cisco

Exemple de configuration du module de réseau EtherSwitch (ESW)

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour le module réseau EtherSwitch installé dans le routeur à services intégrés. Ce document n'aborde pas l'exemple de configuration pour le module de service EtherSwitch.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur de gamme Cisco 2800 sur la version de logiciel 12.4 ou ultérieures de Cisco IOSÝ

  • Module réseau d'EtherSwitch du port 10/100 NM-16ESW-PWR= 16 (nanomètre)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec les versions de matériel et de logiciel suivantes :

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Modules d'EtherSwitch - Concepts

Il y a deux types de modules d'EtherSwitch disponibles pour Cisco ISR. Elles sont :

  • Module réseau d'EtherSwitch (ESW)

  • Module de service EtherSwitch (es)

Des modules ESW sont configurés par IOS du routeur. Ces modules n'exécutent pas le logiciel distinct. Le logiciel est intégré dans l'IOS de routeur hôte. Vous pouvez créer des VLAN, configurez des VLAN, spanning-tree, le VLAN trunking protocol (VTP), et ainsi de suite du routeur hôte. Le routeur enregistre également le fichier de base de données VLAN (vlan.dat) dans l'éclair. Ce document affiche l'exemple de configuration pour le module ESW.

Les modules es ont leurs propres processeurs, moteurs de commutation et mémoire flash qui exécutent l'indépendant des ressources en routeur hôte. Après que le module es soit installé dans le routeur, vous pouvez consoler dans le module es du routeur hôte. Alors vous pouvez créer des VLAN, configurez des VLAN, spanning-tree, VTP, et ainsi de suite du module es. Des modules es sont basés sur la plate-forme de Catalyst 3750.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/82156/ether-switch-nm-config-1.gif

Configurations

Ce document utilise les configurations suivantes :

Configurez les interfaces VLAN

Par défaut tous les ports appartiennent à VLAN1. Vous pouvez créer des VLAN seulement de mode de base de données VLAN. Après que les VLAN soient créés du mode de base de données VLAN, le fichier vlan.dat est créé et enregistré dans le système de fichiers Flash du routeur. Vous pouvez visualiser les VLAN utilisant la commande de showvlan-commutateur. Dans cet exemple, un serveur du protocole DHCP (DHCP) (172.16.10.20) se trouve dans le VLAN 10. La commande d'iphelper-adresse est configurée sur tous les VLAN excepté VLAN 10 afin d'obtenir l'adresse IP du serveur DHCP aux périphériques situés à ces VLAN.

Router1

Create VLANs


Router1#vlan database
Router1(vlan)#vlan 10
VLAN 10 added:
    Name: VLAN0010
Router1(vlan)#vlan 51
VLAN 51 added:
    Name: VLAN0051
Router1(vlan)#vlan 50
VLAN 50 added:
    Name: VLAN0050
Router1(vlan)#vlan 100
VLAN 100 added:
    Name: VLAN0100
Router1(vlan)#vlan 200
VLAN 200 added:
    Name: VLAN0200
Router1(vlan)#exit
APPLY completed.
Exiting....
Router1#



Configure VLANs


Router1(config)#interface vlan 10
Router1(config-if)#ip address 172.16.10.1 255.255.255.0

Router1(config-if)#interface vlan 50
Router1(config-if)#ip address 172.16.50.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 51
Router1(config-if)#ip address 172.16.51.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 100
Router1(config-if)#ip address 172.16.100.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1(config-if)#interface vlan 200
Router1(config-if)#ip address 172.16.200.1 255.255.255.0
Router1(config-if)#ip helper-address 172.16.10.20

Router1#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/2, Fa1/3, Fa1/4, 
                                                Fa1/5, Fa1/6, Fa1/7, Fa1/8,
                                                Fa1/9, Fa1/10, Fa1/11, Fa1/12
                                                Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active    
50   VLAN0050                         active    
51   VLAN0051                         active    
100  VLAN0100                         active    
200  VLAN0200                         active    
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0   
50   enet  100050     1500  -      -      -        -    -        0      0   
51   enet  100051     1500  -      -      -        -    -        0      0   
100  enet  100100     1500  -      -      -        -    -        0      0   

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
200  enet  100200     1500  -      -      -        -    -        0      0   
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0   
1005 trnet 101005     1500  -      -      1        ibm  -        0      0   

Configurez le VTP, le joncteur réseau, le Port canalisé, et le spanning-tree

Par défaut, le mode VTP est le serveur et le nom de domaine est vide. Le VTP peut être configuré seulement du mode de base de données VLAN. Le seul spanning-tree mode pris en charge est PVST+. L'encapsulation de jonction par défaut est dot1q. Quand vous configurez le port de joncteur réseau pour permettre seulement des VLAN spécifiés, vous pourriez recevoir un message d'erreur qui indique la mauvaise liste permise par VLAN. Dans ce cas, vous pourriez devoir permettre au par défaut VLAN 1-2, 1002-1005 avec votre liste de la coutume VLAN. Pour cette raison, vous devez également permettre au par défaut VLAN et à votre coutume VLAN sur le commutateur connecté voisin à ce port de joncteur réseau pour éviter des incohérences de joncteur réseau.

Router1

VTP Configuration


Router1#vlan database
Router1(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.
Router1(vlan)#vtp domain LAB
Changing VTP domain name from NULL to LAB
Router1(vlan)#exit
APPLY completed.
Exiting....



Spanning-Tree Configuration


Router1(config)#spanning-tree vlan 1 root primary
Router1(config)#spanning-tree vlan 10 root primary
Router1(config)#spanning-tree vlan 50 root primary
Router1(config)#spanning-tree vlan 51 root primary
Router1(config)#spanning-tree vlan 100 root primary
Router1(config)#spanning-tree vlan 200 root primary



Trunk and Port Channel Configuration


Router1(config)#interface port-channel 1
Router1(config-if)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if)#switchport trunk allowed vlan 100,200
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Command rejected: Bad VLAN allowed list. You have to include all default vlans,
e.g. 1-2,1002-1005.
Router1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#switchport mode trunk

!--- dot1q is the default encapsulation.

Router1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Router1(config-if-range)#channel-group 1 mode on
Router1(config-if-range)#exit

Access1

Access1 Switch Configuration


Access1(config)#vlan 100,200
Access1(config-vlan)#exit

Access1(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.

Access1(config)#vtp domain LAB
Changing VTP domain name from NULL to LAB

Access1(config)#interface port-channel 1
Access1(config-if)#switchport trunk encapsulation dot1q
Access1(config-if)#switchport mode trunk
Access1(config-if)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if)#exit

Access1(config)#interface range FastEthernet 0/1 - 2
Access1(config-if-range)#switchport trunk encapsulation dot1q
Access1(config-if-range)#switchport mode trunk
Access1(config-if-range)#switchport trunk allowed vlan 1,1002-1005,100,200
Access1(config-if-range)#channel-group 1 mode on
Access1(config-if-range)#exit

Router1#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 52
Number of existing VLANs        : 10
VTP Operating Mode              : Transparent
VTP Domain Name                 : LAB
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0x8D 0x71 0x37 0x29 0x6C 0xB0 0xF2 0x0E
Configuration last modified by 172.22.1.197 at 2-20-07 22:31:06
Router1#
Router1#show interface fastethernet 1/0 trunk

Port      Mode         Encapsulation  Status        Native vlan
Fa1/0     on           802.1q         trunk-inbndl  1
                                      (Po1)

Port      Vlans allowed on trunk
Fa1/0     1,100,200,1002-1005

Port      Vlans allowed and active in management domain
Fa1/0     1,100,200

Port      Vlans in spanning tree forwarding state and not pruned
Fa1/0     1,100,200
Router1#show spanning-tree summary
Root bridge for: VLAN1, VLAN10, VLAN50, VLAN51, VLAN100, VLAN200.
PortFast BPDU Guard is disabled
UplinkFast is disabled
BackboneFast is disabled

Name                 Blocking Listening Learning Forwarding STP Active
-------------------- -------- --------- -------- ---------- ----------
VLAN1                0        0         0        1          1
VLAN10               0        0         0        1          1
VLAN50               0        0         0        1          1
VLAN51               0        0         0        1          1
VLAN100              0        0         0        1          1
VLAN200              0        0         0        1          1
-------------------- -------- --------- -------- ---------- ----------
             6 VLANs 0        0         0        6          6

Configurez les ports d'accès

La configuration de port d'accès est semblable à la configuration standard de commutateur de RÉSEAU LOCAL.

Router1

Port for Server Configuration


Router1(config)#interface fastEthernet 1/2
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 10
Router1(config-if)#spanning-tree portfast
Router1(config-if)#speed 100
Router1(config-if)#duplex full
Router1(config-if)#exit



Port for Printer Configuration


Router1(config)#interface fastethernet 1/3
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#spanning-tree portfast
Router1(config-if)#exit

Configurez le port vocal

La configuration de port vocal est semblable à la configuration standard de commutateur de RÉSEAU LOCAL.

Router1

Configure the port for Voice

Router1(config)#interface fastethernet 1/4
Router1(config-if)#switchport mode access
Router1(config-if)#switchport access vlan 51
Router1(config-if)#switchport voice vlan 50
Router1(config-if)#spanning-tree portfast
Router1(config-if)#mls qos trust cos

Configurez le Qualité de service (QoS)

C'est la configuration QoS par défaut sur le module ESW :

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8
wrr-queue bandwidth is disabled

Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4
wrr-queue cos map is disabled

Router1#show mls qos maps cos-dscp
   Cos-dscp map:
        cos:   0  1  2  3  4  5  6  7
     --------------------------------
       dscp:   0  8 16 26 32 46 48 56

Router1#show mls qos maps dscp-cos

   Dscp-cos map:
       dscp:   0  8 10 16 18 24 26 32 34 40 46 48 56
     -----------------------------------------------
        cos:   0  1  1  2  2  3  3  4  4  5  5  6  7

Ces sections expliquent ces configurations :

Configurez les files d'attente de wrr

Vous ne pouvez pas configurer QoS basé sur port sur les ports de commutateur de la couche 2. Des files d'attente peuvent être configurées seulement d'une configuration globale. L'exemple de configuration trace les valeurs CoS aux quatre files d'attente différentes. Quand un paquet entre dans l'engine de la couche 2 directement d'un port de commutateur, il est placé dans une de quatre files d'attente dans le dynamique, le tampon mémoire 32 partagé par Mo. En expriment des paquets de support qu'entré des Téléphones IP de Cisco sur la Voix VLAN sont automatiquement placés dans le plus prioritaire (file d'attente 4) basée sur la valeur 802.1p (cos 5) généré par le téléphone IP. Les files d'attente sont alors entretenues sur une base pesée de la recherche séquentielle (WRR). Le trafic de contrôle, qui utilise le cos ou le Type de service (ToS) de 3, est placé dans la file d'attente 3.

Router1
Router1(config)#wrr-queue cos-map 1 0 1
Router1(config)#wrr-queue cos-map 2 2
Router1(config)#wrr-queue cos-map 3 3 4
Router1(config)#wrr-queue cos-map 4 5 6 7

!--- wrr-queue cos-map <queue-number> <cos values separated by space>

Router(config)#wrr-queue bandwidth 1 16 64 255

!--- wrr-queue bandwidth <Weight of Queue1> <Weight of Queue2> 
!--- <Weight of Queue3> <Weight of Queue4>

Vérifiez les paramètres de file d'attente :

Router1#show wrr-queue bandwidth
WRR Queue  :   1   2   3   4

Bandwidth  :   1   2   4   8 

!--- Default values


WRR Queue  :   1   2   3   4

Bandwidth  :   1  16  64 255 

!--- Configured values


Router1#show wrr-queue cos-map
CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  2  3  3  4  4  

!--- Default values

CoS Value      :  0  1  2  3  4  5  6  7

Priority Queue :  1  1  2  3  3  4  4  4  

!--- Configured values

Cette table affiche le nombre de file d'attente, la valeur CoS et le poids de chaque file d'attente après la configuration.

Numéro de la file d'attente Valeur CoS Poids
1 0 1 1
2 2 16
3 3 4 64
4 5 6 7 255

Configurez le port pour faire confiance au cos

Router1
Router1(config)#interface fastethernet1/4
Router1(config-if)#mls qos trust cos

!--- Trust the CoS value of the frames from the IP phone.

Router1(config-if)#mls qos cos override

!--- Reset the CoS value of the frames from PC to 0.

Router1(config-if)#exit

Router1(config)#interface range fastEthernet 1/0 - 1
Router1(config-if-range)#mls qos trust cos

!--- Trust the CoS value of the frames from this trunk link.

Router1(config-if-range)#exit

Configurez le régulateur

Ceci sectionne des expositions la configuration de régulateur sur l'interface fa1/2 pour limiter le trafic FTP à 5 Mbits/s.

Router1
Router1(config)#ip access-list extended ACTIVE-FTP
Router1(config-ext-nacl)#permit tcp any any eq ftp
Router1(config-ext-nacl)#permit tcp any any eq ftp-data
Router1(config-ext-nacl)#exit
Router1(config)#class-map ACTIVE-FTP-CLASS
Router1(config-cmap)#match class ACTIVE-FTP
Router1(config-cmap)#exit
Router1(config)#policy-map ACTIVE-FTP-POLICY
Router1(config-pmap)#class ACTIVE-FTP-CLASS
Router1(config-pmap-c)#police 5000000 conform-action transmit exceed-action drop
Router1(config-pmap-c)#exit
Router1(config-pmap)#exit
Router1(config)#interface fastethernet1/2
Router1(config-if)#service-policy input ACTIVE-FTP-POLICY
Router1(config-if)#exit

Il y a peu de restrictions dans la configuration de régulateur dans les modules ESW. Ils sont répertoriés ici :

  • Des cartes de stratégie avec la classification d'ACL dans la direction de sortie ne sont pas prises en charge et ne peuvent pas être reliées à une interface à l'aide de la commande de configuration d'interface de stratégie-MAP-nom de service-policy input.

  • Dans une carte de stratégie, la classe nommée classe-par défaut n'est pas prise en charge. Le commutateur ne filtre pas le trafic basé sur la carte de stratégie définie par la commande de configuration de la carte de stratégie de classe-par défaut de classe.

  • Vous pouvez créer le policy-map et s'appliquer seulement au d'entrée des interfaces ESW. Et dans le policy-map, seulement le régulateur est pris en charge.

    Router1#show policy-map
      Policy Map FINANCE-POLICY
        Class FINANCE-CLASS
          set cos 4
    Router1(config)#interface fastethernet1/4
    Router1(config-if)#service-policy input FINANCE-POLICY
    %Error: FastEthernet1/4 Service Policy Configuration Failed.Only Police Action S
    upported
  • Il n'y a aucun soutien du maintien de l'ordre à un VLAN ou à un niveau commuté de l'interface virtuelle (SVI).

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 82156