Communication sans fil/mobilité : Réseau local sans fil (WLAN)

Exemple de configuration de QoS sur les contrôleurs de réseau local sans fil et les points d'accès légers

16 janvier 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 décembre 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration qui indique comment configurer la qualité de service (QoS) dans le réseau Cisco Unified Wireless en utilisant les contrôleurs de réseau local sans fil Cisco (WLC) et les points d'accès léger (LAP).

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base de la configuration des LAP et des WLC Cisco

  • La connaissance de la façon configurer le routage de base et le QoS dans un réseau câblé

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco 2006 WLC qui exécute la version de microprogramme 4.0

  • LAP de la gamme Cisco 1000

  • Adaptateur client sans fil Cisco 802.11a/b/g exécutant la version de microprogramme 2.6

  • Routeur de Cisco 3725 qui exécute la version de logiciel 12.3(4)T1 de Cisco IOSÝ

  • Routeur de Cisco 3640 qui exécute la version du logiciel Cisco IOS 12.2(26)

  • Deux commutateurs de la gamme Cisco 3500 XL qui exécutent le logiciel Cisco IOS version 12.0(5)WC3b

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

QoS se réfère à la capacité du réseau de fournir un meilleur ou spécial service à un ensemble d'utilisateurs ou des applications au détriment d'autres utilisateurs ou applications.

Avec QoS, la bande passante peut être gérée plus efficacement à travers des réseaux locaux, qui inclut des WLAN et des WAN. C'est comment QoS fournit le service réseau amélioré et digne de confiance :

  • Bande passante dédiée de supports pour les utilisateurs essentiels et les applications

  • Jitter et latence de contrôles (exigés par le trafic en temps réel)

  • Gère et réduit l'encombrement de réseau

  • Forme le trafic réseau pour lisser la circulation

  • Fixe des priorités du trafic réseau

Dans le passé, des WLAN ont été principalement utilisés pour transporter la faible bande passante, le trafic d'application de données. Actuellement, avec l'extension des WLAN dans la verticale (telle que le détail, les finances, et la formation) et les environnements d'entreprise, des WLAN sont utilisés pour transporter des applications de données de bande passante élevée en même temps que sensible au temps, des applications multimédias. Cette condition requise a mené à la nécessité pour QoS Sans fil.

Le groupe de travail d'IEEE 802.11e au sein du comité de normalisation d'IEEE 802.11 s'est terminé la définition standard. Cependant, l'adoption de la norme 802.11e est à ses parties, et comme avec beaucoup de normes il y a beaucoup de composants facultatifs. Juste pendant que ce qui se sont produits avec la Sécurité de 802.11 dans 802.11i, les groupes industriels tels que le Wi-Fi Alliance, et les leaders de l'industrie tels que Cisco définissent les conditions requises principales dans WLAN QoS par leurs programmes du Wi-Fi Multimedia (WMM) et des Cisco Compatibles Extension (CCX). Ceci assure la livraison des fonctionnalités principales et de l'interopérabilité par leurs programmes de certification.

Support de Produits de Cisco Unified Wireless WMM, un système de QoS basé sur l'ébauche d'IEEE 802.11e qui a été éditée par le Wi-Fi Alliance.

Le contrôleur prend en charge quatre niveaux de QoS :

  • Platine/Voix — Assure une haute qualité de service pour la Voix au-dessus de la radio.

  • Or/vidéo — Prend en charge les applications vidéo de haute qualité.

  • Argent/meilleur effort — Prend en charge la bande passante normale pour des clients. C'est la valeur par défaut.

  • Bronze/fond — Fournit la plus basse bande passante pour des services d'invité.

Des clients de la voix sur ip (VoIP) devraient être placés au platine, à l'or, ou à l'argent tandis que des clients de faible bande passante peuvent être placés pour se bronzer.

Vous pouvez configurer la bande passante de chaque niveau de QoS utilisant des profils de QoS et puis s'appliquer les profils aux WLAN. Les paramètres de profil sont poussés aux clients associés à ce WLAN. En outre, vous pouvez créer des rôles de QoS pour spécifier des niveaux de bande passante différente pour des utilisateurs de militaire de carrière et d'invité.

Pour les informations sur la façon dont configurer des profils de QoS utilisant le GUI, référez-vous utilisant le GUI pour configurer des profils de QoS.

Pour les informations sur la façon dont configurer des profils de QoS utilisant le CLI, référez-vous utilisant le CLI pour configurer des profils de QoS.

Référez-vous à la section de Cisco Unified Wireless QoS du guide de conception de mobilité d'entreprise pour plus d'informations sur la façon dont QoS fonctionne dans le réseau de Cisco Unified Wireless.

Ce document fournit un exemple de configuration qui montre comment configurer QoS sur des contrôleurs et communiquer avec un réseau câblé configuré avec QoS.

Améliorations de Marquage des paquets QoS de la couche 3

Les supports réseau de Cisco Unified Wireless posent le marquage de Differentiated Services Code Point IP 3 (DSCP) des paquets envoyés par WLCs et recouvrements. Cette caractéristique améliore comment les Points d'accès (aps) emploient ces informations de la couche 3 afin de s'assurer que les paquets reçoivent le correct au-dessus du - aèrent la hiérarchisation d'AP au client sans fil.

En architecture centralisée WLAN, des données WLAN sont percées un tunnel entre AP et le WLC par l'intermédiaire du point d'accès léger Protocol (LWAPP). Afin de mettre à jour la classification QoS d'origine à travers ce tunnel, les configurations de QoS du paquet de données encapsulé doivent être convenablement tracées à la couche 2 (802.1p) et poser 3 champs (d'IP DSCP) du paquet externe de tunnel.

Ce n'est pas les paquets possibles de Dscp-balise entre le contrôleur et le RECOUVREMENT s'il n'y a aucun DSCP ou 802.1P valeur dans le paquet d'origine lui-même.

Le contrôleur n'applique pas son propre QoS. Le support QoS sur le WLC donne au WLC la capacité d'appliquer la même priorité qui est fixée sur le fil (ou l'application).

Par conséquent, la seule action un WLC ou un AP suffira est de copier la valeur du paquet d'origine sur l'en-tête externe du paquet LWAPP. Le but entier de l'or, de l'argent, et des options de QoS de bronze sur le WLC est d'exécuter les traductions appropriées de QoS entre 802.11e/802.1p VERS LE HAUT des valeurs et des valeurs d'IP DSCP, qui dépendent de l'application ou de la norme qui est utilisée. De nouveau, QoS sur le WLC s'assure que les paquets reçoivent le QoS approprié manipulant de bout en bout. Le contrôleur n'exécute pas son propre comportement de QoS. Le support est là pour que le contrôleur suive le mouvement si QoS existe déjà et la priorité doit être appliquée aux paquets Sans fil. Vous ne pouvez pas faire exister QoS seulement sur le contrôleur.

Le contrôleur ne prend en charge pas le Classe de service (Cos) marquant des valeurs basées sur la configuration WLAN en mode de la couche 2 LWAPP. Il est recommandé pour utiliser la couche 3 LWAPP afin d'implémenter le cos QoS.

C'est un exemple de la façon dont QoS fonctionne avec WLCs. L'application, par exemple CallManager, pourrait placer une valeur de QoS de haute. Par conséquent, le paquet de données d'origine de l'application sera encapsulé par une en-tête IP qui a la valeur DCSP réglée à la haute. Maintenant, le paquet atteint le contrôleur. Ensuite, le paquet passe par le test SSID. Cependant, si vous avez un test SSID sur votre contrôleur configuré pour le bronze de profil de QoS, l'en-tête IP du paquet qui encapsule le contrôleur de formulaire de paquet LWAPP à AP, aura le bronze de valeur (bien que l'en-tête IP autour du paquet d'origine de l'application aura la haute priorité). Ce document suppose que les DCSP réglés par la demande et le profil de QoS de ce SSID sur le contrôleur sont identiques. Ce n'est pas toujours le cas.

/image/gif/paws/81831/qos-wlc-lap1.gif

Par exemple, quand le trafic 802.11e est envoyé par un client WLAN, il a une classification de priorité utilisateur () dans sa trame. AP doit tracer cette classification 802.11e dans une valeur DSCP pour le paquet LWAPP qui porte la trame. Ceci s'assure que le paquet est accordé le niveau de priorité approprié sur son chemin au WLC. Un de processus semblable doit se produire sur le WLC pour des paquets LWAPP allant à AP. En outre, un mécanisme est nécessaire pour classifier le trafic sur AP et le WLC pour des clients non-802.11e, de sorte que leurs paquets LWAPP puissent également être accordés le niveau de priorité approprié. Cette table montre comment des paquets sont manipulés à chaque périphérique :

#~# De À VERS LE HAUT DE (802.1p/802.11e) IP DSCP
1 Contrôleur Point d'accès Il ne traduit pas la valeur DSCP du paquet entrant à l'AVVID 802.1p VERS LE HAUT de la valeur. La valeur DSCP, si actuel dans le paquet, entre d'une manière transparente dans le paquet. Copiez la valeur DSCP du paquet entrant.
2 Point d'accès Client sans fil Client WMM : Traduisez la valeur DSCP du paquet entrant LWAPP au 802.11e VERS LE HAUT de la valeur. Maintenez l'ordre la valeur pour s'assurer qu'elle ne dépasse pas la valeur maximale permise pour la stratégie QoS WLAN assignée à ce client. Paquet d'endroit dans la file d'attente de Tx de 802.11 appropriée pour la valeur HAUTE. Client régulier : Paquet d'endroit dans la file d'attente par défaut de Tx de 802.11 pour la stratégie QoS WLAN assignée à ce client. NON APPLICABLE (la valeur DSCP d'origine est préservée)
3 Point d'accès Contrôleur NON APPLICABLE (les Points d'accès ne prennent en charge pas les balises 802.1Q/802.1p) Client WMM : Maintenez l'ordre le 802.11e VERS LE HAUT de la valeur pour s'assurer qu'elle ne dépasse pas la valeur maximale permise pour la stratégie QoS assignée à ce client ; traduisez la valeur à la valeur DSCP. Client régulier : Utilisez le 802.11e VERS LE HAUT de la valeur pour la stratégie QoS assignée à ce client ; traduisez la valeur à la valeur DSCP.
4 Contrôleur Commutateur ethernet Traduisez la valeur DSCP des paquets entrants LWAPP au 802.1p VERS LE HAUT de la valeur. NON APPLICABLE (la valeur DSCP d'origine est préservée)

Cette prochaine table fournit les traductions qui se produisent entre 802.11e/802.1p VERS LE HAUT des valeurs et des valeurs d'IP DSCP. Puisque l'architecture Cisco pour la Voix, le vidéo et les données intégrées (AVVID) définit la traduction de 802.1 jusqu'à l'IP DSCP, et l'IEEE définit la traduction de l'IP DSCP à 802.11e, deux ensembles différents de traductions doivent être utilisés.

Type de trafic basé sur du Cisco AVVID 802.1p IP DSCP de Cisco AVVID Cisco AVVID 802.1p IEEE 802.11e Notes
Network Control - 7 - Réservé pour le contrôle de réseau seulement
Contrôle d'interréseau 48 6 7 (AC_VO) Contrôle LWAPP
Voix 46 (E-F) 5 6 (AC_VO) Contrôleur : Profil de QoS de platine
Vidéo 34 (AF41) 4 5 (AC_VI) Contrôleur : Profil de QoS d'or
Contrôle de voix 26 (AF31) 3 4 (AC_VI) -
Meilleur effort 0 (SOYEZ) 0 3 (AC_BE) 0 (AC_BE) Contrôleur : Profil argenté de QoS -
Fond (fond d'or de Cisco AVVID) 18 (AF21) 2 2 (AC_BK) -
Fond (fond argenté de Cisco AVVID) 10 (AF11) 1 1 (AC_BK) Contrôleur : Profil en bronze de QoS

Remarque: L'IEEE 802.11e LÈVENT la valeur pour les valeurs DSCP qui ne sont pas mentionnées dans la table sont calculées en considérant 3 bits MSB de DSCP. Par exemple, l'IEEE 802.11e VERS LE HAUT de la valeur pour le DSCP 32 (100 000 dans la binaire) serait la valeur convertie par décimale du MSB (100), qui est 4. Le 802.11e VERS LE HAUT de la valeur du DSCP 32 est 4.

Configuration du réseau

Ce document utilise la configuration réseau suivante :

  • Le réseau câblé comporte des deux Routeurs, Router1 et Router2, qui exécutent l'OSPF entre eux. Les hôtes câblés comportent d'un ftp server (F1), d'un client de Voix (V1) et d'un client visuel (Vi1). Les hôtes câblés se connectent au réseau par un commutateur de la couche 2 qui est connecté à Fast Ethernet du routeur R1.

  • Le réseau Sans fil se connecte au réseau par le Router2 suivant les indications du diagramme. Les hôtes sans fil comportent d'un client FTP (non-WMM activé), d'un client V1 (7920 téléphones) de Voix et d'un client visuel Vi1 (WMM activé).

  • Des paquets vocaux devraient être accordés le plus prioritaire suivi des paquets visuels. Des paquets de FTP doivent être accordés la moins priorité.

  • Sur le réseau câblé, le Détection précoce directe pondérée (WRED) est utilisé afin d'implémenter QoS. Les différents types de trafic sont classifiés et donnés la priorité basé sur les valeurs DSCP. WRED est mis en application sur les paquets prioritaires.

  • Sur le réseau Sans fil, trois WLAN doivent être créés pour chaque type de trafic, et activer des profils appropriés de QoS.

    • WLAN 1 — Clients FTP : Profil en bronze de QoS

    • WLAN 2 — Clients visuels : Profil de QoS d'or

    • WLAN 3 — Clients de Voix : Profil de QoS de platine

Les périphériques pour la connectivité IP et l'enable de base QoS chacun des deux doivent être configurés sur le réseau câblé et le réseau Sans fil.

/image/gif/paws/81831/qos-wlc-lap4.gif

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Afin de configurer les périphériques pour cette installation, ces le besoin d'être exécuté :

Configurez le réseau sans fil pour QoS

Avant que vous configuriez QoS sur WLCs, vous devez configurer le WLC pour le fonctionnement de base et enregistrer les recouvrements au WLC. Ce document suppose que WLC est configuré pour les opérations de base et que les LAP sont enregistrés au WLC. Si vous êtes un nouvel utilisateur qui essaie d'installer le WLC pour l'opération de base avec les LAP, consultez l'Enregistrement léger AP (LAP) sur un contrôleur LAN sans fil (WLC).

Une fois les recouvrements sont enregistrés au WLC, se terminent ces tâches afin de configurer les recouvrements et le WLC pour cette installation :

  1. Configurez les WLAN pour les différentes classes du trafic

  2. Profils de QoS d'enable pour les WLAN

Terminez-vous ces étapes afin de créer un WLAN sur le WLC pour les clients de Voix :

  1. Cliquez sur WLANs depuis l'interface utilisateur graphique (GUI) du contrôleur afin de créer un WLAN.

  2. Cliquez sur New pour configurer un nouveau WLAN.

    Dans cet exemple, le WLAN est nommé VoiceClients et l'ID de WLAN est 1.

  3. Cliquez sur Apply.

    qos-wlc-lap5.gif

  4. Dans la fenêtre de WLAN > Edit, définissez les paramètres spécifiques au WLAN VoiceClients.

    1. Pour le WLAN, choisissez l'interface appropriée du champ Interface Name.

      Cet exemple trace la Voix d'interface au WLAN VoiceClients.

    2. Du Qualité de service (QoS) abaissez le menu, choisissent le profil approprié de QoS pour le WLAN.

      Dans cet exemple, le profil de QoS de platine est sélectionné. Ceci accorde le plus prioritaire à la Voix WLAN.

    3. Pour le paramètre de 7920 supports techniques par téléphone, choisissez le type de contrôle d'admission d'appel (CAC).

      Cet exemple utilise la limite AP CAC.

    4. Sélectionnez les autres paramètres, qui dépendent des conditions requises de conception.

      Les valeurs par défaut sont utilisées dans cet exemple.

    5. Cliquez sur Apply.

      qos-wlc-lap6.gif

      Remarque: N'activez pas le mode WMM si Cisco 7920 téléphones sont utilisés sur votre réseau. Vous ne pouvez pas activer le mode WMM et le mode contrôlé par le client CAC sur le même WLAN. Quand un CAC contrôlé par le AP est activé, AP envoie un élément d'information de propriété industrielle de Cisco CAC (IE) et n'envoie pas l'IE QBSS standard.

Le déploiement de la Voix au-dessus de l'infrastructure WLAN implique de fournir plus que simplement QoS sur le WLAN. Une Voix WLAN doit considérer des conditions requises de couverture d'analyse de site, des conditions requises de comportement d'utilisateur, de errer et le contrôle d'admission. Ceci est couvert des guides de conception de Téléphone IP unifié de la gamme Cisco 7900.

De même, créez les WLAN pour les clients visuels et les clients FTP. Des clients visuels sont tracés au vidéo d'interface dynamique et des clients FTP sont tracés au FTP d'interface dynamique. Ce sont les captures d'écran :

Remarque: Ce document n'explique pas comment créer des VLAN sur WLCs. Référez-vous aux VLAN sur l'exemple Sans fil de configuration de contrôleurs LAN pour les informations sur la façon dont configurer des interfaces dynamiques sur WLCs.

/image/gif/paws/81831/qos-wlc-lap7.gif

qos-wlc-lap8.gif

Remarque: Le soutien de client WLAN de WMM ne signifie pas que le trafic de client tire bénéfice automatiquement de WMM. Les applications qui recherchent les avantages de WMM assignent une classification de niveau de priorité approprié à leur trafic, et le du système d'exploitation doit passer cette classification à l'interface WLAN. Dans des périphériques spécifiques, tels que des combinés téléphoniques VoWLAN, ceci est fait en tant qu'élément de la conception. Cependant, si vous implémentez sur une plate-forme d'usage universel, telle qu'un PC, une classification du trafic de l'application et un support système d'exploitation doit être mis en application avant que les caractéristiques WMM puissent être utilisées au bon effet.

Pour les clients visuels, l'or de profil de QoS est sélectionné et WMM est activé. Pour des clients FTP, le bronze est sélectionné comme profil de QoS et WMM est désactivé parce que dans cet exemple les clients FTP ne prennent en charge pas WMM.

qos-wlc-lap9.gif

qos-wlc-lap10.gif

Remarque: Quand le contrôleur est en mode de la couche 2 et WMM est activé, vous devez mettre les aps sur un port de joncteur réseau afin de leur permettre pour joindre le contrôleur.

Émettez ces commandes afin de configurer les WLAN et le QoS sur WLC utilisant le CLI :

  • Émettez la commande de <wlan-name> de <wlan-id> de config wlan create afin de créer un nouveau WLAN. Pour le WLAN-id, écrivez un ID de 1 à 16. Pour le WLAN-nom, écrivez un SSID jusqu'à 31 caractères alphanumériques.

  • Émettez la commande de <wlan-id> de config wlan enable afin d'activer un WLAN.

  • Émettez le WLAN-id de config wlan qos {bronze | argent | or | commande de platine} afin d'assigner un niveau de QoS à un WLAN.

  • Émettez le config wlan wmm {désactivé | laissé | } commande requise de WLAN-id afin d'activer le mode WMM.

  • Émettez la client-cac-limite de config wlan 7920-support {activée | } commande handicapée de WLAN-id pour les téléphones qui exigent le CA contrôlé par le client.

  • Émettez l'AP-cac-limite de config wlan 7920-support {activée | } commande handicapée de WLAN-id pour les téléphones qui exigent le CAC contrôlé par le AP.

Configurez le réseau câblé pour QoS

Afin de configurer le réseau câblé pour cette installation, vous devez configurer les Routeurs pour la Connectivité de base et activer QoS dans le réseau câblé. L'OSPF est utilisé comme protocole de routage d'unicast.

La caractéristique WRED est utilisée pour implémenter QoS dans le réseau câblé. La caractéristique de Fonction DiffServ Compliant WRED permet à WRED d'utiliser la valeur DSCP quand elle calcule la probabilité de perte pour un paquet.

Ce sont les configurations pour les Routeurs R1 et R2 :

Router1
Router1#show run
Building configuration...

Current configuration : 2321 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router1
!
!
ip subnet-zero
!
!
!
call rsvp-sync
!

!
class-map match-all FTP

!--- Classifies FTP Packets based on Access List 103.

  match access-group 103
class-map match-all Video

!--- Classifies Video Packets based on Access List 102.

  match access-group 102
class-map match-all Voice

!--- Classifies Voice Packets based on Access List 101.

  match access-group 101
!
!
policy-map Marking-For-FTP

!--- Sets DSCP value af11 for FTP packets.

  class FTP
   set ip dscp af11
policy-map Marking-For-Voice

!--- Sets DSCP value ef for Voice packets.

  class Voice
   set ip dscp ef
policy-map Marking-For-Video

!--- Sets DSCP value af41 for Video packets.

  class Video
   set ip dscp af41
!
!
!
interface Serial2/0
 description Connected to Router2
 ip address 10.2.3.2 255.255.255.0
 random-detect dscp-based 

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

 clockrate 56000
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!
interface Serial2/4
 no ip address
 shutdown
!
interface Serial2/5
 no ip address
 shutdown
!
interface Serial2/6
 no ip address
 shutdown
!
interface Serial2/7
 no ip address
 shutdown
!
interface FastEthernet3/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet3/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 10
 ip address 192.168.0.1 255.255.0.0
 service-policy output Marking-For-Voice

!--- Applies the policy Marking-For-Voice to the interface.

!
interface FastEthernet3/0.2
 description Connected to Video Clients
 encapsulation dot1Q 20
 ip address 172.16.0.1 255.255.0.0
 service-policy output Marking-For-Video

!--- Applies the policy Marking-For-Video to the interface.

!
interface FastEthernet3/0.3
 description Connected to FTP Server
 encapsulation dot1Q 30
 ip address 30.0.0.1 255.0.0.0
 service-policy output Marking-For-FTP

!--- Applies the policy Marking-For-FTP to the interface.

!
interface FastEthernet3/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 30.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
!
ip classless
ip http server
!
access-list 101 permit ip 192.168.0.0 0.0.255.255 any

!--- Access list used to classify Voice packets.

access-list 102 permit ip 172.16.0.0 0.0.255.255 any

!--- Access list used to classify Video packets.

access-list 103 permit ip 30.0.0.0 0.0.0.255 any

!--- Access list used to classify FTP packets.

!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer cor custom
!
!
!
dial-peer voice 1 pots
 destination-pattern 4085551234
 port 1/0/0
!
!
line con 0
line aux 0
line vty 0 4
!
end

Router2
Router2#show run
Building configuration...

Current configuration : 1551 bytes
!
version 12.3
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!

!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 description Connected to Voice Clients
 encapsulation dot1Q 40
 ip address 20.0.0.1 255.0.0.0
!
interface FastEthernet0/0.2
 description Connected to Video Clients
 encapsulation dot1Q 50
 ip address 40.0.0.1 255.0.0.0
!
interface FastEthernet0/0.3
 description Connected to FTP Clients
 encapsulation dot1Q 60
 ip address 50.0.0.1 255.0.0.0
!
interface Serial0/0
 description Connected to Router1
 ip address 10.2.3.1 255.255.255.0
 random-detect dscp-based

!--- Enables WRED based on DSCP Value of the packet.

 random-detect dscp 10 30 40

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 30 and 40 packets for the DSCP value 10.

 random-detect dscp 34 40 50

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 40 and 50 packets for the DSCP value 34.

 random-detect dscp 46 50 60

!--- Sets the Minimum and Maximum Threshold of Packets 
!--- to 50 and 60 packets for the DSCP value 46.

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Service-Engine2/0
 no ip address
 shutdown
 hold-queue 60 out
!
router ospf 1

!--- Configures OSPF as the routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 20.0.0.0 0.255.255.255 area 0
 network 40.0.0.0 0.255.255.255 area 0
 network 50.0.0.0 0.255.255.255 area 0
!
ip http server
ip classless
!
!
control-plane
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
gatekeeper
 shutdown
!
!
line con 0
line 65
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line aux 0
line vty 0 4
!
!
end

Vérifiez et dépannez

Une fois que la radio et le réseau câblé sont configurés pour la Connectivité de base et QoS est mis en application, les paquets sont classifiés, marqués et envoyés basé sur les stratégies configurées pour chaque type de trafic.

L'application des caractéristiques de QoS ne pourrait pas être facilement détectée sur un réseau légèrement chargé. Le début de caractéristiques de QoS pour affecter la performance des applications à mesure que le chargement sur le réseau augmente. QoS fonctionne pour garder la latence, le jitter, et la perte pour les types de trafic sélectionnés dans des limites acceptables.

Pour un WMM activé client visuel :

Quand un client visuel du côté de câble envoie des données au client visuel du côté Sans fil, cette séquence d'opérations se produit :

  1. À l'interface FastEthernet sur Router1, la stratégie de Marquage-Pour-vidéo est appliquée aux paquets visuels et les paquets sont identifiés par une valeur DSCP d'AF41.

  2. Les paquets visuels marqués traversent les interfaces série S3/0 sur Router1 et S0/0 sur le Router2. C'est où la probabilité de perte du paquet est vérifiée contre le seuil configuré pour WRED. Quand la longueur moyenne de file d'attente atteint le seuil minimum (40 paquets dans ce cas pour les paquets visuels), WRED relâche aléatoirement quelques paquets avec la valeur DSCP AF41. De même, quand la longueur moyenne de file d'attente dépasse le seuil maximal (50 paquets dans ce cas pour les packedts visuels), WRED relâche tous les paquets avec la valeur DSCP AF41.

  3. Une fois que les paquets visuels accèdent le WLC par le fastethernet sur le Router2, le WLC traduit la valeur DSCP du paquet entrant à l'AVVID 802.1p VERS LE HAUT de la valeur et copie la valeur DSCP du paquet entrant sur le paquet LWAPP comme affiché ici. Dans cet exemple, la valeur DSCP AF41 est traduite 802.1p à la valeur correspondante 4.

    qos-wlc-lap11.gif

  4. Quand le paquet atteint le RECOUVREMENT, le RECOUVREMENT traduit la valeur DSCP du paquet entrant LWAPP au 802.11e VERS LE HAUT de la valeur et maintient l'ordre la valeur afin de s'assurer qu'il ne dépasse pas la valeur maximale permise pour la stratégie QoS WLAN assignée à ce client. Le RECOUVREMENT place alors le paquet dans la file d'attente de Tx de 802.11 appropriée pour la valeur HAUTE. Dans cet exemple, la valeur DSCP AF41 est traduite au 802.11e correspondant VERS LE HAUT de la valeur 5.

    /image/gif/paws/81831/qos-wlc-lap12.gif

Quand un client visuel du côté Sans fil envoie des données au côté de câble, cette séquence d'opérations se produit :

  1. Quand un client activé par WMM envoie un paquet au RECOUVREMENT, le RECOUVREMENT maintient l'ordre le 802.11e VERS LE HAUT de la valeur afin de s'assurer qu'il ne dépasse pas la valeur maximale permise pour la stratégie QoS assignée à ce client. Puis, il traduit la valeur à la valeur DSCP. Dans cet exemple, le vidéo WLAN a été configuré avec de l'or de profil de QoS, qui a un 802.11e VERS LE HAUT de la valeur de 4. Cette valeur est traduite à la valeur DSCP correspondante AF41 et est envoyée au contrôleur.

    /image/gif/paws/81831/qos-wlc-lap13.gif

  2. Le contrôleur traduit la valeur DSCP du paquet entrant LWAPP au 802.1p VERS LE HAUT de la valeur comme affiché et la valeur DSCP d'origine est également envoyée inchangée.

    /image/gif/paws/81831/qos-wlc-lap14.gif

  3. Les paquets avec la valeur DSCP af41 au fastethernet sur le Router2 traversent les interfaces série sur le Router2 et le Router1, et atteignent les clients visuels du côté de câble. Quand le paquet traverse les interfaces série, la probabilité de perte du paquet est vérifiée contre le seuil configuré pour WRED.

Pour un WMM client FTP désactivé :

Quand le ftp server du côté de câble envoie des données au client FTP du côté Sans fil, cette séquence d'opérations se produit :

  1. À l'interface FastEthernet sur Router1, la stratégie de Marquage-Pour-FTP est appliquée aux paquets de FTP et les paquets sont identifiés par une valeur DSCP d'AF11.

  2. Les paquets marqués de FTP traversent les interfaces série s3/0 sur Router1 et S0/0 sur le Router2. C'est où la probabilité de perte du paquet sont vérifiées contre le seuil configuré pour WRED. Quand la longueur moyenne de file d'attente atteint le seuil minimum (30 paquets dans ce cas pour des paquets de FTP), WRED relâche aléatoirement quelques paquets avec la valeur DSCP AF11. De même, quand la longueur moyenne de file d'attente dépasse le seuil maximal (40 paquets dans ce cas pour des paquets de FTP), WRED relâche tous les paquets avec la valeur DSCP AF11.

  3. Une fois que les paquets de FTP accèdent le WLC par le fastethernet sur le Router2, le WLC traduit la valeur DSCP du paquet entrant à l'AVVID 802.1p VERS LE HAUT de la valeur et copie la valeur DSCP du paquet entrant sur le paquet LWAPP comme affiché ici. Dans cet exemple, la valeur DSCP AF11 est traduite à la valeur 1 802.1p correspondante.

  4. Quand le paquet atteint le RECOUVREMENT, le RECOUVREMENT place le paquet dans la file d'attente par défaut de Tx de 802.11 pour la stratégie QoS WLAN assignée à ce client. Dans cet exemple, le paquet est placé dans la file d'attente pour le profil en bronze de QoS.

Quand un client FTP du côté Sans fil envoie des données au côté de câble, cette séquence d'opérations se produit :

  1. Quand un client FTP sur le réseau Sans fil envoie un paquet au RECOUVREMENT, le RECOUVREMENT utilise le 802.11e VERS LE HAUT de la valeur pour la stratégie QoS assignée à ce client. Puis, le RECOUVREMENT traduit la valeur à la valeur DSCP et envoie le paquet au contrôleur. Puisque le client FTP appartient au bronze de profil de QoS IEEE 802.11e VERS LE HAUT de valeur 1 est traduit à la valeur DSCP AF11.

  2. Le contrôleur traduit la valeur DSCP du paquet entrant LWAPP au 802.1p VERS LE HAUT de la valeur comme affiché et la valeur DSCP d'origine est également envoyée inchangée. Le paquet est alors expédié au Router2 par le commutateur de la couche 2.

  3. Les paquets avec la valeur DSCP AF11 au fastethernet sur le Router2 traversent les interfaces série sur le Router2 et le Router1, et atteignent les clients visuels du côté de câble. Quand le paquet traverse les interfaces série, la probabilité de perte du paquet est vérifiée contre le seuil configuré pour WRED.

Une procédure semblable se produit quand traversée de paquet vocal du de câble au réseau Sans fil et vice versa.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Vous pouvez émettre ces commandes Cisco IOS sur les Routeurs afin de dépanner et vérifier votre configuration QoS :

  • show queue {interface-nombre d'interface-nom} — Répertorie des informations sur les paquets qui attendent dans une file d'attente sur l'interface.

  • interface de random-detect de show queueing {interface-nombre d'interface-nom} — listes configuration et informations statistiques au sujet de l'outil de Mise en file d'attente sur une interface.

  • show policy-map interface {interface-nombre d'interface-nom} — Affiche les statistiques et les configurations des stratégies d'entrée et sortie qui sont reliées à une interface. Veillez à utiliser cette commande dans le mode d'exécution approprié.

    Router1#show policy-map interface F3/0.1
     FastEthernet3/0.1
    
      Service-policy output: Marking-For-Voice
    
        Class-map: Voice (match-all)
          18 packets, 1224 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: access-group 101
          QoS Set
            dscp ef
              Packets marked 18
    
        Class-map: class-default (match-any)
          2 packets, 128 bytes
          5 minute offered rate 0 bps, drop rate 0 bps
          Match: any
  • mettez au point les qos réglés — Affiche des informations sur le Marquage des paquets QoS.

Sur le WLC, émettez cette commande afin de visualiser les paramètres de profil de QoS :

  • show qos {bronze/argent/or/platine} — fournit des informations sur le profil de QoS configuré pour les WLAN.

    Voici un résultat témoin de la commande de show qos :

    (Cisco Controller) >show qos Platinum
    
    Description...................................... For Voice Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length..................................... 100
    protocol......................................... none
    
    (Cisco Controller) >show qos Gold
    
    Description...................................... For Video Applications
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  75
    protocol......................................... none
    
    (Cisco Controller) >show qos Bronze
    
    Description...................................... For Background
    Average Data Rate................................   0
    Burst Data Rate..................................   0
    Average Realtime Data Rate.......................   0
    Realtime Burst Data Rate.........................   0
    Maximum RF usage per AP (%)...................... 100
    Queue Length.....................................  25
    protocol......................................... none
  • show wlan <WLAN-ID > — Affiche des informations au sujet du WLAN. Voici un exemple de sortie :

    (Cisco Controller) >show wlan 1
    
    WLAN Identifier.................................. 1
    Network Name (SSID).............................. VoiceClients
    Status........................................... Enabled
    MAC Filtering.................................... Disabled
    Broadcast SSID................................... Enabled
    AAA Policy Override.............................. Disabled
    Number of Active Clients......................... 0
    Exclusionlist Timeout............................ 60 seconds
    Session Timeout.................................. 1800 seconds
    Interface........................................ management
    WLAN ACL......................................... unconfigured
    DHCP Server...................................... Default
    DHCP Address Assignment Required................. Disabled
    Quality of Service............................... Platinum (voice)
    WMM.............................................. Disabled
    CCX - AironetIe Support.......................... Enabled
    CCX - Gratuitous ProbeResponse (GPR)............. Disabled
    Dot11-Phone Mode (7920).......................... Disabled
    Wired Protocol................................... None
    IPv6 Support..................................... Disabled
    Radio Policy..................................... All
    Security
    
       802.11 Authentication:........................ Open System
       Static WEP Keys............................... Disabled
       802.1X........................................ Enabled
       Encryption:..................................... 104-bit WEP
       Wi-Fi Protected Access (WPA/WPA2)............. Disabled
       CKIP ......................................... Disabled
       IP Security Passthru.......................... Disabled
       Web Based Authentication...................... Disabled
       Web-Passthrough............................... Disabled
       Auto Anchor................................... Disabled
       H-REAP Local Switching........................ Disabled
       Management Frame Protection................... Enabled (Global MFP Disabled)

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 81831