Communication sans fil/mobilité : Réseau local sans fil (WLAN)

Exemple de configuration de multicast avec des contrôleurs de réseau local sans fil (WLC) et des points d'accès légers (LAP)

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 décembre 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration sur la façon de configurer les contrôleurs de réseau local sans fil (WLC) et les points d'accès léger (LAP) pour multidiffusion et transmission avec un réseau filaire activé par multidiffusion.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base de la configuration des LAP et des WLC Cisco

  • La connaissance de la façon configurer le routage et la multifusion de base dans un réseau câblé

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • WLC Cisco 4400 exécutant la version de microprogramme 4.0

  • LAP de la gamme Cisco 1000

  • Adaptateur client sans fil Cisco 802.11a/b/g exécutant la version de microprogramme 2.6

  • Routeur de Cisco 2500 qui exécute la version de logiciel 12.4(2) de½ du¿Â du Cisco IOSïÂ

  • Deux commutateurs de la gamme Cisco 3500 XL qui exécutent le logiciel Cisco IOS version 12.0(5)WC3b

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Multidiffusion dans des contrôleurs LAN Sans fil (WLCs)

Avant version de logiciel 3.2 de réseau sans fil unifié Cisco, quand le Protocole IP Multicast a été activé, le contrôleur a livré des paquets de multidiffusion aux clients réseau local de radio (WLAN) en tirant des copies des paquets de multidiffusion, puis a expédié les paquets par un tunnel de Protocol de point d'accès léger d'unicast (LWAPP) à chaque Point d'accès (AP) connecté au contrôleur. Chaque trame reçue de Multidiffusion par le contrôleur d'un VLAN sur le premier routeur de saut a été copiée et envoyé au-dessus du tunnel LWAPP à chacun des aps s'est connecté à lui.

Le contrôleur pourrait devoir générer jusqu'à 300 copies de chaque paquet de multidiffusion, qui dépend du nombre d'aps. Ce mécanisme est inefficace, et place une grande charge de traitement sur le contrôleur. Ceci inonde le réseau avec un grand nombre de paquets monodiffusions en double.

Dans des versions de logiciel 3.2 et ultérieures de réseau sans fil unifié Cisco, la représentation de Multidiffusion du réseau sans fil unifié Cisco a été optimalisée. Ces releases introduisent plus de façon efficace de fournir le trafic de multidiffusion du contrôleur aux aps. Au lieu d'employer l'unicast pour livrer chaque paquet de multidiffusion au-dessus du tunnel LWAPP à chaque AP, un groupe de multidiffusion LWAPP est utilisé pour livrer le paquet de multidiffusion à chaque AP. Ceci permet aux Routeurs dans le réseau pour employer des techniques standard de Multidiffusion pour répliquer et livrer des paquets de multidiffusion aux aps. Pour le groupe de multidiffusion LWAPP, le contrôleur devient la source multicast et les aps vont bien aux récepteurs multicasts. Pour la caractéristique de représentation de Multidiffusion, les aps reçoivent des requêtes de Protocole IGMP (Internet Group Management Protocol) seulement du routeur et des paquets de multidiffusion avec une adresse IP source du contrôleur avec lequel ils sont actuellement associés.

Si votre multifusion de paquet de supports réseau, vous peut configurer la méthode de Multidiffusion que le contrôleur utilise. Le contrôleur exécute la multifusion en deux modes :

  • Mode d'Unicast — En ce mode, les unicasts de contrôleur chaque paquet de multidiffusion à chaque AP associé au contrôleur. Ce mode est inefficace mais pourrait être exigé sur les réseaux qui ne prennent en charge pas la multifusion.

  • Mode de Multidiffusion — En ce mode, le contrôleur envoie des paquets de multidiffusion à un groupe de multidiffusion LWAPP. Cette méthode réduit au-dessus sur le processeur de contrôleur et décale le travail de la réplication de paquet à votre réseau, qui est beaucoup plus efficace que la méthode d'unicast.

    Vous pouvez activer le mode de Multidiffusion utilisant le GUI ou le CLI de contrôleur.

Comportement de Multidiffusion dans différentes versions de logiciel WLC

Avant version de microprogramme 4.0.206.0 WLC, l'expédition de paquet de multidiffusion a activé en mode d'unicast ou de Multidiffusion, transfert de paquet également activé d'émission. Dans la version de microprogramme 4.0.206.0 WLC, l'émission et le trafic de multidiffusion doivent être activés séparément. L'émission est désactivée par défaut. Émettez cette commande du WLC CLI afin d'activer l'émission :

config network broadcast enable

En outre, l'émission utilise le mode de Multidiffusion qui est configuré sur le WLC, même si la Multidiffusion n'est pas activée. Si vous voulez activer l'émission sans activer la Multidiffusion, vous exécutez ceci par l'intermédiaire du CLI mais pas par le GUI. C'est parce que vous ne pouvez pas placer l'adresse IP ou le mode à moins que vous activiez la Multidiffusion dans le GUI. Par conséquent, si le mode de Multidiffusion est monodiffusé et l'émission est activée, c'est les utilisations d'émission de mode (le trafic d'émission est répliqué et unicast vers chaque AP). Si le mode de Multidiffusion est placé à la Multidiffusion avec une adresse de multidiffusion, alors l'émission utilise ce mode (chaque paquet d'émission est envoyé par l'intermédiaire du groupe de multidiffusion aux aps).

config network multicast mode multicast 
                           Or
config network multicast unicast

La Multidiffusion avec le dépassement d'AAA est prise en charge de la version 4.2 et ultérieures Sans fil de contrôleur LAN. Vous devez permettre à la surveillance IGMP sur le contrôleur de faire le travail de Multidiffusion avec le dépassement d'AAA.

Dans la version 4.2 de logiciel contrôleur, la surveillance IGMP est introduite pour diriger mieux des paquets de multidiffusion. Quand cette caractéristique est activée, le contrôleur recueille des rapports IGMP des clients, traite les états, crée de seules identifications groupe de Multidiffusion (MGIDs) des rapports IGMP après avoir vérifié l'adresse de multidiffusion de la couche 3 et le nombre VLAN, et envoie les rapports IGMP au commutateur d'infrastructure. Le contrôleur envoie ces états avec l'adresse source comme adresse d'interface sur laquelle elle a reçu les états des clients.

Le contrôleur met à jour alors la table du Point d'accès MGID sur AP avec l'adresse MAC de client. Quand le contrôleur reçoit le trafic de multidiffusion pour un groupe de multidiffusion particulier, il en avant il à tous les aps. Cependant, seulement ces aps qui ont les clients actifs écoutant ou abonnés à ce groupe de multidiffusion pour envoyer le trafic de multidiffusion sur ce WLAN particulier. Des paquets IP sont expédiés avec un MGID qui est seul pour un d'entrée VLAN et le groupe de multidiffusion de destination. Des paquets de multidiffusion de la couche 2 sont expédiés avec un MGID qui est seul pour l'interface d'entrée.

Remarque: La surveillance IGMP n'est pas prise en charge sur les contrôleurs de gamme 2000, les contrôleurs de gamme 2100, ou le module réseau Sans fil de contrôleur LAN de Cisco pour des Integrated Services Router de Cisco.

Les applications de Multidiffusion ont connu des limites de performances sur les contrôleurs de gamme 2100 et le module réseau Sans fil de contrôleur LAN de Cisco pour des Integrated Services Router de Cisco. Cisco fonctionne pour adresser ces limites dans une future release de code de production. Dans le même temps, Cisco recommande que vous utilisiez la gamme 4400 ou les contrôleurs de WiSM pour des applications intensives de Multidiffusion.

Remarque: La Multidiffusion n'est pas prise en charge sur les aps qui sont connectés directement au port local d'un contrôleur de gamme 2100.

Référez-vous au chapitre de conception de Multidiffusion de Cisco Unified Wireless du guide de conception de mobilité d'entreprise pour plus d'informations sur la Multidiffusion avec WLCs.

Ce document fournit un exemple de configuration qui montre comment configurer la multifusion sur WLCs afin de se connecter à un réseau câblé activé par Multidiffusion.

Itinérance Sans fil de Multidiffusion

Un défi majeur pour un client de Multidiffusion dans un environnement sans fil est de mettre à jour son adhésion de groupe de multidiffusion une fois déplacé au sujet du WLAN. Les baisses dans la connexion Sans fil qui se déplacent d'AP-à-AP peuvent entraîner une interruption dans la demande de Multidiffusion d'un client. Le Protocole IGMP (Internet Group Management Protocol) joue un important rôle dans la maintenance des informations dynamiques d'adhésion à des associations.

Une compréhension de base d'IGMP est importante pour comprendre ce qui arrive à la session de Multidiffusion d'un client quand il erre au sujet du réseau. Dans un cas d'itinérance de la couche 2, des sessions sont mises à jour simplement parce qu'AP étranger, si configuré correctement, appartient déjà au groupe de multidiffusion, et le trafic n'est pas percé un tunnel à un point d'attache différent sur le réseau. Les environnements errants de la couche 3 sont un peu plus complexes de cette manière, et, dépendant sur quel mode de Tunnellisation vous avez configuré sur vos contrôleurs, les messages IGMP envoyés d'un client sans fil peuvent être affectés. Le mode par défaut de Tunnellisation de mobilité sur un contrôleur est asymétrique. Ceci signifie que le trafic de retour au client est envoyé à l'ancre WLC et puis expédié au WLC étranger, où la connexion client associée réside. Des paquets sortants sont expédiés l'interface étrangère WLC. En mode symétrique de Tunnellisation de mobilité, les deux le trafic en entrée et en sortie sont percés un tunnel au contrôleur d'ancre.

Instructions pour l'usage du mode de Multidiffusion

Utilisez ces instructions quand vous activez le mode de Multidiffusion sur votre réseau :

  • La solution de réseau sans fil unifié Cisco utilise quelques plages d'adresses IP pour les buts spécifiques. Maintenez ces plages dans l'esprit quand vous configurez un groupe de multidiffusion :

    Bien que non recommandée, n'importe quelle adresse de multidiffusion peut être assignée au groupe de multidiffusion LWAPP ; ceci inclut les adresses de multidiffusion locales de lien réservé utilisées par OSPF, EIGRP, PIM, HSRP, et d'autres protocoles de Multidiffusion.

    Cisco recommande que des adresses de multidiffusion soient assignées du bloc administrativement scoped 239/8. L'IANA a réservé la plage de 239.0.0.0-239.255.255.255 en tant qu'adresses administrativement scoped pour l'usage dans les domaines privés de Multidiffusion. Voyez la note pour des restrictions supplémentaires. Ces adresses sont semblables en nature aux chaînes privées réservées d'unicast sur IP, telles que 10.0.0.0/8, définies dans le RFC 1918. Les administrateurs réseau sont libres pour utiliser les adresses de multidiffusion dans cette plage à l'intérieur de leur domaine sans crainte de conflit avec d'autres ailleurs en Internet. Cet administratif ou espace d'adressage privé doit être utilisé au sein de l'entreprise et son congé ou entrée bloqués du (AS) autonome de domaine.

    Remarque: N'utilisez pas la plage d'adresses 239.0.0.X ou la plage d'adresses 239.128.0.X. Les adresses dans ces plages superposent avec les adresses MAC locales de lien et inondent tous les ports de commutateur, même avec la surveillance IGMP activée.

    Cisco recommande que les administrateurs de réseau d'entreprise autres subdivisent cette plage d'adresses en plus petites portées administratives géographiques dans le réseau d'entreprise pour limiter la « portée » des applications particulières de Multidiffusion. Ceci empêche le trafic de multidiffusion de haut débit de partir d'un campus (où la bande passante est abondante) et congestionnant les liens WAN. Il tient compte également du filtrage efficace de la Multidiffusion de bande passante élevée d'atteindre le contrôleur et le réseau Sans fil. Pour plus d'informations sur des instructions d'adresse de multidiffusion, référez-vous aux instructions pour l'allocation d'adresse de Protocole IP Multicast d'entreprise.

  • Quand vous activez le mode de Multidiffusion sur le contrôleur, vous devez configurer une adresse de groupe de multidiffusion LWAPP sur le contrôleur. Les aps s'abonnent au groupe de multidiffusion LWAPP utilisant le Protocole IGMP (Internet Group Management Protocol).

  • Les aps de Cisco 1100, 1130, 1200, 1230, et 1240 utilisent des IGMP version 1, 2, et 3. Cependant, la gamme Cisco 1000 aps emploie seulement IGMP v1 pour joindre le groupe de multidiffusion.

  • Le mode de Multidiffusion fonctionne seulement en mode de la couche 3 LWAPP.

  • Les aps dans le mode moniteur, le mode de renifleur, ou le mode escroc de détecteur ne joignent pas l'adresse de groupe de multidiffusion LWAPP.

  • Quand vous utilisez les contrôleurs qui exécutent la version 4.1 ou antérieures, vous pouvez utiliser la même adresse de multidiffusion sur tous les contrôleurs. Si vous utilisez les contrôleurs qui exécutent la version 4.2 ou ultérieures, le groupe de multidiffusion LWAPP configuré sur les contrôleurs doit être différent pour chaque contrôleur utilisé sur le réseau.

  • Si vous utilisez des contrôleurs avec la version 4.1 ou antérieures, le mode de Multidiffusion ne fonctionne pas à travers des événements de mobilité d'intersubnet, tels que le Tunnellisation d'invité, la site-particularité VLAN, ou le dépassement d'interface qui utilise le RAYON. Le mode de Multidiffusion fonctionne dans ces événements de mobilité de sous-réseau quand vous désactivez les configurations de la couche 2 IGMP snooping/CGMP sur le lan câblée.

    Dans les versions ultérieures, c.-à-d., 4.2 ou plus tard, le mode de Multidiffusion ne fonctionne pas à travers des événements de mobilité d'intersubnet, tels que le Tunnellisation d'invité. Il fait, cependant, fonctionner avec l'interface ignore ce RAYON d'utilisation (mais seulement quand la surveillance IGMP est activée) et avec la site-particularité VLAN (groupe VLAN de Point d'accès).

  • Le contrôleur relâche tous les paquets de multidiffusion envoyés aux numéros de port UDP 12222, 12223, et 12224. Assurez-vous que les applications de Multidiffusion sur votre réseau n'utilisent pas ces numéros de port.

  • Le trafic de multidiffusion est transmis à 6 Mbits/s dans un réseau 802.11a. Par conséquent, si la tentative plusieurs WLAN de transmettre à 1.5 Mbits/s, perte de paquets se produit. Ceci casse la session de Multidiffusion.

Configuration du réseau

Dans cette installation, le réseau câblé est composé des trois Routeurs, R1, R2 et R3, qui exécutent l'OSPF entre eux.

Les hôtes câblés se connectent au réseau par un commutateur de la couche 2 qui est connecté au routeur R1. Le réseau Sans fil se connecte au réseau par le routeur R3, suivant les indications du diagramme.

Les périphériques doivent être configurés pour la connectivité IP de base et activent la multifusion dans le réseau. Par conséquent, les utilisateurs peuvent envoyer et recevoir le trafic de multidiffusion du côté de câble au côté Sans fil et vice versa.

Ce document utilise ces adresses IP pour le WLC, le RECOUVREMENT et les clients sans fil :

WLC Management Interface IP address: 172.16.1.30/16
WLC AP Manager Interface IP address: 172.16.1.31/16
LAP IP address: 172.16.1.50/16
Wireless Client C1 IP address: 172.16.1.75/16
Wireless Client C2 IP address: 172.16.1.76/16
Wired Client W1 IP address: 192.168.0.20/16
Wired Client W2 IP address: 192.168.0.30/16
Wired Client W3 IP address: 192.168.0.40/16

/image/gif/paws/81671/multicast-wlc-lap1.gif

Configurez

Afin de configurer les périphériques pour cette installation, ces le besoin d'être exécuté :

Configurez le réseau sans fil pour Multicasting

Avant que vous configuriez la multifusion sur WLCs, vous devez configurer le WLC pour le fonctionnement de base et enregistrer les recouvrements au WLC. Ce document suppose que WLC est configuré pour les opérations de base et que les LAP sont enregistrés au WLC. Si vous êtes un nouvel utilisateur qui essaie d'installer le WLC pour l'opération de base avec les LAP, consultez l'Enregistrement léger AP (LAP) sur un contrôleur LAN sans fil (WLC).

Remarque: N'utilisez pas le 239.0.0.X ou les plages d'adresses 239.128.0.X. Les adresses dans ces plages superposent avec les adresses MAC locales de lien et inondent tous les ports de commutateur, même avec la surveillance IGMP activée. Référez-vous à la section d'adresses de multidiffusion de la couche 2 de la vue d'ensemble de la technologie de Protocole IP Multicast pour plus d'informations sur des adresses superposantes de MAC multicast.

Une fois les recouvrements sont enregistrés au WLC, se terminent ces tâches afin de configurer les recouvrements et le WLC pour cette installation :

  1. Configurez le WLAN pour des clients

  2. Enable Ethernet Multicast Mode par l'intermédiaire du GUI

Configurez le WLAN pour des clients

La première étape est créent un WLAN au auquel les clients sans fil peuvent se connecter et recevoir l'accès au réseau. Terminez-vous ces étapes afin de créer un WLAN sur le WLC :

  1. Cliquez sur WLANs depuis l'interface utilisateur graphique (GUI) du contrôleur afin de créer un WLAN.

  2. Cliquez sur New pour configurer un nouveau WLAN.

    Dans cet exemple, le WLAN est nommé MulticastUsers et l'ID de WLAN est 1.

    /image/gif/paws/81671/multicast-wlc-lap2.gif

  3. Cliquez sur Apply.

  4. Dans la fenêtre WLAN > Edit, définissez les paramètres spécifiques au WLAN.

    1. Pour le WLAN, choisissez l'interface appropriée du champ Interface Name.

      Cet exemple trace l'interface de gestion au WLAN.

    2. Sélectionnez les autres paramètres, qui dépend des conditions requises de conception.

      Les valeurs par défaut sont utilisées dans cet exemple.

    3. Cliquez sur Apply.

      multicast-wlc-lap3.gif

      Remarque: Dans cet exemple, posez 2 méthodes de Sécurité pour authentifier des utilisateurs de sans fil ne sont pas utilisés. , N'en choisissez par conséquent aucun dans le domaine de degré de sécurité de la couche 2. Par défaut, l'option de degré de sécurité de la couche 2 est 802.1x.

      Remarque: Au lieu de tracer le WLAN (SSID) à l'interface de gestion, des interfaces dynamiques peuvent également être configurées sur le WLC pour segmenter les utilisateurs de sans fil et le WLAN peut être tracé aux interfaces dynamiques. Référez-vous aux VLAN sur l'exemple Sans fil de configuration de contrôleurs LAN pour les informations sur la façon dont configurer des interfaces dynamiques sur WLCs.

Émettez ces commandes afin de configurer les WLAN sur WLC utilisant le CLI :

  1. Émettez le <wlan-id > le <wlan-nom > la commande de config wlan create afin de créer un nouveau WLAN. Pour le WLAN-id, écrivez un ID de 1 à 16. Pour le WLAN-nom, écrivez un SSID jusqu'à 31 caractères alphanumériques.

  2. Émettez le <wlan-id > la commande de config wlan enable afin d'activer un WLAN.

    Pour l'exemple dans ce document, les commandes sont :

    config wlan create 1 MulticastUsers
    config wlan enable 1
    

Enable Ethernet Multicast Mode par l'intermédiaire du GUI

L'étape suivante est de configurer le WLC pour multicasting. Procédez comme suit :

  1. De la page Web de général de contrôleur, assurez-vous que le mode de transport LWAPP est placé pour poser 3.

    La caractéristique de représentation de Multidiffusion fonctionne seulement en ce mode.

    /image/gif/paws/81671/multicast-wlc-lap4.gif

    Remarque: Quand la Multidiffusion est activée comme unicast de Multidiffusion, des paquets sont répliqués pour chaque AP ; ceci peut être processeur intensif, ainsi utilisez-le avec prudence. La Multidiffusion activée comme Multidiffusion de Multidiffusion emploie l'adresse de multidiffusion assignée à l'utilisateur pour faire une Multidiffusion plus traditionnelle aux aps.

  2. Du menu déroulant pour Ethernet Multicast Mode, choisissez la Multidiffusion et introduisez une adresse de groupe de multidiffusion.

    Dans cet exemple, l'adresse est 239.255.1.60.

    /image/gif/paws/81671/multicast-wlc-lap7.gif

  3. Cliquez sur Apply.

    Remarque: Le WLC 4100 ne prend en charge pas le mode de Multidiffusion. La Multidiffusion est seulement faite en mode d'unicast. Ceci signifie que le contrôleur doit répliquer le paquet de multidiffusion pour chaque AP et unicast le paquet de multidiffusion vers chacun des aps.

    Émettez ces commandes afin d'activer la Multidiffusion par le CLI :

    1. De la ligne de commande, émettez la commande d'enable de config network multicast global.

    2. De la ligne de commande, émettez la <multicast-groupe-IP-adresse > la commande de config network multicast mode multicast.

      Pour l'exemple dans ce document, les commandes sont :

      config network multicast global enable
      config network multicast mode multicast 239.255.1.60
      

Après l'administrateur active la Multidiffusion (le mode de Multidiffusion est désactivé par défaut) et configure un groupe de multidiffusion LWAPP, les nouveaux travaux d'algorithme de Multidiffusion dans une de ces manières :

Quand la source de groupe de multidiffusion est sur le lan câblée :

Les LWAPP aps téléchargent l'adresse de groupe de multidiffusion du contrôleur LWAPP pendant le processus de jonction normal (au temps de démarrage) au contrôleur. Après qu'AP joigne un contrôleur et télécharge sa configuration, AP émet une demande IGMP afin de joindre le groupe de multidiffusion du contrôleur LWAPP. Ceci déclenche l'installation normale pour l'état de Multidiffusion dans les Routeurs Multidiffusion-activés, entre le contrôleur et les aps. L'adresse IP source pour le groupe de multidiffusion est l'adresse IP d'interface de gestion de contrôleur, pas l'adresse IP d'AP-gestionnaire utilisée pour le mode de la couche 3.

Quand le contrôleur reçoit un paquet de multidiffusion du client l'un des VLAN sur le premier routeur de saut, il communique le paquet au groupe de multidiffusion LWAPP par l'intermédiaire de l'interface de gestion au niveau le plus bas de QoS. Les bits de QoS pour le paquet de multidiffusion LWAPP sont codé en dur au plus inférieur et ne peuvent pas être changés par l'utilisateur.

Le réseau Multidiffusion-activé livre le paquet de multidiffusion LWAPP à chacun des aps qui ont joint le groupe de multidiffusion LWAPP. Le réseau Multidiffusion-activé emploie les mécanismes normaux de Multidiffusion dans les Routeurs pour répliquer le paquet le long de la route, comme nécessaire, de sorte que le paquet de multidiffusion atteigne tous les aps. Ceci soulage le contrôleur de la réplication des paquets de multidiffusion.

Les aps peuvent recevoir d'autres paquets de multidiffusion, mais processus seulement le ce de paquets de multidiffusion provenu le contrôleur auquel ils sont actuellement joints. Toutes les autres copies sont jetées. Si plus d'un WLAN SSID est associé au VLAN d'où le paquet de multidiffusion d'origine a été envoyé, AP transmet le paquet de multidiffusion au-dessus de chaque WLAN SSID (suivant au bitmap WLAN dans l'en-tête LWAPP). En outre, si ce WLAN SSID est sur les deux radios (802.11g et 802.11a), les deux radios transmettent le paquet de multidiffusion sur le WLAN SSID s'il y a des clients associés avec lui, même si ces clients n'ont pas demandé le trafic de multidiffusion.

Quand la source de groupe de multidiffusion est un client sans fil :

Le paquet de multidiffusion est monodiffusé (LWAPP-encapsulé) d'AP au contrôleur, semblable au trafic standard de client sans fil.

Le contrôleur tire deux copies du paquet de multidiffusion. Une copie est envoyée le VLAN associé avec le WLAN SSID sur lequel il est arrivé. Ceci permet à des récepteurs sur le lan câblée de recevoir le flot de Multidiffusion et le routeur pour se renseigner sur le nouveau groupe de multidiffusion. La deuxième copie du paquet LWAPP-est encapsulée et est envoyée au groupe de multidiffusion LWAPP de sorte que les clients sans fil puissent recevoir le flot de Multidiffusion.

Configurez le réseau câblé pour Multicasting

Afin de configurer le réseau câblé pour cette installation, vous devez configurer les Routeurs pour la Connectivité de base et activer la multifusion dans le réseau câblé.

Comme cité précédemment, l'OSPF est utilisé comme protocole de routage d'unicast.

N'importe quel protocole de Multidiffusion peut être utilisé dans le réseau câblé. Ce document utilise le PIM-DM comme protocole de Multidiffusion. Référez-vous au guide de configuration de Protocole IP Multicast de Cisco IOS pour des informations détaillées sur les différents protocoles qui peuvent être utilisés pour multicasting dans un réseau câblé.

Ce sont les configurations pour les Routeurs R1, R2 et R3 :

Routeur R1
RouterR1#show run
Building configuration...

Current configuration : 836 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR1
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 192.168.0.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.3.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR3
 ip address 10.2.4.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial2
 no ip address
 shutdown
!
interface Serial3
 no ip address
 shutdown
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
 network 192.168.0.0 0.0.255.255 area 0
 !
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Routeur R2
RouterR2#show run
Building configuration...

Current configuration : 616 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RouterR2
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 description Connnected to RouterR3
 ip address 10.2.2.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.3.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Routeur R3
RouterR3#show run
Building configuration...

Current configuration : 711 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname RouterR3
!
!
ip subnet-zero
!
ip multicast-routing

!--- Enables IP Multicasting on the network.

!
!
!
interface Ethernet0
 ip address 172.16.1.1 255.255.0.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

 ip cgmp

!--- Enables Cisco Group Management Protocol (CGMP) on the interface 
!--- connected to the Layer 2 switch.

 
!
interface Serial0
 description Connected to RouterR2
 ip address 10.2.2.1 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
interface Serial1
 description Connected to RouterR1
 ip address 10.2.4.2 255.255.255.0
 ip pim dense-mode

!--- Enables PIM-Dense Mode Multicast Protocol on the interface.

!
router ospf 1

!--- Configures OSPF as the unicast routing protocol.

 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 10.0.0.0 0.255.255.255 area 0
!
ip classless
ip http server
!
!
!
!
line con 0
line aux 0
line vty 0 4
!
end

Pour des Commutateurs de la couche 2, aucune configuration n'est exigée pour multicasting. Tous les Commutateurs basés sur IOS de la couche 2 ont le CGMP activé par défaut. Par conséquent, les Commutateurs traitent automatiquement les messages de CGMP des Routeurs.

Vérifiez et dépannez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Afin de vérifier la configuration, vous devez envoyer le trafic de multidiffusion de la source W1 et vérifier si le trafic de multidiffusion traverse le réseau câblé et atteint les membres du groupe de câble et Sans fil, W2, C1 et C2.

Effectuez cette tâche afin de tester si le Protocole IP Multicast est configuré correctement dans votre réseau.

Si tous les Routeurs Multidiffusion-capables sont des membres d'un groupe de multidiffusion, cinglant que le groupe fait répondre tous les Routeurs, qui peuvent être des administratifs et un outil de débogage utiles.

Une autre raison de faire joindre à un routeur un groupe de multidiffusion est quand d'autres hôtes sur le réseau ont une configuration de Protocole IGRP (Interior Gateway Routing Protocol) qui les empêche de répondre correctement à des requêtes IGMP. Quand vous faites joindre au routeur le groupe de multidiffusion, ceci fait mettre à jour les informations de table de routage de Multidiffusion pour ce groupe et garder les Routeurs en amont les chemins pour cet active de groupe. Afin de configurer un routeur pour faire partie du groupe de multidiffusion, émettez cette commande du mode de configuration d'interface :

ip igmp join-group <group-address> 
Example: Router(config-if)#ip igmp join-group 239.255.1.60

Voici la sortie du ping du routeur R3 :

RouterR3#ping 239.255.1.60

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.1.60, timeout is 2 seconds:

Reply to request 0 from 10.2.2.2, 40 ms
Reply to request 0 from 10.2.3.1, 84 ms
Reply to request 0 from 10.2.4.1, 44 ms

Localiser un saut défectueux

Effectuez cette tâche afin de surveiller et diagnostiquer une configuration de base de Protocole IP Multicast. Vous pouvez utiliser cette procédure quand un récepteur et une source ne fonctionnent pas comme prévu.

/image/gif/paws/81671/multicast-wlc-lap6.gif

Voici les sorties du show ip igmp membership et les commandes de compte de show ip mroute pour l'exemple de configuration. Ces sorties ont été prises du routeur R3.

RouterR3#sh ip igmp membership
Flags: A  - aggregate, T - tracked
       L  - Local, S - static, V - virtual, R - Reported through v3
       I - v3lite, U - Urd, M - SSM (S,G) channel
       1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
       / - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
       <ip-address> - last reporter if group is not explicitly tracked
       <n>/<m>      - <n> reporter in include mode, <m> reporter in exclude

 Channel/Group                  Reporter        Uptime   Exp.  Flags  Interface
 *,224.0.1.40                   10.2.2.1        1d21h    stop  2LA    Se0
 *,239.255.1.60                    172.16.1.1      1d06h    02:17 1LA    Et0
RouterR3#sh ip mroute count
IP Multicast Statistics
5 routes using 3094 bytes of memory
2 groups, 1.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)

Group: 239.255.1.60, Source count: 3, Packets forwarded: 6860, 
Packets received: 7087
  Source: 172.16.1.30/32, Forwarding: 304/1/147/0, Other: 304/0/0
  Source: 172.16.1.75/32, Forwarding: 6329/8/57/3, Other: 6329/0/0
  Source: 192.168.0.20/32, Forwarding: 227/1/69/0, Other: 454/227/0

Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

De ces sorties, vous pouvez voir que le trafic de multidiffusion découle de la source W1 et est reçu par les membres du groupe.


Informations connexes


Document ID: 81671