Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Exemple de configuration pour migrer Spanning Tree de PVST+ à Rapid-MST

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour migrer le mode spanning-tree de PVST+ vers Multiple Spanning Tree (MST) dans le réseau de campus.

Conditions préalables

Conditions requises

Référez-vous à Présentation de Multiple Spanning Tree Protocol (802.1s) avant de configurer MST.

Ce tableau montre le support de MST dans les commutateurs Catalyst et la configuration logicielle minimale requise pour ce support.

Plate-forme Catalyst MST avec RSTP
Catalyst 2900 XL et 3500 XL Non disponible.
Catalyst 2950 et 3550 Ý 12.1(9)EA1 de Cisco IOS
Catalyst 3560 Cisco IOS 12.1(9)EA1
Catalyst 3750 Cisco IOS 12.1(14)EA1
Catalyst 2955 toutes les versions de Cisco IOS
Catalyst 2948G-L3 et 4908G-L3 Non disponible.
Catalyst 4000, 2948G et 2980G (Catalyst OS (CatOS)) 7.1
Catalyst 4000 et 4500 (Cisco IOS) 12.1(12c)EW
Catalyst 5000 et 5500 Non disponible.
Catalyst 6000 et 6500 (CatOS) 7.1
Catalyst 6000 et 6500 (Cisco IOS) 12.1(11b)EX, 12.1(13)E, 12.2(14)SX
Catalyst 8500 Non disponible.

  • Catalyst 3550/3560/3750 : L'implémentation de MST dans Cisco IOS Version 12.2(25)SEC est basée sur la norme IEEE 802.1s. Les implémentations de MST dans des versions antérieures de Cisco IOS sont basées sur la prénorme.

  • Catalyst 6500 (IOS) : L'implémentation de MST dans Cisco IOS Version 12.2(18)SXF est basée sur la norme IEEE 802.1s. Les implémentations de MST dans des versions antérieures de Cisco IOS sont basées sur la prénorme.

Composants utilisés

Ce document est créé avec la version du logiciel Cisco IOS 12.2(25) et CatOS 8.5(8), mais la configuration s'applique à la version IOS minimum mentionnée dans la table.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

La fonctionnalité MST est basée sur la norme IEEE 802.1s et sur l'amendement de la norme 802.1Q. MST étend l'algorithme 802.1w Rapid Spanning Tree (RST) à différents spannings-tree. Cette extension accélère la convergence et assure l'équilibrage de charge dans un environnement VLAN. PVST+ et Rapid-PVST+ exécutent l'instance spanning-tree pour chaque VLAN. Dans MST vous pouvez regrouper les VLAN en une seule instance. Cette fonctionnalité utilise Bridge Protocol Data Unit (BPDU) version 3 qui est rétrocompatible avec 802.1D STP, qui utilise BPDU version 0.

Configuration de MSTP : La configuration comprend le nom de la région, le numéro de révision et la mappe d'affectation VLAN-à-instance de MST. Pour configurer le commutateur pour une région, utilisez la commande de configuration globale spanning-tree mst configuration .

Région MST : Une région MST est composée de ponts interconnectés qui ont la même configuration MST. Il n'y a aucune limite quant au nombre de régions MST sur le réseau.

Instances Spanning-tree à l'intérieur d'une région MST : Une instance n'est rien d'autre qu'un groupe de VLAN mappés dans la commande spanning-tree mst configuration . Par défaut, tous les VLAN sont regroupés dans IST0, ce qui s'appelle un IST (Internal Spanning Tree). Vous pouvez créer manuellement des instances numérotées de 1 à 4094 et intitulées MSTn (n =1 à 4094), mais la région ne peut supporter que 65 instances. Certaines versions ne supportent que 16 instances. Référez-vous au guide de configuration logicielle pour votre plate-forme de commutation.

IST/CST/CIST : IST est la seule instance qui peut envoyer et recevoir des BPDU sur le réseau MST. Une instance MSTn est locale par rapport à la région. Les IST des différentes régions sont interconnectés via un Common Spanning Tree (CST). La collection d'IST de chaque région MST et le CST qui connecte les IST forment le Common and Internal Spanning Tree (CIST).

Rétrocompatibilité : MST est rétrocompatible avec PVST+, Rapid-PVST+ et Prestandard MST (MISTP). Le connecteur MST est connecté aux autres commutateurs STP (PVST+ et Rapid-PVST+) par le Common Spanning Tree (CST). Les autres commutateurs STP (PVST+ et Rapid-PVST+) voient la totalité de la région MST comme un commutateur unique. Quand vous connectez le commutateur Prestandard MST avec le commutateur Standard MST, vous devez configurer spanning-tree mst pre-standard dans l'interface du commutateur Standard MST.

Configurez

Cet exemple contient deux sections. La première section montre la configuration active de PVST+. La seconde section montre la configuration qui migre de PVST+ vers rapid-MST+.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Ce schéma comprend les commutateurs suivants :

  • Distribution1 et Distribution2, qui sont dans la couche de distribution

  • Deux commutateurs de couche d'accès appelés Access1 (IOS) et Access2 (CatOS)

  • Deux commutateurs d'agrégation de serveur appelés Services1 et Services2

Les VLAN 10, 30, et 100 acheminent le trafic de données. Les VLAN 20, 40 et 200 acheminent le trafic voix.

/image/gif/paws/72844/MST-1.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration de PVST+

Les commutateurs sont configurés dans PVST+ pour acheminer le trafic de données et le trafic voix selon le schéma de réseau. Voici un court résumé de la configuration :

  • Le commutateur Distribution1 est configuré pour devenir un pont racine principal pour les VLAN de données 10, 30 et 100 avec la commande Distribution1(config)# spanning-tree vlan 10,30,100 root primary et le pont racine secondaire pour les VLAN de voix 20, 40 et 200 utilise la commande Distribution1(config)# spanning-tree vlan 20,40,200 root secondary .

  • Le commutateur Distribution2 est configuré pour devenir un pont racine principal pour les VLAN de voix 20, 40 et 200 avec la commande Distribution2(config)# spanning-tree vlan 20,40,200 root primary et le pont racine secondaire pour les VLAN de données 10, 30 et 100 utilise la commande Distribution2(config)# spanning-tree vlan 10,30,100 root secondary .

  • La commande spanning-tree backbonefast est configurée sur tous les commutateurs pour une convergence plus rapide du STP en cas de défaillance indirecte d'une liaison sur le réseau.

  • La commande spanning-tree uplinkfast est configurée sur les commutateurs de couche d'accès pour une convergence plus rapide du STP en cas de défaillance directe de liaison ascendante.

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 24576
spanning-tree vlan 20,40,200 priority 28672
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Vous pouvez voir que le port Fa1/0/24 est configuré avec la commande spanning-tree vlan 20,40,200 port-priority 64 . Distribution2 est la racine configurée pour les VLAN 20,40 et 200. Distribution2 a deux liaisons à Distribution1 : fa1/0/23 and fa1/0/24. Les deux ports sont des ports désignés pour les VLAN 20, 40 et 200 parce que Distribution2 est la racine pour ces VLAN. Les deux ports ont la même priorité 128 (valeur par défaut). En outre, ces deux liaisons ont le même coût depuis Distribution1 : fa1/0/23 and fa1/0/24. Distribution1 choisit le numéro de port le plus faible des deux ports pour passer le port à l'état forwarding. Le numéro de port le plus faible est Fa1/0/23 mais, selon le schéma de réseau, les VLAN de voix 20, 40 et 200 peuvent traverser Fa1/0/24. Vous pouvez effectuer cela avec les méthodes suivantes :

  1. Diminuez le coût de port dans Distribution1 : Fa1/0/24.

  2. Diminuez la priorité de port dans Distribution2 : Fa1/0/24.

Dans cet exemple, la priorité de port est diminuée pour transmettre les VLAN 20, 40, 200 via fa1/0/24.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Vous pouvez voir que le port Fa0/5 dans Services1, et Fa0/6 et Fa0/48 dans Services2 ont le coût de port et la configuration de priorité de port Spanning Tree. Ici le STP est réglé de sorte que les VLAN 100 et 200 de Services1 et de Services2 puissent traverser les liaisons de jonction entre eux. Si cette configuration n'est pas appliquée, Services1 et 2 ne peuvent pas acheminer le trafic via les liaisons de jonction entre eux. Au lieu de cela, ils choisiront de passer par Distribution1 et Distribution2.

Services2 voit deux chemins de coût égal vers la racine du VLAN 100 (Distribution1) : l'une via Services1 et l'autre via Distribution2. Le STP choisit le meilleur chemin (port racine) dans cet ordre :

  1. Le coût du chemin

  2. ID de pont du commutateur de transmission

  3. La priorité de port la plus faible

  4. Le numéro de port interne le plus faible

Dans cet exemple, les deux chemins ont le même coût, mais Distribution2 (24576) a une priorité plus faible que Services1 (32768) pour le VLAN 100, et donc Services2 choisit Distribution2. Dans cet exemple, coût de port sur Services1 : fa0/5 est défini plus faible pour que Services2 choisisse Services1. Le coût de chemin se substitue au numéro de priorité du commutateur de transmission.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Le même concept est appliqué pour que Services1 choisisse Services2 pour transmettre le VLAN 200. Lorsque vous réduisez le coût pour le VLAN 200 dans Services2 - fa0/6, Services1 choisit fa0/47 pour transmettre le VLAN 200. La condition ici est de transmettre le VLAN 200 via fa0/48. Vous pouvez effectuer cela avec les deux méthodes suivantes :

  1. Diminuez le coût de port dans Services1 : Fa0/48.

  2. Diminuez la priorité de port dans Services2 : Fa0/48.

Dans cet exemple, la priorité de port dans Services2 est diminuée pour transmettre le VLAN 200 via fa0/48.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Migration de MST

Il est difficile de convertir tous les commutateurs du réseau d'entreprise en même temps en MST. En raison de la rétrocompatibilité, vous pouvez les convertir phase par phase. Appliquez les changements dans la fenêtre de maintenance planifiée parce que la reconfiguration de spanning-tree peut perturber le flux de trafic. Quand vous activez MST, RSTP est également activé. Les fonctionnalités UplinkFast et BackboneFast de spanning tree sont des fonctionnalités PVST+ et sont désactivées quand vous activez MST parce qu'elles sont intégrées à RSTP et que MST repose sur RSTP. Pendant la migration, vous pouvez supprimer ces commandes dans IOS. Dans catOS BackboneFast et UplinkFast, les commandes sont automatiquement effacées de la configuration, mais la configuration des fonctionnalités comme portfast, bpduguard, bpdufilter, root guard et loopguard est aussi applicable en mode MST. Ces fonctionnalités s'utilisent de la même façon qu'en mode PVST+. Si vous avez déjà activé ces fonctionnalités en mode PVST+, elles demeurent actives après la migration en mode MST. Quand vous configurez MST, suivez les directives et respectez les restrictions suivantes :

  • La première étape de la migration vers 802.1s/w est d'identifier correctement les ports point à point et les ports d'extrémité. Assurez-vous que toutes les liaisons commutateur à commutateur sur lesquelles une transition rapide est souhaitée sont en mode duplex. Les ports d'extrémité sont définis par la fonctionnalité PortFast.

  • Choisissez un nom de configuration et un numéro de révision communs à tous les commutateurs du réseau. Cisco recommande de placer autant de commutateurs que possible dans une seule région. il n'est pas avantageux de segmenter un réseau en régions distinctes.

  • Décidez soigneusement combien d'instances sont nécessaires dans le réseau commuté, et n'oubliez pas qu'une instance est une topologie logique. Évitez de mapper les VLAN vers une instance 0. Décidez quels VLAN doivent être mappés vers ces instances et choisissez soigneusement une racine et une racine de secours pour chaque instance.

  • Assurez-vous que les jonctions acheminent tous les VLAN mappés vers une instance ou n'acheminent aucun VLAN pour cette instance.

  • MST peut interagir avec les ponts existants qui exécutent PVST+ par port. Il n'est donc pas problématique de mélanger les deux types de ponts si les interactions sont clairement comprises. Essayez toujours de garder la racine du CST et de l'IST à l'intérieur de la région. Si vous interagissez avec un pont PVST+ via une jonction, assurez-vous que le pont MST est la racine pour tous les VLAN autorisés sur cette jonction. N'utilisez pas de ponts PVST comme racine de CST.

  • Assurez-vous que tous les ponts racine spanning-tree PVST on une priorité inférieure (un numéro supérieur) à celle du pont racine CST.

  • Ne désactivez pas le spanning-tree sur les VLAN dans les ponts PVST.

  • Ne connectez pas les commutateurs avec des liaisons d'accès car les liaisons d'accès peuvent diviser un VLAN.

  • Toute configuration MST qui comprend un grand nombre de ports VLAN logiques actuels ou nouveaux doit être effectuée dans une fenêtre de maintenance, car la base de données MST est réinitialisée pour tout changement incrémentiel tel que l'ajout de nouveaux VLAN aux instances ou le déplacement de VLAN à travers les instances.

Dans cet exemple, le réseau de campus a une région MST nommée region1 et deux instances MST1 : les VLAN de données 10, 30 et 100, et MST2 : les VLAN de voix 20, 40 et 200. Vous pouvez voir que MST exécute seulement deux instances, mais que PVST+ exécute six instances. Distribution1 est choisi comme racine régionale CIST. Cela signifie que Distribution1 est la racine pour IST0. Afin d'équilibrer la charge du trafic sur le réseau selon le schéma, Distribution1 est configuré comme racine pour MST1 (instance pour VLAN de données) et MST2 est configuré comme racine pour MST2 (instance pour les VLAN de voix).

Vous devez d'abord migrer le noyau et progresser vers les commutateurs d'accès. Avant de changer le mode spanning-tree, définissez la configuration MST sur les commutateurs. Remplacez ensuite le type STP par MST. Dans cet exemple, la migration a lieu dans l'ordre suivant :

  1. Distribution1 et Distribution2

  2. Services1 et Services2

  3. Access1

  4. Access2

  1. Migration de Distribution1 et Distribution2 :

    
    !--- Distribution1 configuration:
    
    Distribution1(config)#spanning-tree mst configuration
    Distribution1(config-mst)#name region1
    Distribution1(config-mst)#revision 10
    Distribution1(config-mst)#instance 1 vlan 10, 30, 100
    Distribution1(config-mst)#instance 2 vlan 20, 40, 200
    Distribution1(config-mst)#exit
    Distribution1(config)#spanning-tree mst 0-1 root primary
    Distribution1(config)#spanning-tree mst 2 root secondary
    
    
    !--- Distribution2 configuration:
    
    Distribution2(config)#spanning-tree mst configuration
    Distribution2(config-mst)#name region1
    Distribution2(config-mst)#revision 10
    Distribution2(config-mst)#instance 1 vlan 10, 30, 100
    Distribution2(config-mst)#instance 2 vlan 20, 40, 200
    Distribution2(config-mst)#exit
    Distribution2(config)#spanning-tree mst 2 root primary
    Distribution2(config)#spanning-tree mst 0-1 root secondary
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    
    Distribution1(config)#interface FastEthernet1/0/1
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/3
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/5
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/23
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution1(config)#interface FastEthernet1/0/24
    Distribution1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    Distribution2(config)#interface FastEthernet1/0/2
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/4
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/6
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/23
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    !--- STP mode conversion.
    
    Distribution1(config)#spanning-tree mode mst
    Distribution2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic.
    
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#spanning-tree mst 2 port-priority 64
    
    
    !--- PVST+ cleanup.
    
    Distribution1(config)#no spanning-tree backbonefast
    Distribution2(config)#no spanning-tree backbonefast
    Distribution2(config)#interface FastEthernet1/0/24
    Distribution2(config-if)#no spanning-tree vlan 20,40,200 port-priority 64
    

    Remarque: Il est recommandé de définir la racine MST0 manuellement. Dans cet exemple, Distribution1 est choisi comme racine MST0. Distribution1 devient donc la racine CIST.

    Maintenant le réseau a une configuration mixte. Il peut être représenté selon le schéma suivant :

    MST-2.gif

    Distribution1 et Distribution2 sont dans MST region1, et les commutateurs PVST+ voient region1 comme pont unique. Le flux de trafic après la reconvergence est montré dans le schéma 2. Vous pouvez encore régler les commutateurs PVST+ (VLAN spanning-tree x coût) pour équilibrer la charge du trafic des données et de voix selon le schéma 1. Après avoir migré tous les autres commutateurs selon les étapes 2 à 4, vous obtenez la topologie spanning tree finale indiquée dans le schéma 1.

  2. Migration de Services1 et Services2 :

    
    !--- Services1 configuration:
    
    Services1(config)#spanning-tree mst configuration
    Services1(config-mst)#name region1
    Services1(config-mst)#revision 10
    Services1(config-mst)#instance 1 vlan 10, 30, 100
    Services1(config-mst)#instance 2 vlan 20, 40, 200
    Services1(config-mst)#exit
    
    
    !--- Services2 configuration:
    
    Services2(config)#spanning-tree mst configuration
    Services2(config-mst)#name region1
    Services2(config-mst)#revision 10
    Services2(config-mst)#instance 1 vlan 10, 30, 100
    Services2(config-mst)#instance 2 vlan 20, 40, 200
    Services2(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the 
    !--- VLANs that are mapped to an instance.
    
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/47
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services1(config)#interface FastEthernet0/48
    Services1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/47
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    
    
    !--- STP Mode conversion:
    
    Services1(config)#spanning-tree mode mst
    Services2(config)#spanning-tree mode mst
    
    
    !--- MST tuning - to load balance data and voice VLAN traffic:
    
    Services1(config)#interface fastEthernet 0/46
    Services1(config-if)#spanning-tree mst 2 cost 200000
    Services1(config-if)#exit
    Services1(config)#interface fastEthernet 0/47
    Services1(config-if)#spanning-tree mst 2 cost 100000
    Services1(config-if)#exit
    
    Services2(config)#interface FastEthernet 0/6
    Services2(config-if)#spanning-tree mst 1 cost 500000
    Services2(config-if)#exit
    
    
    !--- PVST+ cleanup:
    
    Services1(config)#no spanning-tree uplinkfast
    Services1(config)#no spanning-tree backbonefast
    Services1(config)#interface FastEthernet0/5
    Services1(config-if)#no spanning-tree vlan 100 cost 18
    Services1(config-if)#exit
    
    Services2(config)#no spanning-tree uplinkfast
    Services2(config)#no spanning-tree backbonefast
    Services2(config)#interface FastEthernet0/6
    Services2(config-if)#no spanning-tree vlan 200 cost 18
    Services2(config-if)#exit
    Services2(config)#interface FastEthernet0/48
    Services2(config-if)#no spanning-tree vlan 200 port-priority 64
    Services2(config-if)#exit
    
  3. Migration d'Access1 :

    
    !--- Access1 configuration:
    
    Access1(config)#spanning-tree mst configuration
    Access1(config-mst)#name region1
    Access1(config-mst)#revision 10
    Access1(config-mst)#instance 1 vlan 10, 30, 100
    Access1(config-mst)#instance 2 vlan 20, 40, 200
    Access1(config-mst)#exit
    
    
    !--- Make sure that trunks carry all the VLANs that are mapped to an instance.
    
    Access1(config)#interface FastEthernet0/1
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    !
    Access1(config)#interface FastEthernet0/2
    Access1(config-if)#switchport trunk allowed vlan 10,20,30,40,100,200
    
    !--- STP mode conversion:
    
    Access1(config)#spanning-tree mode mst
    
    
    !--- PVST+ cleanup:
    
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
  4. Migration d'Access2 :

    
    !--- Access2 configuration:
    
    Access2> (enable) set spantree mst config name region1 revision 10
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 1 vlan 10,30,100
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst 2 vlan 20,40,200
    Edit Buffer modified.
    Use 'set spantree mst config commit' to apply the changes
    
    Access2> (enable) set spantree mst config commit
    
    
    !--- Ensure that trunks carry all the VLANs that are mapped to an instance:
    
    Access2> (enable)set trunk 3/3  on dot1q 10,20,30,40,100,200
    Access2> (enable)set trunk 3/4  on dot1q 10,20,30,40,100,200
    
    
    STP mode conversion
    
    Access2> (enable) set spantree mode mst
    PVST+ database cleaned up.
    Spantree mode set to MST.
    
    
    !--- Backbonefast and uplinkfast configurations are cleaned up automatically.
    
    

Vérifiez

Il est recommandé de vérifier la topologie spanning tree chaque fois que la configuration est changée.

Vérifiez que le commutateur Distribution1 est le pont racine pour les VLAN de données 10, 30 et 100 et que le chemin de transmission spanning-tree correspond au chemin indiqué dans le schéma.

 Distribution1# show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.63f6.b700  priority      24576 (24576 sysid 0)
Root          this switch for the CIST
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p


Distribution1#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.63f6.b700  priority      24577 (24576 sysid 1)
Root          this switch for MST1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 200000    128.1    P2p
Fa1/0/3          Desg FWD 200000    128.3    P2p
Fa1/0/5          Desg FWD 200000    128.5    P2p 
Fa1/0/23         Desg FWD 200000    128.23   P2p
Fa1/0/24         Desg FWD 200000    128.24   P2p

Distribution1#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.63f6.b700  priority      28674 (28672 sysid 2)
Root          address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
              port    Gi1/0/24        cost          200000    rem hops 4

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi1/0/1          Desg FWD 200000    128.1    P2p
Gi1/0/3          Desg FWD 200000    128.3    P2p
Gi1/0/23         Altn BLK 200000    128.23   P2p
Gi1/0/24         Root FWD 200000    128.24   P2p

Distribution2#show spanning-tree mst 0

##### MST0    vlans mapped:   1-9,11-19,21-29,31-39,41-99,101-199,201-4094
Bridge        address 0015.c6c1.3000  priority      28672 (28672 sysid 0)
Root          address 0015.63f6.b700  priority      24576 (24576 sysid 0)
              port    Fa1/0/23        path cost     0
Regional Root address 0015.63f6.b700  priority      24576 (24576 sysid 0)
                                      internal cost 200000    rem hops 19
Operational   hello time 2 , forward delay 15, max age 20, txholdcount 6
Configured    hello time 2 , forward delay 15, max age 20, max hops    20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/2          Desg FWD 200000    128.54   P2p
Fa1/0/4          Desg FWD 200000    128.56   P2p
Fa1/0/6          Desg FWD 200000    128.58   P2p
Fa1/0/23         Root FWD 200000    128.75   P2p
Fa1/0/24         Altn BLK 200000    128.76   P2p


!--- CIST root is Distribution1. All the 
!--- switches are in the same region "region1".
!--- Hence in all the switches in the region1 you can see the path cost as 0.


Distribution2#show spanning-tree mst 1

##### MST1    vlans mapped:   10,30,100
Bridge        address 0015.c6c1.3000  priority      28673 (28672 sysid 1)
Root          address 0015.63f6.b700  priority      24577 (24576 sysid 1)
              port    Gi2/0/23        cost          200000    rem hops 1

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/23         Root FWD 200000    128.75   P2p
Gi2/0/24         Altn BLK 200000    128.76   P2p

Distribution2#show spanning-tree mst 2

##### MST2    vlans mapped:   20,40,200
Bridge        address 0015.c6c1.3000  priority      24578 (24576 sysid 2)
Root          this switch for MST2

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi2/0/2          Desg FWD 200000    128.54   P2p
Gi2/0/4          Desg FWD 200000    128.56   P2p
Gi2/0/6          Desg FWD 200000    128.58   P2p
Gi2/0/23         Desg FWD 200000    128.75   P2p
Gi2/0/24         Desg FWD 200000     64.76   P2p

Access2> (enable) show spantree mst 1
Spanning tree mode          MST
Instance                    1
VLANs Mapped:               10,30,100

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24577  (root priority: 24576, sys ID ext: 1)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/3

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32769  (bridge priority: 32768, sys ID ext: 1)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT    200000   32 P2P
 3/4                     blocking      ALTR    200000   32 P2P

Access2> (enable) show spantree mst 2
Spanning tree mode          MST
Instance                    2
VLANs Mapped:               20,40,200

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24578  (root priority: 24576, sys ID ext: 2)
Designated Root Cost        200000     Remaining Hops 19
Designated Root Port        3/4

Bridge ID MAC ADDR          00-d0-00-50-30-00
Bridge ID Priority          32770  (bridge priority: 32768, sys ID ext: 2)

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR    200000   32 P2P
 3/4                     forwarding    ROOT    200000   32 P2P

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 72844