Commutateurs : Commutateurs Cisco Catalyst, s�rie�6500

Exemple de configuration de la migration de Spanning Tree de PVST+ à Rapid-PVST

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour migrer le mode spanning-tree de PVST+ vers rapid-PVST+ dans le réseau de campus. Il explique également la configuration de PVST+, l'équilibrage de charge de Spanning-Tree et les fonctionnalités Uplinkfast et BackboneFast.

Conditions préalables

Conditions requises

Il est recommandé de lire Présentation de Rapid Spanning Tree Protocol (802.1w) avant de configurer rapid-PVST+.

Ce tableau montre le support de Rapid Spanning-Tree Protocol (RSTP) dans les commutateurs Catalyst, et la configuration logicielle minimale requise pour ce support.

Plate-forme Catalyst Rapid-PVST+
Catalyst 2900XL/3500XL Non disponible.
Catalyst 2940 12.1(20)EA2
Catalyst 2950/2955/3550 12.1(13)EA1
Catalyst 2970/3750 12.1(14)EA1
Catalyst 3560 12.1(19)EA1
Catalyst 3750 Metro 12.1(14)AX
Catalyst 2948G-L3/4908G-L3 Non disponible.
Catalyst 4000/2948G/2980G (CatOS) 7.5
Catalyst 4000/4500 (IOS) 12.1(19)EW
Catalyst 5000/5500 Non disponible.
Catalyst 6000/6500 7.5
Catalyst 6000/6500 (IOS) 12.1(13)E
Catalyst 8500 Non disponible.

Composants utilisés

Les informations dans ce document sont basées sur le logiciel de ½ du ¿  de Cisco IOSï Release12.2(25) et le CatOS 8.5(8). Cependant, la configuration s'applique à la version Cisco IOS minimale montrée dans le tableau.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

802.1D Spanning Tree Protocol (STP) a un inconvénient de convergence lente. Les commutateurs Cisco Catalyst supportent trois types de STP, qui sont PVST+, rapid-PVST+ et MST. PVST+ est basé sur la norme IEEE802.1D et inclut les extensions propriétaires Cisco telles que BackboneFast, UplinkFast et PortFast. Rapid-PVST+ est basé sur la norme IEEE 802.1w et a une convergence plus rapide que 802.1D. RSTP (IEEE 802.1w) inclut dans sa version native la plupart des améliorations propriétaires à 802.1D Spanning Tree, comme BackboneFast et UpLinkFast. Rapid-PVST+ a les fonctionnalités uniques suivantes :

  • Utilise Bridge Protocol Data Unit (BPDU) version 2 qui est rétrocompatible avec 802.1D STP, qui utilise BPDU version 0.

  • Tous les commutateurs génèrent des BPDU et les envoient sur tous les ports toutes les 2 secondes, tandis que dans 802.1D STP seul le pont racine envoie les BPDU de configuration.

  • Rôles de ports - port racine, port désigné, port alternatif et port de secours.

  • États du port — Discarding, Learning et Forwarding.

  • Types de port - Port d'extrémité (PortFast), point à point et partagé.

Rapid-PVST utilise RSTP pour fournir une convergence plus rapide. Quand un port RSTP reçoit le 802.1D BPDU existant, il redevient un STP existant et les avantages inhérents de convergence rapide du protocole 802.1w sont perdus lorsqu'il interagit avec les ponts existants.

Configurez

Cet exemple contient deux sections. La première section montre la configuration active de PVST+. La seconde section montre la configuration pour migrer de PVST+ vers rapid-PVST+.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Ce diagramme contient les commutateurs suivants :

  • Distribution1 et Distribution2, qui sont dans la couche de distribution

  • Deux commutateurs de couche d'accès appelés Access1 (IOS) et Access2 (CatOS)

  • Deux commutateurs d'agrégation de serveur appelés Services1 et Services2

Les VLAN 10, 30, et 100 acheminent le trafic de données. Les VLAN 20, 40 et 200 acheminent le trafic voix.

rapidpvst-mig-config1.gif

Configurations

Ce document utilise les configurations suivantes :

Configuration de PVST+

Les commutateurs sont configurés dans PVST+ pour acheminer le trafic de données et le trafic voix selon le schéma de réseau. Voici un court résumé de la configuration :

Distribution1
Distribution1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 8192
spanning-tree vlan 20,40,200 priority 16384
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
 !
 end

Vous pouvez voir que le port Fa1/0/24 est configuré avec la commande spanning-tree vlan 20,40,200 port-priority 64 . Distribution2 est configuré comme racine pour les VLAN 20,40,200. Distribution2 a deux liaisons à Distribution1 : fa1/0/23 and fa1/0/24. Les deux ports sont des ports désignés pour les VLAN 20, 40, 200 parce que Distribution2 est la racine pour ces VLAN. Les deux ports ont la même priorité 128 (valeur par défaut). En outre, ces deux liaisons ont le même coût depuis Distribution1 : fa1/0/23 and fa1/0/24. Distribution1 choisit le numéro de port le plus faible des deux ports pour passer le port à l'état forwarding. Le numéro de port le plus faible est Fa1/0/23. Cependant, selon le diagramme de réseau, les VLAN de voix 20, 40, 200 doivent traverser Fa1/0/24. Vous pouvez effectuer cela avec les méthodes suivantes :

  1. Diminuez le coût de port dans Distribution1 : Fa1/0/24

  2. Diminuez la priorité de port dans Distribution2 : Fa1/0/24

Dans cet exemple, la priorité de port est diminuée pour transmettre les VLAN 20, 40, 200 via fa1/0/24.

Distribution2
Distribution2#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree backbonefast
spanning-tree vlan 10,30,100 priority 28672
spanning-tree vlan 20,40,200 priority 24576
!
vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet1/0/4
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 30,40
!
interface FastEthernet1/0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet1/0/23
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20,30,40,100,200
!
interface FastEthernet1/0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 20,40,200 port-priority 64
 switchport trunk allowed vlan 10,20,30,40,100,200

end

Vous pouvez voir que le port Fa0/5 dans Services1, et Fa0/6 et Fa0/48 dans Services2 ont le coût de port Spanning Tree et la configuration de priorité de port. Ici le STP est réglé de sorte que les VLAN 100 et 200 de Services1 et de Services2 puissent traverser les liaisons de jonction entre eux. Si cette configuration n'est pas appliquée, Services1 et 2 n'achemineront pas le trafic via les liaisons de jonction entre eux. Au lieu de cela, ils choisiront de passer par Distribution1 et Distribution2.

Services2 voit deux chemins de coût égal vers la racine du VLAN 100 (Distribution1). L'un via Services1 et l'autre via Distribution2. Le STP choisit le meilleur chemin (port racine) dans cet ordre :

  1. Coût de chemin

  2. ID de pont du commutateur de transmission

  3. Priorité de port la plus faible

  4. Numéro de port interne le plus faible

Dans cet exemple, les deux chemins ont le même coût. Cependant, Distribution2 (24576) a une priorité plus faible que Services1 (32768) pour le VLAN 100. Par conséquent, Services2 choisit Distribution2. Dans cet exemple, coût du port sur Services1 : fa0/5 est défini plus faible pour que Services2 choisisse Services1. Le coût de chemin se substitue au numéro de priorité du commutateur de transmission.

Services1
Services1#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/5
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 100 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
!
 end

Le même concept est appliqué pour que Services1 choisisse Services2 pour transmettre le VLAN 200. Lorsque vous réduisez le coût pour le VLAN 200 dans Services2 - fa0/6, Services1 choisit fa0/47 pour transmettre le VLAN 200. Cependant, la condition ici est de transmettre le VLAN 200 via fa0/48. Vous pouvez effectuer cela avec les deux méthodes suivantes :

  1. Diminuez le coût de port dans Services1 : Fa0/48

  2. Diminuez la priorité de port dans Services2 : Fa0/48

Dans cet exemple, la priorité de port dans Services2 est diminuée pour transmettre le VLAN 200 via fa0/48.

Services2
Services2#show running-config 
 Building configuration...
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree backbonefast
!
vlan 100,200
!
interface FastEthernet0/6
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 cost 18
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/47
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 100,200
!
interface FastEthernet0/48
 switchport trunk encapsulation dot1q
 switchport mode trunk
 spanning-tree vlan 200 port-priority 64
 switchport trunk allowed vlan 100,200
!
 !
 end

Access1
Access1#show running-config 
 Building configuration...
!
spanning-tree mode pvst
spanning-tree portfast bpduguard default
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan 10,20
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport trunk allowed vlan 10,20
!
 end

Access2
Access2> (enable)show config all 

#mac address reduction
set spantree macreduction enable
!
#stp mode
set spantree mode pvst+
!
#uplinkfast groups
set spantree uplinkfast enable rate 15 all-protocols off
!
#backbonefast
set spantree backbonefast enable
!
#vlan parameters
set spantree priority 49152  1
set spantree priority 49152  30
set spantree priority 49152  40
!
#vlan(defaults)
set spantree enable  1,30,40
set spantree fwddelay 15     1,30,40
set spantree hello    2      1,30,40
set spantree maxage   20     1,30,40
!
#vtp
set vlan 1,30,40
!
#module 3 : 48-port 10/100BaseTX Ethernet
set trunk 3/3  on dot1q 30,40
set trunk 3/4  on dot1q 30,40
!
 end

Uplinkfast et BackboneFast

Il est bon de connaître le comportement d'UplinkFast et de BackboneFast avant de lancer le processus de migration. Dans le schéma de réseau, le commutateur Access1 exécute Cisco IOS. Cette sortie de commande est relevée avant la migration vers le mode rapid-PVST :

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  Uplinkfast enabled

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p


Access1#show spanning-tree summary
Switch is in pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled
BackboneFast                 is enabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Cette sortie de commande est relevée lorsque le mode passe à rapid-PVST+ :

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        3019
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    49162  (priority 49152 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300
  UplinkFast enabled but inactive in rapid-pvst mode

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 3019      128.107  P2p
Fa3/0/2          Altn BLK 3019      128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is enabled but inactive in rapid-pvst mode
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Vous pouvez voir dans la sortie de la commande show spanning-tree summary que UplinkFast et BackboneFast sont activés, mais sont inactifs en mode rapid-PVST. Il est facultatif de supprimer les deux commandes. Aucune opération rapid-PVST n'est affectée si vous ne supprimez pas les commandes. Si vous désactivez UplinkFast avec la commande de mode de configuration no spanning-tree uplinkfast, les valeurs par défaut de la priorité de pont et du coût de port sont restaurées. Il est recommandé d'avoir un numéro élevé pour la priorité de pont du commutateur non racine. Cette sortie de commande s'affiche après la désactivation de la fonctionnalité UplinkFast en mode rapid-PVST :

Access1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             Cost        19
             Port        107 (FastEthernet3/0/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     000f.f794.3d00
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa3/0/1          Root FWD 19        128.107  P2p
Fa3/0/2          Altn BLK 19        128.108  P2p

Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is enabled but inactive in rapid-pvst mode
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

CatOS ne permet pas de passer le mode à rapid-PVST si la fonctionnalité BackboneFast est activée. Vous devez désactiver BackboneFast avant la migration. UplinkFast se comporte de la même façon que dans IOS.

Access2> (enable) set spantree mode rapid-pvst+
Cannot change the spantree mode to RAPID-PVST+ when backbonefast is enabled.

Migration de Rapid-PVST+

Rapid-PVST+ utilise le même format BPDU que le 802.1D et est rétrocompatible. Il est difficile de convertir tous les commutateurs du réseau d'entreprise en même temps en rapid-PVST+. En raison de la rétrocompatibilité, vous pouvez convertir phase par phase. Il est recommandé d'appliquer les changements dans la fenêtre de maintenance planifiée parce que la reconfiguration de spanning-tree perturbe le flux de trafic. Les fonctionnalités Spanning Tree UplinkFast et BackboneFast sont des fonctionnalités PVST+. Ces fonctionnalités sont désactivées quand vous activez rapid-PVST+ parce qu'elles sont intégrées à rapid-PVST+. Par conséquent, pendant la migration vous pouvez supprimer ces commandes. La configuration des fonctionnalités comme PortFast, BPDUguard, BPDUfilter, Root Guard et Loopguard sont aussi applicables en mode rapid-PVST+. Ces fonctionnalités s'utilisent de la même façon qu'en mode PVST+. Si vous avez déjà activé ces fonctionnalités en mode PVST+, elles demeurent actives après la migration en mode rapid-PVST+. Dans cet exemple, la migration a lieu dans l'ordre suivant :

  1. Access1

  2. Access2

  3. Services1 et Services2

  4. Distribution1 et Distribution2

  1. Migration d'Access1 :

    Access1(config)#spanning-tree mode rapid-pvst
    Access1(config)#no spanning-tree uplinkfast
    Access1(config)#no spanning-tree backbonefast
    
    
    Access1#show spanning-tree vlan 10
    
    VLAN0010
      Spanning tree enabled protocol rstp
      Root ID    Priority    24586
                 Address     0015.63f6.b700
                 Cost        19
                 Port        107 (FastEthernet3/0/1)
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
    
      Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
                 Address     000f.f794.3d00
                 Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
                 Aging Time 300
    
    Interface        Role Sts Cost      Prio.Nbr Type
    ---------------- ---- --- --------- -------- --------------------------------
    Fa3/0/1          Root FWD 19        128.107  P2p Peer(STP)
    Fa3/0/2          Altn BLK 19        128.108  P2p Peer(STP)
    
    
    !--- Type P2p Peer(STP) represents that the neighbor switch runs PVST.
    
    
  2. Migration d'Access2 :

    Access2> (enable) set spantree backbonefast disable
    Backbonefast disabled for all VLANs.
    
    Access2> (enable) set spantree mode rapid-pvst+
    PVST+ database cleaned up.
    Spantree mode set to RAPID-PVST+.
    
    
    Access2> (enable) clear spantree uplinkfast
    This command will cause all portcosts, portvlancosts, and the
    bridge priority on all vlans to be set to default.
    Do you want to continue (y/n) [n]? y
    VLANs 1-4094 bridge priority set to 32768.
    The port cost of all bridge ports set to default value.
    The portvlancost of all bridge ports set to default value.
    uplinkfast all-protocols field set to off.
    uplinkfast disabled for bridge.
  3. Migration de Services1 et Services2 :

    Services1(config)#spanning-tree mode rapid-pvst
    Services1(config)#no spanning-tree backbonefast
    
    Services2(config)#spanning-tree mode rapid-pvst
    Services2(config)#no spanning-tree backbonefast
    
  4. Migration de Distribution1 et Distribution2 :

    Distribution1(config)#spanning-tree mode rapid-pvst
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state to
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution1 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution1(config)#no spanning-tree backbonefast
    
    
    Distribution2(config)#spanning-tree mode rapid-pvst
    
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    own
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to
    p
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to
    up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan200, changed state t
     up
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    down
    2d02h: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to
    up
    
    !--- Distribution2 switch has Layer3 VLAN interfaces and it goes 
    !--- down and up during the conversion.
    
    
    Distribution2(config)#no spanning-tree backbonefast
    

Sortie de débogage - mode mixte

Dans un grand réseau d'entreprise, le processus de migration peut prendre quelques jours. Pendant le processus de migration, vous pouvez faire fonctionner le LAN en mode mixte, par exemple quelques commutateurs en mode PVST+ et quelques commutateurs en mode rapid-PVST+. En mode mixte, vous n'obtenez pas les avantages complets de rapid-PVST+. Le temps de convergence globale est le même que celui en mode PVST+. Afin de profiter pleinement de rapid-PVST+, tous les commutateurs en topologie spanning tree doivent exécuter rapid-PVST+. Pour montrer comment le spanning-tree se comporte en mode mixte, un exemple de sortie de commande debug est illustré ici. Distribution1 et Distribution2 sont en mode PVST+ et Access1 est en mode rapid-PVST+.

La sortie de commande debug spanning-tree montre le fonctionnement de STP lorsque la liaison entre Access1 et Distribution1 échoue.

Access1

00:55:13: RSTP(10): updt roles, root port Fa0/1 going down
00:55:13: RSTP(10): Fa0/2 is now root port
00:55:13: RSTP(10): Fa0/2 received a tc ack
00:55:15: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
00:55:16: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

00:55:20: STP: VLAN0010 Topology Change rcvd on Fa1/0/23
00:55:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:55:21: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
00:55:22: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

Distribution2

00:55:06: STP: VLAN0010 Topology Change rcvd on Fa1/0/2
00:55:06: STP: VLAN0010 sent Topology Change Notice on Fa1/0/23

La sortie de commande debug spanning-tree montre le fonctionnement de STP lorsque la liaison entre Access1 et Distribution1 est opérationnelle.

Access1

00:55:40: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
00:55:43:  STP: PVST vlan 10 port Fa0/1 created, ext id 2E42430, vp 3389640
00:55:43: RSTP(10): initializing port Fa0/1
00:55:43: RSTP(10): Fa3/0/1 is now designated
00:55:43:  STP: PVST vlan 20 port Fa0/1 created, ext id 2E42430, vp 300EC20
00:55:43: RSTP(20): initializing port Fa0/1
00:55:43: RSTP(20): Fa0/1 is now designated
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): transmitting a proposal on Fa0/1
00:55:43: RSTP(20): transmitting a proposal on Fa0/1
00:55:43: RSTP(10): updt roles, received superior bpdu on Fa0/1
00:55:43: RSTP(10): Fa0/1 is now root port
00:55:43: RSTP(10): Fa0/2 blocked by re-root
00:55:43: RSTP(10): Fa0/2 is now alternate
00:55:44: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to up
00:55:44: RSTP(20): updt roles, received superior bpdu on Fa0/1
00:55:44: RSTP(20): Fa0/1 is now alternate

Distribution1

00:55:49: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
00:55:50: set portid: VLAN0010 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDB708
00:55:50: STP: VLAN0010 Fa1/0/1 -> listening
00:55:50: set portid: VLAN0020 Fa1/0/1: new port id 8001
00:55:50:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 3C06F20
00:55:50: STP: VLAN0020 Fa1/0/1 -> listening
00:55:51: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to up
00:56:05: STP: VLAN0010 Fa1/0/1 -> learning
00:56:05: STP: VLAN0020 Fa1/0/1 -> learning
00:56:20: STP: VLAN0010 Fa1/0/1 -> forwarding
00:56:20: STP: VLAN0020 sent Topology Change Notice on Fa1/0/24
00:56:20: STP: VLAN0020 Fa1/0/1 -> forwarding


!--- This output is evident that the Access1 switch waits for the 
!--- standard 802.1D Spanning Tree process of listening, learning and forwarding
!--- to complete in Distribution1.




Distribution2

00:55:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24
00:56:06: STP: VLAN0020 Topology Change rcvd on Fa1/0/24


!--- This output shows that Distribution2 is notified
!--- about the indirect link outage by TCN BPDUs.

Sortie de débogage - mode Rapid-PVST+

Les commutateurs Distribution1, Distribution2 et Access1 sont en mode rapid-PVST+. La sortie de commande debug spanning-tree montre le fonctionnement de STP lorsque la liaison entre Access1 et Distribution1 échoue.

Access1

01:31:04: RSTP(10): updt roles, root port Fa0/1 going down
01:31:04: RSTP(10): Fa0/2 is now root port
01:31:06: %LINK-5-CHANGED: Interface FastEthernet0/1, changed state to adminis
tratively down
01:31:07: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, cha
nged state to down

Distribution1

01:31:13: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet1/0/1,
changed state to down
01:31:14: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to down

La sortie de commande debug spanning-tree montre le fonctionnement de STP lorsque la liaison entre Access1 et Distribution1 est opérationnelle.

Access1

01:35:46: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up
01:35:48:  STP: PVST vlan 10 port Fa3/0/1 created, ext id 2E42430, vp 3C8E360
01:35:48: RSTP(10): initializing port Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now designated
01:35:48:  STP: PVST vlan 20 port Fa3/0/1 created, ext id 2E42430, vp 3C8E3E0
01:35:48: RSTP(20): initializing port Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now designated
01:35:48: RSTP(10): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(10): Fa3/0/1 is now root port
01:35:48: RSTP(10): Fa3/0/2 blocked by re-root
01:35:48: RSTP(10): synced Fa3/0/1
01:35:48: RSTP(10): Fa3/0/2 is now alternate
01:35:48: RSTP(20): updt roles, received superior bpdu on Fa3/0/1
01:35:48: RSTP(20): Fa3/0/1 is now alternate
01:35:48: RSTP(10): transmitting an agreement on Fa3/0/1 as a response to a prop
osal

Distribution1

01:35:55: %LINK-3-UPDOWN: Interface FastEthernet1/0/1, changed state to up
01:35:56:  STP: PVST vlan 10 port Fa1/0/1 created, ext id 2DA13A8, vp 3BDCCD8
01:35:56: RSTP(10): initializing port Fa1/0/1
01:35:56: RSTP(10): Fa1/0/1 is now designated
01:35:56:  STP: PVST vlan 20 port Fa1/0/1 created, ext id 2DA13A8, vp 2D21C60
01:35:56: RSTP(20): initializing port Fa1/0/1
01:35:56: RSTP(20): Fa1/0/1 is now designated
01:35:56: RSTP(10): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:56: RSTP(10): received an agreement on Fa1/0/1
01:35:57: RSTP(20): transmitting a proposal on Fa1/0/1
01:35:59: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:01: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:03: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:06: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:08: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:10: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:11: RSTP(20): Fa1/0/1 fdwhile Expired
01:36:12: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:14: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:16: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:18: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:20: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:22: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:24: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): transmitting a proposal on Fa1/0/1
01:36:26: RSTP(20): Fa1/0/1 fdwhile Expired


!--- Distribution1 puts the port Fa1/0/1 as designated for VLANs 10 and 20.
!--- It also proposes that Fa1/0/1 is designated for VLANs 10, 20. Access1 agrees with the 
!--- proposal for VLAN10. However, it does not agree with the proposal for VLAN20 because it  
!--- has the superior BPDU for VLAN20 from Distribution2.

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Il est recommandé de vérifier la topologie spanning tree chaque fois que la configuration est changée.

Vérifiez que le commutateur Distribution1 est le pont racine pour les VLAN de données 10, 30, 100. Vérifiez aussi que le chemin de transmission spanning-tree correspond au chemin figurant dans le schéma de réseau.

Distribution1#show spanning-tree vlan 10

VLAN0010
  Spanning tree enabled protocol rstp
  Root ID    Priority    24586
             Address     0015.63f6.b700
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    24586  (priority 24576 sys-id-ext 10)
             Address     0015.63f6.b700
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa1/0/1          Desg FWD 19        128.1    P2p
Fa1/0/3          Desg FWD 19        128.3    P2p
Fa1/0/5          Desg FWD 19        128.5    P2p
Fa1/0/23         Desg FWD 19        128.23   P2p
Fa1/0/24         Desg FWD 19        128.24   P2p


Access1#show spanning-tree summary
Switch is in rapid-pvst mode
Root bridge for: none
Extended system ID           is enabled
Portfast Default             is disabled
PortFast BPDU Guard Default  is enabled
Portfast BPDU Filter Default is disabled
Loopguard Default            is disabled
EtherChannel misconfig guard is enabled
UplinkFast                   is disabled
BackboneFast                 is disabled
Configured Pathcost method used is short

Name                   Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------

VLAN0010                     1         0        0          1          2
VLAN0020                     1         0        0          1          2
---------------------- -------- --------- -------- ---------- ----------
2 vlans                      2         0        0          2          4

Access2> (enable) show spantree 30
VLAN 30
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-63-f6-b7-00
Designated Root Priority    24606
Designated Root Cost        19
Designated Root Port        3/3
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-1d
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     forwarding    ROOT        19   32 P2P
 3/4                     blocking      ALTR        19   32 P2P

Access2> (enable) show spantree 40
VLAN 40
Spanning tree mode          RAPID-PVST+
Spanning tree type          ieee
Spanning tree enabled

Designated Root             00-15-c6-c1-30-00
Designated Root Priority    24616
Designated Root Cost        19
Designated Root Port        3/4
Root Max Age   20 sec   Hello Time 2  sec   Forward Delay 15 sec

Bridge ID MAC ADDR          00-d0-00-50-30-27
Bridge ID Priority          32768
Bridge Max Age 20 sec   Hello Time 2  sec   Forward Delay 15 sec

Port                     State         Role Cost      Prio Type
------------------------ ------------- ---- --------- ---- --------------------
 3/3                     blocking      ALTR        19   32 P2P
 3/4                     forwarding    ROOT        19   32 P2P


Services1#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        18
             Port        7 (FastEthernet0/5)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Root FWD 18        128.7    P2p
Fa0/46           Desg FWD 19        128.50   P2p
Fa0/47           Desg FWD 19        128.51   P2p

Services1#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        37
             Port        51 (FastEthernet0/47)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     0003.fd63.bb80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/5            Altn BLK 19        128.7    P2p
Fa0/46           Altn BLK 19        128.50   P2p
Fa0/47           Root FWD 19        128.51   P2p

Services2#show spanning-tree vlan 100

VLAN0100
  Spanning tree enabled protocol rstp
  Root ID    Priority    24676
             Address     0015.63f6.b700
             Cost        37
             Port        42 (GigabitEthernet0/42)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32868  (priority 32768 sys-id-ext 100)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Altn BLK 19        128.6    P2p
Fa0/42           Root FWD 19        128.42   P2p
Fa0/43           Altn BLK 19        128.43   P2p

Services2#show spanning-tree vlan 200

VLAN0200
  Spanning tree enabled protocol rstp
  Root ID    Priority    24776
             Address     0015.c6c1.3000
             Cost        18
             Port        6 (GigabitEthernet0/6)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32968  (priority 32768 sys-id-ext 200)
             Address     00d0.2bfc.7d80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/6            Root FWD 18        128.6    P2p
Fa0/42           Desg FWD 19        128.42   P2p
Fa0/43           Desg FWD 19         64.43   P2p

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 72836