Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Guide de configuration et de dépannage du routeur DSL Cisco - Configuration pas à pas du routage RFC1483 avec une adresse IP statique unique

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Votre fournisseur de services Internet (ISP) a assigné une adresse IP publique statique simple à votre routeur de Cisco DSL.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Procédures de configuration

Important : Avant que vous commenciez, clôturez tous les programmes sur le PC qui pourrait surveiller votre COM mettent en communication. Les périphériques tels que des PDA et des appareils photo numériques placent souvent les programmes dans la barre d'état système qui rendent votre port COM inutilisable pour la configuration de votre routeur de Cisco DSL.

Connectez le routeur de Cisco DSL et votre PC

Un rapport de console est établi avec un câble enroulé et connecte le port de console du routeur de Cisco DSL à un port COM sur un PC. Le câble console qui est inclus avec le routeur DSL Cisco est un câble bleu-clair plat. Pour plus d'informations sur les sorties d'un câble enroulé, ou les sorties d'un RJ-45 au convertisseur DB9, référez-vous au guide de câblage pour la console et les ports auxiliaires.

  1. Branchez le connecteur RJ45 sur une des extrémités du câble de console Cisco au port de console du routeur DSL Cisco.

  2. Connectez le connecteur RJ-45 à l'autre bout du câble console à un RJ-45 au convertisseur DB9.

  3. Branchez le connecteur DB9 à un port COM ouvert sur votre PC.

Début et HyperTerminal installé

Procédez comme suit :

  1. Démarrez le programme HyperTerminal sur le PC.

  2. Installez votre session de HyperTerminal.

    1. Assignez un nom à votre session et cliquez sur OK.

    2. Dans le connecter à la fenêtre, annulation de clic.

    3. Choisissez le fichier > le Properties.

    4. De la fenêtre de Properties, allez au connecter utilisant la liste et sélectionnez le port COM où vous connectez l'extrémité DB9 du câble de console.

    5. De la fenêtre de Properties cliquez sur Configure et complétez ces valeurs :

      • Bits par seconde : 9600

      • Bits de données : 8

      • Parité : Aucun

      • Bits d'arrêt : 1

      • Contrôle de flux : Aucun

    6. Cliquez sur OK.

    7. Du menu d'appel, cliquez sur Disconnect.

    8. À partir du menu Call, cliquez sur Call.

    9. La presse entrent jusqu'à ce que vous voyiez un routeur inciter sur votre fenêtre de HyperTerminal.

Effacez les configurations existantes sur le routeur de Cisco DSL

Procédez comme suit :

  1. Enable de type à la demande de routeur afin d'entrer le mode privilégié.

    Router>enable
    Router#
    
    !--- The # symbol indicates that you are in privileged mode.
    
    
  2. Effacez les configurations existantes sur le routeur.

    Router#write erase
    
  3. Rechargez le routeur de sorte qu'il démarre avec une configuration de démarrage vide.

    Router#reload
    System configuration has been modified. Save? [yes/no]:no
    Proceed with reload? [confirm]yes
    
    !--- The router reload can take a few minutes.
    
    
  4. Une fois le routeur rechargé, entrez de nouveau le mode enable.

    Router>enable
    Router#

Configurez le routeur de Cisco DSL

Procédez comme suit :

  1. Configurez l'horodateur de service correctement pour se connecter et afficher la sortie de débogage dans la section dépannage.

    Router#configure terminal
    Router(config)#service timestamps debug datetime msec
    Router(config)#service timestamps log datetime msec
    Router(config)#end
    
  2. Désactivez le logging console sur votre routeur de Cisco DSL afin de supprimer les messages console qui pourraient être déclenchés tandis que vous configurez le routeur.

    Router#configure terminal
          Router(config)#no logging console
          Router(config)#end
    
  3. Configurez le Routage IP, l'ip subnet-zero, et l'ip classless afin de fournir la flexibilité dans des options de configuration de routage.

    Router#configure terminal
    Router(config)#ip routing
    Router(config)#ip subnet-zero
    Router(config)#ip classless
    Router(config)#end
    
  4. Configurez une adresse IP et un masque de sous-réseau sur l'interface Ethernet du routeur DSL Cisco.

    Pour le Traduction d'adresses de réseau (NAT) : Intérieur NAT d'enable (facultatif) sur l'interface Ethernet.

    Router#configure terminal
    Router(config)#interface ethernet 0
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat inside
    Router(config-if)#no shut
    Router(config-if)#end
    
  5. Configurez l'interface ATM de votre routeur de Cisco DSL avec l'aucune commande fermée afin d'évoquer l'interface.

    Router#configure terminal
    Router(config)#interface atm 0
    Router(config-if)#no shut
    Router(config-if)#end
    
  6. Configurez la sous-interface atmosphère de votre routeur de Cisco DSL avec un circuit virtuel permanent atmosphère (PVC) et le type d'encapsulation.

    Router#configure terminal
    Router(config)#interface atm 0.1 point-to-point
    Router(config-subif)#
    Router(config-if)#ip address <ip address> <subnet mask>
    
    !--- For NAT:
    
    Router(config-if)#ip nat outside
    Router(config-subif)#pvc <vpi/vci>
    Router(config-subif-atm-vc)#encapsulation aal5snap
    Router(config-subif-atm-vc)#end
    
  7. Configurez un default route utilisant ATM0.1 comme interface sortante.

    Router#configure terminal
    Router(config)#ip route 0.0.0.0 0.0.0.0 atm0.1
    Router(config)#end
    
  8. Pour NAT : Configurez les commandes NAT globales sur le routeur de Cisco DSL de permettre partager de l'adresse IP publique statique de l'interface de numérotation.

    Router#configure terminal
    Router(config)#ip nat inside source list 1 interface atm0.1 overload
    Router(config)#access-list 1 permit <ip network address of ethernet0> 
     <wildcard mask>
    Router(config)#end
    

    Configurations facultatives

    Groupe NAT, si des adresses IP supplémentaires ont été fournies par votre ISP.

    Router(config)#ip nat inside source list 1 interface atm0.1 overload 
    Router(config)#ip nat pool <nat pool name> <first ip address> 
     <last ip address> netmask <subnet mask>
    Router(config)#end
    

    NAT statique, si les internautes ont besoin de l'accès aux serveurs internes.

    Router(config)#ip nat inside source static tcp <inside ip address of server> 
     {80 or 25} <outside well-known ip address of server> {80 or 25} extendable
    Router(config)#end
    
  9. Pour le protocole DHCP (DHCP) : (Facultatif) configurez le routeur de Cisco DSL comme serveur DHCP avec un groupe d'adresses IP pour assigner aux hôtes connectés à l'interface Ethernet du routeur de Cisco DSL. Le serveur DHCP assigne dynamiquement une adresse IP, le Domain Name Server (DN), et l'adresse IP de passerelle par défaut à vos hôtes.

    Router#configure terminal
    Router(config)#ip dhcp excluded-address <ip address of ethernet0>
    Router(config)#ip dhcp pool <dhcp pool name>
    Router(dhcp-config)#network <ip network address of ethernet0> <subnet mask>  
    Router(dhcp-config)#default-router <ip address of ethernet0> 
    Router(dhcp-config)#dns-server <ip address of primary dns server> 
     <ip address of secondary dns server>
    Router(dhcp-config)#end
    
  10. Activez le logging console sur le routeur de Cisco DSL, et puis écrivez toutes les modifications à la mémoire.

    Router#configure terminal
    Router(config)#logging console
    Router(config)#end
    *Jan 1 00:00:00.100: %SYS-5-CONFIG_I: Configured from console by console
    Router#write memory
    Building configuration... [OK]
    Router#

Configuration

C'est la configuration qui est établie après que vous vous soyez terminé les procédures dans la section de procédures de configuration de ce document.

Routeur de Cisco DSL avec une adresse IP statique simple

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Vérifiez

Votre routeur de Cisco DSL est maintenant opérationnel pour le service de Ligne d'abonné numérique à débit asymétrique (ADSL). Vous pouvez émettre une commande de passage d'exposition afin de voir la configuration.

Router#show run
Building configuration...

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Dépannez

Référez-vous dépannage derrière le routage RFC1483 si votre service ADSL ne travaille pas correctement.


Informations connexes


Document ID: 71136