Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Guide de configuration et de dépannage du routeur DSL Cisco - Routage RFC1483 avec une adresse IP statique unique

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Votre fournisseur de services Internet (ISP) a assigné une adresse IP publique statique simple à votre routeur de la ligne d'abonné numérique de Cisco (DSL).

Conseil : Référez-vous à la configuration pas à pas du routage RFC1483 avec une adresse IP statique simple si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Tâches à exécuter

  • Concevez un schéma d'adressage IP pour votre RÉSEAU LOCAL privé.

  • Configurez manuellement une adresse IP et le masque de sous-réseau sur les Ethernets du routeur de Cisco DSL relient.

  • Configurez l'interface ATM interface de ligne d'abonné numérique d'Asymetric ((ADSL)) du routeur de Cisco DSL avec un circuit virtuel permanent atmosphère (PVC), l'encapsulation, et une adresse IP.

  • Pour le Traduction d'adresses de réseau (NAT) : Configurez NAT sur le routeur de Cisco DSL afin de permettre partager de l'adresse IP publique statique de l'interface ATM.

    • Facultatif : Groupe NAT, si des adresses IP supplémentaires ont été fournies par votre ISP.

    • Facultatif : NAT statique, si les internautes ont besoin de l'accès aux serveurs internes.

  • Configurez chaque PC d'hôte avec une adresse IP, un masque de sous-réseau, une passerelle par défaut, et un serveur de Système de noms de domaine (DNS).

    Pour le protocole DHCP (DHCP) : Alternativement, si vous voulez que le routeur de Cisco DSL assigne à vos clients PC des adresses IP dynamiques, configurez chaque PC pour obtenir une adresse IP et un serveur de DN automatiquement par l'intermédiaire du DHCP.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Configuration

Conseil : Référez-vous à la configuration pas à pas du routage RFC1483 avec une adresse IP statique simple si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas.

Routeur de Cisco DSL avec l'adresse IP statique et NAT

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
ip subnet-zero
!

!--- For DHCP:

ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>
 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
!
interface atm0.1 point-to-point
 ip address <ip address> <subnet mask>

!--- For NAT:

 ip nat outside
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!

!--- For NAT:

ip nat inside source list 1 interface atm0.1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface atm0.1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Référez-vous dépannage derrière le routage RFC1483 si votre service ADSL ne travaille pas correctement.


Informations connexes


Document ID: 71132