Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Guide de configuration et de dépannage du routeur DSL Cisco - Routeur DSL Cisco agissant en tant que client PPPoE avec une adresse IP statique

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Votre fournisseur de services Internet (ISP) a assigné une adresse IP publique statique simple à votre routeur de la ligne d'abonné numérique de Cisco (DSL).

Conseil : Si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas, référez-vous à la configuration pas à pas du PPPoE avec une adresse IP statique.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Tâches à exécuter

  • Concevez un schéma d'adressage IP pour votre RÉSEAU LOCAL privé.

  • Configurez une adresse IP, masque de sous-réseau, et le réglage maximum de la taille de segment de TCP (MSS) sur les Ethernets du routeur de Cisco DSL relient.

  • Configurez l'interface ATM (interface de Ligne d'abonné numérique à débit asymétrique (ADSL)) du routeur de Cisco DSL avec un circuit virtuel permanent atmosphère (PVC) et l'encapsulation.

  • Configurez un groupe virtuel du réseau informatique de données privées de Protocole PPPoE (PPP sur Ethernet) (VPDN) pour le logiciel de Cisco IOSÝ plus tard que 12.2(13)T.

  • Créez et configurez l'interface de numérotation du routeur de Cisco DSL pour le PPPoE avec une adresse IP statique.

  • Pour le Traduction d'adresses de réseau (NAT) : Configurez NAT sur le routeur de Cisco DSL pour permettre partager de l'adresse IP publique dynamique de l'interface de numérotation.

    • Facultatif : Groupe NAT, si des adresses IP supplémentaires ont été fournies par votre ISP.

    • Facultatif : NAT statique, si les internautes ont besoin de l'accès aux serveurs internes.

  • Configurez chaque client PC avec une adresse IP, un masque de sous-réseau, une passerelle par défaut, et un serveur de Système de noms de domaine (DNS).

    Pour le protocole DHCP (DHCP) : Alternativement, si vous voulez que le routeur de Cisco DSL assigne à vos clients PC des adresses IP dynamiques, configurez chaque PC pour obtenir une adresse IP et un serveur de DN automatiquement par l'intermédiaire du DHCP.

Étapes requises possibles de configuration sur le PC

Si votre logiciel du router de Cisco DSL prend en charge l'ip tcp adjust-mss 1452 ou l'IP ajustent-mss 1452 commandes de configuration, aucune autre action n'est nécessaire et vous pouvez continuer la section de configurer.

Si votre logiciel du router de Cisco DSL ne prend en charge pas l'ip tcp adjust-mss 1452 ou l'IP ajustent-mss 1452 commandes de configuration, vous devez changer la taille de Maximum Transmission Unit (MTU) sur chaque PC dans votre RÉSEAU LOCAL qui a l'accès à Internet par le routeur de Cisco DSL. Terminez-vous ces étapes afin de changer la taille de MTU.

  1. Téléchargez la dernière version de l'utilitaire de Dr. TCP de http://www.dslreports.com/front/drtcp.htmlleavingcisco.com .

  2. Régénérez votre page de navigateur pour s'assurer que la page est en cours.

  3. Exécutez l'utilitaire de Dr. TCP.

  4. Du menu choisissez votre adaptateur Ethernet.

  5. Dans le domaine de MTU, type 1492.

  6. Cliquez sur Apply pour sauvegarder la modification, et puis cliquez sur la sortie.

  7. Redémarrez le client PC de PPPoE.

Le changement dans le registre est enregistré quand la procédure termine. Par conséquent, vous devez seulement exécuter l'utilitaire une fois par PC.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Configurations

Conseil : Si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas, référez-vous à la configuration pas à pas du PPPoE avec une adresse IP statique.

Routeur de Cisco DSL avec une adresse IP statique

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
vpdn enable
 no vpdn logging
  vpdn-group pppoe
   request-dialin
    protocol pppoe

!--- These commands are needed only on Cisco IOS Software earlier than than 12.2(13)T.

!
!
ip subnet-zero
!

!--- For DHCP:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server> 
!
interface ethernet0  
 no shut  
 ip address <ip address> <subnet mask> 
 ip tcp adjust-mss 1452 
 
!--- If the ip tcp adjust-mss 1452 command is not supported, try this
 !--- configuration statement: ip adjust-mss 1452. If this command is not
 !--- supported in your current Cisco DSL Router software release, upgrade to the 
 !--- latest Cisco DSL Router software or follow the procedure in the
 !--- "Possible Required Configuration Steps on the PC" section of this document. 


!--- For NAT:

 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no ip address
 bundle-enable
 dsl operating-mode auto
!
interface atm0.1 point-to-point
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  pppoe-client dial-pool-number 1
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
!
interface dialer1
 ip address <ip address> <subnet mask>
 mtu 1492

!--- For NAT:

 ip nat outside
 encapsulation ppp
 dialer pool 1
 ppp chap hostname <username>
 ppp chap password <password>
 ppp pap sent-username <username> password <password>
!

!--- For NAT:

ip nat inside source list 1 interface dialer1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface dialer1 overload

 
 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>




!--- If Internet users require access to an internal server, you can 
!--- add this static NAT configuration statement:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!---  <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless
ip route 0.0.0.0 0.0.0.0 interface dialer1

!--- For NAT:

access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, configure 
!--- access-list 1 permit 10.10.10.0 0.0.0.255 in order to allow NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Référez-vous à dépanner le PPPoE Client de routeur de Cisco DSL si votre service dsl ne fonctionne pas correctement.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 71122