Ethernet longue portée (LRE) et ligne numérique d'abonné (xDSL) : Ligne d'abonné numérique à débit asymétrique (ADSL)

Guide de configuration et de dépannage du routeur DSL Cisco - IRB avec une adresse IP dynamique

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Votre fournisseur de services Internet (ISP) a assigné une adresse IP publique dynamique à votre routeur de la ligne d'abonné numérique de Cisco (DSL).

Conseil : Si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas, référez-vous à la configuration pas à pas d'IRB avec une adresse IP dynamique.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Tâches à exécuter

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Remarque: Cet exemple met en valeur deux types de configurations :

  • Serveur du protocole DHCP (DHCP)

  • Traduction d'adresses réseau (NAT).

Tâches :

  • Concevez un schéma d'adressage IP pour votre RÉSEAU LOCAL privé.

  • Configurez une adresse IP et un masque de sous-réseau sur l'interface Ethernet du routeur DSL Cisco.

  • Configurez l'interface ATM interface de ligne d'abonné numérique d'Asymetric ((ADSL)) du routeur de Cisco DSL avec un circuit virtuel permanent atmosphère (PVC) et l'encapsulation.

  • Routage et mise en parallèle intégrés (IRB) d'enable.

  • Créez et configurez l'interface du Bridge Group Virtual Interface (BVI) du routeur de Cisco DSL pour IRB avec une adresse IP négociée.

  • (Pour NAT) — Configurez NAT sur le routeur de Cisco DSL pour permettre partager de l'adresse IP publique dynamique de l'interface BVI.

    • Facultatif : Groupe NAT, si des adresses IP supplémentaires ont été fournies par votre ISP.

    • Facultatif : NAT statique, si les internautes ont besoin de l'accès aux serveurs internes.

  • Configurez chaque PC d'hôte avec une adresse IP, un masque de sous-réseau, une passerelle par défaut, et un serveur de Système de noms de domaine (DNS).

    (Pour le serveur DHCP) — Alternativement, si vous voulez que le routeur de Cisco DSL assigne les adresses IP dynamiques de vos clients PC, configurez chaque PC pour obtenir une adresse IP et un serveur de DN automatiquement par l'intermédiaire du DHCP.

Configuration

Conseil : Si vous n'êtes pas familiarisé avec la façon configurer des périphériques de Cisco et voudriez suivre une configuration pas à pas, référez-vous à la configuration pas à pas d'IRB avec une adresse IP dynamique.

Routeur de Cisco DSL avec une adresse IP dynamique

!--- Comments contain explanations and additional information.


service timestamps debug datetime msec
service timestamps log datetime msec
!
bridge irb
!
ip subnet-zero
!

!--- For the DHCP Server:


ip dhcp excluded-address <ip address of ethernet0>
ip dhcp pool <dhcp pool name>
 network <ip network address of ethernet0> <subnet mask>
 default-router <ip address of ethernet0>
 dns-server <ip address of dns server>
!
interface ethernet0
 no shut
 ip address <ip address> <subnet mask>

!--- For NAT:


 ip nat inside
 no ip directed-broadcast
!
interface atm0
 no shut
 no ip address
 no ip directed-broadcast
 no atm ilmi-keepalive
 pvc <vpi/vci>
  encapsulation aal5snap
 
!--- Common PVC values supported by ISPs are 0/35 or 8/35.
 !--- Confirm your PVC values with your ISP.

 !
 bridge-group 1
!
interface bvi1
 mac-address <address from line 2 of show interface bvi1>
 ip address dhcp client-id ethernet0

!--- For NAT:


 ip nat outside
 no ip directed-broadcast
!

!--- For NAT:


ip nat inside source list 1 interface bvi1 overload

!--- If you have a pool (a range) of public IP addresses provided 
!--- by your ISP, you can use a NAT Pool. Replace 
!--- ip nat inside source list 1 interface bvi1 overload 

 

!--- with these two configuration statements:
!--- ip nat inside source list 1 pool <nat pool name> overload
!--- ip nat pool <nat pool name> <first ip address> <last ip address> 
!---  netmask <subnet mask>



!--- If Internet users require access to an internal server, you can 
!--- add these static NAT configuration statements:
!--- ip nat inside source static tcp <inside ip address of server> {80 or 25} 
!--- <outside well-known ip address of server> {80 or 25} extendable
!--- Note: TCP port 80 (HTTP/web) and TCP port 25 (SMTP/mail) are used 
!--- for this example. You can open other TCP or UDP ports, if needed.

! 
ip classless 
ip route 0.0.0.0 0.0.0.0 <default gateway to isp>

!--- For NAT:


access-list 1 permit <ip network address of ethernet0> <wildcard mask>

!--- In this configuration, access-list 1 defines a standard access list 
!--- that permits the addresses that NAT translates. For example, if  
!--- your private IP network is 10.10.10.0, the configuration of  
!--- access-list 1 permit 10.10.10.0 0.0.0.255 allows NAT to translate 
!--- packets with source addresses between 10.10.10.0 and 10.10.10.255.

!
bridge 1 protocol ieee
 bridge 1 route ip
!
end  

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Référez-vous dépannage derrière RFC1483 jetant un pont sur avec IRB si votre service ADSL ne travaille pas correctement.

Revenez à la page précédente de ces configuration et guide de dépannage - RFC1483 jetant un pont sur avec des options d'implémentation IRB.

Revenez à la page principale du guide de configuration et de dépannage du routeur de Cisco DSL.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 71100