Communication sans fil/mobilité : Réseau local sans fil (WLAN)

Exemples de configuration d'un module contrôleur de réseau local sans fil (WLCM)

16 janvier 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 décembre 2015) | Commentaires


Contenu


Introduction

Le module contrôleur de réseau local sans fil Cisco (WLCM) permet aux produits Cisco ISR et aux routeurs de la gamme Cisco 3700 de gérer jusqu’à six points d’accès de réseau local sans fil (WLAN) et simplifie le déploiement et la gestion des réseaux WLAN. C’est l’équivalent d’un contrôleur Cisco WLC 2006 mis dans un facteur de forme NM. La seule différence est que le NM-WLC (module WLCM) a seulement un port Fast Ethernet connecté en interne au routeur hôte. Le port Fast Ethernet externe sur la plaque NM est désactivé et inutilisable. Ce document explique comment configurer le WLCM pour différents scénarios.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Connaissance de base du protocole LWAPP (Lightweight Access Point Protocol)

  • Connaissance de base du WLC et des aps légers (recouvrements)

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configuration de base

Pensez au NM-WLC pendant qu'un WLC externe (2006) avec seulement une interface de Fast Ethernet (technicien) (connue sous le nom de port 1) connecté intérieurement au port Fast Ethernet d'un routeur a nommé l'interface de contrôleur WLAN. Ce diagramme affiche un exemple.

Remarque: Le port FastEthernet externe sur la plaque du module de Cisco WLC n'est pas pris en charge.

/image/gif/paws/70530/nm-wlc-config-guide-1.gif

Le moyen classique de se connecter au module est intérieurement chez le routeur avec la commande de session de module de service.

  1. Insérez le module NM-WLC sur le routeur et initialisez le routeur avec une image valide.

    N'importe quelle image (de l'ipbase à adventerprisek9) peut prendre en charge le module NM-WLC. Cette caractéristique a été introduite avec la version du logiciel Cisco IOS 12.4(2)XA1 (logiciel du router). La version de firmware minimum de contrôleur devrait être 3.2.78.0 (logiciel contrôleur).

  2. Configurez une adresse IP sur l'interface wlan-controller 1/0 ; assumer le module est branché à l'emplacement 1 du routeur. Exécutez un aucun fermé s'il est dans l'état d'arrêt.

    c2811#configure terminal
    Enter configuration commands, one per line.  End with CNTL/Z.
    c2811(config)#
    c2811(config)#interface wlan-controller 1/0
    c2811(config-if)#ip address 192.168.99.254 255.255.255.0
    c2811(config-if)#no shut
    c2811(config-if)#end
    c2811#
  3. De la demande de privileged exec, ouvrez une session au contrôleur utilisant la commande de session de module de service.

    c2811#service-module wlan-controller 1/0 session 
    Trying 192.168.99.254, 2066 ... Open

    Remarque: Les commandes Cisco IOS pour le module de theWLCM varie sur le routeur qui exécute le Logiciel Cisco IOS version 12.4(15)T ou plus tard. Référez-vous à configurer Cisco WLCM dans le pour en savoir plus de routeur.

Si le contrôleur est apporté pour la première fois sans la configuration antérieure, il entre automatiquement dans un assistant CLI qui te demande une gamme des informations de configuration. Cet assistant ne peut pas être évité et vous devez écrire toutes les informations qu'il demande. Comprenant à l'avance comment vous voulez que vos configurations regardent quand les aides terminées répondent aux questions. Certaines des informations qu'elles demandent ne sont pas appropriées et utilisées immédiatement mais vous devez toujours les fournir parce qu'elles ne reçoivent pas l'entrée non valide et vous ne pouvez pas également sauter. La sortie ressemble à la sortie dans cette table :

Contrôleur de Cisco
Welcome to the Cisco Wizard Configuration Tool
Use the '-' character to backup
System Name [Cisco_ff:f6:a0]: NMWLC
Enter Administrative User Name (24 characters max): admin
Enter Administrative Password (24 characters max): *****
 
Management Interface IP Address: 192.168.99.24
Management Interface Netmask: 255.255.255.0
Management Interface Default Router: 192.168.99.254 
Management Interface VLAN Identifier (0 = untagged): 0
Management Interface Port Num [1]: 1
Management Interface DHCP Server IP Address: 192.168.99.24
 
AP Manager Interface IP Address: 192.168.99.25
 
AP-Manager is on Management subnet, using same values
AP Manager Interface DHCP Server (192.168.99.24): 192.168.99.24
 
Virtual Gateway IP Address: 1.1.1.1
 
Mobility/RF Group Name: mg1
 
Network Name (SSID): wl15
Allow Static IP Addresses [YES][no]: no
 
Configure a RADIUS Server now? [YES][no]: no
Warning! The default WLAN security policy requires a RADIUS server.
Please see documentation for more details.
 
Enter Country Code (enter 'help' for a list of countries) [US]: US
 
Enable 802.11b Network [YES][no]: YES
Enable 802.11a Network [YES][no]: YES
Enable 802.11g Network [YES][no]: YES
Enable Auto-RF [YES][no]: no
Configuration saved!
Resetting system with new configuration...

Une fois que la configuration est complète, elle redémarre automatiquement avec la nouvelle configuration et arrête à l'utilisateur : incitez où vous fournissez un nom d'utilisateur et mot de passe. (Contrôleur de Cisco) > la demande apparaît alors.

User:admin
Password:*****
(Cisco Controller) >

Une fois que vous êtes dans la demande de contrôleur, vous pouvez faire d'autres configurations ou modifications de ce que vous avez fait par l'assistant CLI. Utilisation ? pour obtenir de l'aide.

Afin de commuter de nouveau au routeur, à la presse ctrl+shift+6, release, et puis appuyer sur le X. Ceci vous porte à la demande de routeur. La session demeure intact, ainsi si vous appuyez sur entre, il vous rappelle le contrôleur. Si vous voulez complètement clair la session, écrivez le débranchement à la demande de routeur.

Quoique le contrôleur ait seulement un port physique (désigné sous le nom de port 1), vous pouvez créer un certain nombre d'interfaces logiques là-dessus, statique ou dynamique, et ces interfaces peuvent être VLAN-étiquetées ou non-marquées. Par défaut, le contrôleur a deux statiques et interfaces non-marquées :

  • Interface de gestion

  • INTERFACE DE AP-MANAGER

L'interface de gestion est utilisée pour la Gestion. Si vous choisissez d'employer une interface gui basée sur le WEB afin de gérer le WLCM, vous devez configurer l'adresse IP sur l'interface de gestion et rendre cela accessible à partir du poste de travail que vous prévoyez de le gérer de.

Remarque: Par défaut, le serveur HTTP sur le contrôleur est désactivé mais le HTTP sécurisé est activé. Par conséquent, l'URL à l'adresse IP de Gestion de contrôleur doit être https://mgt-ip-address.

L'interface d'AP-gestionnaire est utilisée par le contrôleur pour parler aux recouvrements. Puisque les interfaces de Gestion et d'AP-gestionnaire sont non-marquées, elles doivent être dans le même IP de sous-réseau que l'interface WLC sur le routeur.

(Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254
(Cisco Controller) config>interface address ap-manager 
                           192.168.99.25 255.255.255.0 192.168.99.254

Vous pouvez configurer le CLI de deux manières. On est de l'invite normale en précédant le CLI avec le config. L'autre méthode est d'aller au config prompt avec la commande de config et puis d'émettre CLIs sans config de mot. Exemple :

 (Cisco Controller) >config
(Cisco Controller) config>interface address management 
                           192.168.99.24 255.255.255.0 192.168.99.254

ou

(Cisco Controller)>config interface address management 
                        192.168.99.24 255.255.255.0 192.168.99.254

Cet exemple configure l'interface de gestion avec l'adresse IP 192.168.99.24/24 et définit la passerelle par défaut comme 192.168.99.254.

Remarque: La passerelle par défaut sur la Gestion et la Gestion AP devrait indiquer l'adresse IP du port Ethernet WLCM.

Remarque: Une fois que vous configurez ces adresses IP par l'intermédiaire de l'assistant puis vous n'avez pas besoin de ces commandes. C'est juste de te prouver que ces deux adresses IP appartiennent au même sous-réseau et ceci peut également être configuré par l'intermédiaire de la ligne de commande.

Dans des les deux cas, la dernière adresse IP (192.168.99.254) est l'adresse IP de passerelle par défaut. Puisque la seule sortie du contrôleur est par l'intermédiaire du routeur hôte, la passerelle par défaut devrait être l'adresse IP de l'interface wlan-controller1/0 sur le routeur. Avec cette beaucoup de configuration, vous pouvez cingler du routeur à l'adresse IP d'interface de gestion du contrôleur.

c2811#ping 192.168.99.24
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.24, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
c2811# 

Exemple 1 - La configuration de base avec AP s'est connectée à un routeur à bord de Fast Ethernet/de Gigabit Ethernet

Quand un RECOUVREMENT connecté à l'interface à bord de Gigabit Ethernet (g0/0) d'un routeur est mis sous tension, il envoie une requête DHCP pour une adresse IP. Dans cet exemple, le routeur est configuré comme serveur DHCP avec le groupe d'adresse IP du réseau 192.168.100.0/24. Ainsi, le RECOUVREMENT obtient une adresse IP de 192.168.100.101. L'offre DHCP indique également le RECOUVREMENT (par l'intermédiaire d'option 43) que l'adresse IP de contrôleur est 192.168.99.24 (l'adresse IP de Gestion du contrôleur). Le RECOUVREMENT envoie maintenant un unicast de message de détection de contrôleur à 192.168.99.24. Le contrôleur offre l'enregistrement et en conséquence, le RECOUVREMENT s'inscrit au contrôleur.

Employez la commande de show ap summary afin de voir le RECOUVREMENT qui s'inscrit au WLCM.

(Cisco Controller) >show ap summary

AP Name             Slots  AP Type    MAC Addr           Location          Port
------------------  -----  ---------  -----------------  ---------------- 	----
AP11                 2     Cisco      00:0b:85:01:03:30                   	1

Dans cet exemple, le contrôleur est configuré avec deux WLAN (wl15 et wl16) comme décrit plus tard dans le document.

Le client C1 envoie une demande d'association avec SSID wl15. Il associe et obtient une adresse IP de 192.168.15.101 et une passerelle par défaut de 192.168.15.1 du serveur DHCP configuré sur le routeur.

Le client C2 envoie également une demande d'association avec SSID wl16. Il associe et obtient une adresse IP de 192.168.16.101 et une passerelle par défaut de 192.168.16.1. Maintenant il y a deux clients dans deux différents sous-réseaux. La transmission entre eux est possible à l'aide d'un routeur qui exécute le routage entre ses deux sous-interfaces (wlc1/0.15 et wlc1/0.16) comme ce diagramme affiche :

La configuration exigée sur les périphériques pour cette installation est discutée dans la section de configuration de contrôleur de ce document.

/image/gif/paws/70530/nm-wlc-config-guide-2.gif

Configuration de contrôleur

Cette section discute la configuration exigée sur le module de contrôleur.

  1. Créez deux interfaces dynamiques nommées vl15 dans VLAN 15 et vl16 dans VLAN 16.

    (Cisco Controller) >config interface create vl15 15
    (Cisco Controller) >config interface create vl16 16
    
  2. Assignez l'adresse IP, le netmask, et la passerelle par défaut pour ces interfaces VLAN.

    (Cisco Controller) >config interface address vl15 
                                  192.168.15.254 255.255.255.0 192.168.15.1
    
    (Cisco Controller) >config interface address vl16 
                                  192.168.16.254 255.255.255.0 192.168.16.1
    

    Remarque: La passerelle par défaut pour les interfaces dynamiques doit être l'adresse IP de sous-interface sur le routeur pour le VLAN correspondant.

  3. Créez deux WLAN 15 et 16 avec SSID correspondant wl15 et wl16.

    (Cisco Controller) >wlan create 15 wl15
    (Cisco Controller) >wlan create 16 wl16
    
  4. Liez ces WLAN avec les interfaces VLAN correspondantes que vous avez créées (du côté de câble).

    (Cisco Controller) >wlan interface 15 vl15
    (Cisco Controller) >wlan interface 16 vl16
    
  5. Configurez les interfaces dynamiques que vous avez créé avec une adresse IP de serveur DHCP pour expédier les requêtes DHCP de client à.

    Puisque le serveur DHCP est configuré sur le routeur, il devrait indiquer les adresses IP correspondantes de sous-interface du routeur. Si vous avez un serveur DHCP externe, alors il devrait indiquer cette adresse IP.

    (Cisco Controller) >interface dhcp vl15 192.168.15.1
    (Cisco Controller) >interface dhcp vl16 192.168.16.1
    
  6. Par défaut, la méthode d'authentification est dot1x et elle est activée. Afin de fonctionner avec l'authentification ouverte, désactivez-la avec cette commande pour les deux WLAN :

    (Cisco Controller) >wlan security 802.1X disable 15
    (Cisco Controller) >wlan security 802.1X disable 16
    

Cette configuration peut être développée a basé sur vos besoins tels que plus de VLAN/de WLAN, authentification (Lightweight Extensible Authentication Protocol [LEAP], EAP), QoS, et ainsi de suite.

Remarque: Avec WLCM, il est difficile que un RECOUVREMENT découvre le WLCM par l'émission d'IP de sous-réseau. C'est en raison de la manière que le WLCM intègre sur le fond de panier et le RECOUVREMENT et l'interface de gigabit du routeur 2800 qui est directement connecté au RECOUVREMENT doit être le même sous-réseau. Si vous voulez exécuter la détection d'émission d'IP de sous-réseau avec le succès, utilisez le forward-protocol udp de l'IP helper-address/ip 12223 commandes. Généralement le but de ces commandes est d'expédier/relais potentiellement n'importe quelle trame de diffusion IP. Simplement le relais et la direction de lui vers l'interface de gestion WLC devraient être adéquats pour obtenir le WLC pour répondre de nouveau au RECOUVREMENT.

Remarque: Toutes les configurations de contrôleur dans cette section peuvent facilement être faites par l'accès GUI par l'intermédiaire d'un navigateur Web une fois que l'interface de gestion est configurée avec une adresse IP, un netmask, et des informations de passerelle. En outre, n'importe quel routage exigé sur le réseau pour que vos stations de navigateur puissent atteindre le contrôleur est fait. L'URL pour ouvrir la page GUI est https://192.168.99.24.

Configuration du routeur

Terminez-vous ces étapes afin de configurer le routeur pour installé cette section décrit.

  1. Configurez l'interface G0/0 sur le routeur qu'elle est connectée au RECOUVREMENT.

  2. Configurez l'interface wlan-controller 1/0 avec une adresse IP des 192.168.99.0/24 réseaux et les sous-interfaces w1/0.15 dans VLAN 15 et w1/0.16 dans VLAN 16 avec des adresses IP des réseaux 192.168.15.0/24 et 192.168.16.0/24.

  3. Configurez un serveur DHCP sur le routeur avec plusieurs groupes définis.

    • Le groupe lwapp-AP assigne une adresse IP à AP du réseau 192.168.100.0/24 qui inclut également l'option 43 DHCP qui informe AP de l'adresse IP de contrôleur pour entrer en contact.

    • Le groupe client-15 assigne une adresse IP aux clients (de câble/radio) dans VLAN 15 du réseau 192.168.15.0/24.

    • Le groupe client-16 assigne une adresse IP aux clients (de câble/radio) dans VLAN 16 du réseau 192.168.16.0/24.

Cette sortie affiche la configuration sur le routeur :

Routeur
!		
interface GigabitEthernet0/0								
Description: Connected to AP							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 duplex auto									
 speed auto
									
!										
ip dhcp excluded-address 192.168.100.1 192.168.100.100
!
ip dhcp pool lwapp-ap

!--- Creates a DHCP pool for the LAP.

network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15

!--- Creates a DHCP pool for users that connect to WLAN wl15.

network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16

!--- Creates a DHCP pool for users that connect to WLAN wl16.

network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!										
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15

!--- Creates a sub-interface for VLAN 15.
						
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16

!--- Creates a sub-interface for VLAN 16.
					
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0							
!

Exemple 2 - Configurations VLAN avec des aps connectés à un commutateur externe

Le WLCM branché au routeur peut être logiquement considéré équivalent à un WLC externe connecté au routeur par l'intermédiaire d'une interface Ethernet pendant que ce diagramme affiche. Avec la supposition que le module réseau est branché à l'emplacement 1 du routeur, la Connectivité typique se compose :

  • Un WLCM s'est connecté au routeur par l'interface wlan-controller 1/0.

  • Un commutateur connecté de la couche 2 aux Gigabit Ethernet à bord de Routeurs relient G0/0.

  • AP léger Protocol (LWAPP) AP s'est connecté au commutateur.

  • Les clients sans fil C1 et C2 ont associé avec AP, un dans WLAN 15 et l'autre dans WLAN 16.

Cet exemple affiche comment deux VLAN sans fil ou WLAN (wl15 et wl16) sont créés sur le contrôleur, tracé au côté de câble correspondant VLAN 15 et VLAN 16, et comment l'acheminement entre le VLAN 15 et VLAN 16 est fait par le routeur par des sous-interfaces dot1Q.

Sur le routeur, créez une sous-interface sous l'interface WLC (dans le mode de configuration d'interface) pour chaque VLAN, assignez-la au VLAN correspondant, et configurez l'adresse IP des sous-réseaux respectifs.

Voyez la section de configuration de contrôleur de ce document pour les configurations requises sur les périphériques pour cette installation.

/image/gif/paws/70530/nm-wlc-config-guide-3.gif

Configuration de contrôleur

Terminez-vous ces étapes sur le module de contrôleur pour cette installation.

  1. Sur le contrôleur, pour chaque VLAN, créez une interface dynamique dans le VLAN correspondant et assignez une adresse IP, un netmask, et des passerelles par défaut des sous-réseaux respectifs.

    (Cisco Controller)#configure interface create vl15 15
    (Cisco Controller)#configure interface create vl16 16
    
    (Cisco Controller)#configure interface address 
                      Vl15 192.168.15.254 255.255.255.0 192.168.15.1
    (Cisco Controller)#configure interface address 
                      Vl16 192.168.16.254 255.255.255.0 192.168.16.1
    
  2. Créez deux WLAN 15 et 16 avec SSID correspondant wl15 et wl16.

    (Cisco Controller)#configure wlan create 15 wl15
    (Cisco Controller)#configure wlan create 16 wl16
    
  3. Liez ces WLAN avec les interfaces VLAN correspondantes que vous avez créées (du côté de câble).

    (Cisco Controller)#configure wlan interface 15 Vl15
    (Cisco Controller)#configure wlan interface 16 Vl16
    
  4. Configurez les informations de serveur DHCP sur les interfaces des contrôleurs (pour des clients sans fil) ce point aux adresses IP respectives de sous-interface sur le routeur.

    (Cisco Controller)#configure interface dhcp vl15 192.168.15.1
    (Cisco Controller)#configure interface dhcp Vl16 192.168.16.1
    

Avec ces configurations, les deux clients sans fil dans deux WLAN devraient être en service, avec la supposition que la configuration de sécurité appropriée est également faite. Le trafic du client dans WLAN 15 destiné au client dans WLAN 16 est conduit entre les sous-interfaces w1/0.15 et w1/0.16 sur le routeur. Les mêmes configurations peuvent être étendues pour un certain nombre de VLAN jusqu'au nombre maximal de VLAN pris en charge pour le contrôleur (16).

Configuration du commutateur

Avec la supposition que tous les clients câblés sont connectés au commutateur (par exemple, cat3750) qui est trunked au routeur par la yole 1/0/1 d'interface pour le routage d'inter-RÉSEAU LOCAL, connectez le LWAPP AP dans l'interface F1/0/1 sur le commutateur et configurez-le pour VLAN 100.

Interface Fastethernet 1/0/1
Description: Connected to LWAPP AP
Switchport access vlan 100
Switchport mode access
!
Interface Gigabitethernet 1/0/1
Description: Connected to Router
Switchport trunk encapsulation dot1Q
Switchport mode trunk

Configuration du routeur

Terminez-vous ces étapes sur le routeur.

  1. Configurez l'interface G0/0 qu'elle est connectée au commutateur et également aux sous-interfaces exigées pour le Routage inter-VLAN pour le lan câblée.

  2. Configurez l'interface wlan-controller 1/0 avec une adresse IP des 192.168.99.0/24 réseaux et les sous-interfaces w1/0.15 dans VLAN 15 et w1/0.16 dans VLAN 16 avec des adresses IP des réseaux 192.168.15.0/24 et 192.168.16.0/24.

  3. Configurez un serveur DHCP sur le routeur avec plusieurs groupes définis.

    • Le groupe lwapp-AP assigne une adresse IP à AP du réseau 192.168.100.0/24 qui inclut également l'option 43 DHCP qui informe AP de l'adresse IP de contrôleur pour entrer en contact.

    • Le groupe client-15 assigne une adresse IP aux clients (de câble/radio) dans VLAN 15 du réseau 192.168.15.0/24.

    • Le groupe client-16 assigne une adresse IP aux clients (de câble/radio) dans VLAN 16 du réseau 192.168.16.0/24.

    Remarque: Les pools séparés sont nécessaires pour des aps et des clients.

Routeur
ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
								
ip dhcp pool client-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 

ip dhcp pool client-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet0/0
Description: Connected to AP
No ip address							
 load-interval 30									
 duplex auto									
 speed auto
!
interface GigabitEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0	
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
ip address 192.168.15.1 255.255.255.0							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
ip address 192.168.16.1 255.255.255.0

Remarque: Vous pouvez également diriger des services DHCP pour les clients sur le contrôleur. Mais il est recommandé pour fonctionner sur le routeur car le contrôleur n'est pas un véritable serveur DHCP et ne peut pas transmettre des options comme le serveur TFTP exigé pour des applications comme Cisco CallManager Express.

Avec cette configuration, AP peut obtenir l'adresse IP, trouver, et s'inscrire au contrôleur. Deux clients sans fil C1 et C2 devraient pouvoir s'associer avec AP et obtenir l'adresse IP des sous-réseaux respectifs.

Exemple 3 - Configurations avec des aps connectés à un EtherSwitch sur le routeur et les VLAN correspondants de fusionnement des réseaux locaux de câble et Sans fil

Dans ce scénario, il y a un EtherSwitch HWIC branché à l'emplacement 0 ISR HWIC et un NM-WLC branché au client câblé C3 de l'emplacement 1. nanomètre est connecté pour relier F0/0/1 dans VLAN 15 avec une adresse IP de 192.168.15.102 et le client câblé C4 est connecté à F0/0/2 dans VLAN 16 à une adresse IP de 192.168.16.102.

Le LWAPP AP est connecté pour relier F0/0/0 dans VLAN 100 avec une adresse IP de 192.168.100.1. Le routeur est configuré comme serveur DHCP pour servir une adresse IP à AP. Par exemple, AP reçoit une adresse IP de 192.168.100.101, une passerelle par défaut de 192.168.100.1 et une adresse IP de contrôleur de 192.168.99.24 par l'intermédiaire de l'option 43.

Remarque: La configuration exigée sur le contrôleur est semblable à la configuration expliquée dans l'exemple précédent et n'est pas discutée ici. Les sections restantes fournissent la configuration exigée sur le routeur.

/image/gif/paws/70530/nm-wlc-config-guide-4.gif

Les clients sans fil C1 et C2 s'associent avec le RECOUVREMENT dans wl15 et wl16 respectivement. Les clients sans fil C1 et C2 obtiennent également une adresse IP de 192.168.15.101 et de 192.168.16.101 assignés par le serveur DHCP configuré sur le routeur ou un serveur DHCP externe avec des groupes IP pour ces sous-réseaux. Si le serveur DHCP est externe, l'adresse auxiliaire IP doit être configurée sur le VLAN correspondant et les sous-interfaces. De la perspective du routeur, il fait représenter deux VLAN de câble par l'interface vlan 15 et les VLAN sans fil de l'interface vlan 16 et deux représentés par les sous-interfaces w1/0.15 et w1/0.16 dot1Q sous le WLC relient sur le routeur.

Afin de réduire VLAN de câble 15 et radio WLAN 15 ensemble, configurez l'interface vlan 15 et reliez w1/0.15 sous un groupe commun de passerelle, par exemple, le passerelle-groupe 15. De même, afin de réduire VLAN de câble 16 et radio WLAN 16, configurez l'interface vlan 16 et reliez w1/0.16 sous un groupe commun de passerelle, par exemple, le passerelle-groupe 16. Avec cette configuration, la correspondance de câble et les VLAN sans fil appartiennent aux mêmes sous-réseaux 192.168.15.0/24 et 192.168.16.0/24 IP et peuvent parler entre eux dans le groupe de passerelle. Mais afin des clients dans deux groupes différents de passerelle à communiquer entre eux, Routage et mise en parallèle intégrés (IRB) d'enable sur le routeur de sorte qu'ils communiquent par l'intermédiaire des interfaces BVI dans les groupes respectifs de passerelle.

Remarque: Cette configuration est fondée sur l'hypothèse que vous avez EtherSwitch HWIC ou NM-ESW sur le routeur pour le lan câblée. Si vous avez le module de service d'EtherSwitch (NME-ESW) au lieu du NM/HWIC, les interfaces VLAN sont remplacées par les sous-interfaces correspondantes dot1Q sous l'interface de Gigabit Ethernet sur le routeur et le reste de la configuration demeure même.

Configuration du routeur
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 


interface FastEthernet0/0/0								
Description: Connected to AP
Switchport mode access
Switchport access vlan 100
!
interface FastEthernet0/0/1								
Description: Connected to C3
Switchport mode access
Switchport access vlan 15
!
interface FastEthernet0/0/2								
Description: Connected to C4
Switchport mode access
Switchport access vlan 16
!
Interface vlan 15
Bridge-group 15
!
Interface vlan 16
Bridge-group 16

Interface vlan 100							
 ip address 192.168.100.1 255.255.255.0						
 load-interval 30									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Exemple 4 - Les configurations avec des VLAN de câble sous NME-ESW ont fusionné avec des VLAN sans fil sous NM-WLC

Considérez ce scénario où vous avez un module de service EtherSwitch (NME-ESW) branché à l'emplacement 2 et un NM-WLC ISR nanomètre branché à l'emplacement 1. nanomètre. Le NME-ESW peut être considéré équivalent à un commutateur externe connecté au routeur par un lien de Gigabit Ethernet. Le client câblé C3 est connecté pour relier F0/0/1 dans VLAN 15 avec l'adresse IP 192.168.15.102 et le client câblé C4 connecté à F0/0/2 dans VLAN 16 à l'adresse IP 192.168.16.102

Le LWAPP AP est connecté pour relier F0/0/3 dans VLAN 100. L'interface interne d'EtherSwitch (G1/0/2) est intérieurement connectée au routeur hôte aux Gigabit Ethernet 2/0 d'interface. Puisqu'il y a plus d'un VLAN dans le commutateur, le lien interne entre le commutateur et le routeur devrait être configuré comme joncteur réseau. Le routeur est configuré comme un serveur DHCP avec plusieurs groupes afin de servir l'adresse IP à AP et aux clients (de câble et radio).

AP obtient une adresse IP de 192.168.100.101, une passerelle par défaut de 192.168.100.1 et une adresse IP de contrôleur de 192.168.99.24 par l'intermédiaire de l'option 43, et les découvre et s'inscrit au contrôleur. Les clients sans fil C1 et C2 s'associent avec le RECOUVREMENT dans WLAN 15 et 16 et obtiennent l'adresse IP 192.168.15.101 et 192.168.16.101 respectivement. Les clients câblés C3 et C4 dans VLAN 15 et 16 obtiennent également une adresse IP de 192.168.15.102 et de 192.168.16.102 du serveur DHCP.

Afin de fusionner a câblé VLAN 15 avec la radio WLAN 15, configure les interfaces G2/0.15 et l'interface w1/0.15 sous un groupe commun 15 de passerelle. De même, interfaces de dessous G2/0.16 du groupe 16 de passerelle et W1/0.16. Les deux groupes de passerelle communiquent entre eux par leurs interfaces BVI BVI15 et BVI16.

La configuration de contrôleur demeure même que dans les scénarios plus tôt.

/image/gif/paws/70530/nm-wlc-config-guide-5.gif

Configuration du routeur

Configuration du routeur
!

ip dhcp excluded-address 192.168.100.1 192.168.100.100
ip dhcp excluded-address 192.168.15.1 192.168.15.100
ip dhcp excluded-address 192.168.16.1 192.168.16.100
!
ip dhcp pool lwapp-ap
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1 
option 43 ascii "192.168.99.24"
!
ip dhcp pool vlan-15
network 192.168.15.0 255.255.255.0
default-router 192.168.15.1 
!
ip dhcp pool vlan-16
network 192.168.16.0 255.255.255.0
default-router 192.168.16.1 
!
interface GigabitEthernet2/0								
Description: Internally connected to Etherswitch
IP address 20.0.0.1 255.255.255.0
load-interval 30
!
Interface GigabitEthernet2/0.100
Encapsulation dot1Q 100							
 ip address 192.168.100.1 255.255.255.0						

Interface GigabitEthernet2/0.15
Encapsulation dot1Q 15							
 Bridge-group 15
!
Interface GigabitEthernet2/0.16
Encapsulation dot1Q 16							
Bridge-group 16									
 !
interface wlan-controller1/0								
 ip address 192.168.99.254 255.255.255.0							
!										
interface wlan-controller1/0.15								
encapsulation Dot1q 15								
bridge-group 15							
!										
interface wlan-controller 1/0.16							
encapsulation Dot1q 16								
bridge-group 16									
!										
Bridge irb
Bridge 15 route ip
Bridge 15 protocol ieee
Bridge 16 route ip
Bridge 16 protocol ieee

Interface bvi 15
Ip address 192.168.15.1 255.255.255.0
!
Interface bvi 16
Ip address 192.168.16.1 255.255.255.0

Configuration du commutateur

Ouvrez une session du routeur au module de service EtherSwitch avec la commande de session de module de service. Une fois sur le commutateur, configurez le commutateur comme cette sortie affiche :

!
Interface GigabitEthernet 1/0/2
Description: Internally connected to router G2/0 interface.
Switchport trunk encapsulation dot1Q
Switchport mode trunk

!
Interface Fastethernet 0/0/1
Description: Connected to Client C3 in vlan 15
Switchport access vlan 15
Switchport mode access
!
Interface Fastethernet 0/0/2
Description: Connected to Client C4 in vlan 16
Switchport access vlan 16
Switchport mode access
!
Interface Fastethernet 0/0/3
Description: Connected to Client LWAPP AP in vlan 100
Switchport access vlan 100
Switchport mode access

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 70530