Commutateurs : Commutateurs Cisco Catalyst, s�rie 4500

Exemple de configuration de la connexion de commutateurs Catalyst IOS à des téléphones IP Cisco

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (7 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit des exemples de configuration sur des commutateurs Catalyst afin de se connecter aux téléphones IP Cisco. Ce document comporte les configurations du port de commutation, de l'alimentation incorporée et de la qualité de service (QoS). La configuration du port de commutation utilise une macro prédéfinie qui configure les paramètres du port de commutation et de QoS avec un minimum de commandes.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Ce document explique la configuration des commutateurs qui connectent les PC et les téléphones IP sur un port de commutation. Le téléphone IP Cisco contient un commutateur intégré 10/100 à trois ports. Les ports sont des connexions dédiées.

  • Le port 1 se connecte au commutateur Catalyst ou à tout autre périphérique qui prend en charge la voix sur IP.

  • Le port 2 est une interface 10/100 interne qui achemine le trafic téléphonique.

  • Le port 3 se connecte à un PC ou à tout autre périphérique.

Remarque: Seuls deux ports sont physiquement visibles. L'autre port est un port interne qui n'est pas physiquement visible. Dans cette section, le port 2 n'est pas visible.

Le commutateur comporte deux VLAN : le premier achemine le trafic de données et le second, le trafic vocal. Le port de commutation peut être un VLAN d'accès ou de liaison, mais vous devez configurer un VLAN voix pour acheminer le trafic voix.

Si votre commutateur a un module capable de fournir l'alimentation via Ethernet (PoE) aux stations d'extrémité, vous pouvez définir chaque interface sur le module de façon à détecter automatiquement et à appliquer le PoE si la station d'extrémité doit être alimentée. Par défaut, quand le commutateur détecte un périphérique alimenté sur une interface, il suppose que le périphérique alimenté consomme le port maximal qu'il peut fournir. Le maximum est 7 W sur un module PoE existant et 15.4W sur les modules PoE d'IEEE introduits dans la version de logiciel 12.2(18)EW de Cisco IOSÝ. Quand le commutateur reçoit un paquet de Cisco Discovery Protocol (CDP) du périphérique alimenté, la puissance est automatiquement réglée vers le bas sur la quantité spécifique requise par ce périphérique. Normalement, ce réglage automatique fonctionne bien et aucune autre configuration n'est obligatoire ni recommandée. Cependant, vous pouvez spécifier la consommation du périphérique alimenté pour tout le commutateur (ou pour une interface particulière) afin de fournir une fonctionnalité supplémentaire à partir du commutateur. Ceci est particulièrement utile quand le CDP est désactivé ou non disponible.

Puisque la qualité sonore d'un appel téléphonique sur IP peut se détériorer si les données sont envoyées de façon inégale, le commutateur utilise la classe de service (CoS) d'IEEE 802.1p reposant sur QoS. QoS utilise la classification et la planification pour transmettre le trafic réseau provenant du commutateur d'une manière prévisible. Consultez Configuration de QoS pour plus d'informations sur QoS. Cisco AutoQoS automatise le déploiement cohérent des fonctions de QoS sur tous les routeurs et commutateurs Cisco. Il active divers composants de Cisco QoS en fonction de l'environnement réseau et applique les recommandations d'utilisation de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/69632/configuring-cat-ip-phone1.gif

Configurations

La configuration du commutateur Catalyst contient ces configurations :

Configurer le port de commutation pour acheminer le trafic vocal et de données

Quand vous connectez un téléphone IP à un commutateur à l'aide d'une liaison de jonction, cela peut entraîner une forte consommation du CPU dans les commutateurs. Comme tous les VLAN d'une interface donnée sont liés au téléphone, cela accroît le nombre d'instances STP gérées par le commutateur. Ceci augmente l'utilisation du CPU. La liaison provoque également un trafic inutile de diffusion/multicast/diffusion unique sur la ligne téléphonique.

Afin d'éviter ceci, supprimez la configuration de liaison et gardez le VLAN voix et d'accès configuré avec QoS. Techniquement, c'est toujours une liaison, mais elle se nomme Port d'accès multi-VLAN (MVAP). Puisque le trafic voix et de données peut être acheminé par le même port, spécifiez un VLAN différent pour chaque type de trafic. Vous pouvez configurer un port de commutation pour transférer le trafic voix et de données sur des réseaux locaux virtuels différents. Configurez les ports de téléphone IP avec une configuration VLAN voix. Cette configuration crée une pseudo liaison, mais n'exige pas que vous supprimiez manuellement les VLAN inutiles.

La fonctionnalité de VLAN voix permet à des ports d'accès d'acheminer le trafic voix sur IP à partir d'un téléphone IP. La fonctionnalité de VLAN voix est désactivée par défaut. La fonctionnalité Port Fast est automatiquement activée quand le VLAN voix est configuré. Quand vous désactivez le VLAN voix, la fonctionnalité Port Fast n'est pas automatiquement désactivée. Ce sont les options de la configuration de VLAN voix :

Switch(config-if)#switchport voice vlan ?
  <1-4094>  Vlan for voice traffic
  dot1p     Priority tagged on PVID
  none      Do not tell telephone about voice vlan
  untagged  Untagged on PVID
  • Entrez un ID VLAN voix pour envoyer les paquets CDP qui configurent le téléphone IP afin de transmettre le trafic voix dans les cadres 802.1Q, balisé avec l'ID VLAN voix et une valeur CoS de couche 2 (la valeur par défaut est 5 pour le trafic voix et 3 pour le trafic de contrôle de voix). Les ID VLAN valides vont de 1 à 4094. Le commutateur met le trafic voix 802.1Q dans le VLAN voix.

  • Entrez le mot clé dot1p pour envoyer les paquets CDP qui configurent le téléphone IP afin de transmettre le trafic voix dans les cadres 802.1p, balisé avec l'ID VLAN 0 et une valeur CoS de couche 2 (la valeur par défaut est 5 pour le trafic voix et 3 pour le trafic de contrôle de voix). Le commutateur met le trafic voix 802.1p dans le VLAN d'accès.

  • Entrez le mot clé untagged afin d'envoyer les paquets CDP qui configurent le téléphone IP pour transmettre le trafic voix non balisé. Le commutateur met le trafic voix non balisé dans le VLAN d'accès.

  • Entrez le mot clé none pour permettre au téléphone IP d'utiliser sa propre configuration et de transmettre un trafic voix non balisé. Le commutateur met le trafic voix non balisé dans le VLAN d'accès.

Dans le cadre de cet exemple, VLAN 10 transmet le trafic de données et VLAN 20, le trafic voix :

Configurer le commutateur Catalyst pour transmettre le trafic voix et de données
Switch#configure terminal

Switch(config)#interface fastethernet 2/5 

Switch(config-if)#switchport mode access

Switch(config-if)#Switchport access vlan 10

Switch(config-if)#switchport voice vlan 20


!--- Configures the IP phone to transmit voice traffic in
!--- 802.1Q frames tagged with voice VLAN ID 20.


end

Remarque:  Vous ne pouvez pas désactiver la fonctionnalité de plage de ports sur les téléphones 7960/40.

Configurer la prise en charge de l'alimentation incorporée

Cisco offre une large gamme de commutateurs Catalyst prenant en charge un PoE conforme à la norme 802.3af, qui prend également en charge l'implémentation pré-standard PoE de Cisco. IEEE 802.3af-2003 décrit cinq classes d'alimentation auxquelles un périphérique peut appartenir. La classification d'alimentation par défaut dans le cadre d'IEEE 802.3af fournit 15,4 W par périphérique d'alimentation. La fourniture d'un PoE qui utilise la classification IEEE 802.3af par défaut peut accroître de façon significative les besoins en alimentation sur le commutateur PSE (Power Sourcing Equipment) et sur l'infrastructure d'alimentation. Afin de fournir PoE de façon rentable et efficace, les commutateurs Catalyst prennent en charge la gestion de l'alimentation intelligente en plus de la classification IEEE 802.3af. Ceci permet à un périphérique alimenté et à un PSE de négocier leurs fonctionnalités respectives afin de gérer explicitement l'alimentation requise pour le périphérique, ainsi que la façon dont le commutateur PSE gère l'attribution de l'alimentation aux périphériques alimentés.

Entrez la commande show power inline afin d'afficher la consommation électrique susceptible d'être fournie par un commutateur :

Switch#show power inline consumption default
Default PD consumption : 15400 mW

Par défaut, tous les ports de commutation sont configurés de façon à détecter et à alimenter automatiquement les périphériques PoE. Entrez la commande show power inline afin d'afficher l'état de configuration de l'alimentation incorporée de n'importe quel port :

Switch#show power inline FastEthernet 2/5 
Interface Admin  Oper       Power   Device              Class Max
                            (Watts)
--------- ------ ---------- ------- ------------------- ----- ----
Fa2/5     auto   on         7.0     IP Phone 7960       n/a   15.4



!--- You can see the Admin status as auto. This is the default configuration.

Vous pouvez entrer la commande power inline afin de configurer l'alimentation incorporée d'un port individuel. Ceci montre les options de configuration de l'alimentation incorporée :

Switch(config-if)#power inline ?
  auto         Automatically detect and power inline devices
  consumption  Configure the inline device consumption
  never        Never apply inline power
  static       High priority inline power interface
  • Auto — Par défaut, les ports PoE sont configurés sur auto. Les périphériques sont alimentés sur la base du premier arrivé, premier servi. Si les blocs d'alimentation ne fournissent pas suffisamment d'alimentation intégrée pour tous les périphériques alimentés en mode auto, rien ne permet de garantir quels périphériques seront mis sous tension.

  • Static — Les ports statiques ont une priorité plus élevée que les ports auto en termes d'attribution d'alimentation et d'arrêt. Le commutateur alloue l'alimentation d'un port statique lorsqu'il est configuré. L'alimentation est ensuite réservée au port même lorsque rien n'est connecté. L'alimentation allouée peut soit utiliser la valeur maximale par défaut (15,4 W), soit être spécifiée lorsque cette option est utilisée. Cette quantité allouée n'est jamais réglée par la classe d'IEEE ni par des messages CDP.

  • Never — Le Supervisor Engine n'entraîne pas la mise sous tension du port par le module de commutation même si un téléphone non alimenté est connecté.

Avec le mode statique, le périphérique alimenté est obligatoirement mis sous tension lorsqu'il est branché. Cette option est généralement utilisée pour les utilisateurs de priorité élevée, par exemple les cadres d'entreprise ou les points d'accès sans fil. Cependant, si la puissance de la classe IEEE du périphérique alimenté est supérieure à la puissance maximale du port statique, le périphérique alimenté n'est pas mis sous tension. De même, dans le cas d'une alimentation PoE prénorme de Cisco, si le message CDP du périphérique alimenté indique que la puissance requise est supérieure à la puissance maximale allouée sur le port statique, le port est mis hors tension. Dans les situations où le nombre de ports statiques souhaité dépasse les capacités de l'alimentation électrique, un nouveau port statique désigné est placé dans un état de désactivation des erreurs et 0 W sont alloués. Si le commutateur doit arrêter des périphériques alimentés parce qu'une alimentation électrique échoue et que l'alimentation est insuffisante, les périphériques alimentés automatiquement sont arrêtés avant ceux qui sont alimentés de façon statique.

Cet exemple montre la configuration de l'alimentation incorporée d'un port de commutation. Comme expliqué plus tôt dans cette section, la configuration de l'alimentation incorporée d'un port est automatique. Si la configuration par défaut est modifiée et que vous voulez configurer à nouveau le port sur auto, procédez comme décrit ci-après :

Configurer la prise en charge de l'alimentation incorporée pour le commutateur Catalyst qui exécute Cisco IOS
Switch#configure terminal 

Switchj(config)#interface fastethernet 2/5

Switch(config-if)#power inline auto


!--- Configures inline power support on fast Ethernet port 2/5.

Configurer QoS

Vous pouvez utiliser la fonctionnalité auto-QoS pour simplifier le déploiement des fonctions QoS qui existent. Auto-QoS fait des hypothèses au sujet de la conception réseau. Par conséquent, le commutateur peut donner la priorité à différents flux de trafic et utiliser de façon appropriée les files d'attente de sortie au lieu du comportement de QoS par défaut. Par défaut, QoS est désactivé. Le commutateur offre ensuite le service minimal à chaque paquet, indépendamment du contenu ou de la taille de celui-ci, et l'envoie à partir d'une file d'attente simple.

Auto-QoS configure la classification QoS et les files d'attente de sortie. Avant de configurer auto-QoS, assurez-vous qu'aucun QoS n'est configuré sur le commutateur. Quand vous configurez auto-QoS pour la première fois sur le commutateur, QoS est activé sur le commutateur s'il est désactivé, et configure des files d'attente et des seuils en configuration globale. En dernier lieu, le port de commutation est configuré pour faire confiance aux paramètres entrants de CoS et les paramètres de mise en forme du trafic sont configurés pour ce port. Ensuite, chaque fois que vous configurez n'importe quel port avec auto-QoS, le port de commutation est uniquement configuré avec des paramètres QoS.

Activez la commande debug auto qos en mode activation et configurez auto-QoS sur le port de commutation pour découvrir quelles configurations QoS sont appliquées pendant la configuration d'auto-QoS. Le débogage du QoS automatique illustre les commandes appliquées sur le commutateur.

Une fois la commande auto qos entrée, vous pouvez modifier la configuration de QoS en fonction de vos besoins. Cependant, ceci n'est pas recommandé. Vous pouvez consulter les options disponibles pour la commande vocale auto qos ici :

Switch(config-if)#auto qos voip ?
  cisco-phone      Trust the QoS marking of Cisco IP Phone
  cisco-softphone  Trust the QoS marking of Cisco IP SoftPhone
  trust            Trust the DSCP/CoS marking
Configurer Auto-QoS pour les commutateurs Catalyst qui exécutent IOS
Switch#configure terminal 

Switch(config)#interface fastethernet 2/5

Switch(config-if)#auto qos voip cisco-phone


!--- Configures the port to trust the CoS labels 
!--- in the incoming packets and configures the 
!--- traffic-shaping parameters.

Bien que la syntaxe de la commande auto qos soit identique sur tous les commutateurs Catalyst, les configurations de QoS, qui sont appliquées sur les commutateurs Catalyst par auto-QoS, sont différentes parmi les commutateurs Catalyst.

Configurer QoS sur la liaison ascendante de la couche 2

Si le trafic voix doit croiser le commutateur via les liaisons de jonction, vous devez configurer les paramètres QoS sur les ports de jonction. Dans ce cas, vous devez entrer la commande auto qos voip trust au lieu de auto qos voip cisco-phone.

Configurer Auto-QoS sur les liaisons de jonction des commutateurs Catalyst qui exécutent IOS
Switch#configure terminal 

Switch(config)#interface gigabitethernet 1/1

Switch(config-if)#auto qos voip trust


!--- Configures the port to trust the CoS labels 
!--- in the incoming packets and configures the 
!--- traffic-shaping parameters.

Configurer QoS sur la liaison ascendante de la couche 3

Si le trafic voix croise la liaison de la couche 3, vous devez configurer le port avec la commande auto qos voip trust et sur trust dscp. Cet exemple montre la configuration du port de la couche 3 pour transmettre le trafic voix :

Configurer Auto-QoS sur le port de la couche 3 dans le commutateur Catalyst qui exécute IOS
Switch#configure terminal 

Switch(config)#interface gigabitethernet 1/1

Switch(config-if)#auto qos voip trust



!--- Configures the port to trust the CoS labels 
!--- in the incoming packets and configures the
!--- traffic-shaping parameters.
 



Switch(config-if)#mls qos trust dscp



!--- Configures the port to trust the DSCP labels 
!--- in the incoming packets. This command is for 
!--- Catalyst 3560/3750/6500 Switches.




                              or
                              
Switch(config-if)#qos trust dscp



!--- Configures the port to trust the DSCP labels 
!--- in the incoming packets. This command is for 
!--- Catalyst 4500 Switches.

Configurer le commutateur à l'aide d'une macro prédéfinie

Dans les commutateurs de la gamme Cisco Catalyst 3560, 3750 et 4500 qui exécutent le logiciel Cisco IOS Version 12.2 et ultérieure, il y a peu de macros prédéfinies disponibles pour configurer les ports de commutation. Ce sont des exemples des macros et de leurs rôles dans la configuration du port de commutation pour prendre en charge les téléphones IP :

  • cisco-phone — Cette macro est destinée au port de commutation où le téléphone IP est connecté directement et un PC peut être connecté au téléphone. Cette macro configure le port avec l'accès VLAN, le VLAN voix, la sécurité de port, l'interconnexion arborescente portfast/bpduguard et auto qos voip cisco-phone.

  • cisco-switch — Cette macro est destinée au port de liaison ascendante du commutateur d'accès au commutateur de couche de distribution. Si le trafic voix doit croiser le commutateur au niveau des liaisons de jonction, vous pouvez utiliser la macro cisco-switch afin de configurer le port de liaison ascendante. Cette macro configure le port avec la jonction dot1q, l'interconnexion arborescente de type liaison point à point et auto qos voip trust. Cette macro ne doit pas être utilisée avec EtherChannel/les groupes de ports.

Remarque: Ces commutateurs prennent en charge deux types de macro :

Entrez cette commande show pour consulter la macro disponible :

Switch#show parser macro brief

    default global   : cisco-global
    default interface: cisco-desktop
    default interface: cisco-phone
    default interface: cisco-switch
    default interface: cisco-router
    default interface: cisco-wireless

Entrez cette commande show pour consulter le script de la macro :

Switch#show parser macro name cisco-phone

# Cisco IP phone + desktop template

# macro keywords $access_vlan $voice_vlan

# VoIP enabled interface - Enable data VLAN
# and voice VLAN
# Recommended value for access vlan should not be 1
switchport access vlan $access_vlan
switchport mode access

# Update the Voice VLAN value which should be
# different from data VLAN
# Recommended value for voice vlan should not be 1
switchport voice vlan $voice_vlan

# Enable port security limiting port to a 2 MAC
# addressess -- One for desktop on data vlan and
# one for phone on voice vlan
switchport port-security
switchport port-security maximum 2

# Ensure port-security age is greater than one minute
# and use inactivity timer
switchport port-security violation restrict
switchport port-security aging time 2
switchport port-security aging type inactivity

# Enable auto-qos to extend trust to attached Cisco phone
auto qos voip cisco-phone

# Configure port as an edge network port
spanning-tree portfast
spanning-tree bpduguard enable

Cet exemple montre la configuration des ports de commutation dans l'environnement de téléphone IP :

Configurer le commutateur à l'aide d'une macro prédéfinie
Switch#configure terminal 

Switch(config)#interface gigabitethernet 2/5

Switch(config-if)#macro apply $access_vlan 10 $voice_vlan 20


!--- Configures the access port to connect the IP phone. 
!--- The PC connects to the IP phone. It configures the port that 
!--- belongs to access VLAN 10 and voice VLAN 20. It also configures 
!--- auto qos voip cisco-phone.




Switch(config-if)#exit

Switch(config)#interface gigabitethernet 1/1

Switch(config-if)#macro apply cisco-switch $native_vlan 10 



!--- Configures the uplink port as dot1q trunk port 
!--- with native VLAN 10. It also configures auto qos voip trust.

Vérifiez

Entrez cette commande show interface pour confirmer que la configuration fonctionne correctement sur les commutateurs qui exécutent Cisco IOS :

Switch#show interface fastethernet 2/5 switchport

Name:Fa2/5
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: 20 (VLAN0020)
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Dépannez

Catalyst 3560G : Aucune alimentation pour le téléphone IP après le débranchement du périphérique non-PoE

Le Catalyst 3560G ne fournit pas l'alimentation incorporée à un téléphone IP connecté à un port où un périphérique non alimenté a été précédemment connecté et débranché du port. Ce problème se produit avec les paramètres PoE des modes automatique et statique sur le port. Ce problème peut également se produire sur les commutateurs de la gamme 3750. Il a été identifié dans l'ID de bogue Cisco CSCsc10999 (clients enregistrés seulement).

La solution consiste à émettre un arrêt/pas d'arrêt sur le port. Ensuite, le commutateur fournit l'alimentation au téléphone IP. Ce problème a été résolu dans le logiciel Cisco IOS, Version 12.2(25)SED1.

Le téléphone de conférence IP 7935 reçoit l'adresse IP de données au lieu de l'adresse IP vocale

Si le téléphone de conférence IP 7935 est connecté à un commutateur, il reçoit l'adresse IP du VLAN données. Si le téléphone IP 7960 est connecté sur le même port de commutation que le téléphone de conférence IP 7935, 7960 reçoit l'adresse IP sur le VLAN voix.

Ce problème est dû à la conception des téléphones de conférence IP 7935. Ce téléphone de conférence n'a pas de port 10/100 pour connecter un PC comme les autres téléphones IP de la gamme 7900. Le concept de VLAN voix ou de VLAN auxiliaire ne s'applique pas directement aux téléphones de conférence IP 7935.

Consultez Configuration du téléphone de conférence IP 7935 pour des performances optimisées afin de lire une explication détaillée et la solution.

Les téléphones IP ne sont pas fournis avec la dérivation d'authentification MAC (MAB)

Dans un commutateur qui utilise MAB pour accorder l'accès aux périphériques réseau, toutes les adresses MAC de téléphone IP obtenues via le CDP sont autorisées sur le VLAN auxiliaire (voix). Cependant, si le téléphone IP est seul (sans PC connecté) et connecté à un port configuré avec les VLAN voix, il est placé sur le VLAN données. Par conséquent, le téléphone IP rencontrera des problèmes lors de l'inscription auprès de Cisco CallManager.

Pour résoudre ce problème, configurez l'accès VLAN du port avec l'ID du VLAN voix ou connectez le PC au téléphone IP.

Les téléphones IP n'obtiennent pas l'adresse IP du serveur DHCP

Si l'inspection dynamique (DAI) du Protocole de résolution d'adresse (ARP) est activée dans le commutateur, elle dépend des entrées de la base de données de liaison de la surveillance DHCP pour vérifier des liaisons d'adresse IP-à-MAC dans les requêtes ARP entrantes et les réponses. Veillez à activer la surveillance DHCP pour autoriser les paquets ARP ayant des adresses IP attribuées dynamiquement.

En outre, les listes de contrôle d'accès ARP (ACL) ont la priorité sur les entrées de la base de données de liaison de surveillance DHCP. Le commutateur utilise les ACL uniquement si vous les configurez à l'aide de la commande de configuration globale ip arp inspection filter vlan. Le commutateur compare d'abord les paquets ARP aux ACL ARP configurées par l'utilisateur. Si l'ACL ARP refuse le paquet ARP, le commutateur refuse également le paquet même si une liaison valide existe dans la base de données remplie par la surveillance DHCP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 69632