Composition et accès : Cisco ONS 15454 SDH Multiservice Provisioning Platform (MSPP)

Configurer EtherChannel à l'aide d'une carte ML sur ONS 15454 et d'un commutateur Catalyst sur RPR

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce les documentdescribes la procédure pour configurer l'EtherChannel et 802.1Q perçant un tunnel utilisant un commutateur de Cisco Catalyst 3500XL et la Ml-gamme cardent à travers le Resilient Packet Ring (RPR) dans un environnement du Cisco ONS 15454.

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Cisco ONS 15454

  • Cartes Ethernet Cisco ONS 15454 ML-Series

  • Commutateur du Catalyst 3500XL

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version 6.x du Cisco ONS 15454

  • Commutateur du Catalyst 3500XL qui exécute la version de logiciel 12.0(5)XC de Cisco IOSÝ

  • Le ml (empaqueté en tant qu'élément de la version 6.0 ONS 15454) ce exécute la version de logiciel 12.2(27)SV et ultérieures de Cisco IOSÝ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Diagramme du réseau

Ce document utilise un laboratoire installé avec deux ONS 15454 Noeuds et deux Commutateurs du Catalyst 3500 XL. EachONS 15454 est équipé d'une carte ml 1000-2, et un Resilient Packet Ring (RPR) est établi entre eux à travers la carte ml 1000-2. Deux ports Gigabit Ethernet sur le Catalyst 3500 XL sont connectés à deux ports Gigabit Ethernet sur la carte ml 1000-2 respectivement. Le schéma de réseau est affiché dans la figure 1.

Figure 1 : Diagramme du réseau

/image/gif/paws/69342/f1.gif

Configuration

Configurer RPR

Terminez-vous ces étapes pour construire RPR :

  1. Créez un circuit entre le POS 0 de ML1000-2 sur ONS 15454 A et le POS 1 de ML1000-2 sur ONS 15454 B.

  2. Créez un circuit entre le POS 1 de ML1000-2 sur ONS 15454 A et le POS 0 de ML1000-2 sur ONS 15454 B.

  3. Configurez la carte ML1000-2 sur ONS 15454 R.

    1. Activez la transition et l'acheminement intégrés (IRB).

      bridge irb
      
    2. Créez la passerelle 1

      Bridge 1 protocol rstp  
    3. Configurez l'interface SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 3
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
    4. Configurez l'interface POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configurez l'interface POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
  4. Configurez la carte ML1000-2 sur ONS 15454 B.

    1. Activez la transition et l'acheminement intégrés (IRB).

      bridge irb
      
    2. Créez la passerelle 1

      Bridge 1 protocol rstp
      
    3. Configurez l'interface SRP.

      interface SPR1
       no ip address
       no keepalive
       spr station-id 4
       spr topology discovery
       hold-queue 150 in
      !
      interface SPR1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
    4. Configurez l'interface POS0.

      !
      interface POS0
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      
    5. Configurez l'interface POS1.

      !
      interface POS1
       no ip address
       load-interval 30
       spr interface-id 1
       spr keepalive
       crc 32
      !
      

Configurer l'EtherChannel

Terminez-vous ces étapes pour construire l'EtherChannel :

  1. Configurez l'interface GigabitEthernet0/1 et GigabitEthernet0/2 sur CAT3500_A.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  2. Configurez l'interface GigabitEthernet0/1 et GigabitEthernet0/2 sur CAT3500_B.

    !
    interface GigabitEthernet0/1
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    interface GigabitEthernet0/2
     port group 1 distribution destination
     switchport trunk encapsulation dot1q
     switchport mode trunk
    !
    
  3. Configurez ML1000-2 sur ONS 15454 R.

    1. Configurez les interfaces GigabitEthernet 0 et les GigabitEthernets 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configurez le Port canalisé.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      
  4. Configurez ML1000-2 sur ONS 15454 B.

    1. Configurez l'interface GigabitEthernet0 et les GigabitEthernets 1.

      !
      interface GigabitEthernet0
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      interface GigabitEthernet1
       no ip address
       channel-group 1
       mode dot1q-tunnel
       l2protocol-tunnel cdp
       l2protocol-tunnel stp
       l2protocol-tunnel vtp
       no cdp enable
      !
      
    2. Configurez le Port canalisé.

      !
      interface Port-channel1
       no ip address
       hold-queue 225 in
      !
      interface Port-channel1.1
       encapsulation dot1Q 1 native
       no snmp trap link-status
       bridge-group 1
       bridge-group 1 spanning-disabled
      !
      

Vérification

Terminez-vous ces étapes pour vérifier la configuration :

  1. Émettez la commande de show interfaces port-channel du ML1000-2 sur ONS 15454 R. Ce showsthat de commande l'EtherChannel contient deux ports Gigabit Ethernet (voyez les caractères en caractères gras).

    15454A_ML1000-2>show interface port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 000d.28bd.0b34 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 4000 bits/sec, 7 packets/sec
    
      5 minute output rate 2000 bits/sec, 4 packets/sec
    
         495875 packets input, 33757916 bytes
    
         Received 493640 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         55924 packets output, 4080533 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
  2. Émettez la commande de show interfaces port-channel du ML1000-2 sur ONS 15454 B. Cette commande montre que l'EtherChannel contient deux ports Gigabit Ethernet (voyez les caractères en caractères gras).

    15454B_ML1000-2>show int port-channel 1
    
    Port-channel1 is up, line protocol is up 
    
      Hardware is GEChannel, address is 0013.60f8.65f4 (bia 0000.0000.0000)
    
      MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec, 
    
         reliability 255/255, txload 1/255, rxload 1/255
    
     Encapsulation: ARPA, loopback not set
    
      Keepalive set (10 sec)
    
      ARP type: ARPA, ARP Timeout 04:00:00
    
        No. of active members in this channel: 2 
    
            Member 0 : GigabitEthernet0 , Full-duplex, 1000Mb/s
    
            Member 1 : GigabitEthernet1 , Full-duplex, 1000Mb/s
    
      Last input 00:00:00, output 00:00:00, output hang never
    
      Last clearing of "show interface" counters never
    
      Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
    
      Queueing strategy: fifo
    
      Output queue: 0/80 (size/max)
    
      5 minute input rate 3000 bits/sec, 5 packets/sec
    
      5 minute output rate 3000 bits/sec, 6 packets/sec
    
         1970114 packets input, 143644364 bytes
    
         Received 1969971 broadcasts (0 IP multicast)
    
         0 runts, 0 giants, 0 throttles
    
         0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    
         0 watchdog, 0 multicast
    
         0 input packets with dribble condition detected
    
         2256335 packets output, 164715496 bytes, 0 underruns
    
         0 output errors, 0 collisions, 0 interface resets
    
         0 babbles, 0 late collision, 0 deferred
    
         0 lost carrier, 0 no carrier
    
         0 output buffer failures, 0 output buffers swapped out
    
    
  3. Émettez la commande neighbor de show cdp sur le CAT3500_A (voir le schéma 2). Cette commande affiche CAT3500_B en tant que son voisin par l'EtherChannel.

    Figure 2 : voisin de show cdp sur CAT3500_A

    f2.gif

  4. Émettez la commande neighbor de show cdp sur le CAT3500_B (voir le schéma 3). Cette commande affiche CAT3500_A en tant que son voisin par l'EtherChannel.

    Figure 3 : voisin de show cdp sur CAT3500_B

    f3.gif

  5. Réalisez un test de ping.

    1. Configurez VLAN2 sur CAT3500_A avec une adresse IP 192.168.0.2.

      !
      interface VLAN2
       ip address 192.168.0.2 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    2. Configurez VLAN2 sur CAT3500_B avec une adresse IP 192.168.0.4.

      !
      interface VLAN2
       ip address 192.168.0.4 255.255.255.0
       no ip directed-broadcast
       no ip route-cache
      !
      
    3. Émettez la commande ping sur CAT3500_A (voir le schéma 4).

      ping 192.168.0.4
      
      Figure 4 : Test de ping de CAT3500_A à CAT3500_B

      /image/gif/paws/69342/f4.gif

    4. Émettez la commande ping sur CAT3500_B (voir le schéma 5).

      ping 192.168.0.2
      
      Figure 5 : Test de ping de CAT3500_B à CAT3500_A

      /image/gif/paws/69342/f5.gif

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 69342