Voix et communications unifiées : Cisco Unified Communications Manager (CallManager)

Échec du renvoi d'appel hors site - Problème lié au numéro du périphérique appelant

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit une raison pour laquelle un appel externe-à-interne ne peut pas être expédié aux sites externes et fournit une solution dans un environnement de Cisco CallManager.

Conditions préalables

Conditions requises

Cisco recommande que vous ayez la connaissance du Cisco CallManager.

Composants utilisés

Les informations dans ce document sont basées sur le Cisco CallManager 4.x.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Fond

La sélection d'appelant choisit le nombre de répertoire envoyé sur un appel sortant sur une passerelle pour des appels sortants. Ces options spécifient que le nombre de répertoire est envoyé :

  • Créateur — Envoie le nombre de répertoire du périphérique appelant.

  • Réorientez d'abord le nombre — Envoie le nombre de répertoire du périphérique de réorientation.

  • Dernier réorientez le nombre — Envoie le nombre de répertoire du dernier périphérique pour réorienter l'appel.

  • Réorientez d'abord le nombre (externe) — Envoie le nombre de répertoire externe du périphérique de réorientation.

  • Dernier réorientez le nombre (externe) — Envoie le nombre de répertoire externe du dernier périphérique pour réorienter l'appel.

Problème

L'appel le pas de réponse qu'en avant (CFNA) ne fonctionne pas quand un périphérique appelant externe appelle un périphérique interne et le périphérique du destinataire n'expédie pas l'appel à un périphérique externe. Cette liste contient trois tests de scénario. Les deux premiers réussissent et le troisième échoue.

  • Quand vous faites un intérieur appeler à partir d'un périphérique interne à un autre périphérique interne et les deux périphériques se trouvent sur le même chantier, le périphérique récepteur avec succès en avant l'appel à un périphérique externe sur l'état CFNA. Par exemple, le téléphone 1 dans des appels du site A téléphonent au 2 dans le site A, et téléphonent au 2 dans le site A avec succès en avant l'appel au téléphone externe B.

  • Quand vous faites un intérieur appeler à partir d'un périphérique interne à un autre périphérique interne et les périphériques se trouvent sur différents chantiers dans la même organisation, le périphérique récepteur avec succès en avant l'appel à un périphérique externe sur l'état CFNA. Par exemple, le téléphone 1 dans des appels du site B téléphonent au 2 dans le site A, et téléphonent au 2 dans le site A avec succès en avant l'appel au téléphone externe B.

  • Quand vous faites un intérieur appeler à partir d'un périphérique externe à un périphérique interne, le périphérique récepteur n'expédie pas l'appel à un périphérique externe sur l'état CFNA. Par exemple, les appels téléphoniques externes A téléphonent au 1 dans le site A et téléphonent au 1 dans le site A n'expédie pas l'appel au téléphone externe B.

Figure 1 — Topologie

failure-fwd-calls-offst-1.gif

Cause

Ce problème se pose quand vous faites un intérieur appeler à partir d'un périphérique externe et du périphérique interne en avant l'appel à un autre périphérique externe sur l'état CFNA à l'aide du nombre de périphérique externe d'origine comme numéro d'appel. Puisque ce numéro d'appel n'est pas une partie des nombres centripètes directs abonnés de cadran (A FAIT), le transporteur rejette l'appel téléphonique pour la raison du numéro de téléphone non valide.

Le problème est que le t1 est configuré pour appeler de fond basé de code de compte. Puisque le numéro d'appel n'est pas l'un des nombres abonnés de t1, il entraîne des questions de facturation. Par conséquent, le transporteur refuse l'appel.

Solution

La sélection d'appelant sur une passerelle peut envoyer les informations de nombre de répertoire pour n'importe quel appel sortant. Ce champ détermine quel nombre de répertoire est envoyé. Quand un problème se produit, ce paramètre est placé comme créateur. Le numéro de téléphone appelant d'origine (numéro de téléphone externe) est utilisé comme nombre de répertoire appelant. Puisqu'il n'est pas une partie de abonné A FAIT des nombres, le transporteur refuse l'appel pour la raison du numéro de téléphone non valide.

Placez la sélection d'appelant comme réorientent d'abord le nombre pour la passerelle afin de résoudre le problème. Ceci fait utiliser la passerelle A FAIT le numéro de téléphone (numéro de périphérique interne) sur l'état CFNA comme numéro de téléphone appelant. Ce numéro de téléphone tombe dans la plage des numéros de téléphone abonnés. Le transporteur en avant l'appel au destinataire.

Procédez comme suit :

  1. Cisco CallManager Administration de début.

  2. Passerelle choisie de la liste déroulante dans l'onglet de périphérique de la barre de menus.

  3. Sélectionnez réorientent d'abord le nombre de la zone de liste déroulante de sélection d'appelant (voyez la case rouge de rectangle sur le schéma 2).

    Figure 2 — Appels sortants

    failure-fwd-calls-offst-2.gif

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