Communication sans fil/mobilité : VLAN sans fil

Exemple de configuration de réseaux VLAN sur des contrôleurs de réseau local sans fil

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment configurer des VLAN sur les contrôleurs de réseau local sans fil (WLC).

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document. Cependant, ce document suppose qu'un serveur DHCP fournit des adresses IP aux points d'accès (AP) qui sont enregistrés sur le contrôleur.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Configuration A :

    • Commutateur de Catalyst qui exécute le logiciel de Ý de Cisco IOS et un contrôleur WLAN

    • Contrôleur WLAN de Cisco 4404 qui exécute la version de logiciel 7.0

  • Configuration B :

    • Commutateur Catalyst qui exécute le logiciel Catalyst OS (CatOS) et un contrôleur WLAN

    • Contrôleur WLAN de Cisco 4404 qui exécute la version de logiciel 7.0

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Interfaces dynamiques sur WLC

Des interfaces dynamiques, également connues sous le nom d'interfaces VLAN, sont créées par des utilisateurs et conçues pour être analogues aux VLAN pour les clients LAN sans fil. Un contrôleur peut prendre en charge jusqu'à 512 interfaces dynamiques (VLAN). Chaque interface dynamique est individuellement configurée et permet à des flux de communication distincts d'exister sur un ou tous les ports du système de distribution du contrôleur. Chaque interface dynamique contrôle les VLAN et d'autres transmissions entre les contrôleurs et tous les autres équipements réseau, et chacune agit en tant que relais DHCP pour les clients sans fil associés aux WLAN mappés à l'interface. Vous pouvez assigner des interfaces dynamiques aux ports de système de distribution, les WLAN, l'interface de gestion de la couche 2, et l'interface d'AP-gestionnaire de la couche 3. Vous pouvez également tracer l'interface dynamique à un port de sauvegarde.

Vous pouvez configurer zéro, un, ou les plusieurs interfaces dynamiques sur un système de distribution mettent en communication. Cependant, toutes les interfaces dynamiques doivent être sur un VLAN différent ou l'IP de sous-réseau de toutes autres interfaces configurées sur le port. Si le port est non-marqué, toutes les interfaces dynamiques doivent être sur un IP de sous-réseau différent de n'importe quelle autre interface configurée sur le port.

Configurer une interface dynamique avec un sous-réseau secondaire n'est pas pris en charge.

Cisco recommande utilisant des VLAN étiquetés pour des interfaces dynamiques.

Les VLAN avec des contrôleurs WLAN utilisent ce modèle :

/image/gif/paws/68100/wlan_controllers_vlans1.gif

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Configurations des commutateurs Catalyst

Cette section utilise ces configurations :

Commutateur Catalyst qui exécute le Logiciel Cisco IOS
lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Commutateur Catalyst qui exécute le logiciel CatOS
controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- This command should be on one line.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Configuration VLAN de contrôleur WLAN

Configuration de la GUI

Complétez ces étapes sur le contrôleur WLAN.

  1. Depuis l'interface graphique WLC, choisissez Controller > Interfaces. La page Interfaces liste toutes les interfaces qui sont configurées sur le WLC. Afin de créer une nouvelle interface dynamique, cliquez sur New.

    wlan_controllers_vlans2.gif

  2. Entrez le nom de l'interface et l'identificateur VLAN et cliquez sur Apply.

    wlan_controllers_vlans3.gif

  3. Entrez les paramètres spécifiques à ce VLAN. Les paramètres incluent l'adresse IP, le masque de réseau, la passerelle et l'adresse IP du serveur DHCP. Cliquez ensuite sur Apply.

    Voici un exemple.

    wlan_controllers_vlans4.gif

    Remarque: L'adresse IP attribuée à cette interface agit en tant que relais DHCP pour qu'un client obtienne une adresse IP du serveur DHCP. Par exemple, quand un client tente de s'associer à un WLAN/SSID (voir l'étape 5 dans cette configuration) mappé à cette interface dynamique, il exécute une diffusion de sous-réseau local pour identifier le serveur DHCP. Le contrôleur envoie une requête au serveur DHCP (ou à lui-même si c'est le serveur DHCP pour le segment) avec l'adresse IP de cette interface dynamique comme IP de relais au serveur DHCP configuré pour cette interface. Le serveur DHCP attribue une adresse IP au client depuis la portée de DHCP configurée.

  4. Vérifiez la configuration de l'interface.

    Cliquez sur l'onglet de Controller dans le menu en haut de la fenêtre et choisissez Interfaces dans le menu à gauche.

    wlan_controllers_vlans5.gif

  5. Cliquez sur l'onglet WLAN dans le menu en haut de la fenêtre, et le clic créent nouveau.

    wlan_controllers_vlans6.gif

  6. Écrivez l'Identifiant SSID (Service Set Identifier) et le nom de profil et cliquez sur Apply.

    Cet exemple utilise vlan15 pour faciliter la compréhension.

    wlan_controllers_vlans7.gif

  7. Sélectionnez vlan15 dans le menu déroulant Interface Name en bas de la fenêtre, et cliquez sur Apply.

    Dans ce cas, le SSID vlan15 est attaché au nom d'interface vlan15.

    wlan_controllers_vlans8.gif

Configuration CLI

Utilisez cette section afin de configurer votre VLAN par l'intermédiaire de l'interface de ligne de commande (CLI).

  1. Créez l'interface et la balise VLAN associée.

    La commande est config interface create interface_name vlan_id .

    (lab5wlc4404ip15) >config interface create "vlan 15" 15
    

    Remarque: S'il y a un espace dans le nom VLAN/WLAN de même que le cas dans cet exemple, assurez-vous que le nom est dans les devis.

  2. Définissez l'adresse IP et la passerelle par défaut.

    La commande est config interface interface_name IP_address netmask gateway .

    (lab5wlc4404ip15) >config interface address "vlan 15" 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- This command should be on one line.
    
    
  3. Définissez le serveur DHCP.

    La commande est <secondary-server> [secondaire] primaire de <primary-server> de <interface-name> d'interface dynamique de config interface dhcp.

    (lab5wlc4404ip15) >config interface dhcp dynamic-interface "vlan 15" primary 1
    2.168.15.15
    
  4. Émettez cette commande afin de tracer l'interface à un port physique :

    physical_ds_port_number d'operator_defined_interface_name de config interface port. Voici un exemple :

    (Cisco Controller) >config interface port "vlan 15" 2
    
  5. Vérifiez la configuration de l'interface.

    La commande est show interface summary.

    (Cisco Controller) >show interface summary
    
    Interface Name                   Port Vlan Id  IP Address      Type    Ap Mgr Guest
    -------------------------------- ---- -------- --------------- ------- ------ ----
    ap-manager                       2    untagged 10.77.244.207   Static  Yes    N
    
    management                       2    untagged 10.77.244.206   Static  No     N
    
    service-port                     N/A  N/A      50.0.0.1        Static  No     N
    
    virtual                          N/A  N/A      1.1.1.1         Static  No     N
    
    vlan 15                          2    15       192.168.15.10   Dynamic No     N
  6. Définissez l'WLAN.

    La commande est config wlan create wlan_id name .

    (lab5wlc4404ip15) >config wlan create 2 "vlan 15"
    
  7. Définissez l'interface pour le WLAN.

    La commande est config wlan interface wlan_id interface_name .

    (lab5wlc4404ip15) >config wlan interface 2 "vlan 15"
    
  8. Vérifiez le WLAN et l'interface associée.

    La commande est show wlan summary.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN IDÝ  WLAN NameÝÝÝÝÝÝÝÝÝÝÝÝÝÝ StatusÝÝÝÝ ÝÝ Interface NameÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 
    -------Ý Ý--------------------Ý   ---------Ý ÝÝÝ--------------------------------
    1ÝÝÝÝÝÝÝ Ýlab5wlc4404ip15ÝÝÝÝÝÝ   EnabledÝÝÝÝ   managementÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 
    2ÝÝÝÝÝÝÝ Ývlan 15ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ DisabledÝÝÝ   vlan 15ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ 
    
    (lab5wlc4404ip15) >

Cliquez sur ce lien afin de visualiser Cisco prennent en charge le vidéo de la Communauté qui décrit comment configurer des VLAN sur les contrôleurs LAN Sans fil :

VLAN sur les contrôleurs LAN Sans fil leavingcisco.com

wlan_controllers_vlans9.gif

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Vérification des commutateurs Catalyst

  • Commutateur Catalyst qui exécute le logiciel Cisco IOS — show running-config interface interface_type interface_number

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Commutateur Catalyst qui exécute le logiciel CatOS — show config mod

    controller-catos> (enable) show config 2
    
    !--- This command shows non-default configurations only.
    !--- Issue the show config mod all command in order to  
    !--- show both default and non-default configurations.
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Vérification VLAN du contrôleur WLAN

Consultez la section Configuration VLAN dU contrôleur WLAN de ce document, qui comporte des étapes de vérification.

Dépannez

Utilisez cette section pour dépanner votre configuration.

Procédure de dépannage

Complétez ces instructions afin de dépanner votre configuration.

  1. Exécutez une commande ping du contrôleur WLAN à la passerelle par défaut qui est configurée sur l'interface routée par VLAN, puis exécutez une commande ping dans le sens inverse.

    • Contrôleur WLAN :

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Interface routée VLAN :

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = Ý/4 ms
      lab1sup720ip1#
  2. Si les commandes ping sont infructueuses, déployez une capture/un analyseur de paquets sur le commutateur et vérifiez l'étiquetage approprié du VLAN.

    Remarque: Quand vous lancez la commande ping de votre contrôleur à une passerelle de couche 3, qui est sur le même sous-réseau que votre interface dynamique, le contrôleur semble être la source du ping depuis l'interface dynamique.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 68100