Communication sans fil/mobilité : Sécurité WLAN

Exemple de configuration d'un routeur sans fil ISR 1800 avec DHCP interne et authentification ouverte

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon d'un RÉSEAU LOCAL Sans fil (WLAN) sur un Integrated Services Router de Cisco 1800 (ISR).

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • 1800 ISR sur la version de logiciel 12.3 ou ultérieures de ½ du ¿  de Cisco IOSï avec le positionnement avancé de caractéristique de Services IP

    Remarque: Vous pouvez s'appliquer la même configuration aux ISR l'uns des. La configuration n'est pas spécifique à la gamme 1800.

  • PC avec ces cartes réseau sans fil :

    • 802.11a

    • 802.11b

    • 802.11b/g a/b/g

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Connexion Sans fil au routeur

1800_isr_wireless1.gif

Configuration

Instructions pas à pas

Procédez comme suit :

  1. Installez la portée de DHCP et avez exclu des adresses.

    Remarque: Les adresses exclues sont facultatives.

    Référez-vous au serveur DHCP de Cisco IOS pour une explication plus détaillée du serveur DHCP en logiciel de Cisco IOS.

  2. Turn on a intégré le routage et la transition, et a installé le groupe de passerelle.

  3. Assignez une adresse IP pour relier le Bridge Group Virtual Interface 1 (BVI1).

  4. Radio d'installation.

    1. Assignez l'interface Dot11Radio0 ou Dot11Radio1 pour jeter un pont sur le groupe 1.

    2. Assignez un Identifiant SSID (Service Set Identifier) à l'interface par radio, et puis définissez l'authentification ouverte.

Configuration

Ce document utilise la configuration suivante :

Radio de la gamme 1800 ISR et configuration DHCP
1800-ISR#show running-config 
 Building configuration...
 .
 .
!
hostname 1800-ISR
!

!--- Output suppressed.

!
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.2.1 192.168.2.100

!--- This sets up DHCP and excluded addresses. Excluded addresses are optional.

!
ip dhcp pool 1800-ISR
   network 192.168.2.0 255.255.255.0
!
!
bridge irb

!--- Turn on integrated routing and bridging.

!
!
interface Dot11Radio0

!--- This is the wireless radio interface configuration.

 no ip address
 !
 ssid Cisco

!--- Here, the SSID is given as "Cisco".
  
    authentication open 

!--- This defines the authentication as open.

 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 bridge-group 1
 bridge-group 1 subscriber-loop-control
 bridge-group 1 spanning-disabled
 bridge-group 1 block-unknown-source
 no bridge-group 1 source-learning
 no bridge-group 1 unicast-flooding
!
!
interface BVI1
 ip address 192.168.2.1 255.255.255.0
!
ip classless
!

!--- Note: Configure the bridge 1 protocol IEEE and the bridge 1 route IP 
!--- before you create interface BVI1 or add the radio interface to bridge group 1.

!
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
line aux 0
line vty 0 4
!
no scheduler allocate
end

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Employez ces commandes afin de vérifier le DHCP approprié et l'exécution Sans fil :

  • show dot11 associations

  • show ip dhcp binding

Le MAC et les adresses IP doivent s'assortir dans la sortie de la commande de show dot11 associations et la sortie de la commande de show ip dhcp binding. Voici un exemple :

1800-ISR#show dot11 associations

802.11 Client Stations on Dot11Radio0: 

SSID [Cisco] : 

MAC Address��� �IP address����� Device������� ���Name����������Parent�������� State��� �
0040.96ac.345c  192.168.2.101�� CB21AG/PI21AG��� WLCLIENT� ��� self���������� Associated
!

!--- Output suppressed.

!
1800-ISR#show ip dhcp binding 
Bindings from all pools not associated with VRF:
IP address��������� Client-ID/������������� Lease expiration������ Type
���������������������Hardware address/
���������������������User name
192.168.2.101��     0100.4096.ac34.5c������ Dec 18 2005 05:07 PM�� Automatic
1800-ISR#

Dépannez

Utilisez cette section pour dépanner votre configuration.

Commande de dépannage

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

Émettez la commande de paquet de debug ip dhcp server afin de mettre au point l'ip dhcp server. Avec une ouvert-authentification décryptée WLAN, cette commande fournit le plus rapide et la plupart de méthode efficace pour dépanner.

La commande de paquet de debug ip dhcp server affiche ces transactions de données :

/image/gif/paws/68099/1800_isr_wireless2.gif

Cette sortie de la commande de paquet de debug ip dhcp server est un exemple d'une requête DHCP réussie :

1800-ISR#debug ip dhcp server packet

*Dec 17 15:40:50.379: DHCPD: DHCPREQUEST received from client 0100.4096.ac34.5c.
!

!--- This shows the client DHCP discover packet that is sent to the router.

!
*Dec 17 15:40:50.379: DHCPD: No default domain to append - abort update
*Dec 17 15:40:50.379: DHCPD: Sending DHCPACK to client 0100.4096.ac34.5c (192.168.2.101)
!

!--- This shows the router DHCP acknowledgment (ACK) that is sent back to the client.

!
*Dec 17 15:40:50.379: DHCPD: creating ARP entry (192.168.2.101, 0040.96ac.345c).
*Dec 17 15:40:50.379: DHCPD: unicasting BOOTREPLY to client 0040.96ac.345c (192.168.2.101)

Procédure de dépannage

Si vous ne voyez pas l'offre DHCP dans la sortie de la commande de paquet de debug ip dhcp server, commencez à dépanner le protocole de 802.11. Procédez comme suit :

  1. Ne vérifiez les configurations de client sans fil, le SSID, et l'aucune configuration de Sécurité/cryptage.

    Remarque: Le SSID doit être identique dans l'ISR et les clients. Dans ce cas, le SSID est « Cisco ». La figure 1 et la figure 2 affichent les configurations SSID dans Cisco Aironet Desktop Utility (ADU) et l'Aironet Client Utility (ACU). La fenêtre que vous voyez dépend de la carte de client sans fil et des versions de firmware que vous utilisez.

    Figure 1 ? Configurations de Cisco ADU SSID

    1800_isr_wireless3.gif

    Figure 2 ? Configurations ACU SSID de Cisco

    1800_isr_wireless4.gif

    Figure 3 ? Mises à zéro Sans fil de Windows

    /image/gif/paws/68099/1800_isr_wireless5.gif

  2. Vérifiez la compatibilité de WiFi.

    Référez-vous à la pageleavingcisco.com de Wi-Fi Alliance afin de vérifier la compatibilité de WiFi du network interface card Sans fil (NIC) qui est utilisé.

  3. Support technique de Cisco de contact pour davantage d'assistance technique.


Informations connexes


Document ID: 68099