Voix et communications unifiées : Cisco Unity Express

Exemple de configuration de distribution d'appel automatique Cisco CME de base et d'interopération de réception automatique Cisco Unity Express

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des exemples de configuration pour l'usage des caractéristiques de base de la distribution automatique des appels (ACD) de Cisco CallManager Express (CME) (ACD) et de la réception automatique (AA) de Cisco Unity Express.

Conditions préalables

Conditions requises

La connaissance générale des configurations de Cisco CME et de Cisco Unity Express est exigée. Ce document se concentre spécifiquement sur Cisco CME des configurations de base d'interopérabilité ACD et de Cisco Unity Express aa.

Ce qui suit sont les releases minimum pour la fonctionnalité décrite dans cet exemple de configuration :

  • Cisco CME 3.3

  • Version de logiciel 12.4.3 de Cisco IOSÝ

  • Cisco Unity Express 2.1.3

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Un routeur de Cisco 2821 exécutant Cisco CME et Cisco Unity Express

  • Version du logiciel Cisco IOS 12.4.3

  • Cisco CME 3.3

  • Version de script de base 2.1.0.0 ACD

  • Cisco Unity Express 2.1.3

  • Ensemble de fonctionnalités de Cisco IOS de Voix IP

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec des Routeurs de Cisco 2600XM, de Cisco 3700, de Cisco 2800, ou de gamme Cisco 3800 avec la version du logiciel Cisco IOS 12.4.1 ou plus tard.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Ces trois scénarios sont adressés dans ce document :

  • Scénario 1--Using Cisco CME aa et groupes ACD avec le Cisco Unity Express seulement comme destination de messagerie vocale

  • Scénario 2--Using le Cisco Unity Express comme point d'entrée principal aa et Cisco CME aa comme « sous-menu » dans cet aa

  • Scénario 3--Using Cisco CME aa comme point d'entrée principal aa et Cisco Unity Express aa pour fournir des « annonces » flexibles en tant qu'élément de l'aa

Le scénario 1 s'applique quand votre Cisco CME aa est limité à fournir un menu aux appels directs dans des groupes ACD. Dans ce scénario, Cisco CME est utilisé comme destination aa pour des appels entrant, et le Cisco Unity Express est utilisé exclusivement en tant que serveur de messagerie de Voix quand les agents ACD ne sont pas disponibles ou ne répondent pas aux appels dans une heure. Le Cisco Unity Express aa n'est pas utilisé dans ce scénario.

Le scénario 2 est la configuration globale la plus flexible pour intégrer Cisco CME ACD et Cisco Unity Express de base aa. La conception l'a utilisé dans le Cisco Unity Express aa de caractéristiques du scénario 2 pour l'automatisation générale de gestion des appels et pour remettre outre des appels aux agents ACD. Dans ce scénario, le Cisco Unity Express est utilisé comme destination aa pour des appels entrant ; Le Cisco Unity Express fournit également un grand choix de choix de menu à l'appelant (tel que le cadran-par-nom, la cadran-par-extension, et les segments de l'information enregistrée). Un de ces choix dirige quelques appels vers les groupes de Cisco CME ACD. La messagerie vocale de Cisco Unity Express est utilisée d'une manière semblable comme scénario 1.

Le scénario 3 est une variation du scénario 1 dans laquelle Cisco CME aa est utilisé comme destination aa pour des appels entrant et l'ACD est la fonction principale exigée de l'aa. Cependant, le Cisco Unity Express aa est utilisé en tant que « serveur d'annonce » avec Cisco CME aa. Ceci fournit la capacité d'ajouter quelques annonces (telles que des heures ou l'emplacement de bureau) qui ne sont pas disponibles utilisant seulement Cisco CME aa.

Remarque: Les procédures de configuration basées sur GUI fournies en cette publication sont utilisées pour montrer les processus d'implémentation associés avec cet exemple de configuration et pour récapituler les étapes requises pour implémenter des caractéristiques décrites dans tout le document. Cependant, des procédures pas à pas complètes ne sont pas fournies. Cette publication suppose que vous avez une connaissance fonctionnante de Cisco CME et de biais de Cisco Unity Express, aussi bien que des connaissances pratiques du Cisco IOS CLI. Le guide veuillez se référer de Cisco CME et de Cisco Unity Express à administrateur compétent, le guide de configuration, et la référence de commandes pour les détails explicites pour des procédures et l'utilisation des commandes.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Schéma de réseau de figure 1 pour Cisco CME ACD et Cisco Unity Express de base aa

/image/gif/paws/67907/135345.jpg

Configurations

Chacun des trois scénarios de configuration a ces caractéristiques générales :

  • Système de Cisco CME de site unique

  • Joncteurs réseau PSTN intégrés sur le routeur de Cisco CME

  • La configuration définit un plan de numérotation à 4 chiffres avec des extensions de téléphone IP dans les 2000 à 2010 plages, des extensions de non-téléphone (telles que des groupes de recherche) la plage 2020 à 2099, et aux points d'entrée de Cisco Unity Express dans la plage 21 xx.

  • Neuf Téléphones IP sont définis, les extensions 2000 2009.

  • L'installation ACD utilise trois groupes de recherche avec trois Téléphones IP dans chaque groupe.

  • Deux réceptionnistes sont définis, qui sont également une partie des neuf Téléphones IP dans les groupes ACD.

La configuration réseau utilise un routeur de Cisco 2821 avec ces caractéristiques :

  • Accès de réseau IP par l'intermédiaire de l'adresse IP b .168.1.1

  • Configuration de Cisco CME avec neuf Téléphones IP--chacun avec une extension à 4 chiffres (2001 2010)

  • NM-CUE

  • Adresse IP de Cisco Unity Express un .1.11.2

Ce document utilise les configurations suivantes :

Notes de configuration générales en implémentation

La connectivité RTPC utilisée dans cette configuration est par l'intermédiaire d'un joncteur réseau de devises étrangères du bureau (FXO). Si vous avez un joncteur réseau PRI, les configurations regardent exactement les mêmes que ceux donnés dans les exemples de configuration présentés en cette publication, en plus de ces entrées de configuration :

controller T1 2/1
 framing esf
 linecode b8zs
 pri-group timeslots 1-24
!
interface Serial2/1:23
 no ip address
 isdn switch-type primary-ni
 isdn incoming-voice voice
 no cdp enable
!
voice-port 2/1:23
!
dial-peer voice 777 pots
 incoming called-number .
 direct-inward-dial
 port 2/1:23

Les scripts du Cisco Unity Express aa qui sont utilisés dans les exemples présentés en cette publication sont très simples et pour la clarté contiennent le nombre minimal de caractéristiques pour réaliser la fonctionnalité montrée par ce document. Les scripts du Cisco Unity Express aa déployés dans un réseau vivant devraient avoir sensiblement plus de capacité de manipulation d'appel entrant comparée aux réseaux de test de laboratoire. La gestion des appels supplémentaire « étapes » peut inclure ce qui suit :

  • Traitement des erreurs amélioré (comme quand l'appelant appuie sur les chiffres qui ne sont pas sur le menu)

  • Manipulation de délai d'attente (telle que répéter des menus par nombre fixe de périodes)

  • Capacité de bloquer le transfert externe des appels aux destinations externes PSTN (pour éviter la fraude de contournement).

Scénario 1 - Utilisant Cisco CME ACD de base avec la messagerie vocale de Cisco Unity Express

Dans le scénario 1, des appels entrant sont dirigés vers Cisco CME aa (extension 2040), qui fournit à un message de bienvenue et à un menu trois options à l'appelant. Basé sur le choix de l'appelant, l'appel est dirigé vers un de trois groupes de recherche ACD. Si les appels ne sont pas répondus dans le groupe ACD, des appels sont expédiés à une boîte aux lettres de la livraison générale (GDM) pour laisser un message.

Remarque: Vous ne pouvez pas installer un GDM à copier sur la boîte aux lettres de chaque utilisateur (semblable à une liste de distribution).

Dans ce scénario décrit dans cette section, un GDM simple est utilisé de sorte que chacun des neuf agents ACD dans les groupes ACD puisse ouvrir une session à et récupérer des messages. Dans d'autres variations décrites en tant qu'élément du scénario 2, la capacité d'avoir un différent GDM par groupe ACD est explorée.

Écoulement d'appel

L'écoulement d'appel de la configuration dans cette section est illustré dans la figure 2.

Cisco Unity Express aa de figure 2 avec l'écoulement de base de 1appel de scénario de Cisco CME ACD

/image/gif/paws/67907/135346.jpg

Notes de configuration en scénario 1

Des appels PSTN du port FXO (0/3/0) autoterminated (par l'intermédiaire de la commande de plar-opx 2040 de connexion) au numéro pilote de Cisco CME aa (2040). Cisco CME aa présente un message de bienvenue et un menu bienvenu avec trois options--le contenu parlé des demandes est donné dans l'image d'appel-écoulement sur le schéma 2. L'expression bienvenue enregistrée réside dans le fichier Flash en_bacd_welcome.au, alors que les expressions enregistrées de menu résident dans le fichier en_bacd_options_menu.au.

Le message d'accueil GDM pour l'extension 2070 est comme suit : « Merci d'appeler le service client ; personne n'est disponible en ce moment. Veuillez laisser un message et nous renverrons votre appel dès que nous pourrons. »

Une indication de message en attente (MWI) pour des messages dans le GDM est réalisée en expédiant Cisco CME aa (la commande d'audio-messagerie 2070 de param) à une extension intermédiaire (2070) qui sont CFA (call forward all) au pilote de messagerie vocale (2105). Cet expédition est fait au lieu d'indiquer Cisco CME aa directement le pilote de messagerie vocale--ce qui serait fait avec la commande de l'audio-messagerie 2105 de param. L'extension 2070 est le bouton 2 aux téléphones d'agent, et ce bouton indique le MWI pour le GDM, qui est associé avec l'extension 2070--rather qu'avec les nombres de groupe de recherche ACD (2020, 2021 ou 2022). Des nombres « finaux » ne sont pas configurés sur les groupes de recherche parce que les nombres finaux de contournements de logique ACD en faveur de l'expédition aa numérotent (commande d'audio-messagerie de param).

Remarque: Quand cela vous apportent n'importe quelle modification au script, vous devez charger l'application.

Le script de Cisco CME aa est associé avec une adresse IP de bouclage (un .1.1.1) pour assurer le script d'ordres de gestion d'outil (TCL) est toujours --indépendamment de l'état du RÉSEAU LOCAL relie (commande de voip de dial-peer voice 2040). Un pair de cadran dos à dos est utilisé aux appels directs au point d'entrée de Cisco CME aa (2040) pour s'assurer que les appelants PSTN (aussi bien que les Téléphones IP locaux) peuvent appeler l'aa (commande de voip de dial-peer voice 2041).

Configurez Cisco CME pour le scénario 1

Ces étapes récapitulent la configuration pour Cisco CME pour le scénario 1 :

  1. Choisissez configurent > des paramètres de système pour configurer trois groupes de recherche ACD 2020, 2021, et 2022 qui sont associés avec trois options du menu de Cisco CME aa. Voir le schéma 3.

    La figure 3 spécifient des groupes de recherche du Cisco Unity Express ACD

    /image/gif/paws/67907/135352.jpg

  2. Choisissez configurent > des paramètres de système pour configurer les détails pour le groupe de recherche 2020 avec des agents 2001, 2002, et 2003. Voir le schéma 4.

    La figure 4 configurent des détails pour le groupe de recherche 2020

    /image/gif/paws/67907/135353.jpg

  3. Choisissez configurent > des téléphones et cliquent sur l'adresse MAC du téléphone que vous voulez pour changer. La fenêtre de téléphone de modification apparaît (voir le schéma 5).

  4. Écrivez l'extension 2070 au téléphone de l'agent ACD pour obtenir le MWI pour des messages dans le GDM.

    Extension d'associé de figure 5 au bouton spécifique

    /image/gif/paws/67907/135354.jpg

Ce qui suit est (et annoté) la configuration complète CLI de routeur de Cisco CME pour le scénario 1 qui des résultats des modifications spécifiques à la configuration de base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Define the parameters for the Cisco CME ACD TCL script. 
!--- The hunt groups for the
!--- ACD are 2020, 2021, and 2022.

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !

!--- Define the parameters for the Cisco CME AA TCL script. 
!--- The pilot number is 2040.
!--- The voice-mail destination is extension 2070, which is call forward all
!--- (CFA) routed to voice mail (2105).

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the loopback address to which the TCL script is attached.

!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CME AA pilot number 2040.

!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!

!--- Calls to Cisco CME AA pilot number 2040 are associated with a loopback address
!--- a.1.11.1 to ensure that the TCL script is always up.

!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- The back-to-back dial-peer for Cisco CME AA 
!--- pilot number 2040 points to the
!--- AA TCL script and ensures that all PSTN and 
!--- internal callers can reach the AA.

!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!

!--- All calls in the 21xx range are directed to Cisco Unity Express.

!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!

!--- The following section shows nine ACD agents' extensions.

!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2070 is associated with the GDM. 
!--- This extension is used to get MWI
!--- on the ACD agents' phone.

!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- The following section shows phone definitions for the nine ACD agents.
!--- Ephone-dn 11 (2070) is defined as button 2 on each phone, so that all
!--- agents can get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!

!--- Three hunt-groups are used by the ACD scripts. 
!--- There are three agents in each group.

!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configurez le Cisco Unity Express pour le scénario 1

Ces étapes récapitulent la configuration pour le Cisco Unity Express pour le scénario 1 :

  1. Choisissez configurent > des groupes. Cliquez sur alors le groupe (custservice) ce vous veulent éditer. La fenêtre de profil de groupe apparaît (voir le schéma 6).

  2. L'onglet de profil est l'affichage par défaut. Configurez le groupe associé de custservice avec l'extension 2070.

    La figure 6 configurent le profil de groupe

    142424.jpg

  3. Cliquez sur l'onglet de propriétaires/membres (voir le schéma 7).

  4. Configurez les membres (chacun des neuf utilisateurs d'agent ACD) du groupe de custservice.

    La figure 7 configurent des membres du groupe

    135356.jpg

Ce qui suit est (et annoté) la configuration complète CLI de Cisco Unity Express pour le scénario 1 qui des résultats des modifications spécifiques à la configuration de base :

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
!

!--- The custservice group is defined as all the 
!---users that have access to the GDM.

!
groupname custservice create
!

!--- Nine ACD agents are defined as users.

!
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The custservice group (and therefore GDM) 
!--- is associated with extension 2070.

!
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
groupname Administrators member admin
!

!--- Nine ACD agents users are members of the 
!--- custservice group, so they can have
!--- access to the GDM to retrieve messages.

!
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
!

!--- The Cisco Unity Express system AA is defined 
!--- in the system by default, but
!--- is not used in this scenario.

!
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "false"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Define the GDM associated with 2070, 
!--- associated with the custservice group.

!
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
!

!--- Define personal mailboxes for nine ACD agents.

!
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Scénario 2 - Utilisez le Cisco Unity Express aa comme menu de Premier-niveau et l'ACD de base comme deuxième menu de niveau

Dans le scénario 2, des appels entrant sont dirigés vers la coutume aa (numéro pilote 2100) de Cisco Unity Express, qui fournit à un message de bienvenue et à un menu quatre options à l'appelant. Basé sur le choix de l'appelant, l'appel est dirigé vers Cisco CME ACD (option 1), une de deux annonces (options 2 et 3), ou à une boîte aux lettres générale d'affaires (GDM pour extension 2080) associée avec les réceptionnistes (option 4).

Si l'appelant choisit l'option 1, l'appel est remis hors fonction à Cisco CME ACD où Cisco CME aa fournit un deuxième menu de niveau, qui est semblable au scénario 1.

Écoulement d'appel du scénario 2

L'écoulement d'appel de la configuration dans cette section est illustré dans la figure 8.

Écoulement d'appel de figure 8 pour le scénario 2

135360.jpg

Notes de configuration en scénario 2

Des appels PSTN du port FXO (0/3/0) autoterminated au Cisco Unity Express aa (2100).

Le menu de premier-niveau (« merci d'appeler des systèmes de widget ; service client de 1par de presse ; presse 2 pour l'emplacement de bureau ; presse 3 pendant des heures de bureau ; la presse 4 pour laisser une Voix message.") est fournie par la coutume aa (fichier S10_Main_Menu.wav) de Cisco Unity Express.

Le menu de deuxième-niveau (« pour aider à réorienter votre appel : Questions liées au matériel de 1par de presse ; presse 2 pour des questions liées au logiciel ; la presse 3 pour le général questions.") est fournie par les fichiers de demande de Cisco CME aa. La première expression (« pour aider à réorienter votre appel ") est contenue dans le fichier Flash en_bacd_welcome.au, alors que le reste des instructions sont inchangé de la configuration du scénario 1 et sont contenus dans le fichier Flash en_bacd_options_menu.au.

Vous pouvez sauter le message de bienvenue de Cisco CME totalement en enregistrant un petit fichier vide ou en supprimant le fichier de l'éclair de votre routeur (qui fait sauter le logiciel de Cisco CME le message d'accueil). Dans l'exemple du scénario 2 représenté dans cette section, les expressions de menu associées avec des fichiers de la demande de Cisco Unity Express et de Cisco CME ont été structurées pour circuler comme aa simple à l'appelant. Vous pouvez également sauter Cisco CME aa totalement (les choix de message de bienvenue et d'option) à l'aide de la commande de nombre de baisse-à travers-option de param de transférer un appel directement dans Cisco CME ACD tout en sautant Cisco CME aa.

L'extension 2080 et le GDM associé sont ajoutées à la configuration pour fournir une boîte aux lettres générale pour les réceptionnistes. Cette boîte aux lettres est entrée en choisissant l'option 4 du menu de premier-niveau et est manipulée entièrement dans le Cisco Unity Express. L'extension 2080 a été ajoutée aux Téléphones IP 2001 et 2004--the téléphone associé à deux employés qui sont des réceptionnistes (aussi bien que des agents ACD).

Si un appelant choisit 1 du menu de premier-niveau et est dirigé vers les groupes ACD, mais l'appel demeure sans réponse, l'appel est expédié à l'extension 2070--which est le GDM pour les agents ACD.

Configurez Cisco CME pour le scénario 2

Ces étapes récapitulent la configuration pour Cisco CME pour le scénario 2 :

  1. Choisissez configurent > des téléphones. Cliquez sur alors l'adresse MAC du téléphone que vous voulez pour changer. La fenêtre de téléphone de modification apparaît (voir le schéma 9).

  2. Écrivez l'extension 2080 pour boutonner 3 du téléphone du réceptionniste, alors que l'ACD GDM reste le bouton ON 2. Avec cette installation, l'employé obtient le MWI pour le réceptionniste et les boîtes aux lettres ACD GDM.

    La figure 9 ajoutent la touche d'un poste au téléphone du réceptionniste

    /image/gif/paws/67907/135361.jpg

Ce qui suit est (et annoté) la configuration CLI du routeur complet de Cisco CME pour le scénario 2 qui des résultats des modifications spécifiques à la configuration de base.

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2022
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!

!--- PSTN calls are auto-terminated on the Cisco CUE AA pilot number 2100.

!
voice-port 0/3/0
 connection plar opx 2100
!
voice-port 0/3/1
 connection plar opx 2100
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  7  dual-line
 number 2007
 name User27
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  8  dual-line
 number 2008
 name User28
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  9  dual-line
 number 2009
 name User29
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!

!--- Extension 2080 is associated with the receptionists' GDM. 
!--- This extension is used to get MWI on the receptionists' phones.

!
ephone-dn  10
 number 2080
 description Reception GDM
 name Reception GDM
 call-forward all 2105
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!

!--- Ephone-dn 10 (2080) is defined as button 3 on 
!--- phones 2001 and 2004 so that all
!--- receptionists (ephones 1 and 4) get MWI for the GDM.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:11
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:11
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
ephone-hunt 3 longest-idle
 pilot 2022
 list 2007, 2008, 2009
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configurez le Cisco Unity Express pour le scénario 2

Ces étapes récapitulent la configuration pour le Cisco Unity Express pour le scénario 2 :

  1. Ouvrez l'utilitaire de Script Editor de Cisco Unity Express et créez le script fait sur commande de Cisco Unity Express. Voir la figure 10.

    La figure 10 configurent le script du Cisco Unity Express aa pour le menu supérieur de niveau

    /image/gif/paws/67907/135362.jpg

  2. Choisissez la messagerie vocale > la réception automatique et associez le script (S10_CUE-AA-BACD-script.aef) avec le numéro pilote 2100. Voir la figure 11.

    Associé de figure 11 le script avec un numéro pilote

    /image/gif/paws/67907/135363.jpg

  3. Enregistrez toutes les demandes pour le script aa. Vous pouvez ou enregistrer ce hors ligne et télécharger les fichiers .wav au Cisco Unity Express avec le nom du fichier correct, ou vous pouvez l'enregistrer par la gestion par l'intermédiaire de la téléphonie (AVT).

  4. (Facultatif) si vous utilisez l'AVT, le Cisco Unity Express assigne un nom du fichier générique que vous pouvez ultérieurement changer au nom du fichier désiré. Choisissez la messagerie vocale > les demandes et cliquez sur le nom du fichier de système.

  5. (Facultatif) éditez le nom du fichier (s) comme nécessaire dans la boîte de dialogue et cliquez sur l'ok. La fenêtre de messagerie vocale > de demandes affiche maintenant le nom du fichier corrigé (s) dans la liste (voir la figure 12).

    Liste de figure 12 de demandes de script aa

    /image/gif/paws/67907/135364.jpg

  6. Choisissez la messagerie vocale > la réception automatique et ouvrez l'aa établi dans l'étape 1. choisissent des paramètres de script et associent les noms prompts de fichier avec le paramètre correct dans le script.

  7. Choisissez configurent > des groupes et cliquent sur le groupe (réception) ce vous veulent éditer. La fenêtre de profil de groupe apparaît (voir la fenêtre partielle au sommet de la figure 13). L'onglet de profil est l'affichage par défaut.

  8. Cliquez sur l'onglet de propriétaires/membres pour configurer des membres.

    La figure 13 définissent le groupe de réception

    142217.jpg

Ce qui suit est (et annoté) la configuration complète CLI de Cisco Unity Express pour le scénario 2 qui des résultats des modifications spécifiques à la configuration de base.

cue#show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1

!--- Add the reception group.

!
groupname Administrators create
groupname Broadcasters create
groupname custservice create
groupname reception create
username admin create

username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
username user27 create
username user28 create
username user29 create
!

!--- The reception group (and therefore GDM) is associated with extension 2080.

!
groupname custservice phonenumber "2070"
groupname reception phonenumber "2080"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
username user27 phonenumber "2007"
username user28 phonenumber "2008"
username user29 phonenumber "2009"
!

!--- Add membership to group "reception".

!
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname custservice member user27
groupname custservice member user28
groupname custservice member user29
groupname reception member user21
groupname reception member user24
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast

!--- Define a 09:00-17:00 Monday-Friday business schedule for the AA.

!
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Add the custom AA script for the first-tier menu.

!
ccn application s10-cue-aa-bacd
 description "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10-cue-aa-bacd-script.aef"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_CustomerService" "2040"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the custom AA script with the pilot number 2100.

!
ccn trigger sip phonenumber 2100
 application "s10-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
!

!--- Add the GDM for "reception"

!
voicemail mailbox owner "reception" size 3000
 description "Receptionists mailbox"
 end mailbox
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000
description "user26 mailbox"
end mailbox
voicemail mailbox owner "user27" size 3000
description "user27 mailbox"
end mailbox
voicemail mailbox owner "user28" size 3000
description "user28 mailbox"
end mailbox
voicemail mailbox owner "user29" size 3000
description "user29 mailbox"
end mailbox
end

Variation 1 de configuration du scénario 2 - GDMs individuel par groupe de recherche

La configuration pour le scénario principal décrit dans les sections précédentes définit un GDM simple pour tous les messages laissés par des appelants dans les trois groupes ACD (support matériel, support logiciel et questions générales). Cette finesse ne pourrait pas être suffisante pour quelques situations parce que les agents pour un groupe (tel que le support logiciel) ne pourraient pas vouloir patauger par les messages laissés pour le matériel et les comités de soutien de général avant de trouver des messages concernant le support logiciel. Si le volume de messages est élevé, vous pouvez avoir une boîte aux lettres distincte pour chaque groupe ACD.

Avec les groupes de recherche normaux de Cisco CME (quand pas utilisant l'ACD), vous pouvez définir une boîte aux lettres distincte pour chaque groupe de recherche en associant GDMs individuel avec les nombres de groupe de recherche (2020, 2021, 2022) et en indiquant la destination « définitive » du groupe de recherche la messagerie vocale--comme illustré dans les exemples suivants de configuration.

Configurez Cisco CME pour la variation 1 du scénario 2

Ce qui suit sont des variations de configuration de Cisco CME pour GDMs individuel :

ephone-hunt 1 sequential
 pilot 2020
 list 2001, 2002, 2003
 final 2105
 timeout 10
!
!
ephone-hunt 2 sequential
 pilot 2021
 list 2004, 2005, 2006
 final 2105
 timeout 10
!
!
ephone-hunt 3 sequential
 pilot 2022
 list 2007, 2008, 2009
 final 2105
 timeout 10

Configurez le Cisco Unity Express pour la variation 1 du scénario 2

Ces étapes récapitulent la configuration des groupes et du GDMs sur le Cisco Unity Express pour la variation 1 du scénario 2 :

  1. Différents groupes sont définis dans le Cisco Unity Express pour chacun des trois groupes de recherche. Choisissez configurent > des groupes pour définir des groupes. Voir la figure 14.

    La figure 14 définissent différents groupes

    135357.jpg

  2. De configurez > des groupes, cliquent sur le groupe (matériel) que vous voulez éditer. La fenêtre d'onglet de profil par défaut apparaît (voir le dessus de la figure 15).

    La figure 15 configurent les groupes spécifiques

    /image/gif/paws/67907/135358.jpg

  3. Choisissez l'onglet de propriétaires/membres (voir le bas de la figure 15) et cliquez sur la case à gauche pour sélectionner des propriétaires et des membres.

    Ce qui suit sont des variations de configuration de Cisco Unity Express pour GDMs individuel :

    groupname hardware create
    groupname software create
    groupname general create
    groupname hardware phonenumber "2020"
    groupname software phonenumber "2021"
    groupname general phonenumber "2022"
    groupname hardware member user21
    groupname hardware member user22
    groupname hardware member user23
    groupname software member user24
    groupname software member user25
    groupname software member user26
    groupname general member user27
    groupname general member user28
    groupname general member user29
    voicemail mailbox owner "general" size 5520
     description "general mailbox"
     end mailbox
    voicemail mailbox owner "hardware" size 5520
     description "Hardware mailbox"
     end mailbox
    voicemail mailbox owner "software" size 5520
     description "software mailbox"
     end mailbox

Variation 2 de configuration du scénario 2 - GDMs individuel par groupe ACD

Il y a deux inconvénients à la configuration récapitulée dans « la variation de configuration du scénario 2 1--Individual GDMs la section par groupe de recherche ».

  • Cela fonctionne seulement si les groupes de recherche s'appellent directement (extensions 2020, 2021 et 2022), et ne fonctionne pas quand les groupes de recherche sont utilisés comme ACD quand le numéro pilote ACD (2040) s'appelle

  • Il ne fournit aucun moyen de fournir le MWI pour les agents parce que des nombres de groupe de recherche ne peuvent pas être mis aux téléphones comme boutons.

Pour fournir une configuration qui résout ces deux inconvénients, vous pouvez utiliser le script système de xfermailbox dans le Cisco Unity Express. Définissez trois groupes dans le Cisco Unity Express (un pour le matériel, le logiciel, et le général), et associez chaque groupe avec une extension intérimaire (telle que 2030, 2031, et 2032) qui peut être placée comme boutons apparaissant à un téléphone d'agent (et en conséquence fournir le MWI). Cette configuration des groupes, des extensions, et des téléphones est récapitulée dans le tableau 2.

Agent Extension Nombre de groupe de recherche Groupe ACD Boîte aux lettres de groupe
user21 2001 2020 Matériel 2030
user22 2002 2020 Matériel 2030
user23 2003 2020 Matériel 2030
user24 2004 2021 Logiciel 2031
user25 2005 2021 Logiciel 2031
user26 2006 2021 Logiciel 2031
user27 2007 2022 Généralités 2032
user28 2008 2022 Généralités 2032
user29 2009 2022 Généralités 2032

L'écoulement ajusté d'appel pour cette installation modifiée est illustré dans la figure 16.

Écoulement d'appel ajusté par figure 16 pour la variation de script de xfermailbox

/image/gif/paws/67907/135359.jpg

Les appels de direction dans GDMs individuel dans le Cisco Unity Express exige un script personnalisé qui appelle le script système de xfermailbox. Des appels à Cisco CME ACD peuvent seulement être expédiés au Cisco Unity Express à l'aide de la commande simple de nombre d'audio-messagerie de param (les différentes destinations définitives sur les groupes de recherche ne peuvent pas être utilisées pour des écoulements d'appel ACD). Cette commande fournit une extension simple au Cisco Unity Express pour l'entrée dans une boîte aux lettres (extension 2070 dans des configurations précédentes). Le Cisco Unity Express n'a aucune manière de distinguer quel groupe de recherche est le destinataire destiné et ne peut pas déterminer lesquels des trois GDMs à entrer.

Au lieu de cela, dirigez la destination d'audio-messagerie de Cisco CME ACD vers un numéro pilote de Cisco Unity Express (2110) qui écrivent un script personnalisé (s12-xfer-to-mbox.aef). Ce numéro pilote fournit un menu à l'utilisateur offrant un choix des groupes pour lesquels un message peut être laissé (matériel, logiciel, ou général). Le contenu de ce menu est affiché au bas de l'écoulement d'appel dans la figure 16. Basé sur la réponse de l'appelant, la variable de mbox est placée à l'extension appropriée (2030, 2031, ou 2032), et l'appel est remis hors fonction (par l'intermédiaire du script système de xfermailbox) à l'un des trois GDMs.

Les étapes associées avec modifier la configuration du scénario 2 pour manipuler les changements de configuration tracés les grandes lignes du tableau 2 et de la figure 16 sont décrites dans les étapes suivantes :

  1. Ouvrez l'utilitaire de Script Editor de Cisco Unity Express et écrivez un script fait sur commande de Cisco Unity Express appelé le s12-xfer-to-mbox.aef. Voir la figure 17.

    Fenêtre faite sur commande de création de script de Cisco Unity Express de figure 17

    /image/gif/paws/67907/135347.jpg

  2. Choisissez la messagerie vocale > la réception automatique. Voir la figure 18. Ajoutez une nouvelle réception automatique et associez-la avec le script établi dans l'étape 1.

  3. Associez le script de Cisco Unity Express de la coutume s12-xfer-to-mbox.aef avec le numéro pilote 2110. Voir la figure 18.

    Associé de figure 18 le script fait sur commande de Cisco Unity Express avec un numéro pilote

    /image/gif/paws/67907/135348.jpg

  4. Enregistrez la demande (dans ce cas nommée S12_Main_Menu.wav) pour le nouveau script aa. Vous pouvez ou enregistrer ce hors ligne et télécharger le fichier .wav au Cisco Unity Express avec le nom du fichier correct, ou vous pouvez l'enregistrer par la gestion par l'intermédiaire de la téléphonie (AVT).

  5. (Facultatif) si vous utilisez l'AVT, le Cisco Unity Express assigne un nom du fichier générique que vous pouvez ultérieurement changer au nom du fichier désiré. Choisissez la messagerie vocale > les demandes et cliquez sur le nom du fichier de système.

  6. (Facultatif) éditez le nom du fichier dans la boîte de dialogue en tant que nécessaire et cliquez sur OK. La fenêtre de messagerie vocale > de demandes affiche maintenant le nom du fichier corrigé dans la liste (voir la figure 19).

  7. Choisissez la messagerie vocale > la réception automatique et ouvrez l'aa établi pendant l'étape 2. choisissent des paramètres de script et associent le nom du fichier prompt avec le paramètre correct dans le script.

    Liste de figure 19 de demandes enregistrées

    135349.jpg

  8. Choisissez configurent > extension pour définir les extensions 2030, 2031, et 2032 pour associer le GDMs avec chacune de ces extensions. Voir la figure 20.

    La figure 20 définissent des extensions pour associer le GDMs avec des groupes de recherche ACD

    /image/gif/paws/67907/135350.jpg

  9. Choisissez configurent > des téléphones et cliquent sur l'adresse MAC du téléphone que vous voulez pour changer. La fenêtre de téléphone de modification apparaît (voir la figure 21).

  10. Ajoutez les boutons pour 2030, 2031, ou 2032 aux téléphones d'agent ACD pour fournir le MWI.

    Fenêtre de figure 21 illustrant ajoutant des boutons

    /image/gif/paws/67907/135351.jpg

Ce qui suit est la configuration annotée CLI de routeur de Cisco CME pour des changements et des ajouts de la configuration de Cisco CME à la configuration de base de scénario associée avec « configurer Cisco CME pour le scénario 2" section.


!--- Set the Cisco CME AA voice mail destination 
!--- to 2110, the Cisco Unity Express
!--- script entrypoint for the transfer-to-mailbox functionality.

!
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2110
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!

!--- Define the group extensions (2030, 2031 and 2032) to 
!--- be used as button appearances
!--- on the agent phones so they can get MWI for the GDMs. 
!--- Put these extension in CFA
!--- so they never ring and do not disturb the agents.

!
ephone-dn  12
 number 2030
 description HW Cust Svc Mbox
 name HW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  13
 number 2031
 description SW Cust Svc Mbox
 name SW Cust Svc Mbox
 call-forward all 2110
!
ephone-dn  14
 number 2032
 description Gen Cust Svc Mbox
 name Gen Cust Svc Mbox
 call-forward all 2110
!

!--- Add a button appearance of the appropriate 
!--- group extension to each of the
!--- ACD Agent phones.

!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:12 3:10
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:12
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:12
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:13 3:10
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:13
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:13
!
ephone 7
 username "user27"
 mac-address 0003.AAAA.0007
 type 7960
 button 1:7 2:14
!
ephone 8
 username "user28"
 mac-address 0003.AAAA.0008
 type 7960
 button 1:8 2:14
!
ephone  9
 username "user29"
 mac-address 0003.AAAA.0009
 type 7960
 button 1:9 2:14

Ce qui suit est la configuration annotée CLI de Cisco Unity Express pour des changements et des ajouts de la configuration à la configuration de base de scénario associée avec « configurer le Cisco Unity Express pour le scénario 2" section et les modifications précédentes GUI :


!--- Define the three new groups, Hardware, Software and General.

!
groupname hardware create
groupname software create
groupname general create
!

!--- Define the new groups (and therefore GDMs) are associated with 
!--- extensions 2030, 2031 and 2032.

!
groupname hardware phonenumber "2030"
groupname software phonenumber "2031"
groupname general phonenumber "2032"
!

!--- Define the membership of  the Hardware, Software and General groups.

!
groupname hardware member user21
groupname hardware member user22
groupname hardware member user23
groupname software member user24
groupname software member user25
groupname software member user26
groupname general member user27
groupname general member user28
groupname general member user29
!

!--- Define the custom AA script that will branch 
!--- to the xfermailbox.aef system script
!--- when the caller selects the correct GDM from the menu.

!
ccn application s12-xfer-to-mbox
 description "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 script "s12_cue-aa-bacd-script.aef"
 end application
!

!--- Define the pilot number 2110 to the custom script.

!
ccn trigger sip phonenumber 2110
 application "s12-xfer-to-mbox"
 enabled
 maxsessions 8
 end trigger
!

!--- Define the GDMs for each of the groups.

!
voicemail mailbox owner "hardware" size 3000
 description "hardware mailbox"
 end mailbox
voicemail mailbox owner "software" size 3000
 description "software mailbox"
 end mailbox
voicemail mailbox owner "general" size 3000
 description "general mailbox"
 end mailbox

Variation 3 de configuration du scénario 2 - Utilisez la baisse par la fonctionnalité de CD

La baisse par la caractéristique de Cisco CME ACD peut être utilisée pour sauter le menu de Cisco CME aa et pour transférer un appel directement dans l'ACD. Avec cette configuration, le menu entier aa peut être consolidé dans le script du Cisco Unity Express aa. Tandis que l'utilisation de cette caractéristique exige la configuration supplémentaire sur le routeur de Cisco CME, elle simplifie la maintenance du script aa (menus) comparé à séparer les menus et les enregistrements d'annonce entre le Cisco Unity Express aa (menu de niveau 1) et Cisco CME aa (menu de niveau 2).

Dans la configuration de la variation 3 du scénario 2, les deux niveaux du menu aa sont contenus dans le script du Cisco Unity Express aa comme suit :

  • Merci d'appeler des systèmes de widget

    • Service client de 1par de presse

      • Questions relatives de matériel de 1par de presse

      • Presse 2 pour des questions relatives de logiciel

      • Presse 3 pour des questions générales

    • Presse 2 pour l'emplacement de bureau

    • Presse 3 pendant des heures de bureau

    • Presse 4 pour laisser un message vocal

Les choix de menu du niveau 2 résultent en appels étant remis hors fonction du Cisco Unity Express à un numéro pilote individuel de Cisco CME ACD pour chacun de ces groupes :

  • Matériel — Numéro pilote 2040 de Cisco CME ACD

  • Logiciel — Numéro pilote 2041 de Cisco CME ACD

  • Général — numéro pilote 2042 de Cisco CME ACD

Les configurations précédemment présentées dans ce document ont défini un seul numéro pilote ACD (2040). Dans cette variation de configuration, trois numéros pilotes différents de Cisco CME ACD sont définis (2040, 2041, et 2042). Cette variation illustre comment vous pouvez activer la baisse par la fonctionnalité. Utilisant la baisse par la caractéristique saute le menu de Cisco CME aa et spécifie une option particulière de suivre (spécifié dans la commande correspondante CLI). Le système agit comme si l'appelant a appuyé sur l'option spécifiée statiquement dans le CLI. Dans ce scénario, la configuration de Cisco CME aa inclut les adaptations suivantes :

  • La configuration pour le numéro pilote 2040 ACD inclut la commande de la baisse-à travers-option 1 de param

  • La configuration pour le numéro pilote 2041 ACD inclut la commande de la baisse-à travers-option 2 de param

  • La configuration pour le numéro pilote 2042 ACD inclut la commande de la baisse-à travers-option 3 de param

Configurez Cisco CME pour la variation 3 du scénario 2

Ces étapes récapitulent la configuration pour Cisco CME pour la variation 3 du scénario 2 :

  1. Ajoutez Cisco supplémentaire CME aa et la configuration ACD TCL pour les numéros pilotes 2040, 2041 et 2042, utilisant « baisse-à travers » le CLI.

  2. Ajoutez les cadran-pairs pour activer composer les nouveaux numéros pilotes 2040, 204,1 et 2042.

    Ce qui suit est la configuration annotée CLI de routeur de Cisco CME pour les modifications et les ajouts à la configuration de Cisco CME du scénario de base associé avec « configurer Cisco CME pour le scénario 2" section.

    application
     service acd flash:app-b-acd-2.1.0.0.tcl
      param queue-cme-debugs 1
      param aa-hunt1 2020
      param aa-hunt2 2021
      param number-of-hunt-grps 3
      param aa-hunt3 2022
      param queue-len 30
    !
    
    !--- Define the TCL configuration for the Hardware group, using pilot number 2040 
    !--- and "drop-through-option 1". Extension 2030 is associated with the GDM for
    !--- the Hardware group, so this is the voice mail destination.
    
    !
     service hardware-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param max-time-vm-retry 1
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2030
      param aa-pilot 2040
      param number-of-hunt-grps 1
      paramspace english language en
      param handoff-string hardware-aa
      param call-retry-timer 20
      paramspace english location flash:
      param service-name acd
      param drop-through-option 1
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the TCL configuration for the Software group, 
    !--- using pilot number 2041 
    !--- and "drop-through-option 2". Extension 2031 is associated with the GDM for
    !--- the Software group, so this is the voice mail destination.
    
    !
     service software-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param number-of-hunt-grps 1
      paramspace english index 0
      param handoff-string software-aa
      paramspace english language en
      param call-retry-timer 20
      param service-name acd
      paramspace english location flash:
      param drop-through-option 2
      param second-greeting-time 30
      param max-time-vm-retry 1
      param voice-mail 2031
      paramspace english prefix en
      param max-time-call-retry 60
      param aa-pilot 2041
    !
    
    !--- Define the TCL configuration for the General group, using pilot number 2042 
    !--- and "drop-through-option 3". Extension 2032 is associated with the GDM for
    !--- the General group, so this is the voice mail destination.
    
    !
     service general-aa flash:app-b-acd-aa-2.1.0.0.tcl
      param call-retry-timer 20
      paramspace english index 0
      param max-time-call-retry 60
      param voice-mail 2032
      param service-name acd
      param number-of-hunt-grps 1
      param drop-through-option 3
      paramspace english language en
      param handoff-string general-aa
      param max-time-vm-retry 1
      paramspace english location flash:
      param aa-pilot 2042
      param second-greeting-time 30
      paramspace english prefix en
    !
    
    !--- Define the dial-peers for pilot number 2040 and attach the Hardware
    !--- TCL script to this number.
    
    !
    dial-peer voice 2040 voip
     destination-pattern 2040
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20400 voip
     service hardware-aa
     incoming called-number 2040
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    
    !--- Define the dial-peers for pilot number 2041 and attach the Software
    !--- TCL script to this number.
    
    !
    dial-peer voice 2041 voip
     destination-pattern 2041
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20410 voip
     service software-aa
     incoming called-number 2041
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    Ý
    
    !--- Define the dial-peers for pilot number 2042 and attach the General
    !--- TCL script to this number.
    
    !
    dial-peer voice 2042 voip
     destination-pattern 2042
     session target ipv4:a.1.11.1
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad
    !
    dial-peer voice 20420 voip
     service general-aa
     incoming called-number 2042
     dtmf-relay h245-alphanumeric
     codec g711ulaw
     no vad

Configurez le Cisco Unity Express pour la variation 3 du scénario 2

Ces étapes récapitulent la configuration pour le Cisco Unity Express pour la variation 3 du scénario 2 :

  1. Ouvrez l'utilitaire de Script Editor de Cisco Unity Express et ajustez le script s10-cue-aa-bacd.aef pour contenir les deux niveaux du menu aa. Voir la figure 22.

    La figure 22 configurent le script du Cisco Unity Express aa pour les deux niveaux de menu

    /image/gif/paws/67907/142220.jpg

  2. Choisissez la messagerie vocale > la réception automatique et associez le nouveau script (S10A_CUE-AA-BACD-script.aef) avec le numéro pilote 2100. Voir la figure 23.

    Associé de figure 23 le script avec un numéro pilote

    /image/gif/paws/67907/142221.jpg

  3. Enregistrez toutes les demandes requises pour le script aa. Vous pouvez ou enregistrer ces hors ligne et télécharger les fichiers .wav au Cisco Unity Express avec les noms corrects de fichier, ou vous pouvez l'enregistrer par la gestion par l'intermédiaire de la téléphonie (AVT).

  4. (Facultatif) si vous utilisez l'AVT, le Cisco Unity Express assigne les noms génériques d'un fichier que vous pouvez ultérieurement changer au nom du fichier désiré. Choisissez la messagerie vocale > les demandes et cliquez sur le nom du fichier de système.

  5. (Facultatif) éditez le nom du fichier (s) dans la boîte de dialogue en tant que nécessaire et cliquez sur OK. La fenêtre de messagerie > de demandes de The Voice affiche maintenant le nom du fichier corrigé dans la liste.

Ce qui suit est la configuration annotée CLI de Cisco Unity Express pour les modifications et les ajouts à la configuration de Cisco Unity Express de la configuration de base de scénario associée avec le Cisco Unity Express configurant pour le scénario 2 sections.


!--- Define a new AA with script s10a-cue-aa-bacd.aef.

!
ccn application s10a-cue-aa-bacd
 description "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s10a_cue-aa-bacd-script.aef"
 parameter "S10_Hardware" "2040"
 parameter "S10_StoreHours" "S10_StoreHours.wav"
 parameter "S10_Software" "2041"
 parameter "S10_General" "2042"
 parameter "S10_GDM" "2080"
 parameter "S10_StoreLocation" "S10_StoreLocation.wav"
 end application
!

!--- Associate AA pilot number 2100 with the new script.

!
ccn trigger sip phonenumber 2100
 application "s10a-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger

Scénario 3 - Utilisez l'ACD de base comme menu et Cisco Unity Express aa de Premier-niveau comme deuxième menu de niveau

Dans le troisième scénario présenté dans ce document, des appels entrant sont dirigés vers Cisco CME aa (numéro pilote 2040) exactement comme dans le scénario 1. La seule différence est qu'il y a seulement deux groupes ACD (matériel et logiciel), alors que la troisième option du menu principal est d'accéder à une annonce qui décrit l'emplacement de mémoire et les heures de l'exécution.

Remarque: Il n'est pas possible d'inclure des annonces de libre-forme avec Cisco CME aa. Un script personnalisé de Cisco Unity Express est exigé à la place.

Vous pouvez réaliser ce même résultat (du point de vue d'un appelant) avec une variation du scénario 2. L'exemple du scénario 3 est donné pour montrer une autre manière de structurer l'application à la main outre d'un appel de Cisco CME ACD traitant au Cisco Unity Express aa. Utilisant une variation de scénario 2 est probablement la manière plus typique d'établir cette application.

Écoulement d'appel du scénario 3

L'écoulement d'appel de la configuration dans cette section est illustré dans la figure 24.

Écoulement d'appel du scénario 3 de figure 24

135510.jpg

Notes de configuration en scénario 3

Des appels PSTN du port FXO (0/3/0) automatique-sont terminés à Cisco CME aa (2040).

Cisco CME ACD a seulement deux groupes d'agents (2020 et 2021). L'option 3 du menu est utilisée de remettre outre de l'appel au Cisco Unity Express aa pour l'annonce. Au lieu de répertorier un nombre de groupe de recherche, quand les appelants choisissent l'option 3 le système dirige les appelants vers le numéro pilote du Cisco Unity Express aa (2100)--resulting de l'utilisation de la commande de param aa-hunt3 2100.

Configurez Cisco CME pour le scénario 3

La configuration CLI pour le routeur de Cisco CME est affichée dans l'exemple suivant :

CME-2821#show running-config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CME-2821
!
boot-start-marker
boot system flash:
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address b.168.1.1 b.168.1.10
!
ip dhcp pool ITS
   network b.168.1.0 255.255.255.0
   option 150 ip a.1.11.1 
   default-router b.168.1.1 
!
no ip domain lookup
!
voice-card 0
 no dspfarm
!
voice service voip 
 allow-connections h323 to h323
 allow-connections h323 to sip
 supplementary-service h450.12 advertise-only
!

!--- Point option 3 of the menu (aa-hunt3) to the 
!--- Cisco Unity Express AA (2100).

!
application
 service acd flash:app-b-acd-2.1.0.0.tcl
  param queue-cme-debugs 1
  param aa-hunt1 2020
  param aa-hunt2 2021
  param number-of-hunt-grps 3
  param aa-hunt3 2100
  param queue-len 30
 !
 service cme-aa flash:app-b-acd-aa-2.1.0.0.tcl
  param max-time-call-retry 60
  param voice-mail 2070
  paramspace english index 0
  param service-name acd
  param number-of-hunt-grps 3
  param handoff-string cme-aa
  paramspace english language en
  param max-time-vm-retry 1
  paramspace english location flash:
  param aa-pilot 2040
  param second-greeting-time 30
  paramspace english prefix en
  param call-retry-timer 20
!
interface Loopback0
 ip address a.1.11.1 255.255.255.252
!
interface GigabitEthernet0/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet0/1/0
 switchport access vlan 10
!
interface FastEthernet0/1/1
 switchport access vlan 10
!
interface FastEthernet0/1/2
 switchport access vlan 10
!
interface FastEthernet0/1/3
 switchport access vlan 10
!
interface FastEthernet0/1/4
 switchport access vlan 10
!
interface FastEthernet0/1/5
 switchport access vlan 10
!
interface FastEthernet0/1/6
 switchport access vlan 10
!
interface FastEthernet0/1/7
 switchport access vlan 10
!
interface FastEthernet0/1/8
 switchport access vlan 10
!
interface Service-Engine1/0
 ip unnumbered Loopback0
 service-module ip address a.1.11.2 255.255.255.252
 service-module ip default-gateway a.1.11.1
!
interface Vlan1
 no ip address
!
interface Vlan10
 ip address b.168.1.1 255.255.255.0
!
ip classless
ip route a.1.11.2 255.255.255.255 Service-Engine1/0
!
ip http server
ip http path flash:
!
tftp-server flash:P00305000600.bin
tftp-server flash:P00305000600.sbn
!
control-plane
!
voice-port 0/3/0
 connection plar opx 2040
!
voice-port 0/3/1
 connection plar opx 2040
!
voice-port 0/3/2
!
voice-port 0/3/3
!
dial-peer voice 2040 voip
 destination-pattern 2040
 session target ipv4:a.1.11.1
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2041 voip
 service cme-aa
 incoming called-number 2040
 dtmf-relay h245-alphanumeric
 codec g711ulaw
 no vad
!
dial-peer voice 2105 voip
 destination-pattern 21..
 session protocol sipv2
 session target ipv4:a.1.11.2
 dtmf-relay sip-notify
 codec g711ulaw
 no vad
!
telephony-service
 load 7960-7940 P00305000300
 max-ephones 48
 max-dn 192
 ip source-address a.1.11.1 port 2000
 max-redirect 20
 auto assign 1 to 10
 system message CISCO SYSTEMS
 create cnf-files version-stamp 7960 Aug 05 2005 00:00:32
 voicemail 2105
 max-conferences 8 gain -6
 moh music-on-hold.au
 dn-webedit 
 time-webedit 
 transfer-system full-consult
 transfer-pattern 210. blind
 transfer-pattern 2040 blind
!
ephone-dn  1  dual-line
 number 2001
 name User21
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  2  dual-line
 number 2002
 name User22
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  3  dual-line
 number 2003
 name User23
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  4  dual-line
 number 2004
 name User24
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  5  dual-line
 number 2005
 name User25
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  6  dual-line
 number 2006
 name User26
 call-forward busy 2105
 call-forward noan 2105 timeout 10
!
ephone-dn  11
 number 2070
 description GDM
 name Cust Svc GDM
 call-forward all 2105
!
ephone-dn  100
 number 8000....
 mwi on
!
ephone-dn  101
 number 8001....
 mwi off
!
ephone  1
 username "user21" password null
 mac-address 0012.0034.81B7
 type 7960
 button  1:1 2:11
!
ephone  2
 username "user22" password null
 mac-address 0011.2032.C876
 type 7960
 button  1:2 2:11
!
ephone  3
 username "user23" password null
 mac-address 0012.01E8.875F
 type 7960
 button  1:3 2:11
!
ephone  4
 username "user24"
 mac-address 0003.AAAA.0004
 type 7960
 button 1:4 2:11
!
ephone 5
 username "user25"
 mac-address 0003.AAAA.0005
 type 7960
 no auto-line
 button 1:5 2:11
!
ephone 6
 username "user26"
 mac-address 0003.AAAA.0006
 type 7960
 button 1:6 2:11
!
ephone-hunt 1 longest-idle
 pilot 2020
 list 2001, 2002, 2003
 timeout 5
!
ephone-hunt 2 longest-idle
 pilot 2021
 list 2004, 2005, 2006
 timeout 5
!
line con 0
 logging synchronous
line aux 0
line 66
 no activation-character
 no exec
 transport preferred none
 transport input all
 transport output all
line vty 0 4
 login
!
scheduler allocate 20000 1000
ntp master
!
end

Configurez le Cisco Unity Express pour le scénario 3

Ces étapes récapitulent la configuration pour le Cisco Unity Express pour le scénario 3 :

  1. Ouvrez l'utilitaire de Script Editor de Cisco Unity Express et écrivez le script fait sur commande de Cisco Unity Express. Voir la figure 25.

    Heures de mémoire de figure 25 et script d'emplacement

    /image/gif/paws/67907/135367.jpg

  2. Enregistrez la demande (dans ce cas nommée S11_Announcement.wav) pour le script aa (S11_CUE-AA-BACD-script.aef). Vous pouvez ou enregistrer ce hors ligne et télécharger le fichier .wav au Cisco Unity Express avec le nom du fichier correct, ou vous pouvez l'enregistrer par la gestion par l'intermédiaire de la téléphonie (AVT).

  3. (Facultatif) si vous utilisez l'AVT, le Cisco Unity Express assigne un nom du fichier générique que vous pouvez ultérieurement changer au nom du fichier désiré. Choisissez la messagerie vocale > les demandes et cliquez sur le nom du fichier de système.

  4. (Facultatif) éditez le nom du fichier dans la boîte de dialogue et cliquez sur OK. La fenêtre de messagerie vocale > de demandes affiche maintenant le nom du fichier corrigé dans la liste (voir la figure 26).

  5. Choisissez la messagerie vocale > la réception automatique et ouvrez l'aa établi pendant l'étape 2. choisissent des paramètres de script et associent le nom du fichier prompt avec le paramètre correct dans le script.

    Fenêtre de figure 26 affichant des options rapides

    135368.jpg

  6. Choisissez la messagerie vocale > la réception automatique et associez le script avec le numéro pilote 2100 aa. Voir la figure 27.

    Fenêtre de figure 27 affichant l'association du script au numéro pilote aa

    /image/gif/paws/67907/135369.jpg

La configuration CLI pour le système de Cisco Unity Express est affichée dans l'exemple suivant :

cue# 
show running-config
Generating configuration:
clock timezone America/Los_Angeles
hostname cue
ip domain-name cisco.com
ntp server a.1.11.1
groupname Administrators create
groupname Broadcasters create
groupname custservice create
username admin create
username user21 create
username user22 create
username user23 create
username user24 create
username user25 create
username user26 create
groupname custservice phonenumber "2070"
username user21 phonenumber "2001"
username user22 phonenumber "2002"
username user23 phonenumber "2003"
username user24 phonenumber "2004"
username user25 phonenumber "2005"
username user26 phonenumber "2006"
groupname Administrators member admin
groupname custservice member user21
groupname custservice member user22
groupname custservice member user23
groupname custservice member user24
groupname custservice member user25
groupname custservice member user26
groupname Administrators privilege superuser
groupname Administrators privilege ManagePrompts
groupname Administrators privilege ManagePublicList
groupname Administrators privilege ViewPrivateList
groupname Broadcasters privilege broadcast
calendar biz-schedule systemschedule
 closed day 1 from 00:00 to 24:00
 open day 2 from 09:00 to 17:00
 open day 3 from 09:00 to 17:00
 open day 4 from 09:00 to 17:00
 open day 5 from 09:00 to 17:00
 open day 6 from 09:00 to 17:00
 closed day 7 from 00:00 to 24:00
end schedule
ccn application autoattendant
 description "autoattendant"
 enabled
 maxsessions 8
 script "aa.aef"
 parameter "busOpenPrompt" "AABusinessOpen.wav"
 parameter "holidayPrompt" "AAHolidayPrompt.wav"
 parameter "busClosedPrompt" "AABusinessClosed.wav"
 parameter "allowExternalTransfers" "true"
 parameter "MaxRetry" "3"
 parameter "operExtn" "2001"
 parameter "welcomePrompt" "AAWelcome.wav"
 parameter "businessSchedule" "systemschedule"
 end application
ccn application ciscomwiapplication
 description "ciscomwiapplication"
 enabled
 maxsessions 8
 script "setmwi.aef"
 parameter "strMWI_OFF_DN" "8001"
 parameter "strMWI_ON_DN" "8000"
 parameter "CallControlGroupID" "0"
 end application
ccn application promptmgmt
 description "promptmgmt"
 enabled
 maxsessions 1
 script "promptmgmt.aef"
 end application
!

!--- Define the AA script that will provide the announcement.

!
ccn application s11-cue-aa-bacd
 description "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 script "s11_cue-aa-bacd-script.aef"
 end application
ccn application voicemail
 description "voicemail"
 enabled
 maxsessions 8
 script "voicebrowser.aef"
 parameter "logoutUri" "http://localhost/voicemail/vxmlscripts/mbxLogout.jsp"
 parameter "uri" "http://localhost/voicemail/vxmlscripts/login.vxml"
 end application
ccn engine
 end engine
ccn subsystem jtapi
 ccm-manager address 0.0.0.0 
 end subsystem
ccn subsystem sip
 gateway address "a.1.11.1"
 end subsystem
!

!--- Associate the script with the 2100 AA pilot number.

!
ccn trigger sip phonenumber 2100
 application "s11-cue-aa-bacd"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2102
 application "autoattendant"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2105
 application "voicemail"
 enabled
 maxsessions 8
 end trigger
ccn trigger sip phonenumber 2106
 application "promptmgmt"
 enabled
 maxsessions 1
 end trigger
voicemail default language en_US
voicemail default mailboxsize 3000
voicemail broadcast recording time 300
voicemail operator telephone 2001
voicemail mailbox owner "custservice" size 3000
 description "custservice mailbox"
 end mailbox
voicemail mailbox owner "user21" size 3000
 end mailbox
voicemail mailbox owner "user22" size 3000
 end mailbox
voicemail mailbox owner "user23" size 3000
 end mailbox
voicemail mailbox owner "user24" size 3000
description "user24 mailbox"
end mailbox
voicemail mailbox owner "user25" size 3000
description "user25 mailbox"
end mailbox
voicemail mailbox owner "user26" size 3000

description "user26 mailbox"
end mailbox
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Demande BACD pour les réceptions automatiques simples ne lisant pas

Si le fichier BACD est dans l'éclair : le répertoire /bacdprompt/, émettent l'éclair anglais d'emplacement de paramspace : commande /bacdprompt/ dans le service aa.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 67907