Services de mise en réseau d'applications : Cache Engines de la gamme Cisco 500

Exemple de configuration de la redirection de stratégie WCCP dans le Cache Engine de la gamme Cisco 500

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon qui explique comment installer une redirection de stratégie de la version 2 de Web Cache Communication Protocol (WCCPv2) dans un moteur de cache de gamme Cisco 500. Dans cette configuration d'échantillon, vous utilisez la commande de table-map la configuration BGP et en traçant la balise externe de l'attribut WCCP d'entrée dans la table de routage afin de classifier des paquets avec des attributs de Protocole BGP (Border Gateway Protocol) associés avec la source ou l'adresse IP de destination d'un paquet.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur Cisco 7513 qui exécute la version de logiciel 12.0(14)S de Cisco IOSÝ

  • Moteur de cache 550 de Cisco qui exécute le Logiciel Cisco Cache version 2.3

  • Routeur de Cisco 2600 qui exécute le Logiciel Cisco IOS version 12.0

  • Serveurs Web de Windows NT

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Référez-vous au Conventions relatives aux conseils techniques Cisco pour les informations sur des conventions de document.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/12658/wwcp_2_policy.gif

Trafiquez seulement que des voyages à la destination PC2 (qui appartient à AS30) est réorientés au moteur de cache, alors que l'autre trafic de système autonome (AS) (RouterD, serveur de HTTP 3.3.3.3 dans AS33) n'est pas.

Configurations

Ce document utilise les configurations suivantes :

RouterA
!
interface FastEthernet0/0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.17.241.27 255.255.255.0
!
router bgp 10
bgp log-neighbor-changes
network 2.2.2.0
network 172.17.241.0
redistribute connected
neighbor 2.2.2.1 remote-as 20

RouterB
!
ip wccp web-cache password ww policy destination 60
ip cef distributed
!
interface Serial0/0
ip address 1.1.1.2 255.255.255.0
no ip directed-broadcast
!
interface Ethernet5/0
ip address 2.2.2.1 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect in
ip route-cache same-interface
!
router bgp 20
table-map dst
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip classless
!
access-list 1 permit 3.0.0.0 0.255.255.255
route-map DST permit 10
match ip address 1
set ip wccp 60
!
route-map DST permit 20

RouterC
!
interface Serial0/0
ip address 1.1.1.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Ethernet5/0
ip address 3.3.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 30
network 3.3.3.0
redistribute connected
neighbor 1.1.1.2 remote-as 20
neighbor 1.1.1.2 send-community
neighbor 1.1.1.2 route-map setcomm out
neighbor 3.3.3.3 remote-as 33
!
ip classless
ip bgp-community new-format
!
access-list 1 permit 77.0.0.0 0.255.255.255
route-map setcomm permit 10
match ip address 1
set community 4433:1050
!
route-map setcomm permit 20
!

RouterD
!
interface Ethernet0
ip address 3.3.3.3 255.255.255.0
!
router bgp 33
bgp log-neighbor-changes
network 33.33.33.0
redistribute connected
neighbor 3.3.3.1 remote-as 30
!
ip classless
ip http server

Commandes associées

Vous pouvez configurer les exemples de routeur à ces scénarios :

table-map

Employez la commande de table-map afin de changer la stratégie WCCP de la destination à la source. Le trafic qui est réorienté est maintenant représenté par chaque demande de HTTP avec l'adresse IP source spécifiée dans le src de route-map.

!
router bgp 20
table-map src
network 2.2.2.0
redistribute connected
neighbor 1.1.1.1 remote-as 30
neighbor 2.2.2.2 remote-as 10
!
ip wccp web-cache password WW policy source 60
!
access-list 1 permit 172.0.0.0 0.255.255.255
route-map src permit 10
match ip address 1
set ip wccp 60
!
route-map src permit 20
!

match as-path

Changez la condition qui applique la balise WCCP aux routes annoncées BGP. Dans la configuration de RouterC, la balise WCCP est appliquée aux routes BGP qui appartiennent à la communauté particulière 4433:1050. Vous pouvez employer la commande de match as-path afin de sélectionner d'autres critères dans le RouterB tel que le comme-chemin.

ip as-path access-list 121 permit ^30$
!
route-map setlist permit 10
match as-path 121
set ip wccp 60
!

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 12658