Collaboration : Cisco ICM Logger

Assertion constante de Logger, car la table Config_Message_Log est vide

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit une raison pour l'assertion répétitive du processus d'enregistreur sur l'enregistreur, et fournit une solution dans un Intelligent Contact Management (missile aux performances améliorées) ou l'environnement d'entreprise de l'IP Contact Center (IPCC).

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Missile aux performances améliorées de Cisco

  • Microsoft SQL Server

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version 4.5.x et ultérieures missile aux performances améliorées de Cisco

  • Microsoft SQL Server 6.5 et 7.0

  • Server 2000 de Microsoft SQL

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Seulement le fichier central contient la table de Config_Message_Log. La table de Config_Message_Log enregistre des messages de configuration. La table contient ces cinq champs :

  1. RecoveryKey : Le logiciel ICM emploie la valeur de champ de RecoveryKey intérieurement pour dépister le temps virtuel.

  2. LogOperation : Le champ de LogOperation indique le type de modification de configuration. Par exemple, « ajoutez » ou « mettez à jour ».

  3. TableName : Le champ de TableName indique le nom de la table que la modification de configuration affecte.

  4. Date-heure : Le champ date-heure affiche la date et le moment où l'enregistreur se connecte un ensemble de messages.

  5. ConfigMessage : Le champ de ConfigMessage contient tous les messages de configuration dans une transaction.

Problème

Le lgr ou le processus d'enregistreur sur l'enregistreur affirme constamment. En d'autres termes, le processus d'enregistreur commence, échoue, et redémarre à plusieurs reprises.

Le log correspondant contient ce message d'erreur :

la-lgr Fail: Assertion failed: syncMsg.UpdateKey == g.checksumInfo.updateKey.
  File: y:\icm\logger\logger\rtinput.cpp.  Line 691

Afin de visualiser le lgr ou le processus d'enregistreur sur l'enregistreur, vous pouvez visualiser la fenêtre de processus appropriée. Alternativement, employez l'utilitaire Dumplog pour visualiser le log de processus respectif.

Cause

Une table vide de Config_Message_Log est la cause principale de la question. Afin de vérifier si la table de Config_Message_Log est vide, émettez cette commande SQL :

select * from Config_Message_Log

La table de Config_Message_Log ne contient probablement aucune ligne parce que vous sélectionnez la case tronquée de journal des messages de config quand vous dirigez l'administration de base de données d'Intelligent Contact Management (ICMDBA) pour exporter des données de configuration.

Solution

Afin de résoudre ce problème, vous pouvez émettre cette commande SQL :

insert into Config_Message_Log values (0, 'LogBegin', 'Config_Message_Log',
 getdate(),0x0000)

Cette commande SQL Ajoute une ligne à la table de Config_Message_Log.


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