Collaboration : Cisco ICM Logger

Message d'erreur dans le processus de l'enregistreur ICM : « Local Time has Stopped »

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document discute le message d'erreur « heure locale a arrêté », qui apparaît dans la fenêtre de processus de lgr d'enregistreur de l'Intelligent Contact Management (missile aux performances améliorées) dans un environnement missile aux performances améliorées Enterprise Edition de Cisco. Ce document fournit également un contournement possible.

Remarque: Référez-vous au pour en savoir plus de l'ID de bogue Cisco CSCsa91378 (clients enregistrés seulement).

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Contrôleur central d'ICM de Cisco

  • Windows 2000

  • Microsoft SQL Server

  • Microsoft Windows Registry Editor

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version 4.6.2 et ultérieures missile aux performances améliorées Enterprise Edition de Cisco

  • Version 2000, 7.0 et 6.5 de Microsoft SQL Server

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Problème

Quand Cisco ICM Logger est en fonction, le processus de lgr sur l'enregistreur rebondit à plusieurs reprises, et affiche ce message d'erreur :

la-lgr Trace: Local Time Has Stopped for 10000 Milliseconds

Vous pouvez visualiser ce message d'erreur dans la fenêtre de processus de lgr sur l'enregistreur. Alternativement, vous pouvez employer l'utilitaire Dumplog pour visualiser ce message dans le fichier journal de lgr.

Ce message d'erreur indique que le processus de lgr n'a accompli rien en 10,000 millisecondes.

Cause

La « heure locale a arrêté » le message est provoqué par quand le Serveur SQL ne répond pas au processus de lgr pendant 10 secondes.

Quand SQL Sever n'a pas répondu pendant plus de 50 secondes, cinq tels messages se produisent dans une ligne. Quand ceci se produit, le gestionnaire de noeud sur l'enregistreur redémarre le processus de lgr ou redémarre l'enregistreur (stopshut) afin d'essayer d'effacer l'erreur. Ici, la clé de registre de MessageTimeout contrôle la reprise du gestionnaire de noeud, parce que la valeur de registre est placée à 50 secondes par défaut.

Il est recommandé que vous déterminez quelles causes le Serveur SQL à dégrader dans la représentation, et pour le corriger. Voici les la plupart des causes classiques pour la représentation dégradée SQL :

  • Passages d'une sauvegarde de base de données en même temps que les processus d'enregistreur.

  • Des contrôles d'intégrité de la base de données (comme, CHECKDB) sont traités fréquemment.

Si la représentation dégradée SQL n'est pas provoquée par non plus de ces facteurs, mettez au point la question avec la requête sp_who2. Vous devez exécuter la requête sp_who2 quand la « heure locale a arrêté » le message se produit. Vous pouvez alors analyser la sortie de la requête pour déterminer la cause. La cause de la dégradation de serveur SQL peut également être à Windows ou au niveau du système. Dans ce cas, analysez la représentation de Windows à l'aide du moniteur de performances de Windows pour déterminer la cause principale.

Solution

Afin de résoudre ce problème, vous pouvez augmenter la valeur de clé de registre de MessageTimeout, pour prolonger la durée entre les reprises initiées par le gestionnaire de noeud.

Procédez comme suit :

  1. Cliquez sur Start > Run.

  2. Tapez le regedit dans la boîte de dialogue de passage, et l'appuyez sur ENTRENT.

    La fenêtre de Registry Editor est affichée.

  3. Parcourez à cette clé de registre :

    • Pour des versions plus tôt que 5.0 :

      HKEY_LOCAL_MACHINE\Software\GeoTel\ICR\<cust_inst>\
      LoggerA\Logger\CurrentVersion\Configuration\Time\MessageTimeout
    • Pour des versions 5.0 et ultérieures :

      HKEY_LOCAL_MACHINE\Software\Cisco Systems Inc.\ICM\<cust_inst>\
      LoggerA\Logger\CurrentVersion\Configuration\Time\MessageTimeout

      Remarque: La clé de registre est affichée au-dessus des plusieurs lignes ici dues aux limites de l'espace.

  4. Augmentez la valeur de la clé de MessageTimeout de 50 à 120. Ceci augmente le délai d'inactivité de 50 secondes (5 occurrences de la « heure locale a arrêté » le message) à 2 minutes (12 occurrences du message).

    Remarque: Ceci fonctionnera seulement si le Serveur SQL répond au processus de lgr avant que le délai d'inactivité prolongé expire.


Informations connexes


Document ID: 64455