Interfaces et modules Cisco : Plate-forme d'approvisionnement multiservices (MSPP) Cisco ONS 15454 SONET

Installation de plusieurs plug-ins Java pour accéder à CTC

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit la procédure pour installer de plusieurs releases de périphérique prêt à brancher de Javas afin d'accéder à Cisco transportent le contrôleur (CTC).

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Cisco transportent le contrôleur

  • Cisco ONS 15454/15327

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Cisco transportent le contrôleur

  • Cisco ONS 15454/15327

  • Internet Explorer, Netscape et Mozilla (afin d'utiliser trois versions différentes de Java Runtime Environment (JRE) sur le même PC)

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Cette section fournit l'information générale exigée pour vous aider à comprendre le contenu du document mieux.

Plusieurs releases de périphérique prêt à brancher de Javas

Quand vous installez de plusieurs releases de périphérique prêt à brancher de Javas, vous pouvez éliminer la nécessité de retirer et réinstaller une release différente de périphérique prêt à brancher de Javas afin d'accéder aux plusieurs versions logicielles opérationnelles de Cisco ONS15454/15327 avec succès. Après l'implémentation, vous lancez simplement le navigateur approprié basé sur la version de logiciel de système d'exploitation du noeud que vous voulez accéder à.

Les informations de navigateur

Le navigateur sur lequel vous lancez le CTC dépend du runtime environment de Javas 2, la version du Standard Edition (J2SE) JRE qui les supports d'ONS 15454 ou 15327. Le tableau 1 répertorie le navigateur approprié pour chaque version.

Tableau 1 ? Navigateur pour chaque version de J2SE JRE

Version prise en charge par ONS 15454 ou 15327 Navigateur à utiliser pour lancer le CTC
Version 1.2.2 J2SE JRE Microsoft Internet Explorer
Version 1.3.2 J2SE JRE Netscape
Version 1.4.2 J2SE JRE Mozilla

Installation de Mozilla

Vous devez installer Mozilla, même si vous avez déjà installé le Netscape et Internet Explorer. Quand vous install all les trois navigateurs, vous pouvez utiliser trois versions différentes JRE sur le même PC.

Afin d'installer Mozilla, la première étape est de télécharger la version 1.7.1 de Mozilla de www.mozilla.orgleavingcisco.com . Le nom du fichier est mozilla-win32-1.7.1-installer. Procédez comme suit :

  1. Exécutez mozilla-win32-1.7.1-installer. Le Mozilla a installé - La fenêtre bienvenue apparaît (voir le schéma 1).

    Figure 1 ? Mozilla a installé : Fenêtre bienvenue

    moza_ctc_64021_f1.gif

  2. Cliquez sur Next (Suivant). La fenêtre de Contrat de licence logicielle apparaît (voir le schéma 2).

    Figure 2 ? Fenêtre de Contrat de licence logicielle

    /image/gif/paws/64021/moza_ctc_64021_f2.gif

  3. Lisez le permis, et le clic reçoivent. La fenêtre de type d'installation apparaît (voir le schéma 3).

    Figure 3 ? Fenêtre de type d'installation

    moza_ctc_64021_f3.gif

  4. Sélectionnez la case d'option complète. Cliquez sur Next (Suivant). La fenêtre de lancement rapide apparaît (voir le schéma 4).

    Figure 4 ? Fenêtre rapide de déjeuner

    moza_ctc_64021_f4.gif

  5. Cliquez sur Next (Suivant). Le début installent la fenêtre apparaît (voir le schéma 5).

    Figure 5 ? Le début installent la fenêtre

    moza_ctc_64021_f5.gif

  6. Le clic installent afin de mettre sur pied l'installation.

    Après que l'installation soit complète, une demande pour placer Mozilla en tant que navigateur par défaut apparaît (voir le schéma 6).

    Figure 6 ? Message de fin d'installation de Mozilla

    /image/gif/paws/64021/moza_ctc_64021_f6.gif

  7. Clic non.

Installation de périphérique prêt à brancher de Javas

Téléchargez ces releases pour le runtime environment de Javas 2, le Standard Edition (J2SE) du site Web du Sun Microsystemsleavingcisco.com .

  1. La version 1.2.2 (utilisation jre-1_2_2_017-windows-i586.exe ou version ultérieure) J2SE JRE.

  2. La version 1.3.1 (utilisation j2re-1_3_1_14-windows-i586.exe ou version ultérieure) J2SE JRE.

  3. La version 1.4.2 (utilisation j2re-1_4_2_06-windows-i586-p.exe ou version ultérieure) J2SE JRE.

Remarque: Si vous faites déjà installer Javas, Cisco les recommande que vous désinstalliez toutes les versions JRE, et installe de nouveau dans le bon ordre (voir l'ordre d'installation JRE), après que vous installiez Mozilla.

Remarque: Terminez-vous ces étapes afin de désinstaller toutes les versions existantes de JRE :

  1. Choisissez le Start > Settings > Control Panel > Add/Remove Programs.

  2. Sélectionnez la version JRE que vous voulez désinstaller, et le clic retirent.

  3. Ouvrez l'Explorateur Windows.

  4. Du répertoire de fichiers de programme, supprimez tous les répertoires de Javas et de Javasoft.

Ordre d'installation JRE

Voici l'ordre d'installation :

  1. Installez la version 1.4.2 J2SE JRE.

  2. Installez la version 1.3.1 J2SE JRE. Choisissez Netscape en tant que navigateur par défaut quand la demande apparaît. Employez le dossier par défaut pour installer le JRE. Ne changez pas le répertoire.

  3. Installez la version 1.2.2 J2SE JRE. Employez le dossier par défaut pour installer le JRE. Ne changez pas le répertoire.

Après l'installation, créez un nouveau fichier de stratégie Java. Vous pouvez télécharger le JRE 1.3.1_02, stratégie de Javas stratégie installez et de lanceur de la page de téléchargement du logiciel de Cisco (clients enregistrés seulement).

Remplacez le fichier de stratégie Java d'origine avec le nouveau fichier de stratégie Java pour les trois releases J2SE JRE. Voici le chemin au fichier de stratégie Java pour différentes releases :

C:\Program Files\<JavaSoft or Java>\JRE\<JRE release>\lib\security\java.policy

Compatibilité JRE avec ONS 15454 et 15327

Le tableau 2 fournit des informations sur la compatibilité parmi ONS 15454/15327 version logicielle, JRE et le navigateur.

Tableau 2 ? Compatibilité parmi ONS 15454/15327, JRE et le navigateur

Versions logicielles d'ONS Internet Explorer (JRE 1.2.2.x) Netscape (JRE 1.3.1.x) Mozilla (JRE 1.4.2.x)
2.2.0 Oui Non Non
2.2.1 Oui Non Non
2.2.2 Oui Non Non
2.3.4 Oui Non Non
3.2.1 Oui Non Non
3.3.0 Oui Non Non
3.4.0 Non Oui Non
3.4.1 Non Oui Non
4.0.1 Non Oui Non
4.0,2 Non Oui Non
4.1.0 Non Oui Non
4.1.3 Non Oui Non
4.1.4 Non Oui Non
4.6.2 Non Oui Non
4.7 Non Non Oui
5.0 Non Non Oui

Remarque: Si vous utilisez ONS 15454/15327 logiciel de 3.2.1 ou 3.3.0 releases, si le CTC ne lance pas, cliquez sur Delete le cache CTC. Puis lancement CTC de nouveau.

Terminez-vous ces étapes afin de déterminer la version logicielle en cours sur ONS 15454/15327 :

  1. Ouvrez une fenêtre du navigateur.

  2. Dans la barre d'adresse, tapez l'IP address du noeud suivi de /getSwVersion comme affiché par la flèche A dans la figure 7.

    La connexion réseau au noeud doit exister pour l'exécution de la commande réussie.

    Figure 7 ? Déterminez la version logicielle ONS 15454/15327

    /image/gif/paws/64021/moza_ctc_64021_f7.gif

Configuration J2SE JRE

Cette section répertorie les étapes que vous devez se terminer afin de spécifier des paramètres appropriés pour la version J2SE JRE que vous utilisez.

Version 1.2.2 J2SE JRE

Terminez-vous ces étapes afin de spécifier les configurations pour la version 1.2.2 J2SE JRE :

  1. Choisissez le début > tous les programmes > panneau de configuration de module d'extension de Javas.

  2. À Javas (TM) les propriété du plug-in examinent, cochent la case de périphérique prêt à brancher de Javas d'enable, et les POTS de cache dans la case de mémoire dans l'onglet de base (voir le schéma 8).

    Figure 8 ? Version 1.2.2 J2SE JRE : Paramètres de base

    /image/gif/paws/64021/moza_ctc_64021_f8.gif

  3. Allez à l'onglet Avancé.

  4. Sélectionnez l'option par défaut de périphérique prêt à brancher de Javas d'utilisation, et cochez la case juste à temps de compilateur d'enable (voir le schéma 9).

    Figure 9 ? Version 1.2.2 J2SE JRE : Paramètres avancés

    /image/gif/paws/64021/moza_ctc_64021_f9.gif

  5. Allez aux proxys l'onglet.

  6. Cochez la case de configurations du navigateur d'utilisation (voir le schéma 10).

    Figure 10 ? Version 1.2.2 J2SE JRE : Paramètres de proxy

    /image/gif/paws/64021/moza_ctc_64021_f10.gif

  7. Cliquez sur Apply.

Version 1.3.1 J2SE JRE

Terminez-vous ces étapes afin de spécifier les configurations pour la version 1.3.1 J2SE JRE :

  1. Choisissez le début > le module d'extension 1.3.1_X de panneau de configuration > de Javas.

  2. Dans la fenêtre de panneau de contrôle plug-in de Java(TM), cochez la case de connexion de Javas d'enable, et la case de Classloader de réutilisation dans l'onglet de base (voir la figure 11).

    Figure 11 ? Version 1.3.1 J2SE JRE : Paramètres de base

    /image/gif/paws/64021/moza_ctc_64021_f11.gif

  3. Allez à l'onglet Avancé.

  4. Sélectionnez l'option par défaut de connexion de Javas d'utilisation, et cochez l'enable juste dans la case de compilateur de temps (voir la figure 12).

    Figure 12 ? Version 1.3.1 J2SE JRE : Paramètres avancés

    /image/gif/paws/64021/moza_ctc_64021_f12.gif

  5. Allez à l'onglet de navigateur.

  6. Cochez la case de Netscape 6 (voir la figure 13).

    Figure 13 ? Version 1.3.1 J2SE JRE : Configuration du navigateur

    /image/gif/paws/64021/moza_ctc_64021_f13.gif

  7. Allez aux proxys l'onglet.

  8. Cochez la case de configurations du navigateur d'utilisation (voir la figure 14).

    Figure 14 ? Version 1.3.1 J2SE JRE : Paramètres de proxy

    /image/gif/paws/64021/moza_ctc_64021_f14.gif

  9. Cliquez sur Apply.

Version 1.4.2 J2SE JRE

Terminez-vous ces étapes afin de spécifier les configurations pour la version 1.4.2 J2SE JRE :

  1. Choisissez le début > le module d'extension de panneau de configuration > de Javas.

  2. Sélectionnez l'option de console de peau dans la section de console Java, et cochez Javas d'exposition dans la case de barre d'état système dans l'onglet de base (voir la figure 15).

    Figure 15 ? Version 1.4.2 J2SE JRE : Paramètres de base

    /image/gif/paws/64021/moza_ctc_64021_f15.gif

  3. Allez à l'onglet Avancé.

  4. Sélectionnez l'option par défaut de connexion de Javas d'utilisation (voir la figure 16).

    Figure 16 ? Version 1.4.2 J2SE JRE : Paramètres avancés

    /image/gif/paws/64021/moza_ctc_64021_f16.gif

  5. Allez à l'onglet de navigateur.

  6. Contrôle seulement le Mozilla 1.1 ou case postérieure (voir la figure 17).

    Figure 17 ? Version 1.4.2 J2SE JRE : Configurations du navigateur

    /image/gif/paws/64021/moza_ctc_64021_f17.gif

  7. Allez aux proxys l'onglet.

  8. Cochez la case de configurations du navigateur d'utilisation (voir la figure 18).

    Figure 18 ? Version 1.4.2 J2SE JRE : Paramètres de proxy

    /image/gif/paws/64021/moza_ctc_64021_f18.gif

  9. Allez à l'onglet de cache.

  10. Cochez la case de mise en cache d'enable (voir la figure 19).

    Figure 19 ? Version 1.4.2 J2SE JRE : Mise en cache d'enable

    /image/gif/paws/64021/moza_ctc_64021_f19.gif

Vérification

Terminez-vous ces étapes afin de vérifier l'installation :

  1. Ouvrez le navigateur compétent. Pour les informations sur le navigateur à l'utiliser, voir le tableau 1.

  2. Lancez le planificateur de métro pour vérifier si l'application exécute avec succès.

    Remarque: Si vous utilisez la version 2.5 de planificateur de métro, vous devez localiser et créer un fichier .bat de sorte que le planificateur de métro travaille.

    Remarque: Quand vous accédez à ONS 15454/15327 cela exécute la release 4.x.x, une fenêtre peut sembler indiquer qu'un fichier de stratégie plus ancien existe. La fenêtre vous incite à remplacer le fichier de stratégie. Cochez n'affichent pas cette case de message de nouveau, et cliquent sur NON. Si vous cliquez sur l'OUI, le fichier de stratégie Java d'origine est placé comme fichier par défaut, et vous pouvez plus n'accéder à la release 2.x.x.


Informations connexes


Document ID: 64021