Voix : Protocoles de passerelle

Configurer les liaisons PRI Q.SIG entre Call Manager et Avaya S8700/G650 avec intégration de la messagerie vocale Unity

30 juillet 2013 - Traduction automatique
Autres versions: PDFpdf | Anglais (20 août 2006) | Commentaires


Contenu


Introduction

L'objectif de ce document est de présenter aux clients et aux partenaires commerciaux de Cisco les étapes pour configurer les liaisons Q.SIG PRI entre Cisco Call manager et les systèmes Avaya S8700/G650. En outre, ce document détaille les étapes relatives à l'ajout de Cisco Unity sur la plate-forme Cisco Call manager afin d'offrir une prise en charge de la messagerie vocale pour les téléphones IP Cisco et Avaya. C'est particulièrement important dans les situations où l'interopérabilité IP-PBX et l'intégration de la messagerie vocale sont requises. Les captures d'écran des configurations d'Avaya ont été créées avec l'outil d'émulation standard. Vous pouvez également utiliser comme solution de remplacement l'outil de gestion de site d'Avaya (Avaya Site Administration, ASA) pour les tâches de configuration du système Avaya S8700/G650. L'affichage qui en résulte est identique dans les deux cas. Ce document relatif à l'interopérabilité entre IP et PBX et à l'intégration de la messagerie vocale est destiné pour l'usage externe.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Le système d'Avaya IP-PBX utilisé est l'Avaya S8700/G650 exécutant la Communication Manager 2,0 d'Avaya. L'ensemble de caractéristiques Q.SIG est livré la norme avec cette version de logiciel.

  • Les Téléphones IP d'Avaya utilisés dans ce document sont la version 2.01 courante 4610SW et de 4620 micrologiciels de téléphone.

  • Le Cisco Call manager 4.1.(2) a été utilisé afin de contrôler la passerelle du Protocole MGCP (Media Gateway Control Protocol) 3745 avec le module NM-HDV, version 12.2.15ZJ3 courante de Cisco IOS®. Des tests ont été également répétés avec la version 12.3.8.T5 de Cisco IOS®.

  • La version 4.0(4) courante SR1 de Cisco Unity a été utilisée pour le test d'intégration de messagerie vocale.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Installation de test

Le système d'Avaya IP-PBX utilisé était l'Avaya S8700/G650 exécutant la Communication Manager 2,0 d'Avaya. L'ensemble de caractéristiques Q.SIG est livré la norme avec cette version de logiciel. Les téléphones d'AvayaIP utilisés étaient la version 2.01 courante 4610SW et de 4620 micrologiciels de téléphone. Du côté de Cisco, le Cisco Call manager 4.1.2 a été utilisé pour contrôler la passerelle MGCP 3745 avec le module NM-HDV, version 12.2.15ZJ3 courante de Cisco IOS®. Des tests ont été également répétés avec la version 12.3.8.T5 de Cisco IOS®. La version 4.0(4) courante SR1 de Cisco Unity a été utilisée pour le test d'intégration de messagerie vocale.

Topologie de test

/image/gif/paws/63790/top.gif

Interopérabilité entre Cisco et les systèmes d'Avaya IP-PBX

Les sections suivantes fournissent des procédures et des récupérations d'écran pour vous aider à configurer le joncteur réseau Q.SIG entre un Avaya S8700/G650 exécutant la Communication Manager 2,0 d'Avaya et une version 4.1(2) courante de gestionnaire d'appel de plate-forme de Cisco Call manager avec le périphérique de Cisco 3745 MGCP qui fournit la connexion physique de PRI RNIS à l'Avaya S8700/G650.

Procédure sur le système d'Avaya S8700/G650 IP-PBX

Procédez comme suit :

  1. Procédure de connexion au serveur S8700. Exécutez l'ordre de client de système-paramètres d'affichage afin de s'assurer que toutes les caractéristiques nécessaires Q.SIG sont activées sur le serveur S8700.

    /image/gif/paws/63790/proced1.gif

  2. Configurez la carte DS1 pour le PRI Q.SIG.

    2.gif

  3. Configurez un groupe de joncteur réseau. Le type ajoutent le groupe de faisceaux # où # est le joncteur réseau désiré.

    Les trois prochaines captures d'écran rapportent à la configuration de joncteur réseau. Une fois que le groupe de joncteur réseau est créé, ajoutez les 23 canaux DS0 au groupe. C'est un exemple de l'affectation de port : 01A0901 signifie : Gateway# 1, Module A, Slot# 9, DS0 channel# group1.

    /image/gif/paws/63790/3.gif

    4.gif

    5.gif

  4. Ajoutez le groupe et le point de signalisation au groupe de joncteur réseau créé plus tôt.

    /image/gif/paws/63790/6.gif

  5. Ajoutez le modèle d'artère et indiquez-le le groupe de signalisation. Dans cet exemple, le modèle 4 d'artère indique signaler le group# 1 qui a été créé dans l'étape 4.

    /image/gif/paws/63790/7.gif

  6. Ajoutez une entrée dans la table d'AAR afin d'utiliser le modèle d'artère que vous avez créé pour conduire des appels. Dans cet exemple, les appels à l'extension 4XXX de téléphone IP de Cisco utilisent l'entrée de table d'AAR commençant par 4, qui se dirige consécutivement pour conduire le modèle # 4.

    /image/gif/paws/63790/8.gif

  7. Assurez que l'Identification de l'appelant est activée sur chaque téléphone IP envoyer le nom d'appelant.

    /image/gif/paws/63790/9.gif

Procédure sur le Cisco Call manager

Procédez comme suit :

  1. Sous des paramètres de service, assurez-vous que des valeurs temporelles minimum et maximum du remplacement de chemin de début sont placées convenablement afin d'empêcher toutes les questions (telles que des cheveux goupillant).

    Les deux prochaines captures d'écran rapportent aux configurations de paramètres de service Q.SIG :

    /image/gif/paws/63790/10.gif

    11.gif

  2. Ajoutez Cisco 3745 comme passerelle MGCP et configurez le module T-1 NM-HDV pour le PRI Q.SIG.

    Les cinq prochaines captures d'écran rapportent à cette configuration :

    /image/gif/paws/63790/2.gif

    13.gif

    15.gif

    16.gif

    17.gif

  3. Comme dernière étape, créez un groupe d'intrcpt de Cisco Call manager afin de fournir une extension de proposition de chemin au PBX. Assurez-vous que le nombre d'intrcpt d'appel est également introduit dans le paramètre de service d'ID de remplacement du chemin PINX (voyez au step# 1). En outre, le système d'Avaya a besoin d'un modèle d'artère afin de conduire au groupe d'intrcpt.

    /image/gif/paws/63790/8.gif

    Remarque: Assurez-vous que ces deux paramètres de clusterwide (périphérique - PRI et passerelle MGCP) sous des paramètres de service de Cisco CallManager (avancés) apparient la configuration Q.SIG dans le PBX. Tous les joncteurs réseau PBX doivent être configurés exactement en tant que ces paramètres de Cisco CallManager.

    • Codage ASN.1 ROSE OID : Ce paramètre spécifie comment encoder l'object id d'invocation (OID) pour l'élément de service d'exécutions distantes (ROSE). Gardez cet ensemble de paramètres à la valeur par défaut à moins qu'un ingénieur d'assistance technique de Cisco instruise autrement. C'est un champ requis et le par défaut est valeur de gens du pays d'utilisation.

      Ce sont les valeurs valides pour ce paramètre :

      • Utilisez la valeur locale, qui est prise en charge par la plupart des systèmes de téléphonie et doit être utilisée quand le paramètre de service variable Q.SIG est placé à OIN (profil 0x9F de Protocol).

      • Utilisez la valeur globale (OIN), qui est utilisée seulement si le PBX connecté ne prend en charge pas la valeur de gens du pays d'utilisation.

      • Utilisez la valeur globale (ECMA), qui doit être utilisée si le paramètre de service variable Q.SIG est placé à ECMA (profil 0x91 de Protocol).

    • Variante Q.SIG : Ce paramètre spécifie le profil de protocole introduit les éléments d'information sortants d'installation Q.SIG quand le joncteur réseau est configuré pour Q.SIG. Gardez cet ensemble de paramètres à la valeur par défaut à moins qu'un ingénieur d'assistance technique de Cisco instruise autrement. C'est un champ requis, et le par défaut est OIN (profil 0x9F de Protocol).

      Ce sont les valeurs disponibles pour ce paramètre :

      • ECMA (profil 0x91 de Protocol), qui est typiquement utilisé avec ECMA PBX et peut seulement utiliser le profil 0x91 de Protocol. Si ce paramètre de service est placé à ECMA (profil 0x91 de Protocol), le paramètre de service de codage ASN.1 Rose OID doit être placé pour utiliser la valeur globale (ECMA).

      • OIN (profil 0x9F de Protocol), qui est la recommandation OIN de courant. Si ce paramètre est placé à OIN (profil 0x9F de Protocol), alors le paramètre de service de codage ASN.1 Rose OID doit être placé pour utiliser la valeur locale.

        Avertissement : Le Cisco CallManager ne prend en charge pas ECMA en utilisant des joncteurs réseau d'intercluster avec le champ percé un tunnel de Protocol a placé à Q.SIG dans la fenêtre de configuration de joncteur réseau au CallManager Administration. Si vous placiez ce paramètre de service à ECMA (profil 0x91 de Protocol), tous les joncteurs réseau d'intercluster doivent avoir le champ percé un tunnel de Protocol réglé à aucun.

        qsig.gif

Configuration de Cisco 3745

C'est la sortie de commande de show version et de show running-configuration sur le périphérique de Cisco 3745 MGCP. Le controller t1 1/0 sur Cisco 3745 est connecté à la carte PRI DS1 d'Avaya S8700/G650. La signalisation Q.SIG est configurée sur le lien PRI entre Cisco 3745 et l'Avaya S8700/G650.

CCME_CUE_3745# sh vers
Cisco Internetwork Operating System Software 
IOS (tm) 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)
TAC Support: http://www.cisco.com/tac
Copyright (c) 1986-2003 by cisco Systems, Inc.
Compiled Thu 25-Sep-03 22:25 by eaarmas
Image text-base: 0x60008954, data-base: 0x61C2C000

ROM: System Bootstrap, Version 12.2(8r)T2, RELEASE SOFTWARE (fc1)
ROM: 3700 Software (C3745-IS-M), Version 12.2(15)ZJ3, EARLY DEPLOYMENT RELEASE SOFTWARE (fc2)

CCME_CUE_3745 uptime is 39 minutes
System returned to ROM by reload
System image file is "flash:c3745-is-mz.122-15.ZJ3.bin"

cisco 3745 (R7000) processor (revision 2.0) with 246784K/15360K bytes of memory.
Processor board ID JMX0814L3E2
R7000 CPU at 350Mhz, Implementation 39, Rev 3.3, 256KB L2, 2048KB L3 Cache
Bridging software.
X.25 software, Version 3.0.0.
SuperLAT software (copyright 1990 by Meridian Technology Corp).
Primary Rate ISDN software, Version 1.1.
2 FastEthernet/IEEE 802.3 interface(s)
25 Serial network interface(s)
1 terminal line(s)
2 Channelized T1/PRI port(s)
1 ATM AIM(s)
2 Voice FXS interface(s)
2 Voice E & M interface(s)
1 cisco service engine(s)
DRAM configuration is 64 bits wide with parity disabled.
151K bytes of non-volatile configuration memory.
125184K bytes of ATA System CompactFlash (Read/Write)
Configuration register is 0x2102

CCME_CUE_3745# sh run
Building configuration...

Current configuration : 3291 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname CCME_CUE_3745
!
logging queue-limit 100
!
voice-card 1
 dspfarm
!
voice-card 5
 dspfarm
!
ip subnet-zero
!
!
no ip domain lookup
!
isdn switch-type primary-qsig
!
no voice hpi capture buffer
no voice hpi capture destination 
!
!
ccm-manager mgcp
ccm-manager music-on-hold
ccm-manager config server 172.28.221.18  
ccm-manager config
mta receive maximum-recipients 0
!
!
controller T1 1/0
 framing esf
 linecode b8zs
 pri-group timeslots 1-24 service mgcp
!
controller T1 1/1
 framing sf
 linecode ami
!
!
!
interface FastEthernet0/0
 description CCME-CUE-3745_to_cat3550
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 99
!
interface FastEthernet0/0.2
 description NEW_S8700_G650
 encapsulation dot1Q 300
 ip address 172.28.221.49 255.255.255.240
 ip helper-address 172.28.221.19
 h323-gateway voip bind srcaddr 172.28.221.49
!
interface FastEthernet0/0.3
 description MODULAR_MESSAGING_SOLUTION
 encapsulation dot1Q 900
 ip address 172.28.221.129 255.255.255.240
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.4
 encapsulation dot1Q 301
 ip address 10.1.3.1 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.5
 encapsulation dot1Q 302
 ip address 10.1.3.129 255.255.255.128
 ip helper-address 172.28.221.19
!
interface FastEthernet0/0.6
 encapsulation dot1Q 90
 ip address 90.1.1.254 255.255.255.0
 ip helper-address 172.28.221.19
!
interface Serial0/0
 description CCME-CUE-3745_to_3600
 ip address 25.0.0.1 255.0.0.0
 clockrate 256000
 no fair-queue
!
interface Serial1/0:23
 no ip address
 no logging event link-status
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 isdn bind-l3 ccm-manager
 isdn bchan-number-order ascending
 no cdp enable
!
interface Service-Engine2/0
 no ip address
 shutdown
!
router eigrp 100
 network 10.0.0.0
 network 25.0.0.0
 network 90.0.0.0
 network 172.28.0.0
 auto-summary
!
ip http server
ip classless
!
call rsvp-sync
!
voice-port 1/0:23
!
voice-port 4/0/0
!
voice-port 4/0/1
!
voice-port 4/1/0
!
voice-port 4/1/1
!
mgcp
mgcp call-agent 172.28.221.18 2427 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode out-of-band
mgcp rtp unreachable timeout 1000 action notify
mgcp package-capability rtp-package
no mgcp package-capability res-package
mgcp package-capability sst-package
no mgcp timer receive-rtcp
mgcp sdp simple
mgcp fax t38 inhibit
mgcp rtp payload-type g726r16 static
!
mgcp profile default
!
!
!
dial-peer cor custom
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0:23
!
dial-peer voice 999410 pots
 application mgcpapp
 port 4/1/0
!
!
line con 0
 password cisco
 login
line 65
 flush-at-activation
 no activation-character
 no exec
 transport preferred none
 transport input all
line aux 0
line vty 0 4
 password cisco
 login
!
end

Caractéristiques testées pour l'Interopérabilité entre Cisco et les systèmes d'Avaya IP-PBX

Cette section fournit une liste de fonctionnalités testée entre la plate-forme et la Communication Manager courante 2,0 du Cisco Call manager 4.1(2) d'Avaya S8700/G650 par le joncteur réseau PRI Q.SIG :

  • Affichage de nom et de nombre (bidirectionnel)

  • Transfert d'appel

  • Conférence téléphonique entre les deux systèmes

Intégration de la messagerie de vocal Cisco Unity pour prendre en charge Cisco et des Téléphones IP d'Avaya

En ce moment, on peut employer le joncteur réseau Q.SIG afin de faire des appels entre un Avaya S8700/G650 exécutant la Communication Manager 2,0 d'Avaya et une version 4.1(2) courante de gestionnaire d'appel de plate-forme de Cisco Call manager avec le périphérique de Cisco 3745 MGCP fournissant la connexion physique de PRI RNIS à l'Avaya S8700/G650. Un serveur de Cisco Unity peut être ajouté sur la plate-forme de Cisco Call manager afin de fournir le support de messagerie vocale à Cisco et aux Téléphones IP d'Avaya. Afin d'activer ceci, l'administrateur doit configurer le Cisco Unity sur la plate-forme de Cisco Call manager. Cette section inclut les procédures avec des captures d'écran pour que la façon configure le Cisco Unity à la page de Gestion de gestion de Cisco Call manager.

Remarque:  La majeure partie de la configuration est exécutée sur l'assistant de port de messagerie vocale de Cisco.

Ajoutez le Cisco Unity au Cisco Call manager

Procédez comme suit :

  1. Sous la caractéristique, assistant choisi de messagerie vocale > de port de messagerie vocale. Choisi créez un nouveau serveur de messagerie de Voix et ajoutez les ports à lui et cliquez sur Next.

    19.gif

  2. Écrivez un nom de serveur de messagerie de Voix de Cisco, tel qu'AvayaUM3, et cliquez sur Next.

    /image/gif/paws/63790/20.gif

  3. Sélectionnez le nombre de messagerie vocale met en communication désiré et clique sur Next.

    /image/gif/paws/63790/21.gif

  4. Présentez un Pool d'appareils de description et pour les ports de messagerie vocale. Dans la configuration d'échantillon, Avaya VMailPorts a été entré comme description et par défaut en tant que Pool d'appareils.

    /image/gif/paws/63790/4.gif

  5. Écrivez le nombre de répertoire de début, tel que 4406, et l'affichage, tel que la messagerie vocale, et cliquez sur Next.

    /image/gif/paws/63790/2.gif

  6. L'écran suivant demande, « vous voulez ajouter ces nombres de répertoire à une ligne groupe ? » Sélectionnez oui. Ajoutez les nombres de répertoire à un groupe de nouvelle ligne et cliquez sur Next.

    /image/gif/paws/63790/3.gif

  7. Écrivez une ligne nom de groupe qui apparie le serveur de messagerie de Voix que vous avez précédemment présenté, comme AvayaUM3.

    /image/gif/paws/63790/4.gif

  8. L'écran suivant affiche la configuration écrite jusqu'ici. Cliquez sur Finish s'il n'y a aucune modification à la configuration.

    /image/gif/paws/63790/5.gif

  9. Cliquez sur Add un nouveau groupe de recherche sur la page Web de gestion de groupe de recherche.

    /image/gif/paws/63790/6.gif

  10. Écrivez un nom et une description de groupe de recherche, telle qu'Avaya VMailHL. En outre, sélectionnez le par défaut pour le groupe de Cisco Call manager.

    /image/gif/paws/63790/7.gif

  11. Cette capture d'écran est le résultat de l'ajout réussi du groupe de recherche. Cliquez sur Add la ligne groupe.

    28.gif

  12. Sélectionnez la ligne groupe précédemment configuré. Dans ce cas, c'est AvayaUM3.

    /image/gif/paws/63790/9.gif

  13. La capture d'écran suivant donne le résultat de la mise en place réussie de la ligne groupe.

    /image/gif/paws/63790/30.gif

  14. Allez au plan de routage > à l'artère/à recherche > au pilote de recherche. Cliquez sur Add un nouveau pilote de recherche de l'écran de pilote de recherche qui résulte.

    /image/gif/paws/63790/31.gif

  15. Entrez dans le pilote de recherche, tel que 4408, et sélectionnez un groupe de recherche, tel que HL d'Avaya VMail et l'insertion de clic.

    /image/gif/paws/63790/2.gif

  16. Allez à la caractéristique > à la messagerie vocale > au pilote de messagerie vocale et cliquez sur Add un nouveau pilote de messagerie vocale sur l'écran qui résulte.

    /image/gif/paws/63790/3.gif

  17. Introduisez le numéro pilote de messagerie vocale appariant le numéro pilote de recherche précédemment configuré. Dans ce cas, les numéros pilotes de pilote et de messagerie vocale de recherche sont 4408.

    /image/gif/paws/63790/4.gif

  18. Allez à la caractéristique > à la messagerie vocale > au profil de messagerie vocale et cliquez sur Add un nouveau profil de messagerie vocale.

    /image/gif/paws/63790/5.gif

  19. Écrivez le nom de profil et la description de messagerie vocale, telle qu'AvayaVMailProfile, et sélectionnez le numéro pilote de messagerie vocale dans l'étape 17. Dans ce cas, le numéro pilote de messagerie vocale est 4408.

    36.gif

  20. Le clic comporte > indicateur de messagerie vocale > de message en attente > ajoutent un nouveau nombre de message en attente pour ajouter les nombres "Marche/Arrêt" d'indicateur de message en attente (MWI). Incluses ici sont deux captures d'écran pour les nombres "Marche/Arrêt" d'indicateur de message en attente.

    37.gif

    38.gif

Caractéristiques de messagerie de vocal Cisco Unity testées

C'est une liste de caractéristiques de messagerie de vocal Cisco Unity testées avec les Téléphones IP d'Avaya utilisés pour accéder à la messagerie de vocal Cisco Unity par le joncteur réseau PRI Q.SIG entre la plate-forme et la Communication Manager courante 2,0 du Cisco Call manager 4.1(2) d'Avaya S8700/G650 :

  • Message d'accueil interne

  • Message d'accueil de ligne occupée

  • MWI

  • Accès facile de message

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 63790