Logiciels Cisco IOS et NX-OS : Plate-forme d'approvisionnement multiservices (MSPP) Cisco ONS 15454 SONET

Utiliser PAT pour établir une session entre CTC et ONS 15454 lorsque CTC est à l'intérieur du pare-feu

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la translation d'adresses d'adresse du port (PAT) pour établir une session entre le contrôleur de transport de Cisco (CTC) et l'ONS 15454 quand le CTC réside à l'intérieur du Pare-feu.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Ayez la connaissance de base au sujet du Cisco ONS 15454.

  • Connaissez quel support PAT de Routeurs de Cisco.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version 4.6.X et ultérieures du Cisco ONS 15454

  • Version de logiciel 12.1(11) et ultérieures de Cisco IOSÝ

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Topologie

La topologie se compose de ces éléments :

  • Un Cisco ONS 15454

  • Un PC

  • Un routeur de gamme Cisco 2600

ONS 15454 réside dans le réseau externe et agit en tant que serveur. Le PC réside dans le réseau interne, et sert de client CTC. Le routeur de gamme Cisco 2600 fournit le support de TAPOTEMENT.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour obtenir plus d'informations sur les commandes utilisées dans cette section.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

Figure 1 ? Topologie

ctc_ons_pat_01.gif

Configurations

Ce document utilise les configurations suivantes :

  • Cisco ONS 15454

  • PC

  • Routeur de la gamme Cisco 2600

Configuration du Cisco ONS 15454

10.89.238.192 est l'adresse IP d'ONS 15454 (voir la flèche A sur le schéma 2), et 10.89.238.1 représente le routeur par défaut (voir la flèche B sur le schéma 2).

Figure 2 ? Configuration ONS 15454

ctc_ons_pat_02.gif

Terminez-vous ces étapes afin de s'assurer que le CTC communique avec ONS 15454 par PAT :

  1. Cochez le serveur proxy d'enable sur la case de port dans la section de paramètres de passerelle (voir le C de flèche sur le schéma 2).

  2. Sélectionnez l'option réservée au proxy (voir la flèche D sur le schéma 2).

  3. Cliquez sur Apply.

Si vous n'activez pas le serveur proxy, le CTC échoue avec ces messages d'erreur :

  • EID-2199 (voir le schéma 3)

  • Panne pendant l'initialisation de référentiel IOR (voir le schéma 4).

Figure 3 ? Erreur EID-2199

ctc_ons_pat_03.gif

Figure 4 ? Erreur d'initialisation CTC

ctc_ons_pat_04.gif

Configuration de PC

172.16.1.254 est l'adresse IP du PC (voir la flèche A sur le schéma 5), et 172.16.1.1 représente la passerelle par défaut (voir la flèche B sur le schéma 5).

Figure 5 ? Configuration de PC

ctc_ons_pat_05.gif

Configuration du routeur

Cette section fournit la procédure pour configurer le routeur.

Procédez comme suit :

  1. Configurez l'interface interne, où ONS 15454 réside.

    !
    interface Ethernet1/0
     ip address 10.89.238.1 255.255.255.0
     ip nat outside
    !
  2. Configurez l'interface externe, où le client CTC réside.

    interface Ethernet1/1
     ip address 172.16.1.1 255.255.255.0
     ip nat inside
    !
  3. Configurez le support de PAT sur le routeur. La configuration indique que n'importe quel paquet qui arrive sur l'interface interne, que la liste d'accès 1 permet, partage une adresse IP extérieure. L'adresse IP extérieure est 10.89.238.1 dans cette configuration.

    !
    
    !--- Indicates that any packets that arrive on the internal interface, which
    !--- access list 1 permits, share one outside IP address (the address 
    !--- on ethernet1/0).
    
    
    ip nat inside source list 1 int ethernet1/0 overload
    access-list 1 permit 172.16.1.0 0.0.0.255
    !

Vérifiez

Référez-vous à cette section pour vous assurer du bon fonctionnement de votre configuration.

Procédure de vérification

Procédez comme suit :

  1. Exécutez Microsoft Internet Explorer.

  2. Tapez http://10.89.238.192 dans la barre d'adresses de la fenêtre du navigateur, et l'appuyez sur ENTRENT.

    La fenêtre de connexion CTC apparaît.

  3. Tapez le nom d'utilisateur et le mot de passe corrects.

    Le client CTC se connecte avec succès à ONS 15454.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Émettez la commande détaillée par debug ip nat d'activer le suivi détaillé par IP NAT. Vous pouvez visualiser les traductions d'adresses de 172.16.1.254 à 10.89.238.1 (voir la flèche A sur le schéma 6), et de 10.89.238.1 à 172.16.1.254 (voir la flèche B sur le schéma 6).

Figure 6 ? Debug ip nat détaillé

ctc_ons_pat_06.gif

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 63775