Interfaces et modules Cisco : Module de commutation de contenu Cisco

Exemple de configuration de RHI sur le module de commutation de contenu

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour l'injection de santés d'artère (RHI) sur un Module de commutation de contenu Cisco (CSM).

RHI permet au CSM pour annoncer la Disponibilité d'une adresse virtuelle IP (VIP) dans tout le réseau. Les plusieurs périphériques CSM avec des adresses identiques de VIP et les services peuvent exister dans tout le réseau. Un CSM peut ignorer les services d'Équilibrage de charge de serveur (SLB) au-dessus des autres périphériques si les services ne sont plus disponibles sur les autres périphériques. Un CSM peut également fournir les services parce qu'il est logiquement plus près des systèmes client que d'autres périphériques SLB. Le CSM annonce l'adresse de VIP comme route hôte.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur la version 3.x ou 4.x courante CSM.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/60043/rhi_csm.jpg

Configurations

Ce document utilise les configurations suivantes :

  • Catalyst A

  • Catalyst B

Catalyst A
hostname Catalyst A
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.1.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.1.20.1 255.255.255.0
  gateway 10.1.20.2
!
 probe LINUXPING icmp


!--- This probe is to verify that the servers are alive. This could be any 
!--- type of probe.

!
 serverfarm MYLINUX
  nat server
  no nat client
  real 10.1.10.3
   inservice
  real 10.1.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20


!--- The VLAN is important. When the VIP address is not part of the subnet
!--- of any VLAN configured on the CSM, the VLAN is used to tell the CSM on 
!--- which VLAN the traffic is coming in. This allows the CSM to set the 
!--- next-hop correctly when configuring the static route on the MSFC.

  serverfarm MYLINUX
advertise active



!--- The advertise command tells the CSM to create the static route.
!--- If you specify the active option, the static route is created only 
!--- if the vserver is operational.

  inservice
!    
interface Vlan20
 ip address 10.1.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.1.30.97 255.255.254.0
 no ip proxy-arp
!
router ospf 1


!--- In this example, OSPF is used to advertise the VIP through the network.
!--- You can use any IGP however.

 log-adjacency-changes
 redistribute static metric 10 subnets


!--- Since the CSM creates a static route on the MSFC, you simply need to 
!--- redistribute static routes to advertise the VIP.

 network 10.1.0.0 0.0.255.255 area 1
!

La configuration du Catalyst B est identique au Catalyst R. L'adressage IP est légèrement différent parce que le Catalyst B est dans une zone différente du réseau. L'adresse de VIP est identique cependant. La mesure des artères statiques redistribuées a été également changée de sorte que le Catalyst A soit le chemin préférentiel au VIP, et le Catalyst B soit la solution de sauvegarde.

Catalyst B
hostname Catalyst B
!
module ContentSwitchingModule 4 
!
 vlan 10 server
  ip address 10.2.10.97 255.255.254.0
!
 vlan 20 client
  ip address 10.2.20.1 255.255.255.0
  gateway 10.2.20.2
!
 probe LINUXPING icmp
!
 serverfarm MYLINUX
  nat server
  no nat client
  predictor hash address source
  real 10.2.10.3
   inservice
  real 10.2.10.4
   inservice
  probe LINUXPING
!
 vserver RHITEST
  virtual 192.168.1.1 any
  vlan 20
  serverfarm MYLINUX
  advertise active
  inservice
!    
interface Vlan20
 ip address 10.2.20.2 255.255.255.0
 no ip proxy-arp
!
interface Vlan30
 ip address 10.2.30.97 255.255.254.0
 no ip redirects
 no ip proxy-arp
!
router ospf 1
 log-adjacency-changes
 redistribute static metric 20 subnets
 network 10.2.0.0 0.0.255.255 area 2
!

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • charge statique de show ip route — Émettez cette commande de visualiser les artères statiques créées par le CSM pour chaque vserver configuré avec la commande de la publicité. Si vous ne voyez aucune artère, assurez-vous que le vserver est opérationnel et c'il y a un VLAN spécifié sous le vserver.

    SwitchA#show ip route static 
         192.168.1.0/32 is subnetted, 1 subnets
    S       192.168.1.1 [1/0] via 10.1.20.1, Vlan20
    SwitchA#
  • affichez le détail de NOM de nom de vserver modèle csm X

    SwitchB#sho mod csm 4 vservers name rhitest
    
    vserver         type  prot virtual                  vlan state        conns
    ---------------------------------------------------------------------------
    RHITEST         SLB   any  192.168.1.1/32:0         20   OPERATIONAL  0       
    SwitchA#show mod csm 4 probe name linuxping detail
    probe           type    port  interval retries failed  open   receive
    ---------------------------------------------------------------------
    LINUXPING       icmp          120      3       300            10     
     real                  vserver         serverfarm      policy          status
     ------------------------------------------------------------------------------
     10.1.10.4:0        RHITEST         MYLINUX         (default)       OPERABLE
     10.1.10.3:0        RHITEST         MYLINUX         (default)       OPERABLE
  • affichez le détail de NOM de nom de sonde modèle csm X

  • le show ip ospf database auto-commencent — Émettez cette commande de vérifier que l'OSPF annonce l'adresse de VIP.

    SwitchA#sho ip ospf database self-originate 
    
                OSPF Router with ID (10.1.30.97) (Process ID 1)
    
                    Router Link States (Area 1)
    
    Link ID         ADV Router      Age         Seq#       Checksum Link count
    10.1.30.97      10.1.30.97      5           0x80000001 0x00B9BE 2
    
                    Type-5 AS External Link States
    
    Link ID         ADV Router      Age         Seq#       Checksum Tag
    192.168.1.1     10.1.30.97      5           0x80000001 0x00CCC7 0
  • show ip route x.x.x.x

  • show ip ospf database externe x.x.x.x

    lsd#sho ip ospf database external 192.168.1.1
    
                OSPF Router with ID (200.200.200.200) (Process ID 1)
    
    
                    Type-5 AS External Link States
    
      Routing Bit Set on this LSA
      LS age: 39
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.20.97
      LS Seq Number: 80000001
      Checksum: 0x8310
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 20 
            Forward Address: 10.2.20.1
            External Route Tag: 0
    
      Routing Bit Set on this LSA
      LS age: 89
      Options: (No TOS-capability, DC)
      LS Type: AS External Link
      Link State ID: 192.168.1.1 (External Network Number )
      Advertising Router: 10.1.30.97
      LS Seq Number: 80000001
      Checksum: 0xCCC7
      Length: 36
      Network Mask: /32
            Metric Type: 2 (Larger than any link state path)
            TOS: 0 
            Metric: 10 
            Forward Address: 10.1.20.1
            External Route Tag: 0

Dépannez

Il n'y a actuellement aucune information de dépannage spécifique disponible pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 60043