Distribution de vidéo et de contenu : Routeurs haut débit universels de la gamme Cisco uBR7200

Service LAN transparent sur des réseaux de câbles

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Traditionnellement, le système d'arrêt de modem câble Cisco (CMTS) a été utilisé pour fournir des services de données à grande vitesse pour des utilisateurs privés et pour le Réseaux privés virtuels (VPN) basé sur IP de la couche 3.

Il y a, cependant, quelques clients qui ont besoin des connexions de la couche 2 pour exécuter leurs entreprises.

Certaines des raisons de justifier le déploiement d'un réseau privé virtuel de la couche 2 (L2VPN) incluent :

  • Soutien des protocoles non-IPv4

  • Cryptage de bout en bout

  • Plus de contrôle de réseau

  • Utilisation d'une espace adresse d'adresse IP privée

Typiquement, posez 2 services sont fournis par l'opérateur téléphonique (compagnie de téléphone) et utilisent différentes Technologies, telles que les lignes louées, le Relais de trames, le RNIS, l'atmosphère, et d'autres.

Avec l'introduction de la caractéristique transparente de service de RÉSEAU LOCAL de 802.1Q (TLS), l'opérateur de plusieurs services (MSO) peut accroître ses déploiements DOCSIS pour fournir des services de L2VPN et pour améliorer de ce fait ses offres commerciales.

Conditions préalables

Conditions requises

Les lecteurs de ce document devraient avoir connaissance des sujets suivants :

  • Version de logiciel 12.2(15)BC2 de Cisco IOSÝ

  • plate-forme uBR7200VXR

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Routeur haut débit universel Cisco uBR7246VXR

  • Cisco Catalyst 2924-XL (fin de la vie)

  • Routeur Cisco 7206VXR

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Quel est TLS de 802.1Q au-dessus de câble ?

La caractéristique de TLS de 802.1Q fournit les moyens de créer des l2vpn entre les plusieurs sites, semblables aux lignes louées privées, Relais de trames, le RNIS, les atmosphères, SMDS, et semblable qui sont offertes par les compagnies de téléphone.

Dans de nombreux cas, le TLS peut être visualisé comme « Relais de trames - comme » le service. Il peut faciliter beaucoup de structures de trafic, telles que le Point à point, point-à-multipoint, ou a entièrement engrené.

La figure 1 affiche comment un déploiement de TLS de 802.1Q semble conceptuellement comme un VLAN.

Figure 1

/image/gif/paws/60027/tls_over_cable_01.gif

Gestionnaires du marché

Le gestionnaire principal pour l'adoption de cette caractéristique est le potentiel d'augmenter les courants de revenus.

La caractéristique de TLS de 802.1Q permet à un MSO pour concurrencer des compagnies de téléphone en fournissant un service de L2VPN qui peut être plus économique au consommateur final.

L'empreinte de pas MSO touche déjà beaucoup de zones commerciales dans tout leur déploiement. Plusieurs de ces entreprises s'abonnent déjà aux services de télévision par câble et aux services existants de la couche 2 d'une compagnie de téléphone.

Ces services de la compagnie de téléphone L2 tendent à avoir des dépenses récurrentes, telles que l'accès de boucle locale, accès de port de commutateur, et ainsi de suite.

Dans la plupart des cas, le déploiement d'un service de TLS de 802.1Q peut être aussi facile que ceci :

  1. Relâchez un modem câble au site client.

  2. Provision correctement l'équipement du réseau du MSO.

Pour faire la proposition de plus d'attrayant et de commercialisable, le MSO peut choisir d'empaqueter la télévision par câble et le TLS ensemble.

Comment l'exécution de TLS de 802.1Q fonctionne-t-elle ?

Dans une installation de TLS de 802.1Q, le modem câble d'un client spécifique provisioned avec les méthodes standard de ravitaillement qui sont tracées les grandes lignes par DOCSIS.

En plus du ravitaillement, le CMTS est configuré avec les définitions qui sont connues comme cartes dot1q. Les cartes dot1q contiennent l'adresse MAC de modem câble, l'ID DE VLAN, et l'interface sortante. Ces définitions (ou attaches) sont propagées dans la base de données de l'ID de service (SID).

Trafiquez qui provient un modem câble spécifique est étiqueté avec un ID DE VLAN et est puis envoyé sur le réseau, où il peut pont avec d'autres VLAN du même client. Il y a plusieurs manière d'accomplir la transition VLAN.

La figure 2 dépeint une topologie point à point de L2VPN, pour montrer comment le TLS fonctionne.

Figure 2

/image/gif/paws/60027/tls_over_cable_02.gif

Sur chaque CMTS il y a une définition de carte dot1q qui lie l'adresse MAC de modem câble avec un ID DE VLAN et une interface sortante.

Supposez que vous tracez un paquet du site A pour situer B ; les événements suivants expliquent comment CMTS A traite le trafic du site A :

  1. Le modem câble prend la trame Ethernet et ajoute une en-tête DOCSIS, qui inclut le modem câble SID (ou SFID).

  2. Quand le trafic est reçu, le CMTS exécute une consultation SID.

  3. Le CMTS détermine si le trafic est TLS, basé sur le SID.

  4. Si le trafic est TLS, le CMTS regarde dans le paquet et vérifie l'adresse MAC source.

    1. Si l'adresse MAC apparie l'adresse MAC du modem câble, alors le trafic est envoyé au code de commutation de couche 3.

    2. Si l'adresse MAC n'apparie pas l'adresse MAC du modem câble, alors le trafic est étiqueté avec la balise appropriée VLAN et est envoyé sur l'interface sortante appropriée.

Sur le CMTS B, le paquet qui provient le site A est traité de cette façon :

  1. Quand le CMTS reçoit une trame VLAN-étiquetée, il exécute une consultation de base de données pour déterminer si le VLAN est tracé à un modem câble.

  2. Si une correspondance est trouvée, alors le CMTS retire la balise VLAN et ajoute une en-tête DOCSIS.

  3. Le processus CMTS le nouveau paquet DOCSIS, pour se conformer aux paramètres appropriés de cos ou de QoS.

  4. Le paquet est alors envoyé sur l'interface de câble.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

La figure 3 montre la topologie de réseau utilisée dans les configurations et vérifie des sections.

Figure 3

tls_over_cable_03.gif

Configurations

Ce document utilise les configurations suivantes :

  1. CMTS A

  2. CMTS B

  3. Commutateur

  4. Routeur d'agrégation

CMTS A
UBR-1:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.3973.be53 FastEthernet0/1 12 
!

CMTS B
UBR-2:
!
cable l2-vpn-service dot1q
cable dot1q-vc-map 0000.39a7.8a67FastEthernet0/0 21 
!

Commutateur
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         
interface FastEthernet0/3
 switchport trunk encapsulation dot1q
 switchport mode trunk
!         

SW# show vlan id 12

00:44:03: %SYS-5-CONFIG_I: Configured from console by console
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
12   VLAN0012                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
12   enet  100012     1500  -      -      -        -    -        0      0   

SW# show vlan id 21

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
21   VLAN0021                         active    

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
21   enet  100021     1500  -      -      -        -    -        0      0

Routeur d'agrégation
!         
bridge irb
!         
!         
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
!         
interface FastEthernet0/1.12
 encapsulation dot1Q 12
 bridge-group 1
!         
interface FastEthernet0/1.21
 encapsulation dot1Q 21
 bridge-group 1
!         
bridge 1 protocol ieee
!

Vérifiez

Cette section présente les informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Initialisation du modem câble

Quand le modem qui provisioned pour le TLS de 802.1Q est livré en ligne, on crée une carte qui lie le modem à un ID DE VLAN et à une interface de sortie.

Émettez ces commandes de débogage de vérifier le mappage :

Cette sortie affiche comment le CMTS trace le VLAN et l'interface sortante, quand le modem câble est livré en ligne. Il affiche également les id d'écoulement d'en aval et de service ascendant qui sont associés avec le VLAN.


!--- Logs from CMTS A (UBR-1):

UBR-1# show debug

CMTS:
  CMTS L2 VPN debugging is on
CMTS specific:
  Debugging is on for Address 0000.3973.be53, Mask ffff.ffff.ffff

UBR-1#

cmts_l2vpn_init_cm: cm 0000.3973.be53 on Cable3/0, sid 0xA
map to FastEthernet0/1 VLAN id 12
 Mapped DS srv flow 22 on Cable3/0 to FastEthernet0/1 VLAN 12
 Mapped US srv flow 21 sid 10 on Cable3/0 to FastEthernet0/1 VLAN 12

Passage du trafic

Pour voir si ce trafic provient le modem câble ou destiné au modem câble, vous pouvez le mettre au point ou regarder les compteurs.

Pour le mettre au point, activez ces derniers met au point :

Remarque: Ceux-ci met au point sont seulement disponibles sur la plate-forme d'uBR7200.

La sortie d'exemple suivant affiche que le débogage d'un paquet du site A situait B, quand vous lancez le mac-address de mac-address de debug cable bavard et le debug cable l2-vpn conditionnel.

Les premiers mettent au point la ligne sont le paquet originaire du site R. Puisque le paquet est un paquet de ping, les prochains mettent au point la ligne sont la réponse ping. Il affiche comment un paquet est envoyé au modem câble.

UBR-1#

Pkt (size 114) from CM 0000.3973.be53 sid 10 src 0008.a3b6.d371
dst 0008.a3b6.d74b fwd to FastEthernet0/1 vlan 12

Send pkt size 118 from 0008.a3b6.d74b on FastEthernet0/1:vlan 12
to 0008.a3b6.d371 on Cable3/0:0xA CM 0000.3973.be53

Pour visualiser les octets ou les compteurs de paquets, émettez la commande bavarde de mac-address du câble l2-vpn dot1q-vc-map d'exposition :

UBR-1# show cable l2-vpn dot1q-vc-map 0000.3973.be53 verbose

MAC Address                         : 0000.3973.be53
Customer Name                       :
Prim Sid                            : 5
Cable Interface                     : Cable3/0
Ethernet Interface                  : FastEthernet0/1
DOT1Q VLAN ID                       : 12
Total US pkts                       : 0
Total US bytes                      : 0
Total DS pkts                       : 12
Total DS bytes                      : 816

Dépannez

Il n'y a actuellement aucune informations disponibles spécifique pour dépanner cette configuration.

Considérations de conception

Il y a plusieurs facteurs de conception à considérer quand vous déployez des services au-dessus d'un réseau DOCSIS. Certains sont spécifiques au côté câble et les autres sont plus de problèmes généraux.

Côté câble (DOCSIS)

Taille ou débit de canal

Typiquement, la limite principale est sur la bande passante amont. Le tableau 1 affiche les figures approximatives pour les différentes valeurs de débit.

Tableau 1 :

Version DOCSIS Largeur de la Manche (MHZ) Modulation Débit approximatif (Mbits/s)
1.x 1.6 QPSK 2.2
1.x 1.6 16-QAM 4.4
1.x 3.2 16-QAM 8.9
2.0 3.2 64-QAM 13
2.0 6.4 64-QAM 26

La version 1.1 DOCSIS a incorporé beaucoup de caractéristiques qui fournissent l'optimisation de canal ascendant. Certaines de ces caractéristiques incluent :

  • Enchaînement

  • Fragmentation

  • Suppression d'en-tête de charge utile

DOCSIS QoS

Commis contre le meilleur effort — La version 1.0 DOCSIS tient compte d'un taux garanti sur l'en amont seulement. Les versions 1.1 et 2.0 tiennent compte d'un taux garanti dans les deux directions. Afin de garantir un débit de données garanti (CIR), le programmateur CMTS exécute le contrôle d'admission sur l'en amont, pour empêcher la sursouscription.

Latence et jitter commandés — Les concessions non sollicitées de la version 1.1's DOCSIS (UGS) fournit un service comme constant de débit binaire (CBR). La latence et le jitter peuvent être efficacement commandés, pour fournir un débit de données minimum garanti pour le trafic qui exige des concessions à intervalles fixes.

Sécurité

Trafiquez qui traverse l'usine de câble peut être sécurisé avec l'interface de sécurisation de base DOCSIS (le BPI), dans la version 1.0 DOCSIS, ou BPI+, dans de plus nouvelles versions de DOCSIS. Puis, quelqu'un ne peut pas piller ou écouter clandestinement les données du côté câble.

Pour les clients qui ont besoin de plus de Sécurité — par exemple, les institutions financières et semblable — une stratégie de bout en bout d'IPSec est recommandée. Référez-vous à la Sécurité à Cisco.

Problèmes généraux

QoS

Dans un environnement de 802.1Q, il y a trois régions importantes de QoS :

  • Côté CPE — Comment le CPE maintient l'ordre et marque le trafic. Ceci est contrôlé par le client et il est approprié à leurs stratégies QoS internes.

  • Côté câble — Ceci se conforme au protocole DOCSIS et au ravitaillement de modem câble.

  • Circuit principal — Le MSO peut appliquer les stratégies QoS basées sur des accords de niveau de service.

Performance et évolutivité

Sur le CMTS, il y a seulement une légère augmentation de la mémoire pour tenir les structures de données et des cartes dot1q (base de données). Le changement pour des paquets de TLS est identique que pour n'importe quel autre paquet.

Le nombre de VLAN pris en charge varie basé sur la plate-forme.

En jetant un pont sur des groupes variez basé sur la plate-forme.

Comment étendre le TLS de 802.1Q au delà des bornes d'Ethernets

Il y aura des périodes où les clients ont besoin de Connectivité aux sites qui sont au delà des limites d'examen médical d'Ethernets ; par exemple, sites différents villes, villes, ou états.

Dans des ces cas, les MSO peuvent utiliser une des multiples solutions de services de relais d'Ethernets de métro.

Deux de ces solutions qui ont été laboratoire testé sont :

  • Le TLS au-dessus d'un réseau de noyau IP par l'intermédiaire de la couche 2 perce un tunnel la version 3 de protocol (L2TP)

  • TLS au-dessus d'un noyau de Commutation multiprotocole par étiquette (MPLS) par l'intermédiaire de Fonction Ethernet over MPLS (EoMPLS)

Annexe A - Tracé de paquets entre le commutateur L2 et le routeur d'agrégation

Cette section affiche un tracé de paquets d'un paquet de ping entre le commutateur et le routeur d'agrégation. Notez qu'il y a deux paquets de requête ping : un du site A au routeur d'agrégation, et un du routeur d'agrégation pour situer le B. Le même s'applique à la réponse ping.

Frame 1 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 2 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d3:71, Dst: 00:08:a3:b6:d7:4b
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.1 (192.168.50.1),
Dst Addr: 192.168.50.2 (192.168.50.2)
Internet Control Message Protocol
    Type: 8 (Echo (ping) request)
    Code: 0 
    Checksum: 0x3fb9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 3 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0001 0101 = ID: 21
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Frame 4 (118 bytes on wire, 118 bytes captured)
Ethernet II, Src: 00:08:a3:b6:d7:4b, Dst: 00:08:a3:b6:d3:71
802.1q Virtual LAN
    000. .... .... .... = Priority: 0
    ...0 .... .... .... = CFI: 0
    .... 0000 0000 1100 = ID: 12
    Type: IP (0x0800)
Internet Protocol, Src Addr: 192.168.50.2 (192.168.50.2),
Dst Addr: 192.168.50.1 (192.168.50.1)
Internet Control Message Protocol
    Type: 0 (Echo (ping) reply)
    Code: 0 
    Checksum: 0x47b9 (correct)
    Identifier: 0x0008
    Sequence number: 0x0000
    Data (72 bytes)

0000  00 00 00 00 00 3d 3e 4c ab cd ab cd ab cd ab cd   .....=>L........
0010  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0020  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0030  ab cd ab cd ab cd ab cd ab cd ab cd ab cd ab cd   ................
0040  ab cd ab cd ab cd ab cd                           ........

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 60027