Services de mise en réseau d'applications : Commutateurs de services de contenu de la gamme Cisco CSS 11500

Exemple de configuration de redondance boîtier à boîtier sur le CSS 11xxx

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit une configuration d'échantillon pour la Redondance de case-à-case du Commutateur de services de contenu (CSS) 11xxx. la Redondance de Case-à-case fournit la Redondance niveau des châssis entre deux CSS identiquement configurés.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous répondez à ces exigences :

  • Chacun des deux CSS que vous utilisez pour cette configuration redondante doivent exécuter la même version du code. Des différentes versions courantes du code n'est pas prises en charge pour la Redondance.

  • Attendez-vous à ce que le comportement des CSS soit (maître) /standby actif (sauvegarde) ; seulement les écoulements de processus du maître CSS.

  • Vous devez configurer un lien dédié de Fast Ethernet (technicien) entre les CSS pour la pulsation de Protocole VRRP (Virtual Router Redundancy Protocol).

  • N'utilisez pas la case-à-case si vous avez besoin de la connexion d'un périphérique de la couche 2 entre les pairs redondants CSS. Redondance de VIP d'utilisation à la place. Référez-vous à configurer le pour en savoir plus de Redondance de VIP et d'interface virtuelle.

Composants utilisés

Les informations dans ce document sont basées sur la version de SW CSS 11150 : 6.10 Construction 107.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec les versions de matériel et de logiciel suivantes :

  • tout le Cisco CSS 11000 - Produits de la gamme 11500 CSS

  • Version de logiciel 5.0 et ultérieures de Cisco WebNS

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Les CSS participent à une configuration redondante quand un lien de Redondance a été défini entre deux CSS. Le protocole utilisé pour ce lien de Redondance est VRRP, utilisant l'adresse de multidiffusion 224.0.0.18. Les CSS emploient ce lien pour mettre à jour l'état de contact et d'activité entre eux. Seulement un lien de croisé entre les CSS est pris en charge. Vous devez utiliser un câble croisé pour se connecter directement aux ports technicien sur les CSS redondants. N'utilisez pas les périphériques de la couche 2 entre les deux CSS sur le lien redondant. N'installez pas le câble croisé sur des ports de Gigabit Ethernet (GE) ; cette configuration n'est pas prise en charge.

Remarque: Le protocole de Redondance de case-à-case CSS est maintenant pris en charge sur les ports CSS 11501, CSS 11503, et CSS 11506 GE dans la version de logiciel 7.10.1.02 et 7.20.0.01 et plus tard.

Il y a deux conditions principales détectées sur ce lien de Redondance qui pilotent les états principaux et de sauvegarde sur les deux CSS :

  • La première condition met à jour la pulsation, qui est une publicité chaque seconde. Le maître CSS fournit cette pulsation sur le lien de Redondance, et la sauvegarde CSS maintient la pulsation toutes les trois secondes (par défaut). Si les temps de pulsation (par exemple, des pulsations ne sont pas détectées dans cette période), alors la sauvegarde succède comme maître.

    Le nouveau maître CSS commence envoyant des messages de gestion de protocole de Redondance aussi bien que des messages gratuits de Protocole ARP (Address Resolution Protocol) pour mettre à jour les tables ARP sur les Noeuds voisins et les tables d'expédition des périphériques traversiers reliés (par exemple, posez 2 Commutateurs) avec la nouvelle adresse MAC du maître CSS. Le CSS transmet un paquet de demandes d'ARP et un paquet de réponse d'ARP pour chaque invocation gratuite d'ARP.

  • La deuxième condition est celle d'une modification de switch priority VRRP. Le CSS annonçant le plus prioritaire est négocié pour devenir maître. C'est le mécanisme utilisé par les services de liaison ascendante, et certaines des commandes spéciales (décrites ci-dessous) pour initier un événement de Basculement.

Notez qu'au cas où les CSS misconfigured (par exemple, deux CSS ou plus sont installés comme maître de redondance IP), le CSS avec l'adresse IP VRRP la plus élevée succède comme maître.

Le logiciel de Cisco WebNS vous permet à :

  • configurez les plusieurs services de liaison ascendante

  • utilisez le Basculement basé sur un lien allant vers le bas

  • utilisez la synchronisation de configuration ; référez-vous à synchroniser un pour en savoir plus de configuration redondante

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Émettez la commande de Redondance d'IP d'activer la Redondance CSS-à-CSS sur deux CSS reliés avec un câble croisé. Par défaut, la Redondance est désactivée sur les CSS jusqu'à ce que vous émettiez cette commande sur les deux CSS.

Quand vous incluez l'option principale avec cette commande, vous pouvez indiquer quel CSS est le maître CSS. Au commencement, amorçant deux CSS reliés avec un câble croisé détermine ce qui est le maître et ce qui est la sauvegarde. Le CSS qui démarre d'abord est le maître CSS. Si les CSS démarrent en même temps, le CSS avec l'adresse IP numériquement plus élevée devient le maître.

Quand vous émettez la commande de maître de Redondance d'IP sur le CSS, le CSS devient le maître CSS. Vous pouvez émettre cette commande sur le maître en cours ou la sauvegarde. Si vous émettez l'option principale sur la sauvegarde CSS, le CSS devient le maître et l'autre CSS devient automatiquement la sauvegarde.

Si vous indiquez un maître CSS, le CSS regagne l'état principal après être allé vers le bas et puis monte de nouveau. Par exemple, quand le maître CSS descend, la sauvegarde CSS devient maître. Quand l'ancien maître indiqué CSS monte de nouveau, cependant, le CSS devient le maître de nouveau.

Si vous n'avez aucune condition requise d'indiquer un CSS comme maître quand les deux CSS sont, n'incluez pas l'option principale en activant la Redondance sur le maître CSS.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/50405/box_to_box_config.jpg

Configurations

Ce document utilise les configurations suivantes :

  • CSS 11150 FL

  • nws-4-5

CSS 11150 FL
CSS-11150-FL# sh running-config
!Generated on 03/22/2004 18:32:17
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 		


!--- Redundancy is enabled.


  app     			


!--- This is optional if you want to synchronize the configurations.

  app session 172.17.6.2   

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.1 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.2 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

CSS-11150-FL# 

nws-4-5
nws-4-5# sh running-config 
!Generated on 03/22/2004 18:53:37
!Active version: ap0610107a

configure


!*************************** GLOBAL ***************************
  ip redundancy 	


!--- Redundancy is enabled.



  app 


!--- This is optional if you want to syncronize the configurations.

  app session 172.17.6.1 

  ip route 0.0.0.0 0.0.0.0 10.66.86.33 1 

!************************* INTERFACE *************************
interface e1
  bridge vlan 2 

interface e3
  bridge vlan 42 

!************************** CIRCUIT **************************
circuit VLAN1
  redundancy 
         
  ip address 10.1.1.3 255.255.255.0 

circuit VLAN2

  ip address 172.17.6.2 255.255.255.0 
    redundancy-protocol 

circuit VLAN42
  redundancy 

  ip address 10.66.86.45 255.255.255.240 

!************************** SERVICE **************************
service test 
  protocol tcp 
  ip address 10.1.1.1 
  port 80 
  active 

!*************************** OWNER ***************************
owner Cisco 

  content WebServer 
    vip address 10.66.86.44 
    add service test 
    active 

nws-4-5# 


Soutien de plusieurs services de liaison ascendante

Vous pouvez créer un service qui est associé avec l'adresse IP d'un routeur. Ce service permet au maître CSS de surveiller le routeur avec une keepalive (ICMP). Si la keepalive échoue, le maître abandonne le contrôle et la sauvegarde CSS prend le contrôle. Vous pouvez configurer plus d'un service en émettant la commande de Redondance- de type ; les CSS utilisent toutes les liaisons ascendantes de Redondance en prenant la décision de Basculement.

Si un CSS est en activité, et perd toutes les liaisons ascendantes indiquées comme Redondance-, le CSS abandonne l'état active et devient la sauvegarde. Le CSS emploie le protocole de Redondance pour informer l'autre CSS pour devenir actif. Si les deux CSS ont perdu leurs liaisons ascendantes, des séjours CSS dans l'état active pendant 45 secondes, attendant la liaison ascendante pour être livré actif. Après 45 secondes, s'il ne reste aucune liaison ascendante viable, le CSS entre dans le mode de sauvegarde, donnant à l'autre commutateur un essai. Ceci permet aux deux CSS pour obtenir une occasion de tester leurs liaisons ascendantes sans battre dans les deux sens beaucoup de fois chaque minute.

Remarque: Un CSS entre dans le Basculement quand il n'y a plus des services vivants de liaison ascendante.

Considérations

Cette caractéristique est désactivée quand la commande de maître de Redondance d'IP est émise. Quand la commande de maître de Redondance d'IP est émise, la commande de Redondance- de type ne peut pas être configurée. Quand un service est configuré en émettant la commande de Redondance- de type, la commande de maître de Redondance d'IP ne peut pas être émise.

Configuration

CSS11150# configure terminal
CSS11150(config)# service uplink1
CSS11150(config-service[uplink1])# type redundancy-up           

!--- If this upstream router goes down, then fail the switch over.

CSS11150(config-service[uplink1])# ip address 10.66.86.33
CSS11150(config-service[uplink1])# active

Soutien de Basculement de panne d'interface physique

Si des n'importe quelles des interfaces physiques configurées pour la Redondance descendent, le CSS abandonne le contrôle, et la sauvegarde CSS succède immédiatement comme maître. Cette caractéristique est basée sur l'état de lien par opposition au service de Redondance-, qui est basé sur la connectivité IP. Le CSS peut déterminer l'état de lien quand en mode de sauvegarde. Vous devez s'assurer que le chemin en amont ou en aval de la sauvegarde CSS ne fonctionne pas également par cette même interface ; ceci fera agiter les cases CSS la propriété de l'état principal.

Considérations

Cette caractéristique est désactivée en émettant la commande de maître de Redondance d'IP. Quand la commande de maître de Redondance d'IP est émise, la commande d'interface de Redondance-phy échoue. Quand la commande d'interface de Redondance-phy est émise, la commande de maître de Redondance d'IP échoue.

Configuration

CSS-11150-FL# configure terminal
CSS-11150-FL(config)# interface e1
CSS-11150-FL(config-if[e1])# redundancy-phy

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • Redondance SH — Cette commande vérifie que les CSS s'exécutent dans une configuration redondante ; cette commande affiche également quel CSS est maître et ce qui est de sauvegarde, aussi bien que la raison pour le dernier Basculement.

    nws-4-5# sh redundancy
    Redundancy:               Enabled    Redundancy Protocol:      Running   
    Redundancy State:         Master     MasterMode:               No        
    Number of times redundancy state changed to Master:            2         
                                             to Backup:            2         
    Redundancy interface:     172.17.6.2
    Current State Duration:   1 day 02:54:04
    Last Fail Reason:         No Fail    
    VRID:                     128        Priority:                 100 
  • show log sys.log — Cette commande affiche des messages avec les informations pour l'autorité entre les périphériques CSS.

    CSS-11150-FL# sh log sys.log
    
    APR 15 18:05:49 5/1 85 REDUNDANCY-4: Redundancy force master temporarily
    APR 15 18:05:52 5/1 86 REDUNDANCY-4: Transition to redundancy master
    APR 15 18:05:52 5/1 87 VRRP-4: Virtual router 128: master on interface 172.17.6.1
  • affichez l'app et affichez la session d'app — Cette commande affiche l'état de la session d'app.

    nws-4-5# sh app
    APP CONFIGURATION:
    Enabled PortNumber: 5001 MaxFrameSize: 10240
    
    nws-4-5# sh app session
    App Session Information 'no hostname':
    Session ID: 87df3710 IP Address: 172.17.6.1 State: APP_SESSION_UP

Vous pouvez forcer la sauvegarde pour maîtriser pour des entretiens. Émettez la commande de force-maître de Redondance de configurer une sauvegarde CSS comme maître provisoire. C'est une configuration provisoire parce que la commande n'est pas copiée sur la configuration courante. Cette commande est utile dans une configuration redondante quand vous devez prendre le maître CSS off-line pour la maintenance ou une mise à jour.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 50405