IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Présentation de LSP Pseudonode IS-IS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit le pseudonode de paquet link-state (LSP). Un pseudonode est une représentation logique du réseau local qui est générée par un système intermédiaire désigné (DIS) sur un segment du réseau local. Le document décrit également la propagation des informations aux routeurs.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations dans ce document sont basées sur le logiciel et les versions de matériel associés avec :

  • Version de logiciel 12.1(5)T9 de½ du¿Â du Cisco IOSïÂ.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

DIS et le Pseudonode

Cette section décrit le DIS et le pseudonode.

Quel est le DIS ?

Sur des réseaux d'accès multiple avec diffusion, un routeur unique est élu comme DIS. Il n'y a aucun DIS de sauvegarde élu. Le DIS est le routeur qui crée le pseudonode et agit au nom du pseudonode.

Deux tâches principales sont effectuées par le DIS :

  • Créant et mettant à jour le LSP pseudonode pour signaler des liens à tous les systèmes sur le sous-réseau d'émission. Voyez le pour en savoir plus de section de Pseudenode LSP.

  • Inondation des LSP au-dessus du RÉSEAU LOCAL.

L'inondation au-dessus du RÉSEAU LOCAL signifie que le DIS envoie les Protocol Data Unit périodiques de nombre de séquence complète (CSNPs) (valeur par défaut de 10 secondes) récapitulant les informations suivantes :

  • ID LSP

  • Numéro de séquence

  • Somme de contrôle

  • Vie restante

Le DIS est responsable de l'inondation. Il crée et inonde un nouveau LSP pseudonode pour chaque niveau de routage auquel il participe (niveau 1 ou niveau 2) et pour chaque RÉSEAU LOCAL auquel il est connecté. Un routeur peut être le DIS pour tous les réseaux locaux connectés ou un sous-ensemble de réseaux locaux connectés, selon la priorité IS-IS ou l'adresse de la couche 2. Le DIS créera également et inonder un nouveau LSP pseudonode quand une contiguïté de voisinage est établie, démoli, ou le compteur d'intervalles de régénération expire. Le mécanisme de DIS réduit la quantité d'inondation sur des réseaux locaux.

Élection du DIS

Sur un RÉSEAU LOCAL, un des Routeurs s'élit le DIS, basé sur la priorité d'interface (le par défaut est 64). Si toutes les priorités d'interface sont identiques, le routeur avec le point de sous-réseau de connexion le plus élevé (SNPA) est sélectionné. Le SNPA est l'adresse MAC sur un RÉSEAU LOCAL, et l'identifiant de connexion de liaison de données locale (DLCI) sur un réseau de Relais de trames. Si le SNPA est un DLCI et est identique sur les deux côtés d'un lien, le routeur avec l'ID système plus élevé devient le DIS. Chaque interface de routeur IS-IS est assignée une priorité L1 et une priorité L2 dans la plage de 0 à 127.

L'élection de DIS est de préemption (OSPF différent). Si les nouveaux amorçages d'un routeur sur le RÉSEAU LOCAL avec une priorité d'interface plus élevée, le nouveau routeur devient le DIS. Il purge le vieux LSP pseudonode et inonde un nouvel ensemble de LSP.

Quel est le Pseudonode (le RPC) ?

Afin de réduire le nombre de contiguïtés de maillage complet entre les Noeuds sur les liens à plusieurs accès, le lien à plusieurs accès lui-même est modelé comme pseudonode. C'est un noeud virtuel, car le nom implique. Le DIS crée le pseudonode. Tous les Routeurs sur l'émission joignent, y compris le DIS, des contiguïtés de forme avec le pseudonode.

Représentation d'un Pseudonode :

pseodonode.gif

Dans l'IS-IS, un DIS ne synchronise pas avec ses voisins. Après que le DIS crée le pseudonode pour le RÉSEAU LOCAL, il envoie bonjour des paquets pour chaque niveau (1 et 2) toutes les trois secondes et CSNPs toutes les dix secondes. Bonjour les paquets indiquent que c'est le DIS sur le RÉSEAU LOCAL pour ce niveau, et le CSNPs décrivent le résumé de tous les LSP, y compris l'ID LSP, le numéro de séquence, la somme de contrôle, et la vie restante. Les LSP sont toujours inondés à l'adresse de multidiffusion et le mécanisme CSNP corrige seulement pour tous les Protocol Data Unit perdus (PDU). Par exemple, un routeur peut demander le DIS des disparus LSP utilisant un paquet partiel de numéro de séquence (PSNP) ou, consécutivement, pour donner au DIS un nouveau LSP.

CSNPs sont utilisés pour indiquer d'autres Routeurs au sujet de tous les LSP dans une base de données du routeur. Semblable à un paquet de descripteur de base de données OSPF, PSNPs sont utilisés pour demander un LSP et pour accuser réception d'un LSP.

LSP pseudonode

Le LSP pseudonode est généré par le DIS. Le DIS signale tous les voisins de RÉSEAU LOCAL (DIS y compris) dans le LSP pseudonode avec une mesure de zéro. Tous les Routeurs de RÉSEAU LOCAL, y compris le DIS, signalent la Connectivité au pseudonode dans leurs LSP. C'est semblable dans le concept au LSA de réseau dans l'OSPF.

Exemple

Nous emploierons le schéma de réseau suivant pour expliquer comment le LSP pseudonode, généré par le DIS, est utilisé pour signaler tous les voisins de RÉSEAU LOCAL.

Remarque: Dans l'exemple ci-dessous, la caractéristique dynamique d'adresse Internet est enable. Par conséquent, les id de système sont automatiquement tracés aux noms de hôte du routeur affichés dans la sortie en résultant des commandes show ci-dessous.

Diagramme du réseau

isis-pnode.jpg

Configurations

Ces configurations ont été utilisées pour les Routeurs affichés dans le schéma de réseau :

Router isis
Router 6
  
       interface e0
       ip address 172.16.126.6 255.255.255.0 
       ip router isis
       Isis priority 127
	   
       router isis
       net 49.0001.0000.0c4a.4598.00
       is-type level-1
  
  Router 2

       interface e0
       ip address 172.16.126.2 255.255.255.0
       ip router isis
	
       router isis
       net 49.0001.0000.0c8d.e6b4.00
       is-type level-1
	   
  Router 1

       interface e0
       ip address 172.16.126.1 255.255.255.0
       ip router isis


       interface s1
       ip address 172.16.1.1 255.255.255.0
       ip router isis

       router isis
       net 49.0001.0000.5c75.d0e9.00
       is-type level-1
	   
  Router 8
 
       interface s1
       ip address 172.16.1.8 255.255.255.0
       ip router isis
	  
       router isis
       net 49.0001.0000.0c31.c2fd.00
       is-type level-1c

Le tableau suivant décompose la zone, l'adresse MAC, et le réseau pour chacun des Routeurs configurés ci-dessus. Notez que tous les Routeurs sont dans la même zone.

Routeur Zone Adresse MAC NET (titre d'entité réseau)
6 49.0001 0000.0c4a.4598 49.0001.0000.0c4a.4598.00
2 0000.0c8d.e6b4 49.0001.0000.0c8d.e6b4.00
1 0000.5c75.d0e9 49.0001.0000.5c75.d0e9.00
8 0000.0c31.c2fd 49.0001.0000.0c31.c2fd.00

Les Routeurs étant configuré comme décrit dans cette section, vous pouvez utiliser l'ordre d'être-voisin de show clns de visualiser les voisins IS-IS :

router-6# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-6#

router-2# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-1       Et0         Up     L1   64        router-6.01        Phase V
router-2#

router-1# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
router-6       Et0         Up     L1   127       router-6.01        Phase V
router-2       Et0         Up     L1   64        router-6.01        Phase V
router-8       Se1         Up     L1   0         00                 Phase V
router-1#

router-8# show clns is-neighbor

System Id      Interface   State  Type Priority  Circuit Id         Format
Router-1       Se1         Up     L1   0         00                 Phase V
router-8#

Dans le voisin précédent le répertorie, note que les Routeurs connectés au réseau à accès multiple (Ethernet) tout ont le même ID de circuit. L'ID de circuit est un nombre d'un-octet qui les utilisations de routeur d'identifier seulement l'interface IS-IS. Si l'interface est reliée à un réseau à accès multiple, l'ID de circuit est concaténé avec l'ID système du DIS. Ceci est connu comme ID de pseudonode. Notez également, cela que le DIS est le routeur 6 en raison de la priorité IS-IS configurée sous son interface Ethernet.

Base de données IS-IS

Cette sortie affiche la base de données IS-IS de chacun des Routeurs décrits dans la section précédente :

Router-6# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        960               0/0/0
router-6.00-00      * 0x0000006D   0xDD58        648               0/0/0
router-6.01-00      * 0x00000069   0x6DCB        1188              0/0/0
router-2.00-00        0x0000006D   0x59DE        589               0/0/0
router-1.00-00        0x00000074   0xC4B0        759               0/0/0
router-6#

router-2# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        947               0/0/0
router-6.00-00        0x0000006D   0xDD58        633               0/0/0
router-6.01-00        0x00000069   0x6DCB        1172              0/0/0
router-2.00-00      * 0x0000006D   0x59DE        577               0/0/0
router-1.00-00        0x00000074   0xC4B0        746               0/0/0
router-2#

router-1# show isis database

IS-IS Level-1 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
router-8.00-00        0x0000006E   0xFF1A        934               0/0/0
router-6.00-00        0x0000006D   0xDD58        619               0/0/0
router-6.01-00        0x00000069   0x6DCB        1158              0/0/0
router-2.00-00        0x0000006D   0x59DE        561               0/0/0
router-1.00-00      * 0x00000074   0xC4B0        734               0/0/0
router-1#

router-8# show isis database
IS-IS Level-1 Link State Database
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
router-8.00-00*       0x0000006E   0xFF1A        927           0/0/0
router-6.00-00        0x0000006D   0xDD58        607           0/0/0
router-6.01-00        0x00000069   0x6DCB        1147          0/0/0
router-2.00-00        0x0000006D   0x59DE        550           0/0/0
router-1.00-00        0x00000074   0xC4B0        723           0/0/0
router-8#

Pendant que la sortie précédente indique, la commande de show isis database affiche une liste de LSP dans la base de données. Dans ce cas, tous les Routeurs sont des Routeurs du niveau 1 dans la même zone, ainsi ils tous ont les mêmes LSP dans leur base de données IS-IS. Notez que chacun des Routeurs génère un LSP. Le DIS génère un LSP pour lui-même, et il génère également un LSP au nom du pseudonode. Le LSP pseudonode dans cet exemple est 0000.0C4A.4598.01-00.

Nous avons mentionné que les Routeurs sur le RÉSEAU LOCAL envoient seulement des annonces au pseudonode du RÉSEAU LOCAL. Le pseudonode signale tous les voisins de RÉSEAU LOCAL, dans le LSP pseudonode, avec une mesure de zéro — suivant les indications de ces exemples de sortie de commande de détail de lsp de show isis database :

  • Routeur 6 LSP (comme vu du routeur 8)

    Notez que le routeur 6 annonce qu'il peut seulement atteindre son réseau directement connecté et le pseudonode. Dans ce cas, le pseudonode a une mesure de 10. Comme nous avons mentionné, les Routeurs sur le RÉSEAU LOCAL annonceront qu'ils peuvent être atteints au pseudonode du RÉSEAU LOCAL seulement.

    router-8# show isis database router-6.00-00 detail
    IS-IS Level-1 LSP router-6.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.00-00        0x00000071   0xD55C        456           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.6
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • LSP pseudonode (comme vu du routeur 8)

    Le LSP pseudonode annonce tous les voisins de RÉSEAU LOCAL avec une mesure de zéro. Le LSP pseudonode est généré par le DIS, le routeur 6 dans ce cas, au nom du pseudonode.

    Router-8# show isis database router-6.01-00 detail
    IS-IS Level-1 LSP router-6.01-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-6.01-00        0x0000006D   0x65CF        759           0/0/0
      Metric: 0  IS router-6.00
      Metric: 0  IS router-2.00
      Metric: 0  IS router-1.00
    router-8#
  • Router2 LSP (comme vu du routeur 8)

    De nouveau, le Router2 LSP contient les informations de savoir si elles peuvent atteindre son réseau directement connecté et le pseudonode seulement.

    Router-8# show isis database router-2.00-00 detail
    IS-IS Level-1 LSP router-2.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-2.00-00        0x00000072   0x4FE3        791           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.126.2
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IS router-6.01
    router-8#
  • Routeur 1 LSP (comme vu du routeur 8)

    Les seules informations que le routeur 1 LSP contient pour le réseau de RÉSEAU LOCAL sont le réseau lui-même et si elles peuvent atteindre le pseudonode. Puisque le routeur 1 est également connecté à un autre réseau, le réseau série, ce réseau directement connecté est également annoncé.

    Router-8# show isis database router-1.00-00 detail
    IS-IS Level-1 LSP router-1.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-1.00-00        0x00000079   0xBAB5        822           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      Code:   137 Length: 8
      IP Address:  172.16.1.1
      Metric: 10 IP 172.16.126.0 255.255.255.0
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-6.01
      Metric: 10 IS router-8.00
    router-8#
  • Routeur 8 LSP

    Dans ce cas, le routeur 8 n'est pas connecté au RÉSEAU LOCAL, ainsi il n'annonce pas au pseudonode qu'il peut être atteint. Il, cependant, annonce (ce il peut être atteint) à lui-même, au routeur 1, et au réseau directement connecté.

    Router-8# show isis database router-8.00-00 detail
    IS-IS Level-1 LSP router-8.00-00
    LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime  ATT/P/OL
    router-8.00-00*       0x00000072   0xF71E        554           0/0/0
      Area Address: 49.0001
      NLPID:       0xCC 
      IP Address:  172.16.1.8
      Metric: 10 IP 172.16.1.0 255.255.255.0
      Metric: 10 IS router-1.00
      Metric: 0  ES router-8
    router-8#

Informations connexes


Document ID: 49627