IP : Protocoles de routage IP

Exemple de configuration de routage fondé sur la stratégie avec la fonction d'options de suivi multiples

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à un exemple de configuration pour le routage basé sur stratégie avec la caractéristique d'options de cheminement multiple. Cette caractéristique a été introduite dans la version de logiciel 12.3(4)T de Ý de Cisco IOS. Référez-vous à la prise en charge de PBR sur les options de cheminement multiple pour plus d'informations.

Cette caractéristique étend les capacités du cheminement objectif pour vérifier la prochaine adresse IP de saut avant d'expédier le trafic au prochain saut. La méthode de vérification peut être un ping de Protocole ICMP (Internet Control Message Protocol), ping de Protocole UDP (User Datagram Protocol), ou une demande GET de Protocole HTTP (Hypertext Transfer Protocol). L'ICMP est la méthode de vérification la plus commune utilisée sur l'Internet. La plusieurs caractéristique de cheminement d'options est la plus appropriée aux Routeurs qui entretiennent des relations de plusieurs réseaux Ethernet comme prochain saut. Normalement, les interfaces Ethernet se connectent à la ligne d'abonné numérique (DSL) ou aux Modems câble. Actuellement, il n'y a aucune méthode pour détecter un en amont de panne dans le réseau haut débit ISP — les restes d'interface Ethernet hauts et n'importe quelle forme de l'acheminement statique indiquent cette interface. Le point fort de cette caractéristique te permet la sauvegarde deux interfaces Ethernet, choisissent l'interface qui est disponible en envoyant des pings d'ICMP pour vérifier le reachablity, et puis conduisent le trafic à cette interface.

Conditions préalables

Conditions requises

Avant que vous tentiez cette configuration, assurez-vous que vous répondez à cette exigence :

  • Chargez l'ensemble de fonctionnalités d'IOS de base d'entreprise à vos Routeurs, si vous n'avez pas déjà fait ainsi. Si vous avez payé cet ensemble de caractéristiques, vous pouvez le télécharger du secteur de logiciel de téléchargement (clients enregistrés seulement).

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section présente les informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise cette configuration du réseau. Dans ce scénario, R1 est connecté à deux autres FAI (ISP-1 et ISP-2). R1 dépiste l'accessibilité aux deux routeurs de l'ISP.

/image/gif/paws/48003/pbrtracking_01.gif

Configuration

Ce document utilise la configuration suivante :

R1
R1# show running-config 
Building configuration...

Current configuration : 1203 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
clock timezone EST 0
no aaa new-model
ip subnet-zero
no ip domain lookup
!
!
!
!
track 123 rtr 1 reachability

!--- Track Router 1's reachability.

!         
track 124 rtr 2 reachability

!--- Track Router 2's reachability.

!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
 ip address 192.168.0.1 255.255.255.0
!
interface Ethernet1/0
 ip address 192.168.1.1 255.255.255.0
!
interface Ethernet2/0
 ip address 10.10.10.1 255.255.255.0
 ip policy route-map alpha

!--- Enable policy routing on the outgoing interface.

!
ip classless
no ip http server
!
!
!
!
route-map alpha permit 10

!--- Define a route-map to set the next hop depending on 
!--- the state of the tracked routers.

 set ip next-hop verify-availability 192.168.0.10 10 track 123
 set ip next-hop verify-availability 192.168.1.20 20 track 124
!
!
control-plane
!
rtr 1

!--- Define and start Router 1.

 type echo protocol ipIcmpEcho 192.168.0.10
rtr schedule 1 life forever start-time now
rtr 2

!--- Define and start Router 2.


 type echo protocol ipIcmpEcho 192.168.1.20
rtr schedule 2 life forever start-time now
!
line con 0
 transport preferred all
 transport output all
line aux 0
 transport preferred all
 transport output all
line vty 0 4
 login
 transport preferred all
 transport input all
 transport output all
!
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show track — Affichages dépistant les informations.

  • brief de show track — Affichages limités dépistant les informations.

R1# show track           
Track 123
  Response Time Reporter 1 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 8
  Tracked by:
    ROUTE-MAP  0
Track 124
  Response Time Reporter 2 reachability
  Reachability is Up
    3 changes, last change 00:06:43
  Latest operation return code: OK
  Latest RTT (millisecs) 12
  Tracked by:
    ROUTE-MAP  0

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

De la sortie de commande brief de show track, vous pouvez voir que les deux ISP sont accessibles. Si vous arrêtez l'interface qui est connectée à ISP-1, on lui affiche en tant que vers le bas une fois dépisté.

R1# conf t
R1(config)# int ethernet 0/0
R1(config-if)# shutdown
R1(config-if)# end
R1#

*Jan 21 06:06:50.167: %SYS-5-CONFIG_I: Configured from console by console
*Jan 21 06:06:50.807: %LINK-5-CHANGED: Interface Ethernet0/0, changed state to administratively down
*Jan 21 06:06:51.827: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed state to down

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Up
124     rtr       2                    reachability     Up

R1# show track brief
Track   Object                         Parameter        Value
123     rtr       1                    reachability     Down
124     rtr       2                    reachability     Up
R1# 

Remarque: PBR exige le cheminement afin de déterminer si l'interface ou l'artère est en activité. Afin de visualiser l'état de l'artère dépistant, vous pouvez également utiliser la commande de show route-map.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 48003