IP : Protocoles de routage IP

Exemple de configuration de stratégie de routage avec les commutateurs de la gamme Catalyst 3550

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (6 octobre 2015) | Commentaires


Contenu


Introduction

Ce document fournit un exemple de configuration pour le routage de stratégies sur des commutateurs de la gamme Catalyst 3550. Les Commutateurs de gamme Catalyst 3550 ont l'expédition basé par matériel, ainsi les informations d'expédition sont programmées dans la mémoire associative ternaire (TCAM). Pour que le TCAM prenne en charge le Routage à base de règles (PBR), il devrait être formaté en changeant le modèle du Switch Database Management (SDM). Vous devez modifier le modèle SDM, tels qu'il prend en charge 144-bit la couche 3 TCAM. Référez-vous comprennent et configurent le gestionnaire de la base de données de commutation sur des Commutateurs de gamme Catalyst 3550 pour plus d'informations sur SDM.

Remarque: Le Catalyst 3550 a des limites sur les route-map vous commande peut l'utiliser.

Conditions préalables

Conditions requises

Assurez-vous que vous êtes bien informé de ces zones avant que vous tentiez cette configuration :

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Version de logiciel 12.1.19-EA1a de Cisco IOSÝ

  • Cisco Catalyst 3550

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Avant que vous puissiez activer le routage de stratégie, vous devez configurer une de ces commandes en mode de configuration globale, et alors la configuration doit être écrite et le commutateur être rechargée :

  • étendre-correspondance de sdm prefer

  • étendre-correspondance d'accès de sdm prefer

  • sdm prefer conduisant l'étendre-correspondance

CAT3550(config)# access-list 10 permit 20.20.20.0 0.0.0.255
CAT3550(config)# route-map pbr permit 10
CAT3550(config-route-map)# match ip address 10
CAT3550(config-route-map)# set ip next-hop 12.12.12.12

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)#
06:12:31: %L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

CAT3550# show run int vlan 3
Building configuration...

Current configuration : 60 bytes
!
interface Vlan3
ip address 55.55.55.1 255.255.255.0

!--- Command not taken - you need to enable SDM.

end

CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect 
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK] 

ltd-1-2# reload
Proceed with reload? [confirm]

Vous devriez se rendre compte des commandes sans support — référez-vous aux commandes non vérifiées de mappage de route si cette configuration existe :

!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
match ip address 10
set ip default next-hop 12.12.12.12
!

Un message d'erreur est généré si vous essayez de configurer le mappage de route de stratégie sur l'interface :

CAT3550(config)# int vlan 3
CAT3550(config-if)# ip policy route-map pbr
CAT3550(config-if)# end
CAT3550#
00:02:29: %PBR-3-UNSUPPORTED_RMAP: Route-map pbr not supported for Policy-Based Routing

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/47900/cat3550pbr-1.gif

Configurations

Ce document utilise la configuration suivante :

La configuration prend la source de trafic de 20.20.20.X (la liste d'accès 10) et l'envoie à 30.30.30.2 — la configuration ignore la passerelle par défaut réglée à 10.10.10.2.

CAT3550 (Cisco Catalyst 3550)
CAT3550# show running-config 
Building configuration...
.
.
!
interface Vlan1
 ip address 10.10.10.1 255.255.255.0
!
interface Vlan2
 ip address 20.20.20.1 255.255.255.0
 ip policy route-map pbr
!
interface Vlan3
 ip address 30.30.30.1 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 10.10.10.2
ip classless
ip http server
!
!
access-list 10 permit 20.20.20.0 0.0.0.255
route-map pbr permit 10
 match ip address 10
 set ip next-hop 30.30.30.2
!
.
!
end

Quand la commande de set ip next-hop est mise le trafic assorti ne peut pas être vue dans la sortie et c'est un comportement prévu sur un commutateur. C'est parce qu'un commutateur travaille sur le matériel seulement, et les commandes show présentent seulement les informations qui sont traitées en logiciel. Le set ip next-hop fonctionne tout le temps dans le matériel, parce que la table et le processus de routage n'obtiennent jamais vérifié par le commutateur. Il reçoit un paquet et si ce des chutes dans les déclarations de route-map alors il est envoyé directement au prochain saut que vous avez spécifié, sans vérifier la table de routage.

La commande de set ip default next-hop vérifie d'abord la table de routage entière pour voir s'il y a une autre artère à la destination. Si aucune artère n'est trouvée, alors le prochain-saut par défaut est utilisé.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Remarque: Référez-vous aux informations importantes sur les commandes de débogage avant d'utiliser les commandes de débogage.

  • debug ip policy — Affiche les paquets qui sont « stratégie conduite » ou « stratégie rejetée ». Un exemple de la sortie de commande de debug ip policy est :

  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.607: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.607: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.607: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.707: IP: route map pbr, item 10, permit
  *Dec 5 13:33:23.707: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4 (Vlan3),len 100, policy routed
  *Dec 5 13:33:23.707: IP: Vlan2 to Vlan3 30.30.30.1
  *Dec 5 13:33:23.847: IP: s=20.20.20.3 (Vlan2), d=200.200.200.4, len 100, policy match
  *Dec 5 13:33:23.847: IP: route map pbr, item 10, permit

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47900