IP : Protocole OSPF (Open Shortest Path First)

Comment OSPF injecte une route par défaut dans une zone d'extrémité ou une zone d'extrémité totale

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document montre comment Open Shortest Path First (OSPF) injecte un itinéraire par défaut dans une zone de stub ou zone TSA.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/47869/ospfdb10a.gif

Configurations

Ce document utilise les configurations indiquées ici.

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 area 1 stub

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 stub

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • show ip ospf database — Affiche une liste des annonces d'état de liaison (LSA) et les entre dans une base de données d'état de liaison. Cette liste affiche seulement les informations dans l'en-tête LSA.

  • id> récapitulatif de <link-état de show ip ospf database — Affiche les liens récapitulatifs de routeur de cadre de zone (ABR).

  • show ip route — Affiche l'état actuel de la table de routage.

Examinez la base de données OSPF dans une zone d'extrémité

L'ABR pour la zone d'extrémité lance un LSA récapitulatif avec un ID de lien de 0.0.0.0. Il fait ceci même si il n'a pas un default route. Vous pouvez voir ceci se produire avec la commande de show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#           Checksum   Link count 
2.2.2.2    2.2.2.2     19     0x80000001     0x8F8B         1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#           Checksum 
5.0.0.0    2.2.2.2     9       0x80000001     0x8E61 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#           Checksum   Link count 
1.1.1.1    1.1.1.1     1335    0x80000059     0x56DA         2 
2.2.2.2    2.2.2.2     4       0x80000013     0x7FF3         2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     20      0x80000001         0x75C0 
6.0.0.0    2.2.2.2     13      0x80000001         0x2709 


r2.2.2.2#show ip ospf database summary 0.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Summary Net Link States (Area 1) 

  LS age: 184 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 0.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) injects a default route 
  !--- into the stub area. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x75C0 
  Length: 28 
  Network Mask: /0 
        TOS: 0  Metric: 1 
  

r2.2.2.2#show ip route 0.0.0.0 
% Network not in table

!--- The ABR (Router 2.2.2.2) does not have a default route
!--- in its routing table.


r1.1.1.1#show ip route ospf 
O IA 6.0.0.0/8 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:23, Serial2/1/0 

Examinez la base de données OSPF dans totalement une zone d'extrémité

Si vous changez la zone 1 dans l'exemple de zone d'extrémité d'une zone d'extrémité totalement à une zone d'extrémité, l'ABR injecte toujours le LSA récapitulatif de 0.0.0.0 dans la zone 1. La seule différence est que d'autres LSA récapitulatifs ne sont pas envoyés dans totalement la zone d'extrémité.

Remarque: La seule modification de configuration apportée était à l'ABR. La déclaration de NO--résumé a été ajoutée à sa configuration OSPF : NO--résumé de stub de la zone 1.

Cette sortie de commande affiche ce que ressemble à la base de données OSPF dans totalement une zone d'extrémité.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
2.2.2.2    2.2.2.2     617     0x80000001   0x8F8B           1 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
5.0.0.0    2.2.2.2     608     0x80000001   0x8E61 

                Summary ASB Link States (Area 0) 

Link ID   ADV Router   Age     Seq#         Checksum 
1.1.1.1    2.2.2.2     243     0x80000003   0x8F5E 

                Router Link States (Area 1) 

Link ID   ADV Router   Age     Seq#         Checksum     Link count 
1.1.1.1    1.1.1.1     1934    0x80000059   0x56DA           2 
2.2.2.2    2.2.2.2     247     0x80000015   0x7BF5           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age     Seq#               Checksum 
0.0.0.0    2.2.2.2     249     0x80000003         0x71C2  

!--- Notice that this is the only summary LSA 
!--- in the totally stub area. 


r1.1.1.1#show ip route ospf 
O*IA 0.0.0.0/0 [110/65] via 5.0.0.2, 00:04:11, Serial2/1/0 

L'ABR ne lance pas un LSA récapitulatif pour 6.0.0.0/8. En conséquence, le routeur 1.1.1.1 n'a plus une artère pour 6.0.0.0/8. La seule route inter-zone que ce routeur a est le default route.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47869