IP : Protocole OSPF (Open Shortest Path First)

Conversion de la publication à état de liaison OSPF NSSA de type 7 en type 5

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document montre comment Open Shortest Path First (OSPF) convertit une annonce de l'état des liaisons (LSA) NSSA de type 7 en LSA de type 5.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/47867/ospfdb8a.gif

Configurations

Ce document utilise les configurations indiquées ici.

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0

interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
  
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
router ospf 4
 redistribute static metric 5 metric-type 1
 network 5.0.0.0 0.255.255.255 area 1
 network 4.0.0.0 0.255.255.255 area 1
 area 1 nssa
 
ip route 9.0.0.0 255.0.0.0 4.0.0.2

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Serial0/1/0
 ip address 5.0.0.2 255.0.0.0

interface ATM1/0.20
 ip address 6.0.0.2 255.0.0.0
 
router ospf 2
 network 5.0.0.0 0.255.255.255 area 1
 network 6.0.0.0 0.255.255.255 area 0
 area 1 nssa

end

Routeur 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 6.0.0.3 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip ospf database — Affiche une liste du LSAs et les tape dans une base de données d'état de lien. Cette liste affiche seulement les informations dans l'en-tête LSA.

  • show ip ospf database nssa-externe — Affiche des informations seulement au sujet du NSSA LSAs externe.

  • show ip ospf database externe — Affiche des informations uniquement au sujet des LSA externes.

  • show ip ospf database [routeur] [lien-état-id] — affiche une liste de tout le LSAs d'un routeur dans la base de données. LSAs sont produits par chaque routeur, et liens de ces fondamental Routeurs de LSAs liste tous les, ou interfaces, avec les états et les coûts sortants des liens. Ils sont inondés seulement dans la zone de laquelle ils commencent.

  • id> récapitulatif de <link-état de show ip ospf database — Affiche les liens récapitulatifs de routeur de cadre de zone (ABR).

  • show ip route — Affiche l'état actuel de la table de routage.

Examiner la base de données OSPF

Pour voir comment les sembler de base de données OSPF donnés cet environnement de réseau, utilisent la commande de show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router    Age    Seq#           Checksum     Link count 
2.2.2.2    2.2.2.2      1235   0x8000001D     0xD9FF           2 
3.3.3.3    3.3.3.3      1100   0x8000000B     0x9455           2 

                Summary Net Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum 
4.0.0.0    2.2.2.2     1979   0x80000002    0xFDE7 
5.0.0.0    2.2.2.2     1483   0x80000004    0x8864 

                Router Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Link count 
1.1.1.1    1.1.1.1     319    0x8000000C    0xAFA8           3 
2.2.2.2    2.2.2.2     220    0x8000002F    0xD478           2 

                Summary Net Link States (Area 1) 

Link ID   ADV Router   Age    Seq#           Checksum 
6.0.0.0    2.2.2.2     1483   0x8000001C     0x7894 

                Type-7 AS External Link States (Area 1) 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    1.1.1.1     334    0x80000005    0xD738        0 

                Type-5 AS External Link States 

Link ID   ADV Router   Age    Seq#          Checksum     Tag 
9.0.0.0    2.2.2.2     1725   0x80000004    0x50C6        0 

Pour annoncer les artères externes dans un NSSA, le routeur ASBR (Autonomous System Boundary Router) crée LSAs nssa-externe (type 7).

r2.2.2.2#show ip ospf database nssa-external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-7 AS External Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 381 
  Options: (No TOS-capability, Type 7/5 translation, DC)

!--- This can be translated into a type 5 LSA by 
!--- an ABR. 

  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number ) 

!--- The ASBR (Router 1.1.1.1) advertises 
!--- 9.0.0.0/8. 

  Advertising Router: 1.1.1.1

!--- Router ID of the ASBR.
 
  LS Seq Number: 80000005 
  Checksum: 0xD738 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1

!--- Forwarding address is incorrectly specified
!--- as an interface on the ASBR.
 

L'ABR convertit le type 7 LSAs en type 5 LSAs, et propage le type 5 LSAs dans des zones normales.

r2.2.2.2#show ip ospf database external 9.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Type-5 AS External Link States 

  LS age: 1782 
  Options: (No TOS-capability, DC) 
  LS Type: AS External Link 
  Link State ID: 9.0.0.0 (External Network Number )

!--- Router 2.2.2.2 advertises 9.0.0.0/8.
 
  Advertising Router: 2.2.2.2 

!--- When the conversion is complete, the advertising 
!--- router ID becomes the ABR router ID 
!--- because the ABR originates this type 5 LSA. 

  LS Seq Number: 80000004 
  Checksum: 0x50C6 
  Length: 36 
  Network Mask: /8 
        Metric Type: 1 (Comparable directly to link state metric) 
        TOS: 0 
        Metric: 5 
        Forward Address: 4.0.0.1 
        External Route Tag: 0 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  Routing Bit Set on this LSA 
  LS age: 426 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1

!--- For router links, Link State ID is always the same 
!--- as the advertising router (next line). 

  Advertising Router: 1.1.1.1
  LS Seq Number: 8000000C 
  Checksum: 0xAFA8 
  Length: 60 
  AS Boundary Router

!--- Bit E in the router LSA indicates that this router
!--- originates from external LSAs.
 
   Number of Links: 3

!--- There are three links in area 1. 


    Link connected to: a Stub Network

!--- This represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10

!--- The OSPF cost of the Ethernet segment.
 

    Link connected to: another Router (point-to-point) 

!--- Shows that Router 1.1.1.1 is a neighbor with 
	!--- Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1

!--- The interface address that connects to Router
!--- 2.2.2.2 is 5.0.0.1.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the link that connects 
!--- the two routers.

    Link connected to: a Stub Network 

!--- This represents the serial link 5.0.0.0/8.
 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

!--- The OSPF cost of the serial link.

Vous pouvez voir de la sortie grasse ici que bien que le routeur 2.2.2.2 n'en fasse pas redistribuer des déclarations dans sa configuration, c'est toujours un ASBR parce qu'il convertit le type 7 LSAs en type 5 LSAs.

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1361 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001D 
  Checksum: 0xD9FF 
  Length: 48 
  Area Border Router 
  
!--- Bit B is set in the router LSA to indicate
!--- that this router is an ABR.
 
  AS Boundary Router
  
!--- Bit E in the router LSA indicates that this router 
!--- originates from external LSAs.

   Number of Links: 2 
  
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 6.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1

                Router Link States (Area 1) 

  LS age: 346 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000002F 
  Checksum: 0xD478 
  Length: 48 
  Area Border Router 
  AS Boundary Router 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 1245 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 8000000B 
  Checksum: 0x9455 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 6.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Pour annoncer des artères d'une zone dans des autres, l'ABR crée des LSA récapitulatifs (type 3).

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 172 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 4.0.0.0/8 into area 0.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0xFBE8 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 5.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 1687 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 5.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 5.0.0.0/8 into area 0. 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000004 
  Checksum: 0x8864 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 64 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 1697 
  Options: (No TOS-capability, DC) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- The ABR (Router 2.2.2.2) advertises 
!--- 6.0.0.0/8 into area 1.

  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000001C 
  Checksum: 0x7894 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 1 

Les LSA récapitulatifs ASBR ne sont pas nécessaires dans ce cas parce que l'ABR lance le LSA externe, et l'ABR est accessible dans la zone 0. comparent cet exemple à un scénario où le NSSA était une zone normale en regardant l'exemple de base de données comment l'OSPF propage les artères externes dans de plusieurs zones.

Cette sortie de table de routage affiche les différents types d'artères OSPF que 9.0.0.0 est connu en tant que par chaque routeur.

r1.1.1.1#show ip route 9.0.0.0 
Routing entry for 9.0.0.0/8 
  Known via "static", distance 1, metric 0 
  Redistributing via ospf 4 
  Advertised by ospf 4 metric 5 metric-type 1 
  Routing Descriptor Blocks: 
  * 4.0.0.2 
      Route metric is 0, traffic share count is 1

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 01:10:13, Serial0/1/0 
O N1 9.0.0.0/8 [110/79] via 5.0.0.1, 01:07:20, Serial0/1/0 

R3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 6.0.0.2, 02:11:14, ATM2/0.20 
O IA 5.0.0.0/8 [110/65] via 6.0.0.2, 03:10:41, ATM2/0.20 
O E1 9.0.0.0/8 [110/80] via 6.0.0.2, 02:08:11, ATM2/0.20 

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47867