IP : Protocole OSPF (Open Shortest Path First)

Routage OSPF inter-zone

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document traite de la base de données Open Shortest Path First (OSPF) et de la table de routage quand le protocole OSPF fonctionne à travers deux zones.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/47864/ospfdb5a.gif

Configurations

Ce document utilise les configurations suivantes.

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial0/1/0
 ip unnumbered Ethernet0/0/4

interface ATM1/0.20 point-to-point
 ip address 200.0.0.2 255.255.255.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 200.0.0.0 0.255.255.255 area 1

end

Routeur 3.3.3.3
Current configuration:

hostname r3.3.3.3

interface Loopback0
 ip address 3.3.3.3 255.0.0.0

interface ATM2/0.20 point-to-point
 ip address 200.0.0.3 255.255.255.0
 
router ospf 2
 network 200.0.0.0 0.255.255.255 area 1

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip ospf database — Affiche une liste des annonces d'État de lien (LSAs) dans la base de données d'état de lien. Cette liste affiche seulement les informations dans l'en-tête LSA.

  • show ip ospf database [routeur] [lien-état-id] — affiche le contenu du LSA du routeur (LSA de type 1) dans la base de données. Des LSAs du routeur sont produits par chaque routeur, et ces liste fondamentale de LSAs tout le des liens du routeur, ou des interfaces, avec les états et les coûts sortants des liens. Ils sont inondés seulement dans la zone de laquelle ils commencent.

  • id> récapitulatif de <link-état de show ip ospf database — Affiche les liens récapitulatifs de routeur de cadre de zone (ABR).

Examiner la base de données OSPF

Puisque le routeur 2.2.2.2 est l'ABR, il a la base de données pour les deux zones qu'il est connecté à. Cela lui fait le meilleur endroit pour voir la base de données OSPF, utilisant la commande de show ip ospf database.

r2.2.2.2#show ip ospf database

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age    Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      697    0x80000040    0x5A21         2 
2.2.2.2   2.2.2.2      696    0x80000045    0xEE82         2 

                Summary Net Link States (Area 0) 

Link ID     ADV Router   Age  Seq#          Checksum 
200.0.0.0   2.2.2.2      352  0x80000001    0x2546 

                Router Link States (Area 1) 

Link ID   ADV Router Age    Seq#          Checksum   Link count 
2.2.2.2   2.2.2.2    351    0x8000000B    0xCA9D         2 
3.3.3.3   3.3.3.3    354    0x80000006    0x71F7         2 

                Summary Net Link States (Area 1) 

Link ID    ADV Router   Age   Seq#         Checksum 
4.0.0.0    2.2.2.2      689   0x80000001   0xFFE6 
6.0.0.0    2.2.2.2      700   0x80000001   0x63C1 

 r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 773 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created this LSA.

  LS Seq Number: 80000040 
  Checksum: 0x5A21 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that Router 1.1.1.1 is a neighbor 
    !--- with Router 2.2.2.2. 

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
    
 !--- The link is unnumbered, so the address starts with 
	 !--- zero. In the case of unnumbered links, the interface address 
     !--- displays the MIB II IfIndex value that usually starts with 0.
 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
	   
!--- This is the OSPF cost of the link that connects 
       !--- the two routers.
 

    Link connected to: a Stub Network

	!--- This line represents the Ethernet segment 4.0.0.0/8.
 
     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

        Router Link States (Area 0) 

!--- This is the router LSA for 2.2.2.2 in area 0. 


  LS age: 789 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000045 
  Checksum: 0xEE82 
  Length: 48 
  Area Border Router
  
!--- Bit B is set in the router LSA. 
  !--- It indicates that this router is an ABR.
 
   Number of Links: 2
   
!--- There are two links in area 0. 


    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

                Router Link States (Area 1)    
				
!--- This is the router LSA for 
    			!--- Router 2.2.2.2 in area 1. 


  LS age: 445 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 8000000B 
  Checksum: 0xCA9D 
  Length: 48 
  Area Border Router
   Number of Links: 2

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 3.3.3.3 
     (Link Data) Router Interface address: 200.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

r2.2.2.2#show ip ospf database router 3.3.3.3 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 1) 

  LS age: 465 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 3.3.3.3 
  Advertising Router: 3.3.3.3 
  LS Seq Number: 80000006 
  Checksum: 0x71F7 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 200.0.0.3 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 200.0.0.0 
     (Link Data) Network Mask: 255.255.255.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 1 

Pour annoncer des artères d'une zone dans des autres, l'ABR crée les liens récapitulatifs, que vous pouvez voir utilisant la commande récapitulative d'id> de <link-état de show ip ospf database.

r2.2.2.2#show ip ospf database summary 200.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 0) 

  LS age: 487 
  Options: (No TOS-capability, DC, Upward) 

  !--- The Upward keyword indicates that this is not an LSA imported 
  !--- from a VPN backbone (from a PE to a CE).

  LS Type: Summary Links(Network) 
  Link State ID: 200.0.0.0 (summary Network Number)
  
!--- 200.0.0.0/24 is advertised into area 0 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x2546 
  Length: 28 
  Network Mask: /24 
        TOS: 0  Metric: 1 

r2.2.2.2#show ip ospf database summary 4.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 840 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 4.0.0.0 (summary Network Number)
  
!--- 4.0.0.0/8 is advertised into area 1 by 
  !--- the ABR (Router 2.2.2.2).
 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0xFFE6 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 74 

r2.2.2.2#show ip ospf database summary 6.0.0.0 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Summary Net Link States (Area 1) 

  LS age: 861 
  Options: (No TOS-capability, DC, Upward) 
  LS Type: Summary Links(Network) 
  Link State ID: 6.0.0.0 (summary Network Number)
  
!--- 6.0.0.0/8 is advertised into area 1 by the 
  !--- ABR (Router 2.2.2.2). 

  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000001 
  Checksum: 0x63C1 
  Length: 28 
  Network Mask: /8 
        TOS: 0  Metric: 10 

Calculer le plus court chemin

Cette section calcule le plus court chemin de la perspective du routeur 3.3.3.3.

Le routeur 3.3.3.3 regarde dans son propre LSA et voit que le routeur 2.2.2.2 est un voisin. Le routeur 3.3.3.3 regarde alors le LSA du routeur 2.2.2.2's pour vérifier que le routeur 2.2.2.2 voit le routeur 3.3.3.3 en tant que voisin. Si les deux Routeurs se voient comme voisins, ils sont considérés accessibles.

Chaque routeur vérifie également sa table voisine locale (que vous pouvez voir utilisant la commande de show ip ospf neighbor) pour vérifier que les ses et interfaces du voisin sont sur un IP de sous-réseau commun.

Remarque: ce contrôle n'est pas effectué sur une interface non numérotée.

Si les interfaces sont sur un sous-réseau commun, les Routeurs installent des artères pour tous les réseaux de stub répertoriés dans le LSA de leur voisin. Dans cet exemple, 200.0.0.0/24 est le seul réseau de stub répertorié dans le LSA du routeur 2.2.2.2's, auquel le routeur 3.3.3.3 déjà est directement connecté.

Après tout les LSAs du routeur accessibles dans la zone 1 sont examinés, routeur que 3.3.3.3 regarde des LSA récapitulatifs dans la base de données. Il trouve des LSA récapitulatifs pour 4.0.0.0/8 et 6.0.0.0/8. Si le routeur 3.3.3.3 sait atteindre le routeur de la publicité qui a créé le LSA récapitulatif, il installe l'artère dans sa table de routage. Dans cet exemple, le routeur de la publicité est routeur 2.2.2.2. Puisque le routeur 3.3.3.3 sait atteindre le routeur 2.2.2.2, il installe des artères pour 4.0.0.0/8 et 6.0.0.0/8 dans sa table de routage. La mesure pour ces artères est la mesure pour atteindre le routeur de la publicité plus la mesure du LSA récapitulatif. La mesure du LSA récapitulatif est calculée à partir du coût pour atteindre l'intra ou la route inter-zone pour lesquels le LSA récapitulatif est généré.

Remarque: Les Routeurs utilisent le LSA de type 1 pour annoncer les réseaux et d'autres Routeurs auxquels ils sont directement connectés dans une zone, qui est inondée dans la même zone. Ainsi, tous les Routeurs dans la même zone ont les informations topologiques complètes pour leur propre zone. En conséquence, les abr mettent à jour les informations topologiques complètes au sujet de toutes les zones auxquelles ils sont directement reliés. Cependant, quand les abr annoncent un réseau qui appartient à une zone dans une deuxième zone, ils annoncent seulement le préfixe et le masque du réseau à l'aide du LSA Type-3. Les Routeurs dans la deuxième zone ne savent pas les informations topologiques d'autres zones, mais ils ont les informations d'accessibilité pour les réseaux dans d'autres zones.

Cette sortie affiche les artères OSPF dans la table de routage de chaque routeur décrit ci-dessus.

r1.1.1.1# show ip route ospf 
O IA 200.0.0.0/24 [110/65] via 6.0.0.2, 00:09:00, Serial2/1/0 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:14:41, Serial2/1/0 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:09:16, Serial0/1/0 

r3.3.3.3#show ip route ospf
O IA 4.0.0.0/8 [110/75] via 200.0.0.2, 00:09:27, ATM2/0.20 
O IA 6.0.0.0/8 [110/11] via 200.0.0.2, 00:09:27, ATM2/0.20 

Dépannez

Pour les informations sur dépanner l'OSPF quand les informations dans la base de données manquent du Tableau de routage, référez-vous à pourquoi sont quelques artères OSPF dans la base de données mais pas dans le Tableau de routage ? Pour l'information de dépannage générale OSPF, référez-vous dépannage derrière l'OSPF.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47864