IP : Protocole OSPF (Open Shortest Path First)

Routeurs OSPF connectés par un réseau à accès multiple

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document affiche deux Routeurs de Protocole OSPF (Open Shortest Path First) connectés dans un réseau multi-accès.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/47863/ospfdb4a.gif

Configurations

Ce document utilise les configurations indiquées ici.

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Ethernet2/0/2
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Ethernet0/0/2
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Examiner la base de données OSPF

Pour voir comment les sembler de base de données OSPF donnés cet environnement de réseau, regardent la sortie de la commande de show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum  Link count 
1.1.1.1   1.1.1.1     107   0x80000018   0x7966        2 
2.2.2.2   2.2.2.2     106   0x80000015   0x6770        2 

                Net Link States (Area 0) 

Link ID   ADV Router  Age   Seq#         Checksum 
5.0.0.2   2.2.2.2     102   0x80000004   0x7E9D 
  

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 147 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the 
  !--- same as the Advertising Router. 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that created 
  !--- this LSA.
 
  LS Seq Number: 80000018 
  Checksum: 0x7966 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network
    
!--- This router (1.1.1.1) has a link connected to 
    !--- a transit network that has a designated router (DR)
    !--- and backup designated router (BDR) listed here.  

     (Link ID) Designated Router address: 5.0.0.2
	 
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.1
	 
!--- This router's (1.1.1.1) interface address 
     !--- connected to the DR is 5.0.0.1. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The OSPF cost of the link is 10.
 

    Link connected to: a Stub Network 
    
!--- This represents the subnet of the Ethernet segment
    !--- 4.0.0.0/8. 

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
       
!--- The cost of the link is 10. 


r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 162 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000015 
  Checksum: 0x6770 
  Length: 48 
   Number of Links: 2 

    Link connected to: a Transit Network 
     (Link ID) Designated Router address: 5.0.0.2
     
!--- The DR's interface IP address is 5.0.0.2.
 
     (Link Data) Router Interface address: 5.0.0.2
     
!--- Since these values are equal, router
     !--- (2.2.2.2) is the DR. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 
  

r2.2.2.2#show ip ospf database network 5.0.0.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Net Link States (Area 0) 

  Routing Bit Set on this LSA 
  LS age: 182 
  Options: (No TOS-capability, DC) 
  LS Type: Network Links 
  Link State ID: 5.0.0.2 (address of Designated Router)
  
!--- This is the IP address of the DR 
  !--- (not the router ID). 

  Advertising Router: 2.2.2.2
  
!--- This is the router ID of the router that 
  !--- created this LSA.

  LS Seq Number: 80000004 
  Checksum: 0x7E9D 
  Length: 32 
  Network Mask: /8
  
!--- Binary and the DR's interface address with the 
  !--- mask to get to network 5.0.0.0/8. 

        Attached Router: 2.2.2.2
	
!--- The DR's router ID, along with a list of routers 
    !--- adjacent on the transit network. 

        Attached Router: 1.1.1.1 

Calculer le plus court chemin

Cette section calcule l'arbre au chemin le plus court de la perspective du routeur 1.1.1.1.

Le routeur 1.1.1.1 regarde dans son propre LSA et voit qu'il a un lien à un transit network pour lequel 5.0.0.2 est l'adresse de l'interface du DR. Il recherche alors le LSA de réseau avec un ID d'état de lien de 5.0.0.2. Il trouve une liste de Routeurs reliés (Routeurs 1.1.1.1 et 2.2.2.2) dans le LSA de réseau. Ceci implique que tous ces Routeurs sont accessibles par ce transit network. Le routeur 1.1.1.1 peut vérifier que son propre ID est dans la liste. Il alors peut calculer des artères par l'un de ces Routeurs reliés.

Le routeur 1.1.1.1 recherche le LSA du routeur 2.2.2.2's pour vérifier qu'il contient un lien connecté au même transit network, 5.0.0.2. Le routeur 1.1.1.1 peut maintenant installer des artères pour tous les réseaux de stub dans le LSA du routeur 2.2.2.2's.

Le routeur 1.1.1.1 installe une artère pour le réseau 6.0.0.0/8 dans sa table de routage parce que 6.0.0.0/8 ont été répertoriés comme réseau de stub dans son LSA.

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/20] via 5.0.0.2, 00:03:35, Ethernet2/0/2 

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/20] via 5.0.0.1, 00:03:18, Ethernet0/0/2 

La base de données d'état de lien OSPF semble identique si c'est un réseau de diffusion ou un réseau de non-diffusion. La principale différence est le mécanisme voisin de détection. Dans un réseau de diffusion, des voisins sont découverts par des paquets HELLO multicasts. Dans un réseau de non-diffusion, des voisins sont statiquement configurés et des paquets d'unicast bonjour sont envoyés pour former la contiguïté entre les voisins.

Le prochain saut sur des réseaux à accès multiple de Nonbroadcast

Pour explorer la question du prochain saut dans un réseau NBMA (Non-Broadcast Multi-Access), regardez cet exemple. Il y a trois Routeurs sur un transit network (non_DR_a, non_DR_b, et DR de Routeurs). C'est une topologie de hub and spoke sur un support NBMA tel que le Relais de trames, le Mode de transfert asynchrone (ATM), ou le X.25.

/image/gif/paws/47863/ospfdb4b.gif

Quand le non_DR_a de routeur calcule des artères par le non_DR_b de routeur, il fait à non_DR_b de routeur le prochain saut. Cependant, le non_DR_a de routeur n'a pas un circuit virtuel (circuit virtuel) au non_DR_b de routeur, qui signifie que ces Routeurs ne peuvent pas se cingler. L'OSPF installe des artères dans la table de routage avec un prochain-saut qui ne peut pas être atteint.

La solution au problème est d'ajouter une deuxième instruction de mappage de relais de trame pour rendre tous les voisins accessibles par le circuit virtuel allant au Dr. de routeur par exemple :

interface Serial0 
 frame-relay map ip 1.1.1.1 700 broadcast
 
!--- This is a map for the DR. 

 frame-relay map ip 1.1.1.2 700 broadcast
 
!--- This is a map on the same VC data-link connection 
 !--- identifier (DLCI) for a non-DR router. 

Quand vous comparez ce comportement à celui du protocole d'Intermediate System-to-Intermediate System (ISIS), un routeur n'installe pas une artère d'ISIS par un prochain saut, à moins que le prochain saut soit un voisin. Ceci signifie que l'ISIS ne travaille pas à une interface multipoint à moins que les Routeurs soient entièrement engrenés.

L'OSPF installe des artères quoique le prochain saut ne soit pas un voisin, et n'est pas la couche traversante accessible 2. Cependant, vous pouvez réparer ce problème en configurant de plusieurs instructions de mappage.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47863