IP : Protocole OSPF (Open Shortest Path First)

Routeurs OSPF connectés par une liaison point à point numérotée

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document affiche deux Routeurs de Protocole OSPF (Open Shortest Path First) reliés par un lien point par point numéroté.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/47861/ospfdb2a.gif

Configurations

Ce document utilise les configurations indiquées ici.

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.1 255.0.0.0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip address 5.0.0.2 255.0.0.0
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0
 network 5.0.0.0 0.255.255.255 area 0

end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Examiner la base de données OSPF

Pour voir comment les sembler de base de données OSPF donnés cet environnement de réseau, regardent la sortie de la commande de show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router   Age   Seq#          Checksum   Link count 
1.1.1.1   1.1.1.1      522   0x80000002    0x96D3         3 
2.2.2.2   2.2.2.2      401   0x80000003    0x9FC2         3 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 540 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1
  
!--- For router links, the Link State Id is always the same 
  !--- as the Advertising Router (the next line).

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router that  
  !--- created this LSA. 

  LS Seq Number: 80000002 
  Checksum: 0x96D3 
  Length: 60 
   Number of Links: 3 

    Link connected to: another Router (point-to-point)
    
!--- This entry shows that this router (1.1.1.1) is a neighbor
    !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 5.0.0.1
     
!--- Interface on this router (1.1.1.1) which connects the 
     !--- neighbor (2.2.2.2).

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
     	
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the serial link 5.0.0.0/8. 

     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64
		
!--- The OSPF cost of the link is 64.


    Link connected to: a Stub Network
	
!--- This represents the subnet of the 
!--- Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10
		
!--- The OSPF cost of the link is 10.

  

r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

  LS age: 424 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000003 
  Checksum: 0x9FC2 
  Length: 60 
   Number of Links: 3 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 5.0.0.2 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
  
    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 5.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64

Calculer le plus court chemin

Cette section calcule l'arbre au chemin le plus court de la perspective du routeur 2.2.2.2.

Le routeur 2.2.2.2 regarde dans son propre LSA et voit que le routeur 1.1.1.1 est un voisin. Le routeur 2.2.2.2 regarde le LSA du routeur 1.1.1.1's pour vérifier que 1.1.1.1 voit 2.2.2.2 en tant que voisin. Si les deux routeurs se voient comme voisins, ils sont considérés comme accessibles.

Chaque routeur vérifie également sa table voisine locale (vous pouvez la vérifier utilisant la commande de show ip ospf neighbor) pour vérifier que son interface et l'interface du voisin sont sur un IP de sous-réseau commun. S'ils sont, les Routeurs installent des artères pour tous les réseaux de stub répertoriés dans le LSA du routeur de leur voisin.

Dans cet exemple, le routeur 2.2.2.2 installe une artère pour 4.0.0.0/8 dans sa table de routage parce que le routeur 1.1.1.1 a répertorié 4.0.0.0/8 comme réseau de stub dans son propre LSA du routeur. Le routeur 1.1.1.1 a également répertorié 5.0.0.0/8 comme réseau de stub. Cependant, le routeur 2.2.2.2 n'installe pas une artère OSPF pour 5.0.0.0/8 parce qu'elle a une route connectée pour 5.0.0.0/8. Une route connectée est toujours meilleure que dynamiquement une route apprise.

Router 2_2_2_2#
show ip route ospf
 
O    4.0.0.0/8 [110/74] via 5.0.0.1, 00:09:26, Serial0/1/0 

Router 1_1_1_1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 5.0.0.2, 00:00:49, Serial2/1/0 

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 47861