IP : Protocole OSPF (Open Shortest Path First)

Routeurs OSPF connectés par une liaison série non numérotée

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires



Contenu


Introduction

La commande de configuration ip unnumbered vous permet d'activer le traitement d'IP sur une interface série sans lui attribuer une adresse IP explicite. L'interface d'ip unnumbered peut « emprunter » l'adresse IP d'une autre interface qui est déjà configurée sur le routeur. Ceci économise le réseau et l'espace d'adressage. Pour plus d'informations sur la commande d'ip unnumbered, référez-vous à comprendre et à configurer la commande d'ip unnumbered. Ce document montre deux Routeurs de Protocole OSPF (Open Shortest Path First) reliés par une liaison série non-numérotée.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/47860/ospfdb1.gif

Configurations

Ce document utilise les configurations suivantes :

Routeur 1.1.1.1
Current configuration:

hostname r1.1.1.1

interface Loopback0
 ip address 1.1.1.1 255.0.0.0
 
interface Ethernet2/0/0
 ip address 4.0.0.1 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet2/0/0
 
router ospf 1
 network 4.0.0.0 0.255.255.255 area 0

end

Routeur 2.2.2.2
Current configuration:

hostname r2.2.2.2

interface Loopback0
 ip address 2.2.2.2 255.0.0.0
 
interface Ethernet0/0/4
 ip address 6.0.0.2 255.0.0.0
 
interface Serial2/1/0
 ip unnumbered Ethernet0/0/4
 
router ospf 2
 network 6.0.0.0 0.255.255.255 area 0

end

Vérifiez

Cette section fournit des informations pour confirmer que la configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'outil Output Interpreter Tool (clients enregistrés seulement). Ceci vous permet d'afficher une analyse de la sortie de la commande show.

  • show ip ospf database — Affiche une liste des annonces d'État de lien (LSAs) dans la base de données d'état de lien. Cette liste affiche seulement les informations dans l'en-tête LSA.

  • show ip ospf database [routeur] [lien-état-id] — affiche le contenu du LSA du routeur (LSA de type 1) dans la base de données. Des LSAs du routeur sont produits par chaque routeur. Les liens de ces fondamental Routeurs de LSAs liste tous les, ou les interfaces, avec les états et les coûts sortants des liens. Ils sont inondés seulement dans la zone de laquelle ils commencent.

Examiner la base de données OSPF

Pour voir à quoi la base de données OSPF ressemble quand elle est donnée cet environnement de réseau, regardez la sortie de la commande de show ip ospf database.

r2.2.2.2#show ip ospf database 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 

                Router Link States (Area 0) 

Link ID   ADV Router  Age   Seq#           Checksum     Link count 
1.1.1.1   1.1.1.1     254   0x8000001A     0xA6FA           2 
2.2.2.2   2.2.2.2     253   0x80000017     0x4858           2 

r2.2.2.2#show ip ospf database router 1.1.1.1 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 279 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 1.1.1.1   
  
!--- For router links, Link State Id is always the same as the 
  !--- Advertising Router (next line). 

  Advertising Router: 1.1.1.1
  
!--- This is the router ID of the router which created 
  !--- this LSA.

  LS Seq Number: 8000001A 
  Checksum: 0xA6FA 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point)
	
!--- This line shows that this router (1.1.1.1) is a neighbor 
 !--- with 2.2.2.2.

     (Link ID) Neighboring Router ID: 2.2.2.2 
     (Link Data) Router Interface address: 0.0.0.12
		
!--- In the case of unnumbered link, use the MIB II IfIndex  
  !--- value. This value usually starts with 0. 

      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 
	   
!--- This is the OSPF cost of the link that connects 
!--- the two routers.


    Link connected to: a Stub Network 
	
!--- This entry represents the Ethernet segment 4.0.0.0/8.

     (Link ID) Network/subnet number: 4.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10  
	   
!--- This is the OSPF cost of the Ethernet segment. 



r2.2.2.2#show ip ospf database router 2.2.2.2 

       OSPF Router with ID (2.2.2.2) (Process ID 2) 
  

                Router Link States (Area 0) 

  LS age: 295 
  Options: (No TOS-capability, DC) 
  LS Type: Router Links 
  Link State ID: 2.2.2.2 
  Advertising Router: 2.2.2.2 
  LS Seq Number: 80000017 
  Checksum: 0x4858 
  Length: 48 
   Number of Links: 2 

    Link connected to: another Router (point-to-point) 
     (Link ID) Neighboring Router ID: 1.1.1.1 
     (Link Data) Router Interface address: 0.0.0.10 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 64 

    Link connected to: a Stub Network 
     (Link ID) Network/subnet number: 6.0.0.0 
     (Link Data) Network Mask: 255.0.0.0 
      Number of TOS metrics: 0 
       TOS 0 Metrics: 10 

Calculer le plus court chemin

Cette section calcule l'arbre au chemin le plus court de la perspective du routeur 2.2.2.2.

Le routeur 2.2.2.2 regarde dans son propre LSA et voit que le routeur 1.1.1.1 est un voisin. Il regarde alors le LSA du routeur 1.1.1.1's pour vérifier que 1.1.1.1 voit 2.2.2.2 en tant que voisin. Si les deux Routeurs se voient comme voisins, ils sont considérés accessibles. Les Routeurs installent alors des artères pour tous les réseaux de stub répertoriés dans le LSA de leur voisin.

Dans cet exemple, le routeur 2.2.2.2 installe une artère pour 4.0.0.0/8 dans sa table de routage parce que le routeur 1.1.1.1 répertorie 4.0.0.0/8 comme réseau de stub dans son LSA. Ceci est vu avec l'aide de la commande OSPF de show ip route.

r2.2.2.2#show ip route ospf 
O    4.0.0.0/8 [110/74] via 4.0.0.1, 00:06:01, Serial0/1/0 

r1.1.1.1#show ip route ospf 
O    6.0.0.0/8 [110/74] via 6.0.0.2, 00:06:16, Serial2/1/0 

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 47860