Commutation multiprotocole par étiquette (MPLS) : Commutation multiprotocole par étiquette pour VPN (MPLS pour VPN)

Fuite de routage dans les réseaux MPLS/VPN

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit des exemples de configurations pour les fuites de routage dans un environnement MPLS/VPN.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Ceci sectionne contient ces exemples de deux configurations :

  • Conduisez la fuite d'une table de routage globale dans un routage VPN/instance de transfert (VRF) et conduisez la fuite d'un VRF dans une table de routage globale

  • Artère coulant entre différents vrf

Remarque: Pour trouver les informations complémentaires au sujet des commandes dans ce document, utilisez le Command Lookup Tool (clients enregistrés seulement).

Artère coulant d'un Tableau de routage global dans un VRF et artère coulant d'un VRF dans un Tableau de routage global

Cette configuration décrit l'artère coulant d'une table de routage globale dans un VRF et l'artère coulant d'un VRF dans une table de routage globale.

Diagramme du réseau

Cette configuration utilise cette configuration réseau :

/image/gif/paws/47807/routeleaking_01.gif

Configuration

Dans cet exemple, une station du système d'administration de réseaux (NMS) située dans un VRF est accédée à de la table de routage globale. Les Routeurs de Provider Edge (PE) et les Routeurs du fournisseur (p) doivent exporter les informations de NetFlow à une station NMS (10.0.2.2) dans un VRF. 10.0.2.2 est accessible par l'intermédiaire d'une interface de VRF sur PE-4.

Pour accéder à 10.0.2.0/30 de la table globale, une artère statique à 10.0.2.0/30 qui précise de l'interface de VRF est introduite sur le PE-4. Cette artère statique est alors redistribuée par l'intermédiaire du Protocole IGP (Interior Gateway Protocol) à tout le PE et à Routeurs P. Ceci s'assure que tout le PE et Routeurs P peuvent atteindre 10.0.2.0/30 par l'intermédiaire de PE-4.

Une artère statique de VRF est également ajoutée. Les points d'acheminement statiques de VRF au sous-réseau dans le réseau global qui envoie le trafic à cette station NMS. Sans cet ajout, les baisses PE-4 trafiquent, de la station NMS, qui est reçue sur l'interface de VRF ; et le PE-4 envoie l'ICMP : message inaccessible récepteur d'hôte à la station NMS.

Cette section utilise cette configuration :

PE-4
!
ip cef
!
ip vrf vpn2
rd 200:1
route-target export 200:1
route-target import 200:1
!
interface Serial1/0
ip address 10.1.2.5 255.255.255.252
no ip directed-broadcast
!
interface Serial2/0
ip vrf forwarding vpn2
ip address 10.0.2.1 255.255.255.0
no ip directed-broadcast
!
ip classless
ip route 10.0.2.0 255.255.255.252 Serial2/0
ip route vrf vpn2 10.1.2.4 255.255.255.252 Serial1/0
!

Les artères statiques peuvent maintenant être redistribuées dans n'importe quel IGP pour être sur l'ensemble du réseau annoncé. Le même s'applique si l'interface de VRF est une interface de RÉSEAU LOCAL (par exemple, des Ethernets). La commande de configuration exacte pour celle est :

ip route 10.0.2.0 255.255.255.252 Ethernet2/0 10.0.2.2

Remarque: L'adresse IP configurée après que le nom d'interface soit seulement utilisé par Protocole ARP (Address Resolution Protocol), pour savoir quelle adresse pour résoudre.

Remarque: Pour des Commutateurs de gamme 4500, vous devez configurer les entrées statiques d'ARP dans les tables de VRF pour les adresses du prochain saut respectives.

Remarque: Par défaut, le logiciel de ½ du ¿  de Cisco IOSï reçoit les artères statiques de VRF comme configurées. Ceci pourrait compromettre la Sécurité parce qu'il pourrait introduire l'artère coulant entre différents vrf. Vous ne pouvez utiliser l'aucune commande d'ip route static inter-vrf d'empêcher l'installation de telles artères statiques de VRF. Référez-vous au Réseaux privés virtuels (VPN) MPLS pour plus d'informations sur l'aucune commande d'ip route static inter-vrf.

Vérifiez

Cette section fournit des informations pour confirmer que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ip route 10.0.2.0 — Affiche une adresse IP spécifiée conduisant l'entrée.

  • show ip route vrf vpn2 10.1.2.4 — Affiche une entrée de routage de VRF d'adresse IP spécifiée.

PE-4# show ip route 10.0.2.0

Routing entry for 10.0.2.0/30
Known via "static", distance 1, metric 0 (connected)
Routing Descriptor Blocks:
* directly connected, via Serial2/0
Route metric is 0, traffic share count is 1

PE-4# show ip route vrf vpn2 10.1.2.4

Routing entry for 10.1.2.4/30
Known via "static", distance 1, metric 0 (connected)
Redistributing via bgp 1
Advertised by bgp 1
Routing Descriptor Blocks:
* directly connected, via Serial1/0
Route metric is 0, traffic share count is 1

Artère coulant entre différents vrf

Cette configuration décrit l'artère coulant entre différents vrf.

Diagramme du réseau

Cette configuration utilise ce schéma de réseau :

/image/gif/paws/47807/routeleaking_02.gif

Configuration

Vous ne pouvez pas configurer deux artères statiques pour annoncer chaque préfixe entre les vrf, parce que cette méthode n'est pas prise en charge — des paquets ne seront pas conduits par le routeur. Pour réaliser l'artère coulant entre les vrf, vous devez utiliser la fonctionnalité d'importation du route-target et du Protocole BGP (Border Gateway Protocol) d'enable sur le routeur. Aucun voisin BGP n'est prié.

Cette section utilise cette configuration :

PE-4
!
ip vrf vpn1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 route-target import 200:1
!
ip vrf vpn2
 rd 200:1
 route-target export 200:1
 route-target import 200:1
 route-target import 100:1
!
interface Serial1/0
 ip vrf forwarding vpn1
 ip address 10.1.2.5 255.255.255.252
 no ip directed-broadcast
!
interface Serial2/0
 ip vrf forwarding vpn2
 ip address 10.0.2.1 255.255.255.0
 no ip directed-broadcast
router bgp 1
!
address-family ipv4 vrf vpn2
 redistribute connected
 !
address-family ipv4 vrf vpn1
 redistribute connected
!

Vérifiez

Cette section fournit des informations pour dépanner votre configuration.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • le show ip bgp vpnv4 affiche entièrement tous les préfixes VPNv4 qui sont appris par l'intermédiaire du BGP.

PE-4# show ip bgp vpnv4 all

BGP table version is 13, local router ID is 7.0.0.4
Status codes: s suppressed, d damped, h history, * valid,
> best, i - internal, r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 100:1 (default for vrf vpn1)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?
Route Distinguisher: 200:1 (default for vrf vpn2)
*> 10.0.2.0/24 0.0.0.0 0 32768 ?
*> 10.1.2.4/30 0.0.0.0 0 32768 ?

Remarque: L'autre manière de couler des artères entre les vrf est de connecter ensemble deux interfaces Ethernet sur le routeur PE-4 et d'associer chaque interface Ethernet avec un des vrf. Vous devez également configurer les entrées statiques d'ARP dans les tables de VRF pour les adresses du prochain saut respectives. Cependant, ce n'est pas une solution recommandée pour l'artère coulant entre les vrf ; la technique précédemment décrite BGP est la solution recommandée.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 47807