IP : Integrated Intermediate System-to-Intermediate System (IS-IS)

Problème de non-correspondance MTU dans IS-IS

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Des hellos de Protocole IS-IS (Intermediate System-to-Intermediate System) sont complétés à la pleine taille de Maximum Transmission Unit (MTU). L'avantage de compléter IS-IS Hellos (IIHs) au plein MTU est qu'il tient compte du dépistage précoce des erreurs dues aux problèmes de transmission avec de grandes trames ou dues aux mtu mal adaptés sur les interfaces adjacentes.

La remplissage d'IIHs peut être arrêtée (dans des versions de logiciel 12.0(5)T et 12.0(5)S de½ de¿Â de Cisco IOSïÂ) pour toutes les interfaces sur un routeur avec l'aucune commande de hello padding dans le mode de configuration du routeur pour le processus de routage IS-IS. La remplissage d'IIHs peut être sélectivement arrêtée pour le Point à point ou les interfaces multipoints avec l'aucun hello padding multipoint ou aucune commande point par point de hello padding dans le mode de configuration du routeur pour le processus de routage IS-IS. Le hello padding peut également être arrêté sur une base d'interface individuelle utilisant l'aucune commande de configuration d'interface d'isis hello padding.

Un utilisateur désactiverait le hello padding dans la commande évitent de gaspiller la bande passante de réseau au cas où le MTU des deux interfaces seraient le même ou, en cas de pontage translationnel. Tandis que le hello padding est désactivé, les Routeurs de Cisco envoient toujours les cinq premiers hellos IS-IS complétés à la pleine taille de MTU. C'est de mettre à jour les avantages de découvrir des non-concordances de MTU. Des hellos consécutifs ne sont plus complétés.

Ce document explique ce qui se produit quand il y a une non-concordance de MTU sur les interfaces de deux routeurs connectés exécutant l'IS-IS. Le MTU sur le routeur F a été changé de sa valeur par défaut de 1500 octets à 2000 octets avec la commande 2000 de configuration d'interface de mtu. L'interface série « a été agitée. » Par conséquent, pour que la nouvelle valeur de MTU la prenne effet, vous devez désactiver l'interface série 0 avec la commande shutdown, et puis l'activez avec l'aucune commande shutdown.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Problème

Le schéma de réseau et les configurations utilisés pour décrire ce problème sont affichés ici :

/image/gif/paws/47201/isis_mtu_01.gif

Routeur H Routeur F
clns routing
 !

 interface Serial0
  no ip address
  no ip directed-broadcast
  no ip mroute-cache
  encapsulation frame-relay
  frame-relay lmi-type ansi
 !
 interface Serial0.1 

  ip address 10.10.10.4 255.255.255.0
  no ip directed-broadcast
  ip router isis  
  clns router isis 
  frame-relay map clns 132 broadcast
  frame-relay map clns 131 broadcast
  frame-relay map ip 10.10.10.1 132 broadcast
  frame-relay map ip 10.10.10.3 131 broadcast
 !
 interface Serial0.2 point-to-point
  ip address 10.20.20.4 255.255.255.0
  no ip directed-broadcast
  ip router isis 
  clns router isis 
  frame-relay interface-dlci 130   
 !
 router isis 
  passive-interface Ethernet0
  net 49.0001.4444.4444.4444.00
  is-type level-1
clns routing

!
interface Serial2
mtu 2000
 no ip address
 no ip directed-broadcast
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial2.1 point-to-point
 ip address 10.20.20.2 255.255.255.0
 no ip directed-broadcast
 ip router isis 
 clns router isis 
 frame-relay interface-dlci 103   
!
router isis 
 net 49.0001.2222.2222.2222.00
 is-type level-1

Sur les deux Routeurs, vous pouvez voir l'état de la contiguïté entre le routeur F et le routeur H avec l'ordre de show clns neighbors. Dans la sortie du routeur F, notez que la contiguïté avec le routeur H est dans l'état Init. Dans la sortie du routeur H, vous pouvez voir que la contiguïté avec le routeur que F est type EST, et le protocole est extrémité Système-au système intermédiaire (ES-IS). Cette sortie indique qu'il y a un problème avec la contiguïté sans connexion de service réseau (CLNS).

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     294       IS   ES-IS
Router_G       DLCI 131            Se0.1       Up     7         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     27        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Init   26        L1   IS-IS

Si vous activez l'élimination des imperfections de contiguïté-paquet IS-IS avec le debug isis adj packets commandez, vous pouvez voir que le routeur F envoie et reçoit IIHs séquentiel sur la sous-interface de l'interface série 2.1.

Router_F# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1, cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Rec serial IIH from DLCI 103 (Serial2.1), cir type L1,cir id 00
ISIS-Adj: rcvd state DOWN, old state INIT, new state INIT
ISIS-Adj: Action = GOING UP, new type = L1
ISIS-Adj: Sending serial IIH on Serial2.1

Cette sortie prouve que le routeur H ne reçoit pas IIHs sur l'interface série 0.2 du routeur F. Par conséquent, aucune contiguïté IS-IS n'est formée. Au lieu de cela, la contiguïté est le système d'extrémité (es).

Router_H# debug isis adj-packets
IS-IS Adjacency related packets debugging is on
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Sending L1 IIH on Serial0.1
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01
ISIS-Adj: Rec L2 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01 
ISIS-Adj: Sending serial IIH on Serial0.2
ISIS-Adj: Rec L1 IIH from DLCI 132 (Serial0.1), cir type 3, cir id Router_H.01
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01 
ISIS-Adj: Rec L1 IIH from DLCI 131 (Serial0.1), cir type 1, cir id Router_H.01

La cause du problème

Le routeur H ne reçoit pas les hellos du routeur F parce qu'IIHs sont complétés au plein MTU du lien, tandis que des hellos es ne sont pas complétés à la pleine taille de MTU. Ceci se produit parce que le routeur F pense que le MTU est 2000, et il envoie un 2000-octet bonjour, qui est ignoré par le routeur H.

Solution

La solution est de s'assurer que les deux côtés d'un lien ont le même MTU. Une manière de faire ceci est d'utiliser la commande de mtu comme affiché ici :

Router_F# configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)# interface serial 2
Router_F(config-if)# mtu 1500
Router_F(config-if)# shutdown
Router_F(config-if)# no shutdown
Router_F(config-if)# ^Z
Router_F#

Maintenant le routeur H et le routeur F peuvent devenir des voisins et conduire le trafic de chacun.

Router_H# show clns neighbors

System Id      SNPA                Interface   State  Holdtime  Type Protocol
Router_F       DLCI 130            Se0.2       Up     28        L1   IS-IS
Router_G       DLCI 131            Se0.1       Up     8         L1   IS-IS
Router_E       DLCI 132            Se0.1       Up     29        L1   IS-IS


Router_F# show clns neighbors

System Id      Interface   SNPA                State  Holdtime  Type Protocol
Router_H       Se2.1       DLCI 103            Up     24        L1   IS-IS

Le problème de contiguïté de CLNS dû à la non-concordance de MTU peut également être résolu utilisant la commande de clns mtu comme affiché ici :

Router_F#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Router_F(config)#interface serial2
Router_F(config-if)#clns mtu 1500
Router_F(config-if)#^Z
Router_F#

Informations connexes


Document ID: 47201