Services de mise en réseau d'applications : Cisco LocalDirector de la gamme 400

Configuration de la redirection HTTP sur LocalDirector lors de la vérification de la disponibilité du serveur

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Cisco a annoncé l' interruption de vente pour Cisco LocalDirector. Le pour en savoir plus, se rapportent aux notices de fin de vie et de fin de commercialisation de gamme 400 de LocalDirector et à des bulletins de produit.


Contenu


Introduction

Ce document décrit comment configurer la redirection de Protocole HTTP (Hypertext Transfer Protocol) qui te permet pour vérifier la disponibilité du serveur sur le Cisco LocalDirector. La redirection HTTP exige également des adresses IP supplémentaires pour que les adresses directes IP (IMMERSION) tiennent compte d'appeler direct/parcourant.

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel ci-dessous.

  • LocalDirector 416 dans un environnement de travaux pratiques avec des configurations effacées.
  • Version de logiciel 4.2.1 de LocalDirector
  • Microsoft Internet Explorer 5.5
  • Netscape Communicator 4.7

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous fonctionnez dans un réseau vivant, assurez-vous que vous comprenez l'impact potentiel de n'importe quelle commande en fonction avant de l'utiliser.

Diagramme du réseau

Comment configurer la redirection HTTP pour vérifier la disponibilité du serveur

Employez les étapes suivantes pour configurer votre LocalDirector :

  1. Créez un enregistrement « A » pour ce qui suit :
    test.testdomain.com <-> 172.18.124.209 VIP
    ns-ms1-dip.testdomain.com <-> 172.18.124.212 DIP 
    ns-ms2-dip.testdomain.com <-> 172.18.124.211 DIP
    ns-ms1.cisco.com <-> 172.18.124.207 REAL 
    ns-ms2.cisco.com <-> 172.18.124.206 REAL
    172.18.124.211 DIP virtual for 172.18.124.206 REAL (aka s2)
    172.18.124.212 DIP virtual for 172.18.124.207 REAL (aka s1)
    

    Remarque: Vous avez besoin d'IP virtuel de port-limite (VIP), d'IMMERSION, et de vraies adresses, mais vous avez besoin également de deux adresses IP pour chaque vraie adresse pour les connexions sortantes au vrai serveur toujours pour être permises. Ceci tient compte des VIPs sûrs avec une remise envoyée pour de mauvais ports. Il tient compte également d'autre appelle aux immersions pour être livré directement par l'adresse vraie tout en utilisant les adresses IP alternatives pour l'adresse virtuelle de l'IMMERSION.

  2. Créez l'adresse de VIP a (port-limite). Il devrait y a une entrée record « A » dans le Système de noms de domaine (DNS).
    virtual 172.18.124.209:80:0:tcp is 
    
  3. Créez une IMMERSION pour chaque « vrai serveur » qui recevra des appels pour cette adresse de VIP. Utilisez « un numéro IP supplémentaire » dans la première partie de la déclaration.
    direct-ip 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp is
    direct-ip 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp is
    
    Le système créera le suivant pour vous :
    real 172.18.124.207:80:0:tcp is
    real 172.18.124.206:80:0:tcp is
    bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
    bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
    
  4. Créez une redirection de l'uniform resource locator (URL) pour chaque vrai serveur. C'est où le client sera réorienté quand ils frappent le VIP.
    url s2 http://ns-ms2-dip.testdomain.com/%p 302
    url s1 http://ns-ms1-dip.testdomain.com/%p 302
    

    Remarque: Le « %p » dénote la page.

  5. Créez une Commande BACKUP pour chaque IMMERSION au VIP commun. Ceci résout le problème bookmarking. Si un client bookmarks un URL d'une IMMERSION, et si cette IMMERSION (vrai serveur) n'est pas disponible (il est soulevée comme MANQUÉ), alors elle utilisera la Commande BACKUP de faire appeler au client le VIP de nouveau.
    backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
    backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
    

    Remarque: La redirection HTTPS utilise la sauvegarde différemment.

  6. Liez le VIP à chaque commande URL.

    bind 172.18.124.209:80:0:tcp s2
    bind 172.18.124.209:80:0:tcp s1
    
  7. Créez une commande de lien pour chaque URL à la première partie de l'IMMERSION. Ceci crée une association entre l'IMMERSION et l'URLs associés avec ce surnom (par exemple, S1). La commande de lien s'assure que si une IMMERSION est manquée, alors le LocalDirector ne réorientera pas des clients à l'URL qui appellerait cette IMMERSION défectueuse (qui est linéaire tracé avec une vraie adresse IP).
    link s2 172.18.124.211:80:0:tcp
    link s1 172.18.124.212:80:0:tcp
    

commandes show et sortie témoin

commande show version

La commande de show version affiche l'exécution de version de logiciel sur le LocalDirector.

localdirector# show version
LocalDirector 416 Version 4.2.1

affichez la commande de configuration

La commande de configuration d'exposition affiche la configuration en cours d'exécution sur le LocalDirector.

localdirector# show configuration
: Saved
: LocalDirector 416 Version 4.2.1
syslog output 20.7
no syslog console
enable password 000000000000000000000000000000 encrypted
hostname localdirector
no shutdown ethernet 0
no shutdown ethernet 1
no shutdown ethernet 2
interface ethernet 0 auto
interface ethernet 1 auto
interface ethernet 2 auto
mtu 0 1500
mtu 1 1500
mtu 2 1500
multiring all
no secure  0
no secure  1
no secure  2
ping-allow 0
ping-allow 1
no ping-allow 2
ip address 172.18.124.210 255.255.255.0
route 0.0.0.0 0.0.0.0 172.18.124.1 1
arp timeout 30
no rip passive
rip version 1
failover ip address 0.0.0.0
no failover
failover hellotime 30
password dfeaf10390e560aea745ccba53e044ed encrypted
telnet 172.18.124.0 255.255.255.0
telnet 64.105.0.0 255.255.0.0
snmp-server enable traps
snmp-server community public
no snmp-server contact
no snmp-server location
virtual 172.18.124.209:80:0:tcp is
predictor 172.18.124.209:80:0:tcp roundrobin
real 172.18.124.207:80:0:tcp is
real 172.18.124.206:80:0:tcp is
direct-ip 172.18.124.211:80:0:tcp   172.18.124.206:80:0:tcp is
direct-ip 172.18.124.212:80:0:tcp   172.18.124.207:80:0:tcp is
url s2 http://ns-ms2-dip.testdomain.com/%p 302
url s1 http://ns-ms1-dip.testdomain.com/%p 302
backup 172.18.124.211:80:0:tcp 172.18.124.209:80:0:tcp
backup 172.18.124.212:80:0:tcp 172.18.124.209:80:0:tcp
bind 172.18.124.211:80:0:tcp 172.18.124.206:80:0:tcp
bind 172.18.124.212:80:0:tcp 172.18.124.207:80:0:tcp
bind 172.18.124.209:80:0:tcp s2
bind 172.18.124.209:80:0:tcp s1
link s2 172.18.124.211:80:0:tcp
link s1 172.18.124.212:80:0:tcp

affichez la commande de statistiques

La commande de statistiques d'exposition affiche statistiques les vraies et de serveur virtuel.

localdirector(config)# show statistics
          Real Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.207:80:0:tcp           1092            8             2
(DIP) 172.18.124.206:80:0:tcp            960            7             1


       Virtual Machine(s)              Bytes      Packets   Connections
(DIP) 172.18.124.211:80:0:tcp            960            7             1
(DIP) 172.18.124.212:80:0:tcp           1092            8             1
  172.18.124.209:80:0:tcp               3296           26             2
localdirector(config)#

affichez la commande URL

La commande URL d'exposition affiche les informations de connexion à l'URLs.

localdirector(config)# show url
Urls:

             Id  Connect    Rcode   State                     Url
             s2        1      302     IS http://ns-ms2-dip.testdomain.com/%p
             s1        0      302     IS http://ns-ms1-dip.testdomain.com/%p
localdirector(config)#

commande de show syslog

La commande de show syslog affiche les informations de journalisation (telles que la date, le temps, le niveau, et la sortie) :

<165> May 30 11:35:14 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:24 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from In Service to Out Of Service.
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.207:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:28 LD-NOTICE Real machine '172.18.124.206:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:35:28 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'leastconns' to 'slowstart'
<165> May 30 11:35:34 LD-NOTICE Virtual machine '172.18.124.209:80:0:tcp': 
Edited from Out Of Service to In Service.
<162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp' 
from 'slowstart' to 'leastconns'
<162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp' 
from 'slowstart' to 'leastconns'
  

Vérifier la configuration

Utilisez les commandes suivantes de vérifier la configuration :

  • exposition vraie - Affiche des vrais les statistiques et les états serveurs.

  • exposition virtuelle - Affiche une liste de serveurs virtuels, de leurs états, de nombre de connexions, et d'algorithmes d'équilibrage de charge.

  • statistiques d'exposition - Voir ci-dessus.

Dépannez la configuration

commande de Syslog

Le Syslog [IP d'hôte | console | la commande de la sortie facility.level] peut être utilisée pour mettre au point ou dépanner.

Dans cet exemple, http://test.testdomain.com est réorienté à http://ns-ms2-dip.testdomain.com/.

Ce qui suit est sortie témoin de console de Syslog et le Syslog a sorti 20.7 :

localdirector(config)# syslog console
localdirector(config)# <162> May 30 11:36:23 LD-CRIT Switching '172.18.124.212:80:0:tcp'
 from 'slowstart' to 'leastconns'
localdirector(config)# <162> May 30 11:41:24 LD-CRIT Switching '172.18.124.211:80:0:tcp'
 from 'slowstart' to 'leastconns'



Informations connexes



Document ID: 46222