Réseaux de stockage : Commutateurs multicouches de la gamme Cisco MDS 9000

Exemple de configuration de FC Analyzer et SPAN pour commutateurs MDS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Semblable à la ligne de produit pour routeur de Cisco mettez au point la capacité, les commutateurs de stockage de Cisco MDS ont un analyseur de la Manche de fibre (FC) pour examiner des paquets. L'analyseur FC examine des paquets à et des entités que le commutateur fournit. L'analyseur FC peut mettre au point des trames que le commutateur est responsable de la réception ou de l'envoi à un périphérique de stockage. Des vues entre les stations d'extrémité ne peuvent pas être examinées par l'analyseur FC.

Pour examiner l'écoulement de session, la fonctionnalité de Fonction Switched Port Analyzer (SPAN) des Commutateurs MDS devrait être utilisée. Tout comme la fonction d'ENVERGURE sur un commutateur ethernet de Cisco, l'ENVERGURE sur la gamme de produits MDS réplique des données POUR RÉPARTIR des destinations port, de sorte qu'elle puisse être collectée par un périphérique de tiers.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Commutateur du Cisco MDS 9216

  • Commutateur du Cisco MDS 9509

  • Les deux système d'exploitation de réseaux de stockage de passage (SAN-OS) 1.2.1a.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Théorie générale

Vous devez savoir quand utiliser l'outil d'analyseur FC et quand utiliser la caractéristique d'ENVERGURE.

L'analyseur FC est un outil qui collecte les trames qui sont destinées à ou proviennent du superviseur MDS. le trafic de Noeud-à-commutateur ou de commutateur à commutateur peut être vu avec cet outil.

L'ENVERGURE est une caractéristique qui permet les trames qui sont passagères au commutateur à copier sur un deuxième port pour l'analyse. le trafic de Noeud-à-noeud peut être vu avec cette méthode.

Référez-vous à ce diagramme pour une illustration :

/image/gif/paws/46220/analyze_span_1.gif

Le show traffic vert de flèches qui peut être tracé avec l'outil d'analyseur FC, alors que les expositions roses de flèche trafiquent qui peuvent être capturées avec la méthode d'ENVERGURE. On ne peut pas observer le trafic de l'hôte à la mémoire par l'analyseur FC. Seulement le trafic de l'hôte au commutateur ou du commutateur du côté droit peut être vu, quand vous exécuter l'analyseur FC sur le commutateur du côté gauche.

L'ENVERGURE peut être utilisée pour tracer le trafic dans (d'entrée) et (de sortie) de n'importe quel port sur le commutateur. Le Remote SPAN (RSPAN), suivant les indications du diagramme précédent, peut être utilisé pour collecter des trames dans et hors du port de hôte sur le commutateur gauche, avec l'analyseur relié au commutateur de côté droit.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Configurer l'analyseur local FC

/image/gif/paws/46220/analyze_span_2.gif

Remarque: L'intention est de collecter les trames FC dont provenez, ou est destinée à, le superviseur 9612. Des vues de l'hôte à JBOD ne sont pas collectées avec l'outil d'analyseur FC.

Des gens du pays d'analyseur FC sont exécutés de l'interface de ligne de commande (CLI) par l'intermédiaire de la connexion ou du telnet de console. Vous pouvez exécuter un bref affichage pour afficher seulement une petite partie de chaque trame, ou vous pouvez exécuter un suivi détaillé pour afficher la trame entière.

Le suivi est commencé tandis que dans le mode de configuration, et il est arrêté quand vous appuyez sur le CTRL-C. Par défaut, seulement 100 trames sont capturées. Pour capturer plus de 100 trames, ajoutez l'option de commande de limite-capturer-trames à la commande que vous utilisez pour commencer le suivi.

Vous pouvez également utiliser un filtre d'affichage pour limiter la sortie du suivi seulement aux trames spécifiques.


!--- VSAN 13 (0xd) is used here as example.

MDS9216# show fcdomain domain-list vsan 13
 
Number of domains: 2
Domain ID              WWN
---------    -----------------------
0x66(102)    20:0d:00:05:30:00:47:9f [Local] [Principal]
0x6b(107)    20:0d:00:05:30:00:51:1f

MDS9216# show fcns data vsan 13

VSAN 13:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x6600dc    NL    21:00:00:20:37:15:a2:49 (Seagate)       scsi-fcp:target
0x6600e0    NL    21:00:00:04:cf:6e:4a:8c (Seagate)       scsi-fcp:target
0x6600e1    NL    21:00:00:04:cf:6e:37:8b (Seagate)       scsi-fcp:target
0x660101    NL    10:00:00:01:73:00:81:82 (JNI)
0x660201    N     10:00:00:05:30:00:47:9f (Cisco)         ipfc
0x6b0001    N     10:00:00:05:30:00:51:23 (Cisco)         ipfc

Total number of entries = 6

!--- Configure FC analyzer for brief output.

MDS9216# config t

Enter configuration commands, one per line.  End with CNTL/Z.

MDS9216(config)# fcanalyzer local brief display-filter mdshdr.vsan==0xd

Capturing on eth2
  0.000000     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.000095     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 18.721559     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 18.721879     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 19.970287     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 19.970368     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 38.941558     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 38.941849     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 39.940546     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 39.940628     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1

Dans l'exemple suivant, vous avez les mêmes données. Cette fois, cependant, la brève option est omise de la commande, de fournir une vue détaillée de chaque paquet.

MDS9216(config)# fcanalyzer local display-filter mdshdr.vsan==0xd

Capturing on eth2
Frame 1 (100 bytes on wire, 100 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:18.310251000
    Time delta from previous packet: 0.000000000 seconds
    Time relative to first packet: 0.000000000 seconds
    Frame Number: 1
    Packet Length: 100 bytes
    Capture Length: 100 bytes
Ethernet II, Src: 00:00:00:00:00:0a, Dst: 00:00:00:00:ee:00
    Destination: 00:00:00:00:ee:00 (00:00:00:00:ee:00)
    Source: 00:00:00:00:00:0a (00:00:00:00:00:0a)
    Type: Unknown (0xfcfc)
Vegas (FC, SOFf/EOFn)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 70
        TTL: 255
        0111 .... = User Priority: 7
        .... 0000 0010 11.. = Dst Index: 0x000b
        .... ..00 1111 1111 = Src Index: 0x00ff
        Ctrl Bits: Index Directed frame (0x01)
        Timestamp: 42678
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 0
    Vegas Trailer
        EOF: EOFn (3)
        CRC: 4022250974
Fibre Channel
    R_CTL: 0x02
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: SW_ILS (0x22)
    F_CTL: 0x380000 (Exchange Originator, Seq Initiator, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Abort/MS, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1eb4
    RX_ID: 0xffff
    Parameter: 0x00000000
SW_ILS
    Cmd Code: HLO (0x14)
    FSPF Header
        Version: 0x02
        AR Number: 0x00
        Authentication Type: 0x00
        Originating Domain ID: 102
        Authentication: 0000000000000000
    Options: 00000000
    Hello Interval (secs): 20
    Dead Interval (secs): 80
    Recipient Domain ID: 107
    Originating Port Idx: 0x01000b

Frame 2 (60 bytes on wire, 60 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:18.310563000
    Time delta from previous packet: 0.000312000 seconds
    Time relative to first packet: 0.000312000 seconds
    Frame Number: 2
    Packet Length: 60 bytes
    Capture Length: 60 bytes
Ethernet II, Src: 00:00:00:00:00:00, Dst: 00:00:00:00:00:00
    Destination: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Source: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Type: Unknown (0x0000)
Vegas (FC, SOFf/EOFt)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 30
        TTL: 255
        0111 .... = User Priority: 7
        .... 0011 1111 11.. = Dst Index: 0x00ff
        .... ..00 0000 1011 = Src Index: 0x000b
        Ctrl Bits: 0 (0x00)
        Timestamp: 42679
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 241
    Vegas Trailer
        EOF: EOFt (1)
        CRC: 1019832848
Fibre Channel
    R_CTL: 0xc0(ACK1)
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: Unknown (0x00)
    F_CTL: 0xf80000 (Exchange Responder, Seq Recipient, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Cont, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1eb4
    RX_ID: 0x1e66
    Parameter: 0x00000001

Frame 3 (100 bytes on wire, 100 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:19.309559000
    Time delta from previous packet: 0.998996000 seconds
    Time relative to first packet: 0.999308000 seconds
    Frame Number: 3
    Packet Length: 100 bytes
    Capture Length: 100 bytes
Ethernet II, Src: 00:00:00:00:00:00, Dst: 00:00:00:00:00:00
    Destination: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Source: 00:00:00:00:00:00 (00:00:00:00:00:00)
    Type: Unknown (0x0000)
Vegas (FC, SOFf/EOFn)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 70
        TTL: 255
        0111 .... = User Priority: 7
        .... 0011 1111 11.. = Dst Index: 0x00ff
        .... ..00 0000 1011 = Src Index: 0x000b
        Ctrl Bits: 0 (0x00)
        Timestamp: 42779
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 101
    Vegas Trailer
        EOF: EOFn (3)
        CRC: 4200187557
Fibre Channel
    R_CTL: 0x02
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: SW_ILS (0x22)
    F_CTL: 0x380000 (Exchange Originator, Seq Initiator, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Abort/MS, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1e67
    RX_ID: 0xffff
    Parameter: 0x00000000
SW_ILS
    Cmd Code: HLO (0x14)
    FSPF Header
        Version: 0x02
        AR Number: 0x00
        Authentication Type: 0x00
        Originating Domain ID: 107
        Authentication: 0000000000000000
    Options: 00000000
    Hello Interval (secs): 20
    Dead Interval (secs): 80
    Recipient Domain ID: 102
    Originating Port Idx: 0x01011c

Frame 4 (60 bytes on wire, 60 bytes captured)
    Arrival Time: Jul  4, 2003 12:31:19.309646000
    Time delta from previous packet: 0.000087000 seconds
    Time relative to first packet: 0.999395000 seconds
    Frame Number: 4
    Packet Length: 60 bytes
    Capture Length: 60 bytes
Ethernet II, Src: 00:00:00:00:00:0a, Dst: 00:00:00:00:ee:00
    Destination: 00:00:00:00:ee:00 (00:00:00:00:ee:00)
    Source: 00:00:00:00:00:0a (00:00:00:00:00:0a)
    Type: Unknown (0xfcfc)
Vegas (FC, SOFf/EOFt)
    Vegas Header
        .000 .... = Version: 0
        .... 0000 = Andiamo Type: Normal FC frame (0)
        #MPLS Labels: 0
        Packet Len: 30
        TTL: 255
        0111 .... = User Priority: 7
        .... 0000 0010 11.. = Dst Index: 0x000b
        .... ..00 1111 1111 = Src Index: 0x00ff
        Ctrl Bits: Index Directed frame (0x01)
        Timestamp: 42778
        .... .000 = Status: 0 (0)
        0000 0... = Reason Code: 0 (0x00)
        .... 0000 0000 1101 = VSAN: 13
        Checksum: 0
    Vegas Trailer
        EOF: EOFt (1)
        CRC: 4022250974
Fibre Channel
    R_CTL: 0xc0(ACK1)
    Dest Addr: ff.ff.fd
    CS_CTL: 0x00
    Src Addr: ff.ff.fd
    Type: Unknown (0x00)
    F_CTL: 0xf80000 (Exchange Responder, Seq Recipient, Exchg First,
                    Exchg Last, Seq Last, CS_CTL, Last Data Frame - No Info,
                    ABTS - Cont, )
    SEQ_ID: 0xe7
    DF_CTL: 0x00
    SEQ_CNT: 0
    OX_ID: 0x1e67
    RX_ID: 0x1eb5
    Parameter: 0x00000001

De nouveau, le bref suivi est affiché. Cette fois, cependant, le PC sur le port 1/16 est débranché et re-branché pour forcer une procédure de connexion. Vous voyez des trames à et de l'autre commutateur FC, et à et du noeud local relié (le PC).

MDS9216(config)# fcanalyzer local brief display-filter mdshdr.vsan==0xd

Capturing on eth2
  0.000000     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.000310     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
  0.999598     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
  0.999684     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 19.990040     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 19.990295     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 20.990602     ff.ff.fd -> ff.ff.fd     SW_ILS HLO
 20.990682     ff.ff.fd -> ff.ff.fd     FC Link Ctl, ACK1
 26.028780     ff.fc.66 -> ff.fc.6b     SW_ILS SW_RSCN
 26.029087     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 26.029541     ff.fc.6b -> ff.fc.66     SW_ILS SW_ACC (SW_RSCN)
 26.029596     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.151197     00.00.01 -> ff.ff.fe     FC ELS FLOGI
 31.162809     ff.ff.fe -> 66.01.01     FC ELS ACC (FLOGI)
 31.162841     ff.ff.fe -> 66.01.01     FC ELS ACC (FLOGI)
 31.163139     66.01.01 -> ff.ff.fd     FC ELS SCR
 31.163583     ff.ff.fd -> 66.01.01     FC ELS ACC (SCR)
 31.163603     ff.ff.fd -> 66.01.01     FC ELS ACC (SCR)
 31.163835     66.01.01 -> ff.ff.fc     FC ELS PLOGI
 31.163965     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.163985     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.164186     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.164305     ff.fc.66 -> ff.fc.6b     SW_ILS SW_RSCN
 31.164479     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 31.164628     ff.fc.6b -> ff.fc.66     SW_ILS SW_ACC (SW_RSCN)
 31.164670     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.165030     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165050     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165125     ff.fc.6b -> ff.fc.66     dNS GE_ID
 31.165193     ff.fc.66 -> ff.fc.6b     FC Link Ctl, ACK1
 31.165419     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.165577     ff.fc.66 -> ff.fc.6b     dNS ACC (GE_ID)
 31.165781     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165804     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.165943     ff.fc.6b -> ff.fc.66     FC Link Ctl, ACK1
 31.166063     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.166870     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.166892     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.167268     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.167529     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.167549     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.168704     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.169272     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.169294     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.169568     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.170453     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170473     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170756     66.01.01 -> ff.ff.fc     dNS GA_NXT
 31.170975     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.170994     ff.ff.fc -> 66.01.01     dNS ACC (GA_NXT)
 31.171400     66.01.01 -> 66.02.01     FC ELS PLOGI
 31.171562     66.02.01 -> 66.01.01     FC ELS ACC (PLOGI)
 31.171581     66.02.01 -> 66.01.01     FC ELS ACC (PLOGI)
 31.171752     66.01.01 -> 66.02.01     FC ELS PRLI
 31.171812     66.02.01 -> 66.01.01     FC ELS LS_RJT (PRLI)
 31.171832     66.02.01 -> 66.01.01     FC ELS LS_RJT (PRLI)
 31.173863     66.01.01 -> ff.ff.fc     FC ELS LOGO
 31.175020     ff.ff.fc -> 66.01.01     FC ELS ACC (LOGO)
 31.175047     ff.ff.fc -> 66.01.01     FC ELS ACC (LOGO)
 31.175182     66.01.01 -> ff.ff.fc     FC ELS PLOGI
 31.175290     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.175310     ff.ff.fc -> 66.01.01     FC ELS ACC (PLOGI)
 31.175632     66.01.01 -> ff.ff.fa     FC ELS PLOGI
 31.175753     ff.ff.fa -> 66.01.01     FC ELS ACC (PLOGI)
 31.175777     ff.ff.fa -> 66.01.01     FC ELS ACC (PLOGI)
 32.460020     ff.fc.66 -> 66.01.01     FC ELS PLOGI
 32.460050     ff.fc.66 -> 66.01.01     FC ELS PLOGI
 32.460207     66.01.01 -> ff.fc.66     FC ELS ACC (PLOGI)
 32.460246     66.01.01 -> ff.fc.66     FC ELS ACC (PLOGI)
 32.460340     ff.fc.66 -> 66.01.01     FC ELS PRLI
 32.460362     ff.fc.66 -> 66.01.01     FC ELS PRLI
 32.460492     66.01.01 -> ff.fc.66     FC ELS LS_RJT (PRLI)
 32.460525     66.01.01 -> ff.fc.66     FC ELS LS_RJT (PRLI)
 32.461839     ff.fc.66 -> 66.01.01     FC ELS LOGO
 32.461866     ff.fc.66 -> 66.01.01     FC ELS LOGO
 32.462046     66.01.01 -> ff.fc.66     FC ELS ACC (LOGO)
 32.462080     66.01.01 -> ff.fc.66     FC ELS ACC (LOGO)

MDS9216(config)# ^C

MDS9216(config)# exit

Configurer pour l'analyseur distant FC

/image/gif/paws/46220/analyze_span_3.gif

Remarque: L'intention est de collecter les trames FC dont provenez, ou est destinée à, le superviseur 9612. Des vues de l'hôte à JBOD ne sont pas collectées avec l'outil d'analyseur FC.

Le distant d'analyseur FC est exécuté sur un PC qui utilise 0.9(9)leavingcisco.com éthéré ou plus tard et WinPcapleavingcisco.com . L'adresse IP du PC est spécifiée dans la commande qui est émise pour commencer le suivi d'analyseur FC sur le MDS CLI. Sur le PC, la nécessité éthérée également soit commencée de la ligne de commande, et l'adresse IP de l'interface de gestion MDS doit être spécifiée dans la commande.

  1. Pour arrêter le suivi d'analyseur MDS FC, vous devez appuyer sur le CTRL-C du CLI.

    MDS9216# config t
    
    Enter configuration commands, one per line.  End with CNTL/Z.
    
    MDS9216(config)# fcanalyzer remote 64.102.58.114
    
    MDS9216(config)# ^C
    

    Ne spécifiez pas l'option active sur la commande précédente, ou vous devrez ajouter des options supplémentaires à la ligne de commande sur votre PC quand vous commencez éthéré. Ajouter le mot clé actif signifie habituellement que vous devez également configurer le nombre de port TCP. Il est recommandé que vous utilisez les par défaut.

  2. Sur le PC, vérifiez l'adresse IP, et commencez le programme distant éthéré de capture.

    d:\> ipconfig
    
    Windows 2000 IP Configuration
    
    Ethernet adapter wireless:
    
            Connection-specific DNS Suffix  . : cisco.com
            IP Address. . . . . . . . . . . . : 64.102.58.114
            Subnet Mask . . . . . . . . . . . : 255.255.255.128
            Default Gateway . . . . . . . . . : 64.102.58.1
    
    Ethernet adapter builtinE:
    
            Connection-specific DNS Suffix  . : cisco.com
            Autoconfiguration IP Address. . . : 169.254.219.141
            Subnet Mask . . . . . . . . . . . : 255.255.0.0
            Default Gateway . . . . . . . . . :
    
    d:\> cd ethereal099
    
    D:\Ethereal099> ethereal099 -i rpcap://172.18.172.56/eth2
    
  3. Une fois que les lancements du programme, choisissent la capture et puis cliquent sur OK pour initier la collecte de paquet.

    /image/gif/paws/46220/analyze_span_4.gif

    Les paquets FC qui sont collectés apparaissent en tant qu'autre dans l'affichage récapitulatif.

    /image/gif/paws/46220/analyze_span_5.gif

  4. Cliquez sur l'arrêt pour arrêter la collecte de paquet et pour commencer la partie de vue de suivi du programme.

    /image/gif/paws/46220/analyze_span_6.gif

    Vous pouvez utiliser des filtres pour limiter l'affichage à un flux de trafic spécifique.

  5. S'il y a problème avec l'initiation distante de capture, vous pouvez voir un écran d'erreurs semblable à celui dans la prochaine image. L'analyseur FC n'est pas en activité sur le MDS, ou le mot clé actif a été utilisé sans port spécifié.

    /image/gif/paws/46220/analyze_span_7.gif

Configurer pour le SPAN local

/image/gif/paws/46220/analyze_span_8.gif

Remarque: L'intention est de collecter — avec l'analyseur FC sur le port 1/15 — des trames FC à et de l'hôte sur le port 1/16 des 9216.

Un analyseur FC sur des expositions du port 1/15 commandées place, mais pas les positionnements commandés qui se produisent sur le lien qui est SPANed. Le périphérique d'analyseur FC peut être un adaptateur d'analyseur de port (PAA) et un PC qui est s'exécuter éthéré, semblable à un périphérique de Finisar.

Configuration MDS 9216

MDS9216# show run

vsan 13

vsan 13 interface fc1/16
vsan 13 interface fc2/16

boot system bootflash:/m9200-ek9-mzg.1.2.0.77.bin
boot kickstart bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin

 interface fc1/15
switchport mode SD
switchport speed 2000
no shutdown

 interface fc1/16
no shutdown

 interface mgmt0
ip address 172.18.172.56 255.255.255.0

span session 1
destination interface fc1/15
source interface fc1/16 rx

source interface fc1/16 tx

Affichages MDS 9216

MDS9216# show interface fc 1/15

fc1/15 is up
    Hardware is Fibre Channel
    Port WWN is 20:0f:00:05:30:00:47:9e
    Admin port mode is SD
    Port mode is SD
    Port vsan is 1
    Speed is 2 Gbps
    Beacon is turned off
    5 minutes input rate 73704 bits/sec, 9213 bytes/sec, 13 frames/sec
    5 minutes output rate 2275584 bits/sec, 284448 bytes/sec, 430 frames/sec
      2839098 frames input, 1883173240 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      3049460 frames output, 2038253240 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

MDS9216# show interface fc 1/16 

fc1/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:10:00:05:30:00:47:9e
    Admin port mode is auto, trunk mode is on
    Port mode is FL, FCID is 0x660100
    Port vsan is 13
    Speed is 2 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 16
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 771568 bits/sec, 96446 bytes/sec, 171 frames/sec
    5 minutes output rate 1503144 bits/sec, 187893 bytes/sec, 258 frames/sec
      1238843 frames input, 691853044 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1864744 frames output, 1357707740 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 49 loop inits
      10 output OLS, 0 LRR, 10 NOS, 14 loop inits

MDS9216# show interface fc 2/16

fc2/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:50:00:05:30:00:47:9e
    Admin port mode is FX
    Port mode is FL, FCID is 0x660000
    Port vsan is 13
    Speed is 1 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 1647552 bits/sec, 205944 bytes/sec, 283 frames/sec
    5 minutes output rate 845624 bits/sec, 105703 bytes/sec, 188 frames/sec
      1867680 frames input, 1361393600 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1241179 frames output, 694505284 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 2 loop inits
      0 output OLS, 0 LRR, 0 NOS, 2 loop inits

MDS9216# show fcns data vsan 13

VSAN 13:
--------------------------------------------------------------------------
FCID        TYPE  PWWN                    (VENDOR)        FC4-TYPE:FEATURE
--------------------------------------------------------------------------
0x6600dc    NL    21:00:00:20:37:15:a2:49 (Seagate)       scsi-fcp:target
0x6600e0    NL    21:00:00:04:cf:6e:4a:8c (Seagate)       scsi-fcp:target
0x6600e1    NL    21:00:00:04:cf:6e:37:8b (Seagate)       scsi-fcp:target
0x660101    NL    10:00:00:01:73:00:81:82 (JNI)

Total number of entries = 4

MDS9216# show span session brief

--------------------------------------------------------
 Session  Admin          Oper           Destination
          State          State          Interface
--------------------------------------------------------
 1        no suspend     active         fc1/15

MDS9216# show span session 1

Session 1 (active)
   Destination is fc1/15
   No session filters configured
   Ingress (rx) sources are
     fc1/16,
   Egress (tx) sources are
     fc1/16,

MDS9216# show span internal info session 1

====================================
Admin Configuration for session [1]
====================================
Name:
Destination port: [100e000] [fc1/15] Flags [1]
State: [0] not suspended
Session Flags: [0] <>
Session Filter rx:  none
Session Filter tx:  none
Source interface - rx: fc1/16
Source interface - tx: fc1/16
Source vsan (rx):  none
Session [1] is UNLOCKED txn[0] cfg[0] rid[80000000]
====================================
Runtime Data for session [1]
====================================
Status <active: 0 inactive 1> : [0] active
State reason:[0] Flags [6]rx_span_bit [0] tx_span_bit[1] ( 4s invalid)
oper configured PHYSICAL ports
fc1/16
PHYSICAL ports undergoing configuration
none
PHYSICAL ports in error state
none
PHYSICAL ports (incl. dest) link status
fc1/15, fc1/16

Configurer pour le SPAN distant

/image/gif/paws/46220/analyze_span_9.gif

Remarque: L'intention est de collecter — l'analyseur FC étant relié aux 9509 — des trames FC à et de l'hôte sur les 9216. L'interface St doit avoir un convertisseur d'interface de gigabit (GBIC) installé et la vitesse doit apparier le port de la destination d'envergure (écart-type) sur les 9509.

Avant que vous tentiez de configurer RSPAN, assurez-vous que ces points sont abordés :

  • Tous les Commutateurs doivent exécuter le code 1.2 MDS ou plus tard.

  • Aucun câble ne devrait être relié au petit facteur de forme enfichable (SFP) dans le port terminal d'envergure (St).

  • Assurez-vous que le tunnel FC est avant que vous commenciez à collecter des trames.

  • L'analyseur FC peut être un PAA et un PC qui est s'exécuter éthéré, semblable à un périphérique de Finisar.

S'il y a des commutateurs intermédiaires entre la source d'ENVERGURE et la destination d'ENVERGURE commutez, suivez cette procédure :

  1. Créez une interface active VSAN dans le même sous-réseau que la source du tunnel et la destination.

  2. Routage IP d'enable.

  3. FC-Tunnellisation d'enable.

  4. Utilisation SAN-OS 1.2 ou plus tard.

Configuration MDS 9216

MDS9216# show version

Cisco Storage Area Networking Operating System (SAN-OS) Software
TAC support: http://www.cisco.com/tac
Copyright (c) 2002-2003 by Cisco Systems, Inc. All rights reserved.
The copyright for certain works contained herein are owned by
Andiamo Systems, Inc. and/or other third parties and are used and
distributed under license.

Software
  BIOS:      version 1.0.7
  loader:    version 1.0(3a)
  kickstart: version 1.2(1) [build 1.2(0.77)] [gdb]
  system:    version 1.2(1) [build 1.2(0.77)] [gdb]

  BIOS compile time:       03/20/03
  kickstart image file is: bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin
  kickstart compile time:  6/29/2003 0:00:00
  system image file is:    bootflash:/m9200-ek9-mzg.1.2.0.77.bin
  system compile time:     6/29/2003 0:00:00

Hardware
  RAM 963108 kB

  bootflash: 503808 blocks (block size 512b)
  slot0:          0 blocks (block size 512b)

  MDS9216 uptime is 0 days 21 hours 28 minute(s) 20 second(s)

  Last reset at 50030 usecs after Thu Jul  3 13:09:31 2003
    Reason: Reset Requested by CLI command reload
    System version: 1.2(0.45c)

MDS9216# show run

Building Configuration ...

 interface fc-tunnel 13
destination 10.0.0.2
source 10.0.0.1
no shutdown

vsan database
vsan 13

 interface vsan13
ip address 10.0.0.1 255.255.255.0
no shutdown

vsan 13 interface fc1/16
vsan 13 interface fc2/16

boot system bootflash:/m9200-ek9-mzg.1.2.0.77.bin
boot kickstart bootflash:/m9200-ek9-kickstart-mzg.1.2.0.77.bin
fc-tunnel enable

ip routing
zone default-zone permit vsan 13

 interface fc1/12
no shutdown

 interface fc1/15
switchport mode ST
switchport speed 1000
rspan-tunnel interface fc-tunnel 13
no shutdown

 interface fc1/16
no shutdown

 interface fc2/16
no shutdown

 interface mgmt0
ip address 172.18.172.56 255.255.255.0

span session 1
destination interface fc-tunnel 13
source interface fc1/16 rx

source interface fc1/16 tx

!--- Output suppressed.

Affichages MDS 9216

MDS9216# show interface fc 1/16

fc1/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:10:00:05:30:00:47:9e
    Admin port mode is auto, trunk mode is on
    Port mode is FL, FCID is 0x660100
    Port vsan is 13
    Speed is 2 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 16
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 1480080 bits/sec, 185010 bytes/sec, 331 frames/sec
    5 minutes output rate 2907712 bits/sec, 363464 bytes/sec, 498 frames/sec
      574444 frames input, 320246452 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      865170 frames output, 629303788 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 10 loop inits
      5 output OLS, 0 LRR, 5 NOS, 9 loop inits

MDS9216# show interface fc 2/16

fc2/16 is up
    Hardware is Fibre Channel
    Port WWN is 20:50:00:05:30:00:47:9e
    Admin port mode is FX
    Port mode is FL, FCID is 0x660000
    Port vsan is 13
    Speed is 1 Gbps
    Transmit B2B Credit is 0
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    5 minutes input rate 2905056 bits/sec, 363132 bytes/sec, 498 frames/sec
    5 minutes output rate 1480184 bits/sec, 185023 bytes/sec, 330 frames/sec
      867932 frames input, 632889576 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      576681 frames output, 322771132 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 2 loop inits
      0 output OLS, 0 LRR, 0 NOS, 2 loop inits

MDS9216# show interface fc 1/15

fc1/15 is up
    Hardware is Fibre Channel
    Port WWN is 20:0f:00:05:30:00:47:9e
    Admin port mode is ST
    Port mode is ST
    Port vsan is 1
    Speed is 1 Gbps
    Rspan tunnel is fc-tunnel 13
    Beacon is turned off
    5 minutes input rate 4391896 bits/sec, 548987 bytes/sec, 827 frames/sec
    5 minutes output rate 4391896 bits/sec, 548987 bytes/sec, 820 frames/sec
      1431232 frames input, 941079708 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1406853 frames output, 941079708 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

MDS9216# show interface fc 1/12

fc1/12 is trunking
    Hardware is Fibre Channel
    Port WWN is 20:0c:00:05:30:00:47:9e
    Peer port WWN is 20:5d:00:05:30:00:51:1e
    Admin port mode is auto, trunk mode is on
    Port mode is TE
    Port vsan is 1
    Speed is 2 Gbps
    Transmit B2B Credit is 12
    Receive B2B Credit is 255
    Receive data field Size is 2112
    Beacon is turned off
    Trunk vsans (admin allowed and active) (1-5,13,20,777)
    Trunk vsans (up)                       (1,13)
    Trunk vsans (isolated)                 (2-5,20,777)
    Trunk vsans (initializing)             ()
    5 minutes input rate 384 bits/sec, 48 bytes/sec, 0 frames/sec
    5 minutes output rate 4458296 bits/sec, 557287 bytes/sec, 827 frames/sec
      19865 frames input, 2220112 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1468709 frames output, 971064244 bytes
        0 discards, 0 errors
      0 input OLS, 2 LRR, 0 NOS, 0 loop inits
      2 output OLS, 2 LRR, 0 NOS, 2 loop inits

MDS9216# show interface fc-tunnel 13

fc-tunnel 13 is up
Dest   IP Addr: 10.0.0.2   Tunnel ID: 13
Source IP Addr: 10.0.0.1   LSP ID: 1
Explicit Path Name:
Outgoing interface: fc1/12
Outgoing Label(s) to Insert: 10005:0:1:ff'h
Record Routes:
10.0.0.2

MDS9216# show interface vsan 13

vsan13 is up, line protocol is up
    WWPN is 10:00:00:05:30:00:47:9f, FCID is 0x660201
    Internet address is 10.0.0.1/24
    MTU 1500 bytes, BW 1000000 Kbit
    2207 packets input, 170332 bytes, 0 errors, 0 multicast
    14952 packets output, 2225444 bytes, 0 errors, 0 dropped

MDS9216# show span session 1

Session 1 (active)
   Destination is fc-tunnel 13
   No session filters configured
   Ingress (rx) sources are
     fc1/16,
   Egress (tx) sources are
     fc1/16,

MDS9216# show fc-tunnel internal states

number of sessions : 1
Sess: 10.0.0.2 Tunnel-ID 13 Ext-Tunnel-ID 10.0.0.1

MDS9216# show fc-tunnel internal data

vsan interfaces:
  vsan 13: 10.0.0.1/255.255.255.0  [2]
  vsan 2: 15.0.0.4/255.255.255.0  [2]
next hop switch information:
  10.0.0.2 {vsan (13), 0x6b0001/8}: [4] fc1/12
layer 2 interfaces:
  fc1/12: Trunking, Up

Configuration MDS 9509

RTP-9509-1# show run

Building Configuration ...
vsan database
vsan 13

 interface vsan13
ip address 10.0.0.2 255.255.255.0
no shutdown

vsan 13 interface fc2/16

boot system bootflash:/m9500-sf1ek9-mzg.1.2.0.77.bin sup-1
boot kickstart bootflash:/m9500-sf1ek9-kickstart-mzg.1.2.0.77.bin sup-1
boot system bootflash:/m9500-sf1ek9-mzg.1.2.0.77.bin sup-2
boot kickstart bootflash:/m9500-sf1ek9-kickstart-mzg.1.2.0.77.bin sup-2

fc-tunnel enable
fc-tunnel tunnel-id-map 13 interface fc2/6

ip routing

switchname RTP-9509-1

 interface fc2/6
switchport mode SD
switchport speed 1000
no shutdown

 interface fc2/29
switchport mode E
no shutdown

 interface mgmt0
ip address 172.18.172.57 255.255.255.0

Affichages MDS 9509

RTP-9509-1# show interface fc 2/29

fc2/29 is trunking
    Hardware is Fibre Channel
    Port WWN is 20:5d:00:05:30:00:51:1e
    Peer port WWN is 20:0c:00:05:30:00:47:9e
    Admin port mode is E, trunk mode is on
    Port mode is TE
    Port vsan is 501
    Speed is 2 Gbps
    Transmit B2B Credit is 255
    Receive B2B Credit is 12
    Receive data field Size is 2112
    Beacon is turned off
    Trunk vsans (admin allowed and active) (1,13,86,100,501)
    Trunk vsans (up)                       (1,13)
    Trunk vsans (isolated)                 (86,100,501)
    Trunk vsans (initializing)             ()
    5 minutes input rate 4497752 bits/sec, 562219 bytes/sec, 835 frames/sec
    5 minutes output rate 344 bits/sec, 43 bytes/sec, 0 frames/sec
      1934604 frames input, 1285716656 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      16903 frames output, 932076 bytes
        0 discards, 0 errors
      1 input OLS, 1 LRR, 2 NOS, 0 loop inits
      3 output OLS, 1 LRR, 2 NOS, 0 loop inits

RTP-9509-1# show interface fc 2/6

fc2/6 is up
    Hardware is Fibre Channel
    Port WWN is 20:46:00:05:30:00:51:1e
    Admin port mode is SD
    Port mode is SD
    Port vsan is 1
    Speed is 1 Gbps
    Beacon is turned off
    5 minutes input rate 0 bits/sec, 0 bytes/sec, 0 frames/sec
    5 minutes output rate 4421448 bits/sec, 552681 bytes/sec, 835 frames/sec
      0 frames input, 0 bytes
        0 discards, 0 errors
        0 CRC,  0 unknown class
        0 too long, 0 too short
      1912319 frames output, 1263982444 bytes
        0 discards, 0 errors
      0 input OLS, 0 LRR, 0 NOS, 0 loop inits
      0 output OLS, 0 LRR, 0 NOS, 0 loop inits

RTP-9509-1# show interface fc-tunnel 13
                           ^
% invalid interface range detected at '^' marker.

!--- This is because the tunnel is not defined on the 9509.

RTP-9509-1# show interface vsan 13

vsan13 is up, line protocol is up
    WWPN is 10:00:00:05:30:00:51:23, FCID is 0x6b0001
    Internet address is 10.0.0.2/24
    MTU 1500 bytes, BW 1000000 Kbit
    15071 packets input, 2243728 bytes, 0 errors, 1 multicast
    2342 packets output, 185864 bytes, 0 errors, 0 dropped

RTP-9509-1# show fc-tunnel tunnel-id-map

tunnel id  egress interface
     13             fc2/6
     14

RTP-9509-1# show fc-tunnel internal states

number of sessions : 1
Sess: 10.0.0.2 Tunnel-ID 13 Ext-Tunnel-ID 10.0.0.1

RTP-9509-1# show fc-tunnel internal data

vsan interfaces:
  vsan 13: 10.0.0.2/255.255.255.0  [2]
next hop switch information:
layer 2 interfaces:
  fc2/6: Non-Trunking, Up

Notes pour des périphériques d'adaptateur d'analyseur de port

Le port Ethernet est de cuivre, et il a automatique-détecte des vitesses de GBP 1 ou de 100 Mbits/s. 0.9(9) Ou plus tard éthéré et WinPcap doit être installé sur le PC.

Le port FC exige un SFP et un câble LC-à-LC pour la connexion au MDS.

Ce sont des positions de commutateur sur le PAA :

  • Des positions de commutateur numéro 1, 2, 3, et 4 de gauche à droite.

  • Dans la prochaine liste, un 1 indique que l'interrupteur à positions multiples est allumé ou SE LÈVE. Un 0 indique que l'interrupteur à positions multiples est éteint VERS LE BAS ou.

    0001 1G  NTM
    1001 1G  ETM
    0101 1G  STM
    0011 1G  DTM
    
    0000 2G  NTM
    1000 2G  ETM
    0100 2G  STM
    0010 2G  DTM
    
    1111 1G  MNM
    
    !--- Used for diagnostics only.
    
    
  • Commutez 4 dicte la vitesse (sur = 1G, outre de = 2G). Mode tronqué d'ordres des Commutateurs 1, 2, et 3. Toutes les modifications exigent un arrêt et redémarrage.

Ce sont les modes :

  • Aucun mode tronqué (NTM) — Des trames FC ne sont passées sans aucune modification.

  • Les Ethernets tronquent le mode (ETM) — Ramène la taille de charge utile de 528 lignes à 368 lignes, tronque la trame FC à un maximum de 1496 octets.

  • Mode tronqué peu profond (STM) — Ramène la taille de charge utile de 528 lignes à 58 lignes, tronque la trame FC à un maximum de 256 octets.

  • Mode profondément tronqué (DTM) — Ramène la taille de charge utile de 528 lignes à 10 lignes, tronque la trame FC à un maximum de 64 octets.

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 46220