IP : IP version 6 (IPv6)

Connexion 6bone utilisant les tunnels 6to4 pour IPv6

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document décrit comment un client de campus d'entreprise (par exemple, un établissement d'enseignement, une petite entreprise de logiciel, ou une petite entreprise de fabrication) peut se connecter au 6bone à l'aide des tunnels 6to4. Le 6bone est un réseau de test d'IP version 6 (IPv6) qui a été installé pour aider à l'évolution et au déploiement de l'IPv6 en Internet.

Ce document est un d'un ensemble de documents que le support et complètent la publication de stratégies de déploiement d'IPv6, qui est disponible aux guides de conception d'IPv6.

Vous devriez lire ce document en même temps que des stratégies de déploiement d'IPv6 pour comprendre mieux des activités de predeployment d'IPv6.

Conditions préalables

Conditions requises

Avant que vous implémentiez un tunnel 6to4 au 6bone, vous devez effectuer les tâches suivantes :

  • Identifiez le routeur de cadre à votre site que vous configurerez pour exécuter la double-pile. Ce routeur de cadre doit avoir une charge statique, ipv4 addres globalement routable.

  • Un permis de données est exigé pour activer toutes les caractéristiques d'IPv6. Afin de vérifier quel permis est activé sur le routeur, utilisez la commande de show license.

  • De l'ISP 6bone, obtenez l'ipv4 addres du routeur du relais 6to4 que vous utiliserez pour l'accès 6bone.

    Remarque: Quand vous configurez les tunnels pour votre entreprise encadrent des Routeurs, vous doivent utiliser des adresses globalement routable d'ipv4. Les adresses d'ipv4 utilisées en exemples de configuration dans ce document ne sont pas globalement routable et sont fournies dans des buts illustratifs seulement.

  • Assurez-vous que vos DN exécute (ou a les capacités équivalentes de) la version 9 de Berkeley Internet Name Domain (GRIPPAGE), qui fournit une implémentation des principaux composants des DN pour l'IPv6. La configuration DNS est hors de portée de ce document.

  • Identifiez que l'implémentation en cours de double-pile en logiciel de Cisco IOS permet une solution d'administration de réseaux provisoire, qui permet des applications telles que le TFTP, ping, telnet, et traceroute à exécuter au-dessus d'un ipv4 ou d'un transport d'IPv6.

  • Sélectionnez un protocole de routage intérieur d'IPv6, tel que RIPng, qui est approprié à votre configuration réseau. Pour la simplicité, la solution présentée dans ce document utilise une artère statique. Le protocole de routage extérieur d'ipv4 approprié manipule le routage extérieur.

  • Configurez tous vos Routeurs de double-pile pour utiliser le RIP.

Référez-vous à la bibliothèque de configuration d'IPv6 de Cisco IOS pour plus d'informations sur configurer votre réseau pour l'IPv6.

Composants utilisés

Les informations dans ce document sont basées sur des images de Cisco IOS avec le support d'IPv6.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

La figure suivante affiche la topologie du réseau initiale d'ipv4 pour le client de campus d'entreprise. Ce réseau utilise plusieurs Routeurs pour fournir la connectivité IP parmi des utilisateurs locaux. Une connexion permanente d'ipv4 à un fournisseur de services Internet (ISP) fournit la Connectivité externe

/image/gif/paws/45741/6bone_tc_1-01.gif

Le tableau suivant décrit les périphériques utilisés dans cette solution.

Périphérique Routeur de cadre d'entreprise routeur de l'ISP 6bone
Nom d'hôte 6bone-gw ipv6-router
Type de châssis Routeur de Cisco 3660 Routeur Cisco 7206
Interfaces physiques 2 interface série de Fast Ethernet 4 des Ethernets 2 4 interface série de Fast Ethernet 4 des Ethernets 2
Logiciel chargé Cisco IOS version 12.2(4)T Cisco IOS version 12.2(4)T
Mémoire RAM 64MV ; Éclair du Mo 16 RAM DU MO 128 ; Éclair du Mo 20
Adresses IP Ethernet0 : Ipv4 192.168.99.1 Tunnel2002 : IPv6 2002:C0A8::1/128 Ethernet0/0 : Ipv4 192.168.33.1 Tunnel2002 : IPv6 2002:C0A8:2102::1/128

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Comment les tunnels 6to4 fonctionnent

Un tunnel 6to4 est configuré sur un routeur de cadre de double-pile d'entreprise. Tout le trafic d'IPv6 d'entreprise destiné pour le 6bone est conduit au-dessus de l'ipv4 par le tunnel 6bone au routeur de relais ISP 6to4. Le trafic du 6bone à un hôte d'entreprise est conduit au-dessus de l'ipv4 par le tunnel au routeur de cadre de double-pile d'entreprise, et puis à la destination host d'IPv6.

Les avantages à l'entreprise d'utiliser les tunnels 6to4 sont comme suit :

  • Tunnels des supports logiciels 6to4 de Cisco IOS.

  • La configuration d'hôte d'utilisateur est simple — elle exige le temps système de Gestion minimal.

  • Le tunnel est automatique ; aucune configuration d'entreprise-particularité n'est exigée au site du relais 6to4. puits d'échelle des tunnels 6to4.

  • Cette solution facilite des adresses IP dynamiques à l'entreprise.

  • Le tunnel existe seulement pour la durée de la session.

  • Un tunnel 6to4 exige seulement une configuration une fois à l'ISP, qui fait le relais 6to4 entretenir disponible simultanément à beaucoup d'entreprises.

Limites des tunnels 6to4

l'utilisation du tunnel 6to4 a les limites suivantes :

  • On ne permet pas NAT indépendamment géré le long du chemin du tunnel.

  • Vous ne pouvez pas facilement implémenter l'hébergement multiple.

  • Le mécanisme du tunnel 6to4 fournit un bloc d'adresses de /48 ; plus d'adresses ne sont disponibles.

  • Puisque les tunnels 6to4 sont configurés beaucoup-à-un et le trafic du tunnel peut provenir de plusieurs points finaux, les tunnels 6to4 peuvent fournir seulement les informations routières globales à l'ISP.

  • L'ipv4 addres sous-jacent détermine le préfixe d'ipv6 addres de l'entreprise 6to4, ainsi le transfert à l'IPv6 indigène exige renuméroter le réseau.

  • Cette solution est limitée à la charge statique ou au routage BGP4+.

Un scénario de Tunnellisation

Un petit fournisseur de logiciel (considéré un campus universitaire typique d'entreprise) avec un réseau d'ipv4 discute une fusion avec une autre société qui exécute l'IPv6 sur son réseau. Pour évaluer la Connectivité l'affectez que la fusion aurait sur les sociétés fusionnées, le client veut développer sa connaissance d'IPv6 en se connectant au 6bone. Les objectifs professionnels du client de campus d'entreprise discutés dans ce document sont comme suit :

  • Acquérez l'expérience d'IPv6 sur un circuit principal établi d'IPv6 utilisant sa topologie existante d'ipv4, avec un investissement minimal.

  • Testez les procédures transitoires et opérationnelles dans un environnement du monde réel d'IPv6 avant de déployer l'IPv6.

    Les procédures transitoires sont ces procédures qui sont nécessaires pour migrer de l'ipv4 vers l'IPv6. Ces procédures incluent installer des Routeurs et des systèmes d'extrémité de double-pile, des mécanismes de perçage d'un tunnel, des serveurs de Système de noms de domaine (DNS), et, à l'avenir, le test de la traduction de Traduction-Protocol d'adresse réseau (NAT-PT).

    Des procédures opérationnelles sont liées à la Gestion de réseau, à l'administration d'éléments des hôtes de double-pile et des systèmes d'extrémité, et à d'autres fonctions similaires.

  • Testez les applications et les réalisations d'IPv6 sur les postes de travail locaux.

  • Réduisez le temps système de Gestion associé avec une connexion 6bone.

    Remarque: Bien que le 6bone comporte beaucoup de types des organismes (par exemple, universitaire et organismes gouvernementaux, matériel et fournisseurs de logiciels, et fournisseurs de services), ce document utilise l'ISP du terme 6bone en se rapportant à l'organisation qui est à l'extrémité 6bone du tunnel.

Configurez

L'ipv4 addres de votre routeur de cadre est 192.168.99.1. Dérivez votre préfixe 6to4 de votre ipv4 addres en convertissant les composants décimaux de l'ipv4 addres en hexadécimal et puis en préfixant « 2002 » aux nombres hexadécimaux en résultant. Ainsi le préfixe 6to4 pour les Noeuds d'IPv6 dans votre réseau est 2002:C0A8:6301::/128.

La partie C0A8:6301 de l'ipv6 addres précédent est formée de l'ipv4 addres en convertissant chaque octet du dotted decimal notation en son équivalent hexadécimal, suivant les indications du tableau 6.

Décimal Hexadécimal
192 C0
168 A8
99 63
1 01

Cette section présente les informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

Cette figure affiche la topologie d'un tunnel 6to4 typique au 6bone.

/image/gif/paws/45741/6bone_tc_1-02.gif

Configurations

Votre ISP 6bone t'a fourni l'ipv4 addres à son routeur du cadre 6bone : 192.168.33.1. Employez les informations d'adresse précédentes pour configurer un tunnel 6to4 sur votre routeur identifié de cadre de double-pile en écrivant les commandes suivantes :

Routeur d'entreprise
ipv6 unicast-routing

interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0

interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4


!--- In some cases, a user will require a data license 
!-- in order to issue the tunnel mode ipv6ip command.

 ipv6 route 2002::/16 Tunnel2002
 ipv6 route ::/0 2002:C0A8:2101::1

Le 2002:C0A8:2101::1 dans la deuxième commande d'ipv6 route est l'ipv6 addres du routeur de relais ISP 6to4 qui permet d'accéder au 6bone. La partie de l'adresse C0A8:2101 est dérivée de l'ipv4 addres (192.168.33.1) du routeur du relais 6to4 en quelque sorte semblable au tableau 6.

À l'autre bout du tunnel, le routeur de cadre à votre ISP 6bone aurait une configuration comme l'exemple suivant de routage d'unicast d'IPv6 :

Routeur de relais ISP 6to4
ipv6 unicast-routing

interface ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0

interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4

ipv6 route 2002::/16 tunnel2002

Routeur 6bon2-gw d'entreprise
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname 6bone-gw
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router domain name
!
ip domain-name EnterpriseDomain.com
!
! Configure DNS name servers
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:100::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:200::1/64
 ipv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
ipv6 route ::/0 2002:C0A8:2101::1
ipv6 router rip v6rip
!
end
 end

routeur de l'ISP de l'IPv6 6bone
maui-soho-01# show running-config 
 Building configuration...
 .
 .
 .
 username maui-nas-05 password cisco

 ! Identify the version of Cisco IOS software running on the router
!
version 12.2
!
! Include timestamps on log and debug entries that are useful for
! troubleshooting and optimizing the network.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Specify that passwords will be encrypted in configuration output.
!
service password-encryption
!
! Configure the router name
!
hostname ipv6-router
!
! Configure boot options
!
boot system flash slot0:
boot system flash bootflash:
!
! Configure logging
!
logging buffered 10000 debugging
!
! Configure secret password
!
enable secret 5 [removed]
!
! Configure clock timezone and summertime rule
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Configure router's domain name
!
ip domain-name 6boneISP.com
!
! Configure DNS name servers
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Enable IPv6 routing
!
ipv6 unicast-routing
!
! Configure Tunnel interface
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 ipv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode ipv6ip 6to4
!
! Configure physical interface
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 ipv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Other interfaces are all unused
!

interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Configure basic IP routing
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Configure IPv6 static route
!
ipv6 route 2002::/16 tunnel2002
!
end

Vérifiez

Cette tâche facultative explique comment confirmer que votre tunnel est configuré et fonctionnant correctement. Les commandes contenues dans les étapes principales peuvent être utilisées dans n'importe quel ordre et peuvent devoir être répétées

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

  • enable

  • nombre de show interfaces tunnel [comptabilité]

  • destination de ping [protocole]

  • show ip route [adresse [masque]]

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 45741