IP : Protocoles de routage IP

Exemple de configuration de la méthode statique du protocole de tunnellisation de couche 2 (version 3) et de la méthode de fonctionnement en épingle à cheveux (hairpinning)

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document présente un exemple de configuration pour les méthodes statique et en épingle de la troisième version du protocole de transmission tunnel de couche 2 (L2TPv3).

Cette table décrit le soutien de modification de version logicielle de Ý de Cisco IOS de L2TPv3 :

Version du logiciel Cisco IOS Description du support L2TPv3
12.0(21)S Le soutien initial de plan de données de L2TPv3 a été introduit sur les Plateformes de gamme Cisco 7200, de gamme Cisco 7500, de Cisco 10720, et de gamme Cisco 12000.
12.0(23)S Le support d'avion du contrôle L2TPv3 a été introduit sur les Plateformes de gamme Cisco 7200, de gamme Cisco 7500, de Cisco 10720, et de gamme Cisco 12000.
12.3(2)T Cette caractéristique a été intégrée dans le Logiciel Cisco IOS version 12.3(2)T.

Vous devez permettre au Technologie Cisco Express Forwarding (CEF) d'utiliser la caractéristique L2TPv3. Le sous-mode de configuration de xconnect est bloqué jusqu'à ce que le CEF soit activé. Sur les Plateformes distribuées, telles que la gamme Cisco 7500, si le CEF est désactivé tandis qu'une session est établie, la session est démolie et reste vers le bas jusqu'à ce que le CEF soit réactivé. Utilisez l'ip cef ou la commande distribuée d'ip cef d'activer le CEF.

Spécifiant une adresse IP source pour configurer une interface de bouclage est fortement recommandé. Si vous ne configurez pas une interface de bouclage, le routeur sélectionne la meilleure adresse locale disponible, qui pourrait être n'importe quelle adresse IP configurée sur une interface de noyau-revêtement. Cette configuration peut empêcher l'établissement d'un canal de contrôle. L'adresse de bouclage doit être accessible des principaux réseaux.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous êtes bien informé de :

Composants utilisés

Ce document n'est pas limité à des versions de matériel et de logiciel spécifiques.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous aux Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

/image/gif/paws/45660/l2tp_v3_01.jpg

Remarque: Les Routeurs R2 et R3 sont utilisés par le fournisseur. Les Routeurs R1, R4, R5, et R6 sont des consommateurs finaux. À l'aide de L2TPv3, le routeur R4 semble avoir une liaison directe à R5 ; cela vaut également pour la connexion entre le routeur R1 au routeur R6.

Configurations

Ce document utilise les configurations suivantes :

  • Pseudo-fil statique par un nuage IP. L'élément pertinent de la configuration peut être trouvé dans R2 et R3 où deux tunnels unidirectionnels sont configurés.

  • Pseudo-fil d'épingle à cheveux ou commutation locale (d'un port à un autre port dans le même routeur). La configuration est faite seulement sur R2 et se compose configurer deux tunnels unidirectionnels indiquant deux bouclages, qui sont tous deux sur le routeur R2.

R2
R2# show running-config 
Building configuration...
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R2
!
!
clock timezone EST 10
ip subnet-zero
ip cef
no ip domain-lookup
l2tp-class R2signal
 hello 10
 password 0 cisco
 cookie size 8
!
pseudowire-class wireR5R4
 encapsulation l2tpv3
 protocol l2tpv3 R2signal
 ip local interface Loopback0
 ip dfbit set
!
pseudowire-class wireR6R1
 encapsulation l2tpv3
 protocol l2tpv3 R2signal
 ip local interface Loopback1
 ip dfbit set
!
pseudowire-class wireR1R6
 encapsulation l2tpv3
 protocol l2tpv3 R2signal
 ip local interface Loopback2
 ip dfbit set
!
interface Loopback0
description Used by wireR5R4 for Static Connection
 ip address 2.2.2.2 255.255.255.255
 no ip directed-broadcast
!
interface Loopback1
description Used by wireR6R1 for Hair Pinning Connection
 ip address 2.2.2.6 255.255.255.255
 no ip directed-broadcast
!
interface Loopback2
description Used by wireR1R6 for Hair Pinning Connection
 ip address 2.2.2.1 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
description Connection to R1
 no ip address
 no ip directed-broadcast
 xconnect 2.2.2.6 16 encapsulation l2tpv3 pw-class wireR1R6
!
interface Ethernet1/0
description Connection to Pretend Cloud.
 ip address 20.20.20.2 255.255.255.0
 no ip directed-broadcast
 no cdp enable
!
interface Ethernet2/0
description Connection to R5
 no ip address
 no ip directed-broadcast
 no cdp enable
 xconnect 3.3.3.3 12 encapsulation l2tpv3 pw-class wireR5R4
!
interface Ethernet3/0
description Connection to R6
 no ip address
 no ip directed-broadcast
 xconnect 2.2.2.1 16 encapsulation l2tpv3 pw-class wireR6R1
!
ip classless
ip route 3.3.3.3 255.255.255.255 20.20.20.3

!--- The other end of wireR5R4 loopback (3.3.3.3) must be
 

!--- reachable from this router. Hair Pinning loopbacks
 

!--- are reachable—there is no need for additional routes.

!
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

R3
R3# show running-config 
Building configuration...
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R3
!
!
clock timezone EST 10
ip subnet-zero
ip cef
!
l2tp-class R3signal
 hello 10
 password 0 cisco
 cookie size 8
!
pseudowire-class wireR4R5
 encapsulation l2tpv3
 protocol l2tpv3 R3signal
 ip local interface Loopback0
 ip dfbit set
!
interface Loopback0
description Use by wireR4R5 for static connection
 ip address 3.3.3.3 255.255.255.255
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 20.20.20.3 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet1/0
 no ip address
 no ip directed-broadcast
 no cdp enable
 xconnect 2.2.2.2 12 encapsulation l2tpv3 pw-class wireR4R5
!
ip classless
ip route 2.2.2.2 255.255.255.255 Ethernet0/0

!--- The other end of wireR4R5 loopback (3.3.3.3) must be
 

!--- reachable from this router.

!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

Configuration de routeur de fin de tunnel du client R1R6 (pseudo-fil) :

R1
R1# show running-config 
Building configuration...
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R1
!
!
clock timezone EST 10
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0/0
 ip address 10.10.10.1 255.255.255.0
 no ip directed-broadcast
!
ip classless
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

R6
R6# show running-config 
Building configuration...
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R6
!
!
clock timezone EST 10
ip subnet-zero
no ip domain-lookup
!
interface Ethernet0/0
 ip address 10.10.10.6 255.255.255.0
 no ip directed-broadcast
!
ip classless
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

Configuration de routeur de fin de tunnel du client R4R5 (pseudo-fil) :

R4
R4# show running-config 
Building configuration...
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R4
!
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 30.30.30.4 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
!
ip classless
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

R5
R5# show running-config 
Building configuration...
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname R5
!
!
ip subnet-zero
!
interface Ethernet0/0
 ip address 30.30.30.5 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 log-adjacency-changes
 network 30.30.30.0 0.0.0.255 area 0
!
ip classless
!
line con 0
 exec-timeout 0 0
 privilege level 15
line aux 0
line vty 0 4
 login
!
end

Vérifiez

Cette section présente des informations que vous pouvez utiliser pour vous assurer que votre configuration fonctionne correctement.

R4# show ip ospf neighbor 
Neighbor ID  Pri  State     Dead Time   Address     Interface
30.30.30.5    1   FULL/DR   00:00:39    30.30.30.5  Ethernet0/0

R5# show ip ospf neighbor  
Neighbor ID  Pri  State     Dead Time   Address     Interface
30.30.30.4    1   FULL/BDR  00:00:38    30.30.30.4  Ethernet0/0


R1# show cdp neighbors 
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater
Device ID   Local Intrfce  Holdtme Capability Platform  Port ID
R6           Eth 0/0       158        R       7206VXR   Eth 0/0

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • le show l2tun tunnel entièrement pour afficher l'état actuel d'une session L2TPv3 et pour afficher des informations sur des sessions actuellement configurées, y compris des noms d'hôte locaux et distants L2TP, des comptes d'agrégat de paquet, et des canaux de contrôle L2TP, utilisent le show l2tun tunnel toute la commande dans le mode d'exécution.

    R2# show l2tun tunnel all
     Tunnel Information Total tunnels 3 sessions 3
    
    Tunnel id 54217 is up, remote id is 44186, 1 active sessions
         Tunnel state is established, time since change 00:12:07
         Tunnel transport is IP (115)
         Remote tunnel name is R2
         Internet Address 2.2.2.6, port 0
         Local tunnel name is R2
         Internet Address 2.2.2.1, port 0
         Tunnel domain is 
         VPDN group for tunnel is -
         L2TP class for tunnel is R2signal
         88 packets sent, 87 received
         10086 bytes sent, 11092 received
         Control Ns 76, Nr 74
         Local RWS 1024 (default), Remote RWS 1024 (max)
         Tunnel PMTU checking disabled
         Retransmission time 1, max 1 seconds
         Unsent queuesize 0, max 0
         Resend queuesize 0, max 2
         Total resends 0, ZLB ACKs sent 72
         Current nosession queue check 0 of 5
         Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
         Sessions disconnected due to lack of resources 0
    
    Tunnel id 44186 is up, remote id is 54217, 1 active sessions
         Tunnel state is established, time since change 00:12:08
         Tunnel transport is IP (115)
         Remote tunnel name is R2
         Internet Address 2.2.2.1, port 0
         Local tunnel name is R2
         Internet Address 2.2.2.6, port 0
         Tunnel domain is 
         VPDN group for tunnel is -
         L2TP class for tunnel is R2signal
         87 packets sent, 88 received
         11092 bytes sent, 10086 received
         Control Ns 74, Nr 76
         Local RWS 1024 (default), Remote RWS 1024 (max)
         Tunnel PMTU checking disabled
         Retransmission time 1, max 1 seconds
         Unsent queuesize 0, max 0
         Resend queuesize 0, max 1
         Total resends 0, ZLB ACKs sent 74
         Current nosession queue check 0 of 5
         Retransmit time distribution: 0 0 0 0 0 0 0 0 0 
         Sessions disconnected due to lack of resources 0
    
    Tunnel id 24124 is up, remote id is 48735, 1 active sessions
         Tunnel state is established, time since change 00:11:00
         Tunnel transport is IP (115)
         Remote tunnel name is R3
         Internet Address 3.3.3.3, port 0
         Local tunnel name is R2
         Internet Address 2.2.2.2, port 0
         Tunnel domain is 
         VPDN group for tunnel is -
         L2TP class for tunnel is R2signal
         155 packets sent, 158 received
         15230 bytes sent, 17586 received
         Control Ns 69, Nr 67
         Local RWS 1024 (default), Remote RWS 1024 (max)
         Tunnel PMTU checking disabled
         Retransmission time 1, max 1 seconds
         Unsent queuesize 0, max 0
         Resend queuesize 0, max 2
         Total resends 1, ZLB ACKs sent 65
         Current nosession queue check 0 of 5
         Retransmit time distribution: 0 0 1 0 0 0 0 0 0 
         Sessions disconnected due to lack of resources 0
    
    R3# show l2tun tunnel all
     Tunnel Information Total tunnels 1 sessions 1
    
    Tunnel id 48735 is up, remote id is 24124, 1 active sessions
         Tunnel state is established, time since change 00:12:36
         Tunnel transport is IP (115)
         Remote tunnel name is R2
         Internet Address 2.2.2.2, port 0
         Local tunnel name is R3
         Internet Address 3.3.3.3, port 0
         Tunnel domain is 
         VPDN group for tunnel is -
         L2TP class for tunnel is R3signal
         180 packets sent, 176 received
         19766 bytes sent, 17316 received
         Control Ns 77, Nr 79
         Local RWS 1024 (default), Remote RWS 1024 (max)
         Tunnel PMTU checking disabled
         Retransmission time 1, max 1 seconds
         Unsent queuesize 0, max 0
         Resend queuesize 0, max 1
         Total resends 1, ZLB ACKs sent 78
         Current nosession queue check 0 of 5
         Retransmit time distribution: 0 0 1 0 0 0 0 0 0 
         Sessions disconnected due to lack of resources 0
  • le show l2tun session entièrement pour afficher l'état actuel d'une session de la couche 2 et pour afficher des informations de protocole sur un canal de contrôle L2TPv3, utilisent le show l2tun session toute la commande dans le mode d'exécution.

    R2# show l2tun session all
     Session Information Total tunnels 3 sessions 3
    Session id 19996 is up, tunnel id 54217
         Call serial number is 1492400000
         Remote tunnel name is R2
         Internet address is 2.2.2.6
         Session is L2TP signalled
         Session state is established, time since change 00:15:37
         112 Packets sent, 111 received
         12309 Bytes sent, 13312 received
         Receive packets dropped:
          out-of-order: 0
          total: 0
         Send packets dropped:
          exceeded session MTU: 0
          total: 0
         Session vcid is 16
         Session Layer 2 circuit, type is Ethernet, name is Ethernet0/0
         Circuit state is UP
         Remote session id is 19999, remote tunnel id 44186
         DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
         Session cookie information:
         local cookie, size 8 bytes, value 6E 47 8C 4A BA BF 7E A4 
         remote cookie, size 8 bytes, value 7F 9F 65 C4 C7 5B 57 FF 
         FS cached header information:
         encap size = 32 bytes
         00000000 00000000 00000000 00000000
         00000000 00000000 00000000 00000000
         
         Sequencing is off
    Session id 19999 is up, tunnel id 44186
         Call serial number is 1492400000
         Remote tunnel name is R2
         Internet address is 2.2.2.1
         Session is L2TP signalled
         Session state is established, time since change 00:15:38
         111 Packets sent, 112 received
         13312 Bytes sent, 12309 received
         Receive packets dropped:
          out-of-order: 0
          total: 0
         Send packets dropped:
          exceeded session MTU: 0
          total: 0
         Session vcid is 16
         Session Layer 2 circuit, type is Ethernet, name is Ethernet3/0
         Circuit state is UP
         Remote session id is 19996, remote tunnel id 54217
         DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
         Session cookie information:
         local cookie, size 8 bytes, value 7F 9F 65 C4 C7 5B 57 FF 
         remote cookie, size 8 bytes, value 6E 47 8C 4A BA BF 7E A4 
         FS cached header information:
         encap size = 32 bytes
         00000000 00000000 00000000 00000000
         00000000 00000000 00000000 00000000
         
         Sequencing is off
    Session id 20005 is up, tunnel id 24124
         Call serial number is 1492400002
         Remote tunnel name is R3
         Internet address is 3.3.3.3
         Session is L2TP signalled
         Session state is established, time since change 00:14:29
         200 Packets sent, 204 received
         19650 Bytes sent, 22100 received
         Receive packets dropped:
          out-of-order: 0
          total: 0
         Send packets dropped:
          exceeded session MTU: 0
          total: 0
         Session vcid is 12
         Session Layer 2 circuit, type is Ethernet, name is Ethernet2/0
         Circuit state is UP
         Remote session id is 17834, remote tunnel id 48735
         DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
         Session cookie information:
         local cookie, size 8 bytes, value 22 09 F1 E9 BC 8C 00 94 
         remote cookie, size 8 bytes, value 39 DD CB 00 9C 4B 1C 8C 
         FS cached header information:
         encap size = 32 bytes
         00000000 00000000 00000000 00000000
         00000000 00000000 00000000 00000000
         
         Sequencing is off
    
    R3# show l2tun session all
     Session Information Total tunnels 1 sessions 1
    Session id 17834 is up, tunnel id 48735
         Call serial number is 1492400002
         Remote tunnel name is R2
         Internet address is 2.2.2.2
         Session is L2TP signalled
         Session state is established, time since change 00:23:53
         327 Packets sent, 322 received
         33758 Bytes sent, 31248 received
         Receive packets dropped:
          out-of-order: 0
          total: 0
         Send packets dropped:
          exceeded session MTU: 0
          total: 0
         Session vcid is 12
         Session Layer 2 circuit, type is Ethernet, name is Ethernet1/0
         Circuit state is UP
         Remote session id is 20005, remote tunnel id 24124
         DF bit on, ToS reflect disabled, ToS value 0, TTL value 255
         Session cookie information:
         local cookie, size 8 bytes, value 39 DD CB 00 9C 4B 1C 8C 
         remote cookie, size 8 bytes, value 22 09 F1 E9 BC 8C 00 94 
         FS cached header information:
         encap size = 32 bytes
         00000000 00000000 00000000 00000000
         00000000 00000000 00000000 00000000
         
         Sequencing is off

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Vous pouvez utiliser la trousse à outils de bogue (clients enregistrés seulement) pour plus d'informations sur ces bogues L2TPv3 liées à la caractéristique :

  • CSCdz01467 (clients enregistrés seulement) — (r) L2TPv3 résolu : Compteur de paquet de tunnel, compte inexact d'affichages.

  • CSCeb56061 (clients enregistrés seulement) — (r) L2TPv3 résolu : L2TPv3oETH génère des tunnels de zombie.

  • CSCeb35497 (clients enregistrés seulement) — (r) séquençage résolu L2TPv3 : Tx Seqnum ne s'enveloppe pas à 1 après 16777215.

  • CSCdz48481 (clients enregistrés seulement) — (r) la configuration résolue de hairpinning L2TPv3 n'est plus prise en charge.

  • CSCec00463 (clients enregistrés seulement) — (r) L2TPv3 résolu : Panne de decap de mode de port Ethernet de yole

  • CSCec44356 (clients enregistrés seulement) — (r) C10720 résolu : La correspondance 802.1P dans le hairpinning L2TPv3 est cassée.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 45660