Sécurité : Dispositifs de sécurité de la gamme Cisco PIX 500

PIX 6.2 : Exemple de configuration NTP avec et sans tunnel IPSec

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon pour synchroniser l'horloge du Pare-feu PIX un Serveur de synchronisation de réseau utilisant le Protocole NTP (Network Time Protocol). PIX 1 communique directement avec le Serveur de synchronisation de réseau. Le trafic de NTP de passages PIX 2 par un tunnel d'IPSec à PIX 1, qui consécutivement en avant les paquets au Serveur de synchronisation de réseau.

Remarque: Un routeur peut également être utilisé en tant que serveur de NTP pour synchroniser l'horloge du Pare-feu PIX. Référez-vous configurent un routeur de Cisco pour être un pour en savoir plus de serveur de NTP.

Conditions préalables

Conditions requises

Avant de tenter cette configuration, assurez-vous que vous répondez à ces exigences :

  • La Connectivité de bout en bout d'IPSec doit être établie avant de commencer cette configuration de NTP.

  • Le support de NTP a été ajouté dans la version de PIX 6.2. Le Pare-feu PIX doit exécuter la version 6.2 ou ultérieures.

  • Le permis de Pare-feu PIX doit être activé pour le cryptage de Norme de chiffrement de données (DES) (à un niveau minimum de cryptage).

Composants utilisés

Les informations dans ce document sont basées sur la version de logiciel de Logiciels pare-feu Cisco PIX 6.3(3).

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions de documents, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/45400/pix-ntp.gif

Configurations

Ce document utilise les configurations indiquées ici.

Configuration PIX 1
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto
interface ethernet2 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
nameif ethernet2 dmz0 security10
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix1
domain-name cisco.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21<br>fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list nonat permit ip 10.0.6.0 255.255.255.0 host 209.165.201.2
access-list ipsec permit ip 10.0.6.0 255.255.255.0 host 209.165.201.2
pager lines 24
mtu outside 1500
mtu inside 1500
mtu dmz0 1500
ip address outside 209.165.201.3 255.255.255.224
ip address inside 10.0.6.1 255.255.255.0
no ip address dmz0
ip audit info action alarm
ip audit attack action alarm
no failover
failover timeout 0:00:00
failover poll 15
no failover ip address outside
no failover ip address inside
no failover ip address dmz0
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 10.66.79.161 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius 
aaa-server LOCAL protocol local 
ntp authentication-key 1 md5 ********
ntp trusted-key 1
ntp server 10.0.6.5 key 1 source inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
fragment chain 1
sysopt connection permit-ipsec
crypto ipsec transform-set vpn esp-3des esp-md5-hmac 
crypto map cisco 10 ipsec-isakmp
crypto map cisco 10 match address ipsec
crypto map cisco 10 set peer 209.165.201.2
crypto map cisco 10 set transform-set vpn
crypto map cisco interface outside
isakmp enable outside
isakmp key ******** address 209.165.201.2 netmask 255.255.255.255 
isakmp keepalive 10
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:bf28afe92a93af6170d8de380afeb424
: end

Configuration PIX 2
PIX Version 6.3(3)
interface ethernet0 auto
interface ethernet1 auto shutdown
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 2KFQnbNIdI.2KYOU encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname pix2
domain-name vpn.cisco.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list ipsec permit ip host 209.165.201.2 10.0.6.0 255.255.255.0
pager lines 24
logging on
logging buffered debugging
mtu outside 1500
mtu inside 1500
ip address outside 209.165.201.2 255.255.255.224
ip address inside 10.1.1.10 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 209.165.201.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+ 
aaa-server RADIUS protocol radius 
aaa-server RADIUS (inside) host 1.1.1.1 cisco timeout 10
aaa-server LOCAL protocol local 
ntp authentication-key 1 md5 ********
ntp trusted-key 1
ntp server 10.0.6.5 key 1 source outside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set vpn esp-3des esp-md5-hmac 
crypto map cisco 10 ipsec-isakmp
crypto map cisco 10 match address ipsec
crypto map cisco 10 set peer 209.165.201.3
crypto map cisco 10 set transform-set vpn
crypto map cisco interface outside
isakmp enable outside
isakmp key ******** address 209.165.201.3 netmask 255.255.255.255
isakmp identity address
isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5
isakmp policy 10 group 2
isakmp policy 10 lifetime 86400
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:26d03e15146cf920b3d7ab61eaf75905
: end
[OK]
pix2(config)#

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

  • show ntp status — Affiche les informations d'horloge de NTP.

    pix1#show ntp status
    	Clock is synchronized, stratum 9, reference is 10.0.6.5
    	nominal freq is 99.9984 Hz, actual freq is 99.9984 Hz, precision is 2**6
    	reference time is af99ca9d.ab979ef4 (06:47:57.670 UTC Tue May 11 1993)
    	clock offset is -27.3950 msec, root delay is 1.04 msec	
    	root dispersion is 7906.14 msec, peer dispersion is 7878.71 msec
  • show ntp associations [détail] — Affiche les associations configurées de Serveur de synchronisation de réseau.

    pix1#show ntp associations detail
    	10.0.6.5 configured, authenticated, our_master, sane, valid, stratum 8
    	ref ID 127.127.7.1, time af99cb13.44a14229 (06:49:55.268 UTC Tue May 11 1993)
    	our mode client, peer mode server, our poll intvl 64, peer poll intvl 64
    	root delay 0.00 msec, root disp 0.03, reach 17, sync dist 2123.413
    	delay 1.07 msec, offset -311.1441 msec, dispersion 2122.85
    	precision 2**18, version 3
    	org time af99cb1d.53083e9b (06:50:05.324 UTC Tue May 11 1993)
    	rcv time af99cb1d.a2d2a9b5 (06:50:05.636 UTC Tue May 11 1993)
    	xmt time af99cb1d.a27b176f (06:50:05.634 UTC Tue May 11 1993)
    	filtdelay =     1.07    1.05    1.04    1.04    0.00    0.00    0.00    0.00
    	filtoffset = -311.14  -30.13  -27.39  -19.99    0.00    0.00    0.00    0.00
    	filterror =     0.02    0.99    1.97    2.94 16000.0 16000.0 16000.0 16000.0

Dépannez

Cette section fournit des informations que vous pouvez utiliser pour dépanner votre configuration.

Dépannage des commandes

Certaines commandes show sont prises en charge par l'Output Interpreter Tool (clients enregistrés uniquement), qui vous permet de voir une analyse de la sortie de la commande show.

Remarque: Avant d'émettre des commandes de débogage, référez-vous aux informations importantes sur des commandes de debug.

  • validité de debug ntp — Validité d'horloge de ntp peer d'affichages.

    C'est sortie de débogage de la non-concordance principale :

    NTP: packet from 10.0.6.5 failed validity tests 10
     	  Authentication failed
    
  • paquet de debug ntp — Les informations de paquet de NTP d'affichages.

    Quand il n'y a aucune réponse du serveur, seulement le paquet de xmit de NTP est vu sur le PIX sans le paquet récepteur de NTP.

    NTP: xmit packet to 10.0.6.5:
     leap 0, mode 3, version 3, stratum 9, ppoll 64
     rtdel 0077 (1.816), rtdsp 3e290 (3885.010), refid 0a000605 (10.0.6.5)
     ref c3390a82.f50ac415 (12:16:02.957 UTC Thu Oct 16 2003)
     org c3390a82.f70e3cc7 (12:16:02.965 UTC Thu Oct 16 2003)
     rec c3390a82.f50ac415 (12:16:02.957 UTC Thu Oct 16 2003)
     xmt c3390ac2.f6363336 (12:17:06.961 UTC Thu Oct 16 2003)
    NTP: rcv packet from 10.0.6.5 to 209.165.201.2 on ntp0:
     leap 0, mode 4, version 3, stratum 8, ppoll 64
     rtdel 0000 (0.000), rtdsp 0002 (0.031), refid 7f7f0701 (127.127.7.1)
     ref c3390ac0.65629071 (12:17:04.396 UTC Thu Oct 16 2003)
     org c3390ac2.f6363336 (12:17:06.961 UTC Thu Oct 16 2003)
     rec c3390ac2.f8c541ec (12:17:06.971 UTC Thu Oct 16 2003)
     xmt c3390ac2.f8d6f76f (12:17:06.972 UTC Thu Oct 16 2003)
     inp c3390ac3.5d1f1568 (12:17:07.363 UTC Thu Oct 16 2003)

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 45400