IP : Protocole OSPF (Open Shortest Path First)

Conception de réseaux de numérotation de fournisseurs de services à grande échelle avec OSPF

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Pour concevoir un réseau commuté est une tâche provocante pour les fournisseurs d'accès Internet (ISP). Chaque ISP emploie une seule méthode pour concevoir des réseaux commutés. Cependant, tous les ISP partagent les mêmes sujets de préoccupation quand ils conçoivent des réseaux commutés, comme répertorié ici :

  • Comment les artères de groupe doivent-elles être propagées dans le noyau ISP ?

  • Quel protocole de routage doit être utilisé pour porter ces artères dans le noyau ?

  • Ces artères commutées devraient-elles être récapitulées avant l'envoi dans le noyau ?

  • Que doit être pris en considération quand les groupes sont distribués ?

  • Que se produit si les groupes sont statiques ?

Ce document aborde la plupart des questions ci-dessus et traite les pratiques en matière de conception d'utiliser le Protocole OSPF (Open Shortest Path First) de Protocole IGP (Interior Gateway Protocol) dans un environnement de cadran ISP. L'OSPF est au centre réseau employé souvent des ISP. Dans ce document, nous évitons d'introduire un protocole distinct pour porter les artères de groupe de cadran — nous employons l'OSPF pour propager les artères de groupe de cadran dans le noyau.

Topologie du réseau

La topologie représentée ici est une topologie du réseau typique de cadran ISP. Les ISP qui fournissent des services à accès commuté ont habituellement une gamme de serveurs d'accès à distance (NAS) qui sont typiquement AS5300 ou AS5800. Les serveurs sont responsables de la fourniture de l'adresse IP à tous les utilisateurs qui introduisent dans l'ISP et veulent utiliser des services Internet. Les serveurs de NAS sont alors connectés à un périphérique d'agrégation, qui est typiquement un routeur de Cisco 6500. Le routeur 6500 propage les artères commutées dans le noyau, qui permet aux principaux Routeurs pour fournir des services Internet aux utilisateurs finaux. La figure 1 affiche un scénario (POP) typique de Point of Presence.

Figure 1 ? Un scénario POP typique

ispdial.jpg

Groupes de numérotation ISP

Un ISP traite typiquement deux types d'adresses IP de groupe :

  • Statique

  • Central

Groupe statique

Avec les groupes statiques, les ISP ont un ensemble spécifique d'adresses IP dédiées à chaque serveur de NAS. Un utilisateur qui rencontre le NAS reçoit une des adresses IP dédiées du groupe. Par exemple, si la plage d'adresses statique du groupe NAS1 est 192.168.0.0/22, il y a approximativement 1023 adresses IP. Un utilisateur qui rencontre NAS1 reçoit une des adresses dans la plage de 192.168.0.0 à 192.168.3.254.

Groupe central

Avec les groupes centraux, les ISP ont une plage plus étendue des adresses IP distribuées dans tout tout le NASs dans un BRUIT simple. Un utilisateur qui rencontre le NAS reçoit une adresse IP du groupe central, qui est plage très étendue. Par exemple, si la plage d'adresses centrale de groupe est 192.168.0.0/18, et eux sont distribués entre 14 serveurs de NAS, là sont approximativement 14000 adresses IP.

Conception commutée avec un groupe statique

Il est plus facile gérer les groupes statiques d'un point de vue de routage. Quand un groupe statique est défini sur NAS, le groupe doit être propagé au noyau pour conduire des buts.

Employez ces méthodes pour propager les artères commutées de l'NAS :

  • Créez une artère statique à la plage d'adresses IP de groupe, se dirigeant pour annuler 0, avec l'adresse de groupe redistribuée sur le NAS.

  • Assignez l'adresse IP de groupe sur un bouclage, sur le NAS avec le type de réseau point par point OSPF, y compris le bouclage dans une zone OSPF.

  • Configurez une artère statique sur un routeur de cadre de zone (ABR) pour l'adresse IP de groupe étant dirigée vers le routeur ASBR (Autonomous System Boundary Router) de NAS — c'est une méthode préférée parce que la récapitulation peut être exécutée à l'ABR.

Créez une artère statique à la plage d'adresses de groupe se dirigeant pour annuler 0

Si vous utilisez cette méthode, une artère statique doit être créée pour le chaque NAS. Cette artère statique doit couvrir l'adresse statique précise de plage de groupe se dirigeant pour annuler 0. par exemple, si l'adresse statique de groupe est 192.168.0.0/22, la configuration de route statique sur le NAS est :

NAS1(config)# ip route 192.168.0.0 255.255.252.0 null0
NAS1(config)# router ospf 1
NAS1(config-router)# redistribute static subnets
NAS1(config-router)# end

L'adresse de groupe est redistribuée dans l'OSPF, qui propage ces informations dans le noyau sous la forme externe de la publicité d'état de lien du type 5 (LSA).

Assignez à l'adresse de groupe sur un bouclage sur le NAS avec le type de réseau de Point à point OSPF

Si vous utilisez cette méthode, aucune artère statique n'est exigée. L'adresse de groupe est assignée comme sous-réseau sur une interface de bouclage. Le type de réseau par défaut sur l'interface de bouclage est le BOUCLAGE, qui, selon RFC 2328leavingcisco.com doit être annoncé dans l'OSPF comme /32 — c'est pourquoi vous devez changer le type de réseau sur le bouclage au Point à point. Le type de réseau point par point force l'OSPF pour annoncer le subnet address du bouclage, qui est dans ce cas 192.168.0.0/22. Voici la configuration :

NAS1(config)# interface loopback 1
NAS1(config-if)# ip addreess 192.168.0.1 255.255.252.0
NAS1(config-if)# ip ospf network-type point-to-point
NAS1(config-if)# router ospf 1
NAS1(config-router)# network 192.168.0.0 0.0.3.255 area 1
NAS1(config-router)# end

Cette configuration crée un lien de stub de routeur dans le LSA du routeur et est propagée comme artère interne OSPF plutôt qu'une artère externe OSPF.

Configurez l'artère statique sur l'ABR pour l'adresse de groupe, indiquant le NAS (l'ASBR)

Si vous utilisez cette méthode, vous n'avez pas besoin de n'exécuter aucune configuration sur NAS. Toute la configuration se produit au périphérique d'ABR ou d'agrégation. Les pools d'adresses sont statiques. Par conséquent, l'artère statique est facilement générée et le routeur peut diriger le prochain saut vers le NAS respectif, le routeur ASBR (Autonomous System Boundary Router). Ces artères statiques doivent être redistribuées dans l'OSPF par les sous-réseaux statiques de redistribution sous l'OSPF. Exemple :

ABR(config)# ip route 192.168.0.0 255.255.252.0 <next-hop ip address (NAS1)>
ABR(config)# ip route 192.168.4.0 255.255.252.0 <next-hop ip address (NAS2)>

! --- and so on for the remaining 12 NAS boxes.

ABR(config)# router ospf 1
ABR(config-router)# redistribute static subnets
ABR(config-router)# end

C'est la méthode préférée parce que la récapitulation peut être exécutée sur l'ABR. La récapitulation peut également se produire dans les deux premières méthodes, mais les configurations de récapitulation sont nécessaires sur le chaque NAS par rapport à cette méthode, où une configuration de récapitulation est nécessaire seulement dans ce routeur.

Si les groupes statiques sont dans le bloc contigu, la récapitulation peut être exécutée sur l'ABR parce que toutes les artères statiques sont sur l'ABR. Exemple :

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Conception commutée avec l'affectation dynamique IP d'un pool d'adresses central

Pour cette conception commutée, supposez que le groupe central d'adresse IP est configuré sur le serveur de Service RADIUS (Remote Authentication Dial-In User Service). Chaque BRUIT a un numéro composé du service d'informations de nombre (DNIS) et le serveur de RAYON a les groupes distincts d'adresse IP pour chaque DNIS. En outre, tout le NASs qui se terminent des appels pour un DNIS sont dans la même zone et parlent au même routeur d'agrégation.

Les groupes centraux d'adresse IP apportent une certaine complexité dans la conception de protocole de routage. Quand vous composez un numéro de DNIS pour un BRUIT, il n'y a aucune garantie au sujet du NAS auquel vous vous connectez et de l'adresse IP qui te sera assignée du groupe central d'adresse IP pour cela DNIS. En conséquence, la récapitulation sur le chaque NAS est impossible pour les adresses assignées hors du groupe DNIS. Redistributed a connecté le sous-réseau est nécessaire dans le chaque NAS ainsi il peut propager toutes les informations à l'ABR ou au périphérique d'agrégation. Là un problème est-il sont-ils avec cette conception — parce que LSAs externe peut seulement être récapitulé sur l'ASBR et dans cette conception, les ASBR les serveurs de NAS, comment l'ABR exécuteront-ils la récapitulation pour les artères externes provenant le NASs ?

Afin de résoudre ce problème de conception, Cisco recommande que la zone à laquelle les serveurs de NAS appartiennent soit configurée dans pas aussi la zone tronquée (NSSA) (voir le schéma 2) :

Figure 2 ? Configuration dans une zone pas aussi tronquée

/image/gif/paws/44944/ispdial2.jpg

Référez-vous à la zone Non-Ainsi-tronquée OSPF (NSSA) pour plus d'informations sur OSPF NSSAs.

Voici les avantages si vous définissez une zone comme NSSA :

  • Toutes les artères de NAS peuvent être récapitulées à l'ABR parce que les régénérés d'ABR/traduit le type 7 LSA en type 5. LSA.

  • Chaque BRUIT ne portera pas les artères qui appartiennent à un autre BRUIT parce que NSSA ne permet pas LSAs externe.

La configuration des sous-réseaux redistribués et connectés est nécessaire dans tout le NASs parce que les groupes d'adresse IP à travers tout le NASs ne sont pas statiques — n'importe quel NAS peut porter n'importe quelle adresse IP dans cette plage d'adresses IP centrale.

NAS1(config)# router ospf 1
NAS1(config-router)# redistribute connected subnets
NAS1(config-router)# end

Si vous exécutez cette configuration sur tout le NASs, une configuration de récapitulation est exécutée sur l'ABR parce que tout le type 7s LSA sont régénérés sur l'ABR et traduits dans le type 5s LSA. Puisque l'ABR génère un type complètement nouveau 5 LSA et l'ID de routeur de la publicité est l'ID du routeur d'ABR, l'ABR agit en tant qu'ASBR et permet la récapitulation des artères qui étaient précédemment le type 7s LSA (lancé par le NASs).

ABR(config)# router ospf 1
ABR(config-router)# summary-address 192.168.0.0 255.255.192.0
ABR(config-router)# end

Notez que la zone entre l'ABR et le NAS est NSSA, qui peut être configuré comme suit :

ABR(config)# router ospf 1
ABR(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa
ABR(config-router)# end

Problème d'évolutivité de zone

Si vous avez beaucoup de serveurs de NAS dans une zone, et chaque le NAS redistribue 1000 artères ou plus dans la zone, la question se pose-t-elle — combien de serveurs de NAS chaque zone doit-elle comporter ? Si tous les serveurs de NAS sont dans la même zone, la zone peut devenir instable parce que la zone doit porter 1000 artères ou plus de tous les serveurs de NAS. Dans cet exemple de 14 serveurs de NAS, il peut potentiellement redistribuer 14000 artères, qui est un nombre énorme. Afin d'apporter plus d'évolutivité à la zone, Cisco recommande que vous divisiez la zone en plusieurs sous-domaines, de s'assurer que chaque zone n'affecte pas d'autres zones si de l'instabilité se produit dans une zone (voir le schéma 3) :

Figure 3 ? Divisez la zone

ispdial3.jpg

Afin de déterminer le nombre de serveurs de NAS pour maintenir dans une zone, vous devez vérifier le nombre d'artères chaque NAS injecte. Trois serveurs de NAS dans une zone peuvent être suffisants si chaque le NAS injecte 3000 ou plus des artères. Ne mettez pas trop peu de serveurs de NAS dans chaque zone parce que, si vous avez trop de zones, l'ABR peut devenir dû surchargé à la création des récapitulations dans chaque zone. Cependant, vous pouvez résoudre ce problème si vous faites toutes les zones NSSA totalement tronqué, qui ne permet pas la redistribution d'aucune route récapitulative dans la zone. Cette action réduit la quantité d'informations chaque NAS porte en plus de ses propres 1000 artères ou plus, et réduit la quantité de chargement que l'ABR réalise la redistribution des LSA récapitulatifs dans chaque zone. Ajoutez le mot clé de NO--résumé sur l'ABR pour exécuter la configuration, comme affiché ici :

ABR#(config)# router ospf 1
ABR#(config-router)# network 10.10.10.0 0.0.0.255 area 1 nssa no-summary
ABR#(config-router)# end

Le lien entre l'ABR et les serveurs de NAS n'a pas besoin de sortir dans chaque zone ainsi l'ABR n'a pas besoin de créer des résumés dans chaque zone pour ces routes connectées. Le principal avantage de NSSA est que chacun des 3000 artères ou plus dans une zone ne coulent pas dans d'autres zones puisque NSSA ne porte pas LSAs externe. Quand l'ABR traduit tout le type 7s LSA NSSA en zone 0, il n'envoie aucun type 5s LSA dans d'autres zones en raison des caractéristiques NSSA.

Conclusion

Concevoir le réseau commuté ISP peut être une tâche provocante, mais avec quelques considérations il peut être amélioré et fournir plus de solution évolutive. L'incorporation de NSSA peut être efficace en Gestion d'évolutivité parce qu'elle permet une réduction significative de la quantité d'artères que chaque le NAS doit porter une fois comparé à une situation où NSSA n'est pas utilisé. Les aides de récapitulation également réduisent la taille de la table de routage, particulièrement dans le cas du groupe central d'adresse IP, parce que la commande de configuration connectée par redistribuer est exigée sur les serveurs de NAS. L'affectation contiguë de bloc d'adresse IP dans le chaque NAS aide également pendant la récapitulation parce que chaque BRUIT peut être récapitulé dans un grand bloc et le noyau ne doit pas porter une surabondance d'artères.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 44944