Voix et communications unifiées : Cisco Unified Communications Manager (CallManager)

Configuration de la passerelle MGCP Cisco IOS

16 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document :

  • Vous guide par une configuration simple de Protocole MGCP (Media Gateway Control Protocol)

  • Présents seulement les commandes minimum requises pour établir une configuration qui fonctionne pour un routeur avec le Foreign Exchange Office deux (FXO) et deux ports du Foreign Exchange Station (FXS)

Remarque: Les instructions dans ce travail de document pour un Cisco expriment les Routeurs de la passerelle 200 (VG200) et des gammes Cisco 2600 et 3600 qui exécutent la version de logiciel 12.1(5)T et ultérieures de Cisco IOSÝ. Référez-vous à la documentation du logiciel de Cisco IOS pour les versions logicielles prises en charge d'autres passerelles MGCP de Cisco IOS.

Symptômes :

Vous pouvez potentiellement rencontrer cette liste de symptômes quand vous configurez le Cisco CallManager avec des passerelles MGCP de Cisco IOS avec le FXO analogique et les ports FXS :

  • La passerelle MGCP ne s'inscrit pas au Cisco CallManager. Référez-vous à la panne d'enregistrement de passerelle MGCP avec le Cisco CallManager.

  • L'Identification de l'appelant ne travaille pas aux ports FXO. C'est parce que l'Identification de l'appelant n'est pas prise en charge avec des ports FXO une fois configurée pour le MGCP. Configurez la passerelle en H.323 mode à la place.

  • La pagination supplémentaire bloque des ports FXO pendant le hookflash à moins que les utilisateurs aillent complètement le hors fonction-crochet. Shut a suivi par l'aucun fermé remet à l'état initial le port. Ceci est lié à l'ID de bogue Cisco CSCef62275 (clients enregistrés seulement) une fois réparé dans le Logiciel Cisco IOS version 12.3(14)T et plus tard.

Ce document est la partie d'un jeu de six-documents :

Conditions préalables

Conditions requises

Cisco vous recommande de prendre connaissance des rubriques suivantes :

  • Une passerelle de Cisco IOS qui exécute une version logicielle de Cisco IOS qui prend en charge le MGCP avec le Cisco CallManager

  • Cisco VG200

Remarque: Il y a d'autres logiciel Cisco IOS séries de version qui prennent en charge le MGCP sur des Routeurs de Cisco. La version du logiciel Cisco IOS 12.1XM est un exemple.

attention Attention : La syntaxe pour certaines des commandes MGCP est différente dans d'autres versions logicielles de Cisco IOS. Référez-vous à la documentation pour votre configuration pour déterminer la syntaxe qui est exigée.

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • 1 * X Cisco VG200/2 X FXS/2 FXO/1 Fast Ethernet 10/100 port ; Logiciel Cisco IOS Version 12.1(5)T

  • 1 * Cisco CallManager 3.0(5a) qui fonctionne sur un MCS7835

  • 2 * Combinés téléphoniques analogiques

  • 2 * Téléphones IP de Cisco 7960

Référez-vous à la matrice de compatibilité de version de logiciel de Cisco Unified CME et de Cisco IOS pour les versions logicielles recommandées de compatibilité entre le Cisco CallManager et la passerelle de Cisco IOS.

Remarque: Le Logiciel Cisco IOS version 12.2(11)T et plus tard est recommandé a basé sur les améliorations d'ordre de ccm-gestionnaire. L'ordre de ccm-gestionnaire exige le Logiciel Cisco IOS version 12.1(5)XM et plus tard tous les Routeurs (2600 et 3600) et le VG200.

Le Cisco 2600 et 3600 Routeurs prennent en charge le MGCP s'ils exécutent le Logiciel Cisco IOS version 12.1(3)T et plus tard. Les versions logicielles dont vous avez besoin sont basées sur les caractéristiques que vous devez activer. Le serveur Cisco CallManager doit exécuter la version de logiciel 3.0(5)a ou ultérieures. La configuration de routeur est identique pour tous les types de Routeurs. La configuration de Cisco CallManager est également identique pour tous les types de Routeurs.

Version du logiciel Cisco IOS 12.1(5)XM1 et support postérieur le VG200. Les versions logicielles dont vous avez besoin sont basées sur les caractéristiques que vous devez activer. Utilisez la version de logiciel 3.0(5)a et ultérieures quoique le VG200 soit pris en charge dans des versions de logiciel de logiciel Cisco CallManager plus tôt.

Remarque: Il y a d'autres logiciel Cisco IOS séries de version qui prennent en charge le MGCP sur des Routeurs de Cisco. La version du logiciel Cisco IOS 12.1XM est un exemple.

attention Attention : La syntaxe pour certaines des commandes MGCP est différente dans d'autres versions logicielles de Cisco IOS. Référez-vous à la documentation pour votre configuration pour déterminer la syntaxe requise.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Tâches à exécuter

Procédez comme suit :

  1. Configurez une adresse IP sur l'interface Ethernet de passerelle de Cisco IOS.

  2. Assignez un nom unique à la passerelle de Cisco IOS.

  3. Configurez la passerelle de Cisco IOS pour exécuter le MGCP comme protocole de signalisation.

  4. Configurez le nom d'adresse IP ou de Système de noms de domaine (DNS) pour le serveur Cisco CallManager.

  5. Sélectionnez le type de codecs et la fonction multifréquence de relais de double tonalité (DTMF).

  6. Dites à la passerelle de Cisco IOS qu'elle communique avec un serveur Cisco CallManager.

  7. Liez l'application MGCP aux ports vocaux.

  8. Activez les ports vocaux.

  9. Connectivité IP d'enable.

Pas à pas

Remarque: Le reste de ce document se rapporte au VG200. Les débuts VG200 avec une configuration par défaut, comme elle est livré transporté.

Procédez comme suit :

  1. Configurez une adresse IP sur l'interface Ethernet VG200 et activez l'interface.

    router(config)#interface fastethernet 0/0
    router(config-if)#ip address 172.16.1.206 255.255.255.0
    router(config-if)#no shut
    
  2. Assignez un nom unique au VG200. Ceci permet au serveur Cisco CallManager pour l'identifier.

    router(config)#hostname VG200A 
    
    /* This is how CallManager keeps track of the MGCP network */
    /* devices it is communicating with. This name must be     */
    /* unique.                                                 */
  3. Configurez le VG200 pour exécuter le MGCP comme protocole de signalisation.

    VG200A(config)#mgcp
    
  4. Configurez l'adresse IP ou le nom DNS pour le serveur Cisco CallManager.

    VG200A(config)#mgcp call-agent 172.16.1.252
    
    VG200A(config)#ccm-manager config server 172.16.1.252
    
    VG200A(config)#ccm-manager config
    

    La commande de mgcp call-agent est utilisée de configurer l'adresse et le protocole de l'agent d'appel pour des points finaux MGCP sur une passerelle de medias. Cette commande peut être utilisée pour spécifier la version du protocole utilisé. Le pour en savoir plus, se rapportent au mgcp call-agent.

    L'ordre de serveur de ccm-manager config est utilisé de spécifier le serveur TFTP dont la passerelle de Protocole MGCP (Media Gateway Control Protocol) télécharge des fichiers de configuration du Cisco CallManager XML.

    La commande de ccm-manager config est exigée pour activer le téléchargement des fichiers de configuration du Cisco CallManager XML.

    Remarque: Émettez ces commandes de configurer des Cisco CallManagers redondants dans la batterie de Cisco CallManager :

    VG200(config)#ccm-manager redundant-host [ip-address |
      dns-name] [ip-address | dns-name] 
    VG200(config)#ccm-manager switchback {graceful | immediate
      |schedule-time hh:mm | uptime-delay minutes} 
  5. Sélectionnez le type de codecs et la fonction de relais de DTMF.

    VG200A(config)#mgcp dtmf-relay codec all mode out-of-band
    
  6. Émettez cette commande d'activer le soutien du Cisco CallManager dans le MGCP :

    VG200A(config)#ccm-manager mgcp
    
  7. Liez l'application MGCP aux ports vocaux.

    Remarque: Émettez la commande de show voice port de déterminer le type de ports que le VG200 a et dans quelle commande ils sont installé.

    VG200A(config)#dial-peer voice 1 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/0
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 2 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/0/1
    
    /* FXO port */
    
    VG200A(config)#dial-peer voice 3 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/0
    
    /* FXS port */
    
    VG200A(config)#dial-peer voice 4 pots
    VG200A(config)#application MGCPAPP
    VG200A(config)#port 1/1/1
    
    /* FXS port */

    Remarque: La commande de l'application MGCPAPP distingue les majuscules et minuscules dans des quelques versions logicielles de Cisco IOS. Émettez toujours cette commande dans le haut de casse à moins que vous sachiez que votre version logicielle ne distingue pas les majuscules et minuscules. Regardez la sortie de la commande show running-config afin de vérifier si votre version logicielle distingue les majuscules et minuscules. Le Logiciel Cisco IOS version 12.1(5)T ne distingue pas les majuscules et minuscules.

  8. Assurez-vous que les ports vocaux sont activés.

    Remarque: L'arrêt et aucune commande shutdown n'affectent les deux ports sur une carte d'interface vocale (carte d'interface virtuelle). Émettez la commande sur seulement une de ces ports.

    VG200A(config)#voice-port 1/0/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXO port */
    
    VG200A(config)#voice-port 1/1/0
    VG200A(config-voiceport)#no shutdown
    Both ports are in service
    
    /* FXS port */s
  9. Connectivité IP d'enable.

    Activez le Routage IP si les appareils voip l'uns des avec lesquels le VG200 communique se trouvent sur différents sous-réseaux ou VLAN. Vous devez également créer un réseau par défaut, ou la passerelle du dernier recours. Cette étape affiche comment effectuer les deux tâches :

    VG200A(config)#ip routing
    VG200A(config)#ip route 0.0.0.0 0.0.0.0 ip_address_of_gateway
    
    

    Remarque: Le VG200 n'est pas un routeur IP. Vous ne pouvez pas exécuter des protocoles de Routage IP tels que le protocole de Protocole RIP (Routing Information Protocol), de Protocole IGRP (Interior Gateway Routing Protocol), ou de Protocole OSPF (Open Shortest Path First) là-dessus. Il se comporte plutôt une station d'extrémité (client) en ce qui concerne la connectivité IP.

    Remarque: Vous pouvez configurer un protocole de routage au lieu des artères statiques sur les autres passerelles de Cisco IOS, qui sont essentiellement des Routeurs avec des interfaces vocales. L'importante question est d'assurer la connectivité IP entre les appareils voip.

    Remarque: La commande de Routage IP n'apparaît pas dans la configuration parce qu'elle est normalement en fonction par défaut quand vous activez le Routage IP. Les commandes par défaut n'apparaissent pas habituellement en configuration de routeur Cisco. Les images du Cisco IOS VG200 ignorent ce comportement par défaut en ne codant en dur l'aucune commande de Routage IP dans la configuration initiale. Cette configuration est créée quand l'image est amorcée :

    • Sur une plate-forme où la commande de write erase a effacé la configuration

    • Sur un VG200 qui n'a été jamais configuré

    La commande ip_address_of_gateway de 0.0.0.0 0.0.0.0 d'artère d'IP fait installer le VG200 une passerelle de dernier recours sur la table de routage. La commande de show ip route confirme ceci. L'adresse IP de passerelle est 172.16.1.1 dans cet exemple :

    VG200A#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 172.16.1.1 to network 0.0.0.0
    
    C    172.16.0.0/16 is directly connected, FastEthernet0/0
    S*   0.0.0.0/0 [1/0] via 172.16.1.1
    VG200A#

    Remarque: La commande d'ip classless est également exigée afin de cette passerelle de dernier recours pour être efficace. La commande d'ip classless est activée par défaut. Cette commande est une du quelque Cisco IOS que le par défaut de logiciel commande que révèle dans une configuration une fois activé et apparaît également sous le forme no une fois désactivé. Émettez la commande d'ip classless d'activer l'ip classless si votre configuration inclut la ligne aucun ip classless.

attention Attention : Le Cisco CallManager contrôle tous les éléments de configuration liés au plan de cadran. Ne configurez pas ces éléments dans la passerelle MGCP pour des points finaux MGCP-gérés (ceux avec la commande de mgcpapp d'application dans la déclaration de pair de cadran). Ne configurez pas l'un de ces fonctions :

  • Sous des pairs de cadran

    • destination-pattern

    • cible de session

  • Sous des ports vocaux

    • connexion {plar | lien-line | joncteur réseau}

Résumé

Le VG200 est maintenant prêt à communiquer avec le serveur Cisco CallManager. Le VG200 envoie périodiquement des messages dans la tentative d'établir une connexion. La connexion s'établit automatiquement quand la configuration de serveur Cisco CallManager est complète. Vous ne devez pas faire pour promouvoir des modifications sur le VG200.

Remarque: Remettez à l'état initial les ports de passerelle après que vous vous terminiez la configuration, comme indiqué dans cet exemple :

router(config)#voice-port 1/0/0
router(config-voiceport)#shutdown
Both ports are out of service
router(config-voiceport)#no shutdown

Configurations

Cette table contient la configuration complète de VG200A pour ce document :

Configuration VG200A
VG200A#show running-config           
Building configuration...

Current configuration : 1244 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname VG200A
!
boot system flash
boot system rom
boot system tftp vg200 172.16.1.253
no logging buffered
logging rate-limit console 10 except errors
no logging console
enable secret #####
enable password #####
!
ip subnet-zero
no ip finger
no ip domain-lookup
!
mgcp
mgcp call-agent 172.16.1.252
mgcp dtmf-relay codec all mode out-of-band
mgcp sdp simple
call rsvp-sync
!
!
!
!
!
ccm-manager mgcp
!
!
interface FastEthernet0/0
 ip address 172.16.1.206 255.255.0.0
 no ip mroute-cache
 speed auto
 full-duplex
!
ip default-gateway 172.16.1.1
ip classless
no ip http server
!
snmp-server engineID local 000000090200000196983000
snmp-server community public RO
!
voice-port 1/0/0
!
voice-port 1/0/1
!
voice-port 1/1/0
!
voice-port 1/1/1
!
dial-peer voice 1 pots
 application mgcpapp
 port 1/0/0
!
dial-peer voice 2 pots
 application mgcpapp
 port 1/0/1
!
dial-peer voice 3 pots
 application mgcpapp
 port 1/1/0
!
dial-peer voice 4 pots
 application mgcpapp
 port 1/1/1
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password ww
 login
!
end

VG200A#

Les informations de version VG200A
VG200A>show version
Cisco Internetwork Operating System Software
IOS (tm) VG200 Software (VG200-I6S-M), Version 12.1(5)T,  
RELEASE SOFTWARE (fc1)

Copyright (c) 1986-2000 by Cisco Systems, Inc.
Compiled Sat 11-Nov-00 10:33 by ccai
Image text-base: 0x80008088, data-base: 0x807D4784

ROM: System Bootstrap, Version 12.1(1r) [phanguye 1r], RELEASE 
SOFTWARE (fc1)

VG200A uptime is 19 hours, 37 minutes
System returned to ROM by reload
System image file is "flash:vg200"

cisco VG200 (MPC860) processor (revision 0x102) with 28672K/
4096K bytes of memory
y.
Processor board ID JAB0414058X (0)
M860 processor: part number 0, mask 49
1 FastEthernet/IEEE 802.3 interface(s)
2 Voice FXO interface(s)
2 Voice FXS interface(s)
32K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

VG200A>

Dépannage de la passerelle MGCP IOS

Un échec d'appel de manière, sur l'appel sortant ou les appels d'arrivée individuellement, peut se produire dans une passerelle MGCP IOS. Afin de résoudre ce problème, modifiez la passerelle MGCP. Généralement, ceci implique une reconfiguration des interfaces PRI et/ou des interfaces FXO. Puis, une reprise du protocole de mgcp relatif à la passerelle en n'émettant l'aucune commande IOS de mgcp et le mgcp commandent en mode de configuration globale.

Ne peut pas faire des appels à partir d'un téléphone analogique connecté à la passerelle IOS MGCP. Un signal d'occupation est reçu.

Exécutez cette procédure afin de résoudre ce problème :

  1. Assurez-vous que la commande de mgcpapp d'application est configurée sur le port applicable.

  2. Commandez à nouveau les cadran-pairs de réseau téléphonique public commuté (POTS) pour répertorier les cadran-pairs CallManager-générés par Cisco d'abord dans la liste de cadran-pair. Assurez que de cela le Contrôle d'appel centripète et extérieur est manipulé par le cadran-pair correct sous le contrôle MGCP.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 42105