IP : Tunnel série (STUN)

Exemple de configuration de tunnels de protocoles asynchrones dans BSTUN

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Des protocoles async dédiés et indigènes ne sont directement pris en charge avec aucune implémentation de Cisco. Cependant, le Tunnellisation async-générique du tunnel sériel de bloc (BSTUN) peut fournir la capacité limitée de percer un tunnel ces données.

Conditions préalables

Conditions requises

Aucune spécification déterminée n'est requise pour ce document.

Composants utilisés

Les informations de ce document sont basées sur les versions de logiciel et matériel suivantes :

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Informations générales

Les protocoles async tels que le TC500 de Diebold à communiquer à l'argent ATMs ou au HyperTerminal de Tunnellisation d'un PC à un autre PC n'ont aucun support direct ou implémentation dans le ½ du ¿  du Cisco IOS ïÂ. Car le nom implique, c'est une implémentation générique qui a une certaine capacité pour porter ce type de données. Ceci est connu comme BSTUN async-générique, et exige IBM ou l'ensemble de fonctionnalités d'IOS d'entreprise.

BSTUN async-générique a été initialement conçu pour porter les paquets unidirectionnels et petits des périphériques de sécurité à un périphérique d'enregistrement. BSTUN async-générique, cependant, peut porter le trafic interactif. Essentiellement, cette implémentation se relie à l'indigène, des périphériques asynchrones et reçoit les données dans l'interface série et puis dans un tampon mémoire. Périodiquement, les données mises en mémoire tampon sont alors encapsulées dans un paquet TCP et envoyées au pair BSTUN où elles sont désencapsulées et envoyées au périphérique asynchrone relié au site distant.

BSTUN async-générique est une exécution simpliste. Le routeur n'a aucune capacité à configurer pour avoir la connaissance du début de la trame (SOF), de l'extrémité de la trame (EOF), ou du schéma de adressage du protocole async. Si la plage d'adresses de la trame est dans chaque trame, est d'un octet de long, et est le même lieu dans la trame, alors la commande d'adresse-décalage d'asp peut être émise pour spécifier au routeur où trouver l'adresse dans la trame, comme exampled plus tard dans ce document. Dans beaucoup de situations, cependant, il n'y aura pas une plage d'adresses contenue dans le protocole. N'avoir aucune connaissance de la construction async de protocole signifie que le routeur ne peut pas discerner des paquets individuels d'autres s'ils ne sont pas séparés par un délai prévu. Approximativement 40 ms est exigés entre les trames au bits/seconde 9600 pour fournir la durée adéquate de routeur pour discerner correctement un paquet des autres. Le routeur voit simplement qu'un flux de données dans lui est interface série et puis enveloppe ces données dans le TCP. Il n'y a aucune possibilité que le routeur peut prennent des décisions de routage a basé sur n'importe quel aspect individuel de la trame entrante. Ainsi, BSTUN async-générique doit être les attachés physiquement conçus d'ainsi seulement un périphérique à l'interface série de routeur. Il n'y a aucune caractéristique d'accusé de réception local. BSTUN prend en charge le gens du pays-ACK pour le protocole BISYNC IBM3270 seulement.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant.

/image/gif/paws/41983/bstun_41983-A.gif

Les deux PC utilisent le HyperTerminal de Microsoft ou au lieu d'un des PC pourrait être une connexion dans le port de console d'un routeur de Cisco. Ces configurations d'échantillon représentent des configurations mises en application des Routeurs pas précédemment configurés dans un scénario de laboratoire, et affichent les parties appropriées de la configuration requise. Ceux-ci sont configurés qui assument 9600 bits/sec, la connexion 8N1.

Configurations

Ce document utilise les configurations affichées dans cette section.

  • Routeur principal (routeur de Cisco 1700)

  • Routeur distant (routeur de Cisco 3640)

  • Routeur principal (routeur de Cisco 3600)

  • Distant #1 (routeur de Cisco 1700)

  • Distant #2 (routeur de Cisco 1700)

Routeur principal (routeur de Cisco 1700)
main#show running-config 
Building configuration...
.
.
.
ip subnet-zero
bstun peer-name 10.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 10.1.1.1 255.0.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
interface serial1
   ip address 20.1.1.1 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 1
   speed 9600
   databits 8
   parity none
   stopbits 1
.
.
.
!
end

Routeur distant (routeur de Cisco 3640)
REMOTE#show running-config 
Building configuration...
bstun peer-name 30.1.1.1.
bstun protocol-group 1 async-generic
interface loopback 0
   ip address 30.1.1.1
interface ethernet1/0
   shutdown
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
   
interface serial 2/1
   ip address 20.1.1.2 255.0.0.0
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 65
   speed 9600
   parity none
   databits 8
   stopbits 1
.
.
!
end

Remarque: Quand vous émettez la commande async de couche physique sur l'interface série, une ligne TTY est assignée à l'interface série. Cette définition de ligne TTY est où les databits, les stopbits, la parité, et la vitesse sont configurés. C'est la formule pour déterminer quelle ligne correspond à quelle interface série.

line#= (slot# X 32) + interface# + 1

Le show line dans la sortie distante de configuration de routeur indique dans la colonne d'extrême droite le numéro de ligne correspondant. Serial2/0 est représenté par la ligne 65 et les définitions physiques pour ce lien sont configurées sous la ligne 65

REMOTE#sh line 
   Tty Typ     Tx/Rx        A Modem  Roty AccO AccI   Uses   Noise  Overruns   Int 
*    0 CTY                      -        -          -        -        -          0           0         0/0           - 
    65 TTY   9600/9600  -        -          -        -        -      0           0         0/0     Se2/0 
   129 AUX 9600/9600  -        -          -        -        -        0           0         0/0       - 
   130 VTY                     -        -          -        -        -          0           0         0/0       - 
   131 VTY                     -        -          -        -        -          0           0         0/0       - 
   132 VTY                     -        -          -        -        -          0           0         0/0       - 
   133 VTY                     -        -          -        -        -          0           0         0/0       - 
   134 VTY                     -        -          -        -        -          0           0         0/0       - 

Line(s) not in async mode -or- with no hardware support: 
1-64, 66-128 

Dans ce scénario, un tandem communique avec les périphériques ATM distants. Dans cette configuration d'échantillon, le protocole async exécute un protocole 4800 7E2 et le routeur connecté principal au TANDEM est un routeur de gamme 3600 aux Routeurs à distance de gamme 1700. Voir le ce schéma de réseau.

bstun_41983-B.gif

Routeur principal (routeur de Cisco 3600)
main#show running-config 
Building configuration...
bstun peer-name 10.1.1.1.
bstun protocol-group 1 async-generic
bstun protocol-group 2 async-generic
interface loopback 0
   ip address 10.1.1.1
interface serial1/0
   encapsulation frame-relay
interface serial 1/0.1 point-to-point
   ip address 20.1.1.1 255.255.255.0
   frame-relay interface-dlci 100
interface serial 1/0.2 point-to-point
   ip address 20.2.1.1 255.255.255.0
   frame-relay interface-dlci 200
interface serial 2/0
   physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 1
   bstun route all tcp 30.1.1.1
   
interface serial 2/1
 physical-layer async
   encapsulation bstun
   asp role secondary
   bstun group 2
   bstun route all tcp 30.2.1.1
   
ip route 30.2.1.0 255.255.0.0 20.2.1.2
ip route 0.0.0.0 0.0.0.0 20.1.1.2
line 65
   speed 4800
   parity even
   databits 7
   stopbits 1
.
line 66
   speed 4800
   parity even
   databits 7
   stopbits 1
.
!
end

Distant #1 (routeur de Cisco 1700)
REMOTE1#show running-config 
Building configuration...
bstun peer-name 30.1.1.1
bstun protocol-group 1 async-generic
interface loopback0
   ip address 30.1.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 1
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.1.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.1.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Distant #2 (routeur de Cisco 1700)
REMOTE2#show running-config
Building configuration...
bstun peer-name 30.2.1.1
bstun protocol-group 2 async-generic
interface loopback0
   ip address 30.2.1.1 255.255.0.0
interface serial0
   physical-layer async
   encapsulation bstun
   asp role primary
   bstun group 2
   bstun route all tcp 10.1.1.1
interface serial1
   encapsulation frame-relay
interface serial1.1 point-to-point
   ip address 20.2.1.2 255.255.255.0
   frame-relay interface-dlci 100
ip route 0.0.0.0 0.0.0.0 20.2.1.1
line 1
   speed 4800
   databits 7
   parity even
   stopbits 2
.
.
.
!
end

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

BSTUN reçoit un paquet dans l'interface série, l'encapsule, et envoie ce paquet TCP au routeur distant quand le bstun route toute la commande de TCP est émis. Le paquet TCP est reçu au routeur distant et est désencapsulé. Les données sont envoyées sur l'interface série. Si cette connexion ne fonctionne pas, les données entrantes doivent d'abord être vérifiées avec le debug asp packet. Vous voyez les données reçues par le routeur sur l'interface série. Puisque le routeur n'a aucune construction de protocole et varie selon le protocole async, l'échantillon mettent au point n'est pas fourni. Le flux de données vu par le routeur doit apparier ce qui est envoyé par le périphérique. S'il ne s'assortit pas, très probablement, la vitesse, les databits, la parité, ou les stopbits ne sont pas configurés pour apparier le périphérique. Ceci peut être le cas aussi bien si aucune donnée n'est reçue.

Si des données sont reçues sur l'interface série, émettez la commande de show bstun afin d'afficher si la connexion est ouverte ou fermée. L'état ouvert avec seulement des paquets transmis indique que le TCP est envoyé au pair du distant BSTUN. En ce moment, un test de ping de l'adresse IP du bstun peer-name local à l'adresse IP distante de bstun peer-name vérifie si l'IP est configuré et fonctionnant correctement. Si le test de ping est réussi, alors au distant, émettez la commande de debug asp packet afin de déterminer si le paquet est reçu et envoyé sur l'interface série au périphérique asynchrone.

Terminez-vous ces étapes afin de dépanner.

  1. Vérifiez les données est reçu dans le routeur hôte avec la commande de debug asp packet.

  2. Assurez la connectivité IP avec des pings d'approvisionnement de test de ping de l'adresse IP de bstun peer-name à l'adresse IP distante du bstun peer-name distant.

  3. Au distant, vérifiez que des paquets sont envoyés au périphérique distant avec la commande de debug asp packet.

  4. Si le protocole async a une adresse contenue dans les paquets envoyés au routeur, il peut être salutaire d'émettre la commande de décalage-adresse d'asp sous l'interface avec le nombre approprié d'octet correspondant à où l'adresse est contenue dans le paquet. La valeur par défaut pour ceci est 0. par exemple, si le paquet est 01C1ABCDEF, où C1 est l'adresse, l'interface série peut être configuré avec la commande de la décalage-adresse 01 d'asp. Dans certains cas, ceci permet au routeur pour identifier un paquet et augmente la probabilité que le routeur traite les données comme paquet encadré et pas juste comme un flux de données.


Informations connexes


Document ID: 41983