IP : Protocole IP Multicast

Comment implémenter une stratégie de filtrage pour les points de rendez-vous

18 octobre 2016 - Traduction automatique
Autres versions: PDFpdf | Anglais (27 avril 2015) | Commentaires


Contenu


Introduction

Ce document explique comment implémenter une stratégie de filtrage pour les point de rendez-vous (RPS) à l'agent de mappage RP dans un environnement de Multidiffusion où une configuration RP Dynamique est appliquée (auto-RP).

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

  • Compréhension de base du Protocol Independent Multicast (PIM)

Composants utilisés

Utilisez ce diagramme comme référence dans tout ce document :

/image/gif/paws/41680/rp_announce_02.gif

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Auto-RP

L'auto-RP est une façon dynamique d'apprendre les informations RP pour chaque routeur dans le réseau. Ceci est réalisé quand vous distribuez toutes les informations groupe-à-RP par l'intermédiaire du Protocole IP Multicast.

Tous les Routeurs PIM-activés joignent automatiquement le groupe de détection de Cisco RP (224.0.1.40) qui leur permet pour recevoir toutes les informations du mappage groupe-à-RP. Ces informations sont distribuées par une entité appelée l'agent de mappage RP. Les agents de mappage eux-mêmes joignent un autre groupe — Cisco RP annoncent le groupe (224.0.1.39). Tout le candidat que la RPS s'annoncent dans les messages multicasts périodiques a visé le RP annoncent l'adresse de groupe.

L'agent de mappage écoute toutes les annonces de candidat RP et construit une table avec les informations. Si plusieurs la RPS s'annoncent pour une plage de groupe multicast, l'agent de mappage choisit seulement un — le RP avec l'adresse IP la plus élevée. Il annonce alors le RP à tous les Routeurs PIM dans le réseau utilisant un message de détection RP. Les agents de mappage envoient à ces informations toutes les 60 secondes (la valeur par défaut).

Adresses de filtrage RP

Vous pouvez utiliser la commande access-list de groupe-liste de liste d'accès de RP-liste d'ip pim rp-announce-filter de filtrer certaine RPS pour certains groupes de multidiffusion.

La commande access-list de groupe-liste de liste d'accès de RP-liste d'ip pim rp-announce-filter a seulement la signification si elle est configurée à l'agent de mappage. La liste d'accès de RP-liste définit une liste d'accès de RPS de candidat qui, si permise, sont reçues pour les plages de Multidiffusion spécifiées dans la commande access-list de groupe-liste.

Remarque: Utilisez cette commande avec prudence. La RPS qui sont appariés par la RP-liste (permise par une déclaration d'autorisation) ont leurs groupes de multidiffusion filtrés par la groupe-liste. La RPS qui sont refusés (par un explicite ou implicite refusent) ne sont pas sujets au filtrage de leurs groupes de multidiffusion et «  » sont aveuglément reçus comme RPS de candidat pour tous leurs groupes. En d'autres termes, seulement la RPS qui sont permis par la RP-liste ont leurs groupes de multidiffusion filtrés par la groupe-liste. Toute autre RPS sont reçues sans examen.

Un RP supplémentaire annoncent que le filtre est nécessaire pour filtrer efficacement la RPS qui sont reçus sans examen. La section de filtrage d'exemple clarifie cette procédure.

Exemple de filtrage

Dans le diagramme dans la section utilisée par composants, R2 et R4 s'annoncent comme RPS de candidat pour ces groupes (qui annoncent ces informations par l'intermédiaire des messages de détection RP) :

  • 224.1.0.1

  • 224.1.0.2

  • 224.1.0.3

R3 est configuré comme agent de mappage et recueille ces informations, construit sa table, et envoie seulement une adresse RP à R6, qui est seulement un routeur PIM-activé. Le Protocole IS-IS (Intermediate System-to-Intermediate System) est utilisé dans cet exemple comme protocole de routage d'unicast, mais n'importe quel autre protocole fonctionnerait aussi bien. Le mode de sparseDense PIM est nécessaire pour recevoir les informations de Multidiffusion pour des groupes 224.0.1.39 et 224.0.1.40 sans avoir un RP configuré pour ces groupes. En d'autres termes, le mode de sparseDense fonctionne comme le mode dense s'il n'y a aucun RP connu. Quand un RP est connu, le mode de sparseDense est utilisé pour les groupes pour lesquels le RP s'annonce.

Configuration R2

hostname R2

ip multicast-routing

interface Loopback0
 ip address 50.0.0.2 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.2.0.2 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0002.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupB
!         
!         
ip access-list standard groupB
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuration R4

hostname R4

ip multicast-routing

interface Loopback0
 ip address 50.0.0.4 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Serial3/0
 ip address 10.3.0.4 255.255.255.0
 ip router isis
 ip pim sparse-dense mode

router isis 
 net 49.0002.0000.0000.0004.00

ip pim send-rp-announce Loopback0 scope 16 group-list groupA
!         
!         
ip access-list standard groupA
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Configuration R3

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0003.00

Configuration R6

hostname R6

ip multicast-routing

interface Loopback0
 ip address 50.0.0.6 255.255.255.255
 ip router isis
 
interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.6 255.255.255.0
 ip router isis 
 ip pim sparse-dense-mode

router isis 
 net 49.0002.0000.0000.0006.00

Si vous voulez filtrer R4 car un RP possible pour n'importe lequel de ces groupes et ont seulement R2 comme RP fonctionnant, configurez un RP annoncent le filtre dans R3 :

ip pim rp-announce-filter rp-list filtering-RP group-list filtering-group
!         
!         
ip access-list standard filtering-RP
 permit 50.0.0.2
 deny    50.0.0.4


!--- ACL "filtering-RP" specifically allows R2 and explicitly denies R4.


ip access-list standard filtering-group
 permit 224.1.0.1
 permit 224.1.0.2
 permit 224.1.0.3

Puis, pour effacer les associations du courant groupe-à-RP, émettez la commande de clear ip pim rp-mapping à R3 et à R6.

Cependant, si vous visualisez R6, vous pouvez voir que ne sont pas les informations ce que vous comptez :

R6#show ip pim rp mapping 
PIM Group-to-RP Mappings

Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1

!--- RP is R4

    Info source: 65.0.0.3 (?), elected via Auto-RP
         Uptime: 00:00:02, expires: 00:02:55

Si vous visualisez R3, vous pouvez voir qu'aucun filtrage n'est exécuté réellement :

R3# show ip pim rp mapping
PIM Group-to-RP Mappings
This system is an RP-mapping agent

!--- This line confirms that R3 is configured as the mapping agent.


Group(s) 224.1.0.1/32
  RP 50.0.0.4 (?), v2v1

!--- No filtering has taken effect.

    Info source: 50.0.0.4 (?), elected via Auto-RP

!--- R4 is elected because it has a higher IP address.

         Uptime: 00:09:06, expires: 00:02:53
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.2/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:27
Group(s) 224.1.0.3/32
  RP 50.0.0.4 (?), v2v1
    Info source: 50.0.0.4 (?), elected via Auto-RP
         Uptime: 00:09:06, expires: 00:02:51
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), via Auto-RP
         Uptime: 00:09:29, expires: 00:02:28

L'adresse de R4 est spécifiquement refusée, et n'est pas sujette à aucun filtrage de ses groupes de multidiffusion — elle «  » est aveuglément reçue par l'agent de mappage. L'agent de mappage sélectionne un RP basé sur l'adresse IP la plus élevée (dans cet exemple, 50.0.0.4) et puis en avant ces informations à R6.

Configurez un autre RP annoncent le filtre qui permet R4 et refuse tous ses groupes afin de filtrer efficacement l'adresse R4 :

ip pim rp-announce-filter rp-list filtering-R4 group-list filtering-groupR4

ip access-list standard filtering-R4
 permit 50.0.0.4
ip access-list standard filtering-groupR4
 deny   any

Si vous visualisez R3 et activez la commande d'auto-RP de debug ip pim dès que vous recevrez un RP annoncez le message de R4, vous pouvez voir ces messages :

R3#
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Received RP-announce, from 50.0.0.4, RP_cnt 1, ht 181
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.1/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.3/32 for RP 50.0.0.4
*Apr 30 09:09:06.651: Auto-RP(0): Filtered 224.1.0.2/32 for RP 50.0.0.4

Puis, quand vous visualisez la table groupe-à-RP, vous pouvez seulement voir R2 :

R3#show ip pim rp mapping 
PIM Group-to-RP Mappings
This system is an RP-mapping agent

Group(s) 224.1.0.1/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:52
Group(s) 224.1.0.2/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:54
Group(s) 224.1.0.3/32
  RP 50.0.0.2 (?), v2v1
    Info source: 50.0.0.2 (?), elected via Auto-RP
         Uptime: 00:00:04, expires: 00:02:55

En conclusion, si vous voulez avoir R2 comme RP pour 224.1.0.1, et R4 comme RP pour 224.1.0.2 et 224.1.0.3, vous avez cette configuration à R3 :

hostname R3

ip multicast-routing

interface Loopback0
 ip address 50.0.0.3 255.255.255.255
 ip router isis
 ip pim sparse-dense mode

interface Ethernet1/0.1
 encapsulation dot1Q 65
 ip address 65.0.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial2/0
 ip address 10.2.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

interface Serial3/0
 ip address 10.3.0.3 255.255.255.0
 ip router isis
 ip pim sparse-dense-mode

router isis
 net 49.0002.0000.0000.0003.00

ip pim rp-announce-filter rp-list filtering-RP2 group-list filtering-group2
ip pim rp-announce-filter rp-list filtering-RP4 group-list filtering-group4
!        
!        
ip access-list standard filtering-RP2
 permit 50.0.0.2

ip access-list standard filtering-RP4
 permit 50.0.0.4

ip access-list standard filtering-group2
 permit 224.1.0.1

ip access-list standard filtering-group4
 permit 224.1.0.2
 permit 224.1.0.3

Vérifiez

Aucune procédure de vérification n'est disponible pour cette configuration.

Dépannez

Il n'existe actuellement aucune information de dépannage spécifique pour cette configuration.


Informations connexes


Document ID: 41680