Commutation LAN : Routage inter-VLAN

Configuration du routage entre réseaux locaux virtuels (InterVLAN) avec les commutateurs de la gamme Catalyst 3750/3560/3550

18 octobre 2014 - Traduction automatique
Autres versions: PDFpdf | Anglais (26 septembre 2014) | Commentaires


Contenu


Introduction

Ce document explique comment configurer le routage inter-VLAN avec les commutateurs de la gamme Cisco Catalyst 3750/3560/3550. Le document fournit un exemple de configuration pour le routage inter-VLAN avec un commutateur de la gamme Catalyst 3550, qui exécute le logiciel d'image multicouche améliorée (EMI) dans un scénario de réseau classique. Le document utilise un commutateur de la gamme Catalyst 2950 et un commutateur Catalyst 2948G comme commutateurs en armoire de couche 2 (L2) qui se connectent au commutateur Catalyst 3550. La configuration du Catalyst 3550 comprend également une route par défaut pour tout le trafic en direction d'Internet lorsque le saut suivant indique un routeur Cisco 7200VXR. Vous pouvez substituer un pare-feu ou tout autre routeur au routeur Cisco 7200VXR.

Conditions préalables

Conditions requises

Assurez-vous que vous répondez à ces exigences avant d'essayer cette configuration :

Composants utilisés

Les informations contenues dans ce document sont basées sur les versions de matériel et de logiciel suivantes :

  • Catalyst 3550-48 qui exécute le logiciel Cisco IOS® Version 12.1(12c)EA1 EMI

  • Catalyst 2950G-48 qui exécute le logiciel Cisco IOS Version 12.1(12c)EA1 EI

  • Catalyst 2948G qui exécute le système d'exploitation Catalyst (CatOS) version 6.3(10)

Remarque: La configuration du routeur Cisco 7200VXR n'est pas pertinente et n'est donc pas reprise dans le présent document.

Les informations contenues dans ce document ont été créées à partir des périphériques d'un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si votre réseau est opérationnel, assurez-vous que vous comprenez l'effet potentiel de toute commande.

Produits connexes

Cette configuration peut également être utilisée avec les versions de matériel et de logiciel suivantes :

  • Tout commutateur Catalyst 3750/3560/3550 qui exécute le logiciel EMI ou le logiciel Cisco IOS Version 12.1(11)EA1 d'image multicouche standard (SMI), et versions ultérieures

  • Tout modèle de commutateur Catalyst 2900XL/3500XL/2950/3550 ou CatOS, utilisé comme commutateur de couche d'accès

Conventions

Pour plus d'informations sur les conventions utilisées dans ce document, reportez-vous à Conventions relatives aux conseils techniques Cisco.

Théorie générale

Dans un réseau commuté, les VLAN séparent les périphériques dans différents domaines de collision et sous-réseaux de couche 3 (L3). Les périphériques d'un VLAN peuvent communiquer entre eux sans devoir recourir au routage. Les périphériques de différents VLAN ont besoin d'un périphérique de routage pour communiquer entre eux.

Les commutateurs L2 uniquement nécessitent un périphérique de routage L3. Le périphérique est soit externe au commutateur soit à l'intérieur d'un autre module sur le même châssis. Un nouveau type de commutateur incorpore des fonctions de routage au sein du commutateur. Par exemple, le 3550. Le commutateur reçoit un paquet, détermine que le paquet appartient à un autre VLAN, et l'envoie au port approprié de l'autre VLAN.

Une conception réseau typique segmente le réseau en fonction du groupe ou de la fonction auxquels le périphérique appartient. Par exemple, le VLAN Ingénierie contient uniquement des périphériques associés au service d'ingénierie, et le VLAN Finances contient uniquement des périphériques associés au service des finances. Si vous activez le routage, les périphériques de chaque VLAN peuvent communiquer entre eux sans que tous les périphériques aient besoin de se trouver dans le même domaine de diffusion. Une telle conception de VLAN présente également un avantage supplémentaire. La conception permet à l'administrateur de restreindre les communications entre les VLAN grâce à l'utilisation des listes d'accès. Dans l'exemple du présent document, vous pouvez utiliser des listes d'accès qui empêchent le VLAN Ingénierie d'accéder aux périphériques du VLAN Finances.

Le commutateur ne route pas les paquets non-IP entre les VLAN et les ports routés. Vous pouvez transférer ces paquets non-IP grâce au pontage de secours. Pour pouvoir utiliser cette fonctionnalité, l'image IP Services, préalablement connue sous le nom d'image multicouche améliorée (EMI), doit être installée sur votre commutateur.

Voici un lien à un vidéo (disponible sur la Communauté de support de Ciscoleavingcisco.com ) qui explique comment configurer le routage d'InterVLAN sur une gamme Catalyst 3550 commutent :

Comment configurer le routage entre réseaux locaux virtuels (InterVLAN) sur les commutateurs de couche 3 leavingcisco.com

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Utilisez l'outil Command Lookup Tool (clients enregistrés seulement) pour trouver plus d'informations sur les commandes utilisées dans ce document.

Diagramme du réseau

Ce document utilise la configuration réseau suivante :

189-a.gif

Dans ce schéma, un petit exemple de réseau doté d'un commutateur Catalyst 3550 fournit le routage inter-VLAN entre les divers segments. Par défaut, le commutateur Catalyst 3550 agit en tant que périphérique L2 et désactive le routage IP. Afin que le commutateur fonctionne avec un périphérique L3 et fournisse le routage inter-VLAN, vous devez activer le routage IP globalement.

Ces VLAN sont les trois VLAN définis par l'utilisateur :

  • VLAN 2 — VLAN utilisateur

  • VLAN 3 - VLAN serveur

  • VLAN 10 - VLAN de gestion

La configuration de passerelle par défaut sur chaque serveur et chaque périphérique hôte doit être l'IP de l'interface VLAN qui correspond au commutateur 3550. Par exemple, pour les serveurs, la passerelle par défaut est 10.1.3.1. Les commutateurs de la couche d'accès, Catalyst 2950 et 2948G, sont agrégés par liaison au commutateur Catalyst 3550.

La route par défaut pour le commutateur Catalyst 3550 pointe vers le routeur Cisco 7200VXR. Le commutateur Catalyst 3550 utilise cette route par défaut pour router le trafic à destination d'Internet. Par conséquent, le trafic pour lequel le commutateur 3550 n'a pas d'entrée de table de routage est transféré vers le routeur 7200VXR pour être traité.

Conseils pratiques

  • Assurez-vous que le VLAN natif pour une liaison 802.1Q est identique aux deux extrémités de la liaison agrégée. Si le VLAN natif à l'une des extrémités est différent du VLAN natif de l'autre extrémité, le trafic des VLAN natifs des deux côtés ne peut pas être transmis correctement sur la liaison. Si la transmission ne s'effectue pas correctement, cela peut indiquer des problèmes de connectivité dans votre réseau.

  • Séparez le VLAN de gestion du VLAN utilisateur ou du VLAN serveur, comme dans ce schéma. Le VLAN de gestion est différent du VLAN utilisateur ou serveur. Avec cette séparation, toute tempête de diffusion/paquets sur le VLAN utilisateur ou serveur n'affecte pas la gestion des commutateurs.

  • N'utilisez pas VLAN 1 pour la gestion. Tous les ports des commutateurs Catalyst sont par défaut définis sur VLAN 1, et tous les périphériques qui se connectent aux ports non configurés sont sur le VLAN 1. L'utilisation du VLAN 1 pour la gestion peut entraîner d'éventuels problèmes de gestion des commutateurs, comme l'explique le second conseil.

  • Utilisez un port de couche 3 (routé) pour se connecter au port de la passerelle par défaut. Dans cet exemple, vous pouvez facilement remplacer un routeur Cisco 7200VXR avec un pare-feu qui se connecte au routeur de la passerelle Internet.

  • N'exécutez pas de protocole de routage entre le commutateur Catalyst 3550 et le routeur de la passerelle Internet. Cet exemple configure une route statique par défaut sur le commutateur 3550 à la place. Cette configuration est la plus appropriée s'il n'existe qu'une seule route vers Internet. Veillez à configurer des routes statiques, de préférence récapitulées, sur le routeur de passerelle (7200VXR) pour les sous-réseaux qui peuvent être atteints par le commutateur Catalyst 3550. Cette étape est très importante car cette configuration n'utilise pas de protocole de routage.

  • Si votre réseau contient deux commutateurs Catalyst 3550, vous pouvez connecter simultanément les commutateurs de la couche d'accès aux deux commutateurs 3550. Exécutez le protocole HSRP (Hot Standby Router Protocol) entre les commutateurs pour fournir la redondance dans le réseau. Pour plus d'informations sur la configuration du protocole HSRP, référez-vous à la section Configuration du protocole HSRP de Configuration des services IP.

  • Si vous avez besoin de bande passante supplémentaire pour les ports de liaison ascendante, vous pouvez configurer EtherChannel. L'EtherChannel fournit également la redondance de liaison en cas de défaillance de liaison.

Configurations

Ce document utilise les configurations suivantes :

Catalyst 3550 (commutateur Catalyst 3550-48)
Cat3550#show running-config 
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

!--- Enable IP routing for interVLAN routing.

ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

!
interface FastEthernet0/5
 description to SERVER_1

!--- Configure the server port to be in the server VLAN, VLAN 3.

switchport access vlan 3

!--- Configure the port to be an access port to prevent trunk negotiation delays.

 switchport mode access
 no ip address

!--- Configure PortFast for initial Spanning Tree Protocol (STP) delay. Refer to
!--- Using PortFast and Other Commands to Fix Workstation Startup Connectivity Delays
!--- for more information.

spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/48
 description To Internet_Router

!--- The port that connects to the router converts into a routed (L3) port.

no switchport

!--- Configure the IP address on this port. 

ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

!--- Configure IEEE 802.1 (dot1q) trunking, with negotiation, on the L2 switch.
!--- If there is not support for Dynamic Trunking Protocol (DTP) on the far switch, 
!--- issue the switchport mode trunk command to force the switch port to trunk mode.
!--- Note: The default trunking mode is dynamic auto. If you establish a trunk link 
!--- with the default trunking mode, the trunk does not appear
!--- in the configuration, even though a trunk has been established on 
!--- the interface. Use the show interfaces trunk command to verify the 
!--- establishment of the trunk. 

switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

!--- This IP address is the default gateway for users.

 ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

!--- This IP address is the default gateway for servers.

ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

!--- This IP address is the default gateway for other L2 switches.

 ip address 10.1.10.1 255.255.255.0
!
ip classless

!--- This route statement allows the 3550 to send Internet traffic to 
!--- the default router which, in this case, is the 7200VXR (Fe 0/0 interface).

ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Remarque: Puisque le commutateur 3550 est configuré comme serveur de protocole d'agrégation de réseaux locaux virtuels (VTP), il n'affiche pas la configuration VTP. Ce comportement est normal. Ce commutateur utilise ces commandes pour créer un serveur VTP avec trois VLAN définis par l'utilisateur en mode de configuration globale :

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT
Catalyst 2950 (commutateur Catalyst 2950G-48)
Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Output suppressed.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

!
interface FastEthernet0/33
 description HOST_1

!--- Configure HOST_1 to be the user VLAN, VLAN 2.

 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Output suppressed.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- This IP address manages this switch. 

ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Configure the default gateway so that the switch is reachable from other
!--- VLANs/subnets. The gateway points to the VLAN 10 interface on the 3550.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Remarque: Puisque le commutateur Catalyst 2950 est configuré comme client VTP, il n'affiche pas la configuration VTP. Ce comportement est normal. Le commutateur 2950 obtient l'information de VLAN auprès du serveur VTP, c'est-à-dire le commutateur 3550. Ce commutateur 2950 utilise ces commandes pour faire du commutateur un client VTP dans le domaine VTP cisco à partir du mode de configuration globale :

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client
Commutateur Catalyst 2948G
Cat2948G> (enable) show config 
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- Configure the VTP domain to be the same as the 3550, the VTP server.

set vtp domain cisco

!--- Choose the VTP mode as client for this switch.

set vtp mode client
!
#ip

!--- Configure the management IP address in VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- Define the default route so that the switch is reachable.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Configure HOST_2 and SERVER_3 ports in respective VLANs.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Configure trunk to 3550 with dot1q encapsulation.

set trunk 2/49 desirable dot1q 1-1005
end

Vérifiez

Cette section fournit des informations qui vous permettront de vérifier que votre configuration fonctionne correctement.

L'Outil Interpréteur de sortie (clients enregistrés uniquement) (OIT) prend en charge certaines commandes show. Utilisez l'OIT pour afficher une analyse de la sortie de la commande show .

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk  
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Dépannez

Utilisez cette section pour dépanner votre configuration.

Procédure de dépannage

Procédez comme suit :

  1. Si vous ne pouvez pas envoyer une commande ping aux périphériques d'un même VLAN, vérifiez l'attribution de VLAN des ports source et de destination pour vous assurer que la source et la destination se trouvent dans le même VLAN.

    Afin de contrôler l'affectation de VLAN, exécutez la commande show port mod/port pour CatOS ou la commande show interface status pour le logiciel Cisco IOS.

    Si la source et la destination ne sont pas dans le même commutateur, assurez-vous que vous avez configuré l'agrégation de liaison correctement. Afin de vérifier la configuration, exécutez la commande show trunk pour CatOS ou la commande show interfaces trunk pour le logiciel Cisco IOS. En outre, vérifiez que le VLAN natif correspond de chaque côté. Assurez-vous que le masque de sous-réseau correspond entre les périphériques source et de destination.

  2. Si vous ne pouvez pas envoyer de commande ping aux périphériques des différents VLAN, assurez-vous que vous pouvez envoyer une commande ping à leur passerelle par défaut respective.

    Remarque: Voir l'étape 1.

    En outre, assurez-vous que la passerelle par défaut du périphérique pointe vers l'adresse IP de l'interface de VLAN appropriée. Assurez-vous que le masque de sous-réseau correspond.

  3. Si vous ne pouvez pas atteindre Internet, assurez-vous que la route par défaut définie sur le commutateur 3550 pointe vers l'adresse IP correcte, et que l'adresse de sous-réseau correspond au routeur de passerelle Internet.

    À des fins de vérifications, exécutez les commandes show ip interface id-interface et show ip route. Assurez-vous que des routes vers Internet et les réseaux internes sont définies sur le routeur de passerelle Internet.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 41260