Services de mise en réseau d'applications : Moteurs de contenu Cisco de la gamme 500

Configuration de WCPP version 2 sur Catalyst 3500

17 décembre 2015 - Traduction automatique
Autres versions: PDFpdf | Anglais (22 août 2015) | Commentaires


Contenu


Introduction

Ce document fournit à une configuration d'échantillon pour la version 2 du Web Cache Communication Protocol (WCCP) sur le Catalyst 3550 le Cisco Content Engine 560.

Avant de commencer

Conventions

Pour plus d'informations sur les conventions des documents, référez-vous aux Conventions utilisées pour les conseils techniques de Cisco.

Conditions préalables

Aucune condition préalable spécifique n'est requise pour ce document.

Composants utilisés

Cette configuration a été développée et testée utilisant le logiciel et les versions de matériel suivants.

  • Version de logiciel 12.1(11)EA1a s'exécutante de Cisco Catalyst 3550 Cisco IOSÝ

  • Application de Cisco du Cisco Content Engine 560 et version s'exécutantes 4.2.3 du logiciel réseau de Réseau de diffusion de contenu (ACNS)

Les informations présentées dans ce document ont été créées à partir de périphériques dans un environnement de laboratoire spécifique. Tous les périphériques utilisés dans ce document ont démarré avec une configuration effacée (par défaut). Si vous travaillez dans un réseau opérationnel, assurez-vous de bien comprendre l'impact potentiel de toute commande avant de l'utiliser.

Configurez

Cette section vous fournit des informations pour configurer les fonctionnalités décrites dans ce document.

Remarque: Pour obtenir des informations supplémentaires sur les commandes utilisées dans ce document, utilisez l'Outil de recherche de commande (clients enregistrés seulement).

Diagramme du réseau

Ce document utilise la configuration réseau indiquée dans le diagramme suivant :

/image/gif/paws/29461/diagram.jpg

Configurations

Ce document utilise les configurations présentées ci-dessous.

  • Catalyst 3550

  • Engine satisfaite 560

Catalyst 3550
GIULIO#sh run
Building configuration...
Current configuration : 3426 bytes
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
!
hostname GIULIO
!
enable password ww
!
ip subnet-zero
ip routing



!--- Only TCP port 80 may be redirected.
!--- You need to issue the sdm prefer extended-match command
!--- on the switch. Refer to the Verify and Troubleshoot section for 
!--- further information.


ip wccp web-cache
!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
Ýno switchport
Ýip address 10.48.66.217 255.255.254.0
!
interface FastEthernet0/2
Ýno ip address
!
interface FastEthernet0/3
Ýno ip address
!
interface FastEthernet0/4
Ýno ip address
!
interface FastEthernet0/5
Ýno ip address
!
interface FastEthernet0/6
Ýno ip address
!ÝÝÝÝÝÝÝÝÝ
interface FastEthernet0/7
Ýno ip address
!
interface FastEthernet0/8
Ýno ip address
!
interface FastEthernet0/9
Ýno ip address
!
interface FastEthernet0/10
Ýno ip address
!
interface FastEthernet0/11
Ýno ip address
!
interface FastEthernet0/12
Ýno ip address
!
interface FastEthernet0/13
Ýno ip address
!
interface FastEthernet0/14
Ýno ip address
!
interface FastEthernet0/15
Ýno ip address
!
interface FastEthernet0/16
Ýno switchport
Ýip address 33.33.33.33 255.255.255.0
Ýduplex full
Ýspeed 100
!
interface FastEthernet0/17
Ýno ip address
!
interface FastEthernet0/18
Ýno ip address
!ÝÝÝÝÝÝÝÝÝ
interface FastEthernet0/19
Ýno ip address
!
interface FastEthernet0/20
Ýno ip address
!
interface FastEthernet0/21
Ýno ip address
!
interface FastEthernet0/22
Ýno ip address
!
interface FastEthernet0/23
Ýno ip address
!
interface FastEthernet0/24
Ýno ip address
!
interface FastEthernet0/25
Ýno ip address
!
interface FastEthernet0/26
Ýno ip address
!
interface FastEthernet0/27
Ýno ip address
!
interface FastEthernet0/28
Ýno ip address
!
interface FastEthernet0/29
Ýno ip address
!
interface FastEthernet0/30
Ýno ip address
!
interface FastEthernet0/31
Ýno ip address
!
interface FastEthernet0/32
Ýno ip address
!
interface FastEthernet0/33
Ýno ip address
!
interface FastEthernet0/34
Ýno ip address
!
interface FastEthernet0/35
Ýno ip address
!
interface FastEthernet0/36
Ýno ip address
!
interface FastEthernet0/37
Ýno ip address
!
interface FastEthernet0/38
Ýno ip address
!
interface FastEthernet0/39
Ýno ip address
!
interface FastEthernet0/40
Ýno ip address
!
interface FastEthernet0/41
Ýno ip address
!
interface FastEthernet0/42
Ýno ip address
!
interface FastEthernet0/43
Ýno ip address
!
interface FastEthernet0/44
Ýno ip address
!
interface FastEthernet0/45
Ýno ip address
!
interface FastEthernet0/46
Ýno ip address
!
interface FastEthernet0/47
Ýno ip address
!
interface FastEthernet0/48


!--- On this WCCP implementation, only input redirection is allowed.


Ýno switchport
Ýip address 1.1.1.1 255.255.255.0
Ýip wccp web-cache redirect in
!
interface GigabitEthernet0/1
Ýno ip address
!
interface GigabitEthernet0/2
Ýno ip address
!
!



!--- This access list 100, if associated as 'in' to Fa0/48, 
!--- can show if packets are reaching the Catalyst from the PC client.


access-list 100 permit tcp any eq www any log
access-list 100 permit tcp any any eq www log

access-list 100 permit any any any log

ip default-gateway 10.48.66.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.48.66.1
ip http server
!
!
!
!
line con 0
Ýexec-timeout 0 0
Ýpassword cisco
line vty 0 4
Ýexec-timeout 0 0
Ýpassword ww
Ýlogin
line vty 5 15
Ýlogin
!
end

GIULIO#

Engine satisfaite 560
agra#sh run 
  hostname agra 
  ! 
  ! 
  ! 
  ! 
  ! 


!--- The Standby feature on the Content Engine  is optional in the 
!--- implementation, but it works fine with the Catalyst.

  interface FastEthernet 0/0 
  Ýip address 122.122.122.1 255.255.255.0 
  Ýstandby 1 ip 33.33.33.31 255.255.255.0
  Ýstandby 1 priority 120 
  Ýno autosense 
  Ýbandwidth 100 
  Ýfull-duplex 
  Ýexit 
  interface FastEthernet 0/1 
  Ýip address 122.122.123.1 255.255.255.0 
  Ýstandby 1 ip 33.33.33.31 255.255.255.0  
  Ýstandby 1 priority 80 
  Ýno autosense 
  Ýbandwidth 100 
  Ýfull-duplex 
  Ýexit 
  ! 
  ! 
  ip default-gateway 33.33.33.33 
  ! 
  primary-interface FastEthernet 0/0 
  ! 
  ! 
  ! 
  ! 


!--- The logging console is only used for troubleshooting, as it may cause 
!-- high CPU on the Content Engine in production.
Ý 
  logging console enable 
  logging console priority debug 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  ! 
  
  wccp router-list 1 33.33.33.33 
  wccp web-cache router-list-num 1 l2-redirect 

!--- The assign-method-strict is not necessary.

  wccp version 2 


!--- Catalyst 3550 implementation of WCCP allows only Layer 2 redirection, 
!--- and not generic routing encapsulation (GRE). In addition, only TCP 
!--- port 80 may be redirected. 

  ! 
  ! 
  username admin password 1 bVmDmMMmZAPjY 
  username admin privilege 15 
  ! 
  ! 
  ! 
  ! 
  authentication login local enable primary 
  authentication configuration local enable primary 
  ! 
  !               

agra#

Vérifiez et dépannez

Cette section fournit des informations que vous pouvez employer pour confirmer que votre configuration fonctionne correctement et pour dépanner plus loin.

  • Afin d'activer la redirection WCCP dans le commutateur de Catalyst, vous devez émettre la commande d'étendre-correspondance de sdm prefer (et redémarrer le commutateur). En émettant la commande de show sdm prefer, vous pouvez voir la configuration réelle du matériel TCAM/ASIC dans le commutateur.

  • Comme implémentation de WCCP dans le Catalyst 3550 est limité, émettant la commande de show ip wccp n'affiche pas le nombre de paquets étant réorientés. Cet index demeure à 0. En outre, le même Catalyst peut avoir de plusieurs engines satisfaites dans la batterie de cache, mais seulement un Catalyst WCCP est permis. La sortie de la commande de show ip wccp sur le Catalyst est affichée ci-dessous.

    GIULIO#sh ip wccp 
    
    Global WCCP information: 
      ÝÝÝ Router information: 
      ÝÝÝÝÝÝÝ Router Identifier:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ  33.33.33.33 
      ÝÝÝÝÝÝÝ Protocol Version:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ  2.0 
    
    ÝÝÝ Service Identifier: web-cache 
      ÝÝÝÝÝÝÝ Number of Cache Engines:ÝÝÝÝÝÝÝÝÝÝÝÝÝ  1 
      ÝÝÝÝÝÝÝ Number of routers:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ1 
      ÝÝÝÝÝÝÝ Total Packets Redirected:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ0 
      ÝÝÝÝÝÝÝ Redirect access-list:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ  -none- 
      ÝÝÝÝÝÝÝ Total Packets Denied Redirect:ÝÝÝÝÝÝÝ  0 
      ÝÝÝÝÝÝÝ Total Packets Unassigned:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝ0 
      ÝÝÝÝÝÝÝ Group access-list:ÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝÝ  -none- 
      ÝÝÝÝÝÝÝ Total Messages Denied to Group:ÝÝÝ     0 
      ÝÝÝÝÝÝÝ Total Authentication failures:ÝÝÝÝÝÝÝÝÝ0 
      Ý
                                  Statistics - Requests
                                                    Total             % of Requests
                                ---------------------------------------------------
         Total Received Requests:                       4                         -
                  Forced Reloads:                       0                       0.0
                   Client Errors:                       0                       0.0
                   Server Errors:                       0                       0.0
             URL Blocked (Reset):                       0                       0.0
                     URL Blocked:                       0                       0.0
          Sent to Outgoing Proxy:                       0                       0.0
    Failures from Outgoing Proxy:                       0                       0.0
    Excluded from Outgoing Proxy:                       0                       0.0
                 ICP Client Hits:                       0                       0.0
                 ICP Server Hits:                       0                       0.0
                   If-Range Hits:                       0                       0.0
               HTTP 0.9 Requests:                       4                     100.0
               HTTP 1.0 Requests:                       0                       0.0
               HTTP 1.1 Requests:                       0                       0.0
           HTTP Unknown Requests:                       0                       0.0
               Non HTTP Requests:                       0                       0.0
              Non HTTP Responses:                       0                       0.0
          Chunked HTTP Responses:                       0                       0.0
            Http Miss Due To DNS:                       0                       0.0
         Http Deletes Due To DNS:                       0                       0.0
    
    
    agra#sho stat http savings 
                             Statistics - Savings
                            Requests                          Bytes
             -----------------------------------------------------------
      Total:                       4                           3132
       Hits:                       3                           2349
       Miss:                       1                            783
    Savings:                    75.0 %                         75.0 %
    
    
    agra#sho stat netstat 
    Active Internet connections (w/o servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State      
    tcp        0      0 33.33.33.31:8999        10.48.66.123:2011       ESTABLISHED 
    
    udp        0      0 127.0.0.1:10000         127.0.0.1:32346         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10001         127.0.0.1:32347         ESTABLISHED 
    
    udp        0      0 127.0.0.1:10002         127.0.0.1:32345         ESTABLISHED
  • Si la liste d'accès 100 est appliquée au trafic d'arrivée sur FastEthernet 0/48, un message semblable au suivant devrait être envoyé à la console pour chaque paquet de HTTP envoyé par le navigateur de client à l'Internet :

    *MarÝ 1 04:19:09: %SEC-6-IPACCESSLOGP: list 109 permitted tcp 1.1.1.2(1828)    -> 10.48.66.125(80), 1 packet Ý    
    
    
  • Sur l'engine satisfaite, les commandes suivantes te permettent pour voir le nombre de paquets envoyés par l'engine satisfaite :

    • affichez les demandes de HTTP de statistiques

    • affichez le netstat de statistiques

    • affichez l'épargne de HTTP de statistique

    Tous les paquets envoyés à l'Internet ont une adresse IP source identique à l'engine satisfaite, excepté quand l'engine satisfaite est dans le mode bypass et les demandes sont envoyées par l'adresse IP source de PC client à la place.

Conversations connexes de la communauté de soutien de Cisco

Le site Cisco Support Community est un forum où vous pouvez poser des questions, répondre à des questions, faire part de suggestions et collaborer avec vos pairs.


Informations connexes


Document ID: 29461